Jump to content
kmalcherczyk

Problem z Prestashop 1.5

Recommended Posts

Po instalacji wszystko działa normalnie jeśli chodzi o zarządzanie sklepem ale mam pewien problem. Pierwszy raz pracuje w Prestashop i stąd mój problem a na forum nie potrafię znaleźć na niego odpowiedzi.

 

Strona aktualnie wygląda tak: http://serwer1374283.home.pl/Outletowe/index.php

Mimo standardowego szablonu strona dziwnie wygląda, czym może to być spowodowane?

Share this post


Link to post
Share on other sites

Dzięki za pomoc lecz mam kolejny problem.

Po instalacji szablonu wyskoczyło kilka błędów:

Warning: Copy/Paste your errors if you want to manually set the image type (in the "Images" page under the "Preferences" menu):

Some kind of image could not be added because they exists. Here's the list:

Name image type: small_leoshoe (Width: 45px, Height: 45px)

Name image type: medium_leoshoe (Width: 58px, Height: 58px)

Name image type: large_leoshoe (Width: 264px, Height: 264px)

Name image type: thickbox_leoshoe (Width: 600px, Height: 600px)

Name image type: category_leoshoe (Width: 500px, Height: 150px)

Name image type: home_leoshoe (Width: 168px, Height: 106px)

Name image type: large_scene (Width: 520px, Height: 189px)

Name image type: thumb_scene (Width: 161px, Height: 58px)

Name image type: product (Width: 225px, Height: 135px)

Name image type: manufac (Width: 145px, Height: 70px)

Name image type: small_default (Width: 45px, Height: 45px)

Name image type: medium_default (Width: 58px, Height: 58px)

Name image type: large_default (Width: 264px, Height: 264px)

Name image type: thickbox_default (Width: 600px, Height: 600px)

Name image type: home_default (Width: 168px, Height: 106px)

Name image type: category_default (Width: 500px, Height: 150px)

Name image type: scene_default (Width: 520px, Height: 189px)

Name image type: m_scene_default (Width: 161px, Height: 58px)

 

 

A szablon wyświetla jakby również z błędami bo się poprzesuwał... Jest to czysta kopia prestashop i nie mam jeszcze produktów itp nie wiem czy to tego wina czy jak...

http://serwer1374283.home.pl/Outletowe/

Edited by kmalcherczyk (see edit history)

Share this post


Link to post
Share on other sites

oj, kompletnie nie czytelny ten fragment ;)

 

ale oznacza to tyle, że obrazki które szablon próbuje utworzyć już istnieją (są zdefiniowane) w preferences > image.

 

drugi komunikat mówi, że zainstalowano moduły.

 

 

wszystko jest ok.

 

pozostaje Ci jedynie wygenerować thumbnails (prefereces > images) - jest tam narzędzie do regeneracji miniatur.

Share this post


Link to post
Share on other sites

dziękuję, zaraz zobacze :) Jestem bardzo zadowolony z twojej pomocy i szybkości z jaką odpowiadasz na pytania, jeszcze nigdy nie spotkałem się z takim czymś.

 

EDIT. Szukam tego i nie widzę jak to wygenerować czy możesz podać mi jakoś bardziej szczegółową instrukcje jak to zrobić bo pierwszy raz w tym pracuję i w ogóle nie mogę się jeszcze odnaleźć.

Edited by kmalcherczyk (see edit history)

Share this post


Link to post
Share on other sites

Szukam tego i nie widzę jak to wygenerować czy możesz podać mi jakoś bardziej szczegółową instrukcje jak to zrobić bo pierwszy raz w tym pracuję i w ogóle nie mogę się jeszcze odnaleźć.

Share this post


Link to post
Share on other sites

1) otwórz Preference > Zdjęcia

qTJHEM5.png

 

 

2) zjeżdżasz na dół i masz:

 

7tR0hoC.png

 

 

klikasz w ponowne generowanie miniatur.

 

 

czynności sprawią, że obrazy na stronie będą widoczne.

dodatkowo, oprócz tego konieczne będzie pewnie spersonalizowanie szablonu (wlasne obrazy w sliderze itp)

Share this post


Link to post
Share on other sites

Zrobiłem jak mówiłeś a mimo że szablon jest dobry bo działał ludziom nadal u mnie jest dziwnie poprzesuwany.

 

"Generowanie miniatur zakończone powodzeniem"

 

http://serwer1374283.home.pl/Outletowe/index.php

 

Tak miał wyglądać:

 

http://www.leotheme.com/prestashop/themes/216-leo-sportshoes.html

Edited by kmalcherczyk (see edit history)

Share this post


Link to post
Share on other sites

okay, plus jest taki, że teraz pojawiły się zdjęcia produktów ;)

 

JDbastG.png

 

 

teraz pozostaje kwestia personalizacji.

Nigdy nie jest tak, że będziesz miał kalkę tego co jest na obrazku ( http://www.leotheme.com/prestashop/themes/216-leo-sportshoes.html ). Musisz teraz spersonalizować poszczególne elementy template.

 

dla przykładu, zdjęcia w sliderze:

Vpxvc19.png

 

te obrazy są STANDARDOWYMI obrazami jaki są prestashop, nie są one dopasowane do tego template, daltego musisz wgrać swoje. (moduły > home slider) klikasz w konfiguruj i wgrywasz swoje, dopasowane do szerokości obrazy.

 

masz tam również jakiś dodatkowy slider zainstalowany (lof coin slider?)

8NE3Qms.png

 

 

musisz również zmienić ilość wyświetlanych polecanych produktów itp.

 

 

 

wszystko robisz konfigurując wykorzystywane moduły.

Share this post


Link to post
Share on other sites

Z tego co widzę to trudniejsze niż myślałem ;//

Mam rozumieć że teraz najlepiej gdy stworze obrazki swoje i je wrzucę na stronę i wtedy te wszystkie przesunięcia itp się poprawią a skąd mam wiedzieć który moduł to np. ten slider bo nie nazywa się po prostu slider i skąd wziąść rozmiary tych banerów wiem że może pytania są banalne ale totalnie się tutaj gubię...

Share this post


Link to post
Share on other sites

Generalnie jest tak, że wszystko to co widzisz w swoim sklepie - to zwykle jakiś moduł. Np. kolumny i ich zawartość (blok kategorii, blok koszyka) menu, polecane produkty, nowe produkty itp. Za te wszystkie elementy odpowiadają moduły. Ich kompletną listę masz w zakładce MODUŁY w back office. Możesz tam nimi zarządzać - konfigurowac, usuwać, instalować, włączać i wyłączać.

Metodą prób i błędów możesz dojść do tego za co dany moduł odpowiada...

 

niestety, aby w pełni skonfigurować sklep musisz nabrać trochę wprawy, wiedzieć za co dany moduł odpowiada itp. Trochę jest z tym zabawy, ale gdy już całość ogarniesz - satysfakcja niesamowita ;)

 

 

Co do slidera. W konfiguracji modułu, np. homeslider masz podane wymiary które trzeba wgrać, mało tego sam możesz je ustawić. Jak wejdziesz na stronę konfiguracyjną tego modułu to zobaczysz pola gdzie definiujesz szerokość i wysokość obrazków.

Share this post


Link to post
Share on other sites

No właśnie znalazłem 1 slider ale pozostałych nie potrafię i widzę że zabawy z tym na parę dobrych godzin. W razie problemów będę pisał :)

Share this post


Link to post
Share on other sites

dzieje się tak gdyż moduł lof new products nie jest przetłumaczony na język polski. Musisz go przetłumaczyć ręcznie.

Jak? w zakładce lokalizacja > tłumaczenia z rozwijanej listy wybierasz tłumaczenia modułów, klikasz w polską flagę, odszukujesz moduł na liście i tłumaczysz

Share this post


Link to post
Share on other sites

Ok poradziłem sobie grzebiąc w kodzie strony bo chociaż na tym się znam edytowałem plik default.tpl i działa :) Ale pewnie twój sposób będzie prostszy więc wykorzystam go w reszcie. Problem mam znów z ustawieniem wielkości jednego z modułów bo mimo iż zmieniam jego wielkość to nie zmienia się na stronie, chodzi mi dokładnie o ten sam modul "lof new products"

Share this post


Link to post
Share on other sites

Tylko wysokość obrazków które tam są bo jednak będą się tam wyświetlać koszulki a chciałbym żeby strona była czysta i przejżysta a zdjęcia duże bez niepotrzebnych opcji. A gdy w konfiguracji modułu zmieniam wielkość to nie zmienia się ona na stronie, mogę wpisać nawet 800 i nic ;/

 

I jeszcze jak możesz to gdzie dodaje się pozycje w menu bo po dodaniu kategori nie wyświetlają mi się na głównej stronie w menu.

Chciałbym takie menu:

Główna / Kategorie / Grupoun / Wyprzedaż / Kontakt

Edited by kmalcherczyk (see edit history)

Share this post


Link to post
Share on other sites

Strone jak widzisz trochę ogarnąłem i poradziłem sobie z problemami ale nadal nie wiem jak te menu zrobić.

Chciałbym np. w Menu Kategorie i żeby z tego wysuwały się Mężczyzna / Kobieta a potem z tych 2 kategori poszczególne.. Kategorie stworzyłem ale nie wiem jak dodać to do menu.

 

http://serwer1374283.home.pl/Outletowe/index.php

Share this post


Link to post
Share on other sites

Nie chcę spamować ale czy znajdzie się osoba która jest mi w stanie pomóc bo niestety tylko na was mogę liczyć :(

 

Problem rozwiązany!

Edited by kmalcherczyk (see edit history)

Share this post


Link to post
Share on other sites

nie wiem dokładnie jaki tam moduł używasz (do obsługi menu)

wygląda mi to na standardowe top horizontal menu.

 

w ustawieniach modułu - możesz zbudować wielopoziomowe menu, wówczas będzie się ono rozwijać tak jak w defaultowym template presty.

Share this post


Link to post
Share on other sites

1) otwórz Preference > Zdjęcia

qTJHEM5.png

 

 

2) zjeżdżasz na dół i masz:

 

7tR0hoC.png

 

 

klikasz w ponowne generowanie miniatur.

 

 

czynności sprawią, że obrazy na stronie będą widoczne.

dodatkowo, oprócz tego konieczne będzie pewnie spersonalizowanie szablonu (wlasne obrazy w sliderze itp)

Nie wyświetlają mi się zdjęcia produktów, miniaturki. Zrobiłem to co ww. napisano ale nie pomogło. Co jeszcze można sprawdzić ?

 

--edycja

 

dziwne jest to ze zmienil sie adres odnośników:

....info/img/p/7/5/75.jpg

 

na

 

...info/img/p/11-75.jpg

Edited by mr.suchy (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More