Jump to content

Manual Upgrade Guide - PS 1.2., PS 1.3, PS 1.4, 1.5, 1.6.Upgrade only Database


Recommended Posts

It is very simple to upgrade your project PS 1.2. to PS 1.6.X.

Simply upgrade manually. You don't need to do any export.

How to:

Upgrade database only - PS versions 1.2., PS 1.3., PS 1.4., PS 1.5. and also PS 1.6. latest version:

Before upgrade:
a - download upgrade package from HERE: http://www.prestasho...lopers-versions. Unpack zip-file to your local hard-drive.

b - save your database as back-up, save your FTP - Preferably both externally on your own hard drive.

Upgrade:
a - Delete all the folders and files from your the FTP EXCLUDING /config (whole folder, subfolders and files) and /img (whole folder, subfolders and files)

b - Upload the unpacked download from the new Prestashopversion to your FTP EXCLUDING /img/p and /img/c

c - type in your browser the following link: yourdomain/install/upgrade/upgrade.php.

d - upgrade processes begin and after it is ready a "done" site will quit the process as successful.

e - close this browser windows to close also the session and cookies which are logged.

f - On your FTP delete the folder /install

g - and rename the folder /admin

h - log in as usual: your domain/renamedadmin/

i - regenerate all your images from tab -> preferences -> images

Please be aware that if you have an own theme for your shop or bought modules (also free), they will not work after you upgrade from bigger versions. This means: third party extras of PS 1.3 will not work on PS 1.4, third party extras of PS 1.4 will not work on PS 1.5, third party extras from PS 1.5. will not work on PS 1.6.

If you are having problems with your upgraded shop, so remind to use the possibility of debugging-features on board, which is:

activate the following debug lines in your file /config/defines.inc.php:

/* Debug only */
define('_PS_MODE_DEV_', true);
if (_PS_MODE_DEV_)
{
@ini_set('display_errors', 'on');
define('_PS_DEBUG_SQL_', true);
/* Compatibility warning */
define('_PS_DISPLAY_COMPATIBILITY_WARNING_', true);
}

Please do not activate debugging BEFORE UPGRADE IS COMPLETED ! This is only to debug AFTER an UPGRADE.


If you upgrade older versions to PS 1.6. manually, than possibly you will have a smarty_lazy_cache problem. How to add this missing tables to your database you will find here:
https://www.prestashop.com/forums/topic/555189-ps_smarty_lazy_cache-doesnt-exist/?do=findComment&comment=2402475


I've already upgraded several PS 1.2., PS 1.3, PS 1.4., PS 1.5 and also PS 1.6. in same release, if 1-click module fails with  jqXHR  error by this way without having any issues.

After manual upgrade please also clear your cache (smarty and browser) and take into consideration to reset your modules, as they after upgrade could get stuck.


Good luck.

  • Like 7

Share this post


Link to post
Share on other sites

  • 1 month later...
  • 2 weeks later...

Hi CD2500,

I tried your solution and here is what happens:

 

( ! ) Warning: include(C:\wamp\www\prestanew\config/../modules/mobile_theme/Mobile_Detect.php) [<a href='function.include'>function.include</a>]: failed to open stream: No such file or directory in C:\wamp\www\prestanew\config\settings.inc.php on line 9
Call Stack
# Time Memory Function Location
1 0.0015 907920 {main}( ) ..\upgrade.php:0
2 0.0022 943536 include_once( 'C:\wamp\www\prestanew\config\settings.inc.php' ) ..\upgrade.php:63
( ! ) Warning: include() [<a href='function.include'>function.include</a>]: Failed opening 'C:\wamp\www\prestanew\config/../modules/mobile_theme/Mobile_Detect.php' for inclusion (include_path='.;C:\php\pear') in C:\wamp\www\prestanew\config\settings.inc.php on line 9
Call Stack
# Time Memory Function Location
1 0.0015 907920 {main}( ) ..\upgrade.php:0
2 0.0022 943536 include_once( 'C:\wamp\www\prestanew\config\settings.inc.php' ) ..\upgrade.php:63
( ! ) Fatal error: Class 'Mobile_Detect' not found in C:\wamp\www\prestanew\config\settings.inc.php on line 9
Call Stack
# Time Memory Function Location
1 0.0015 907920 {main}( ) ..\upgrade.php:0
2 0.0022 943536 include_once( 'C:\wamp\www\prestanew\config\settings.inc.php' ) ..\upgrade.php:63

 

Do you know what this means?

post-86383-0-51860200-1373656070_thumb.jpg

Edited by ubergirl (see edit history)

Share this post


Link to post
Share on other sites

I'm web administrator at a prestashop ecommerce application.. We are running prestashop v1.4.5.1 an older version, now i'm upgrading our prestashop to the latest available version v1.5.4.1. As i have manually upgraded it followed the exact instructions you mentioned. Everything is working perfectly but just when i click on checkout button, everytime i get "The Page is not redirecting properly" error message.

 

Can you please help me what is the issue?

Share this post


Link to post
Share on other sites

  • 1 month later...
  • 3 weeks later...

dont work for me ...

 

Fatal error: Class 'PrestaShopException' not found in /home/doiplus2/public_html/install/classes/exception.php on line 28

 

happens the same with me. I have tried with the last version but it fails with a timeout. when I tried with the version specified the OP I got that error.

 

I have a 1.4.1.0 so I expected to have some trouble. since neither the last version nor the preferred by the OP have worked I'm going to try all versions starting from 1.4.4 and see if I get lucky at some point but I would prefer a better and more reliable solution.

Share this post


Link to post
Share on other sites

  • 1 month later...
  • 4 weeks later...

I have the same issue with this upgrade, all orders (800+) have disappeared, except for 5!

 

I just tested upgrading a copy of my site using this method as I was having issues with an upgrade I did using the 1-Click Upgrade module.

 

Not having much luck upgrading my 1.4.9 store at all :)

Share this post


Link to post
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Please can you help? I am sitting with PS 1.4.3 and need to upgrade but the 1-click upgrade does not work.
I have read your post on the manual upgrade but is not sure on how to upgrade as the instructions is not very clear. I can see that I must use the old config and image files to upgrade. Do I need to install a new ver first before importing the config/image files?
When and how do I use the old db.
Thanks.

Share this post


Link to post
Share on other sites

We made several manual upgrades with the a.m. instruction, why I also posted it. Keep in mind that if you have made changes on core or database, added new tables or features to the database the upgrade can fail.

 

In this case before you upgrade you should deinstall ALL not native modules and than on this database make the manual upgrade.

 

My instruction is written for upgrades only for the native software and older Prestashop versions to latest 1.5. IT IS NOT SUITABLE FOR UPGRADES INSIDE PS 1.5 to PS 1.5 or minor versions inside a major release. For this please use the 1-click upgrade module which do not fail if the software ist original. In case of doubt deinstall all modules not native and try an upgrade with the 1-click-module. Afterwards you can install the non-native modules again and see if they are working or making troubles.

 

From our experience most of the problems caused by failed upgrades are adaptations/overrides and not native modules changing the core of Prestashop.

 

@ gerhardus - please follow step-by-step the instructions.

 

 

a - Delete all the folders and files from your the FTP EXCLUDING /config (whole folder, subfolders and files) and /img (whole folder, subfolders and files)

 

Before this make a back-up of database and FTP

 

b - save your database as back-up, save your FTP - Preferably both externally on your own hard drive.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Hello,

the process worked almost fine for me. I have upgraded PS 1.4.8.2 to PS 1.5.6.2. Everything worked fine, apart from the fact that I cannot see the product images in the front end.

I see all my products in the back office, thumbnails and everything but in the front end all images have gone.

I will try to work it out, meantime if anyone has any idea please let me know.

I have the feeling that my front office is looking at a different path.

Kind regards,

Marianna

Share this post


Link to post
Share on other sites

Hello again,

I've found the solution to my problem quickly and easily, so I'd like to share it with you.

I've noticed that the new installation of PS 1.5.6.2 according to the steps described by "PrestaShop Legend" did not have on the backoffice images in the form of "home_default", "large_default" etc but instead I had "home", "large" etc.

So I created new image types with the correct names and afterwards I asked PS to regenerate thumbnails and everything worked fine!

Kind regards,

Marianna

Share this post


Link to post
Share on other sites

  • 2 weeks later...
  • 4 weeks later...
  • 1 month later...
  • 4 weeks later...

Hi guys,

 

I try to find someone (prestashop employee or a company) who can upgrade a PS 1.2.5.0 to (at least) PS 1.5.3.1 (preferably 1.6).

I`m paying for this project, but I need it to be done without "after" problems and I want him (or them) to guarantee that after this upgrade I will have ALL MY DATABASE (categories, products,order,customers,invoices etc).

 

 If someone is interested, please send me a PM.

 

Thank you.

Edited by foarteiute (see edit history)

Share this post


Link to post
Share on other sites

  • 3 months later...

Hi,

I did the upgrade as described above by prestashop team "how to upgrade manuaally version 1.2.5 to 1.5.3".

 

I changed also the info in the file for debug but the problem is still not resolved.

All my images, products, modules , categories are not visible.

during install, I was tald to delete all the tabs of the database to continue. Then I uploaded the database backup from myAdmin panel completly without errors.

 

After thant the frontend shows a store as it's a new shop without example products and all the modules are show.

 

When I click on the modules tab, I get the message :

 

Fatal error: Access level to dibs::$smarty must be protected (as in class PaymentModule) or weaker in /home/parisfol/public_html/boutique/modules/dibs/dibs.php on line 404
[PrestaShop] Fatal error in module dibs:
Access level to dibs::$smarty must be protected (as in class PaymentModule) or weaker

 

now, I can'ty access to the modules neither to my images, products and catyegories. Many months of work spent with the last message to build the store.

 

Do you have a real solution to get my store visible really ?

 

If it continues, I can't stay blocked and I have to make a restore backup of my old store v 1.2;5 because I dont'have time to spend again many weeks to rebuild a store.

 

Thanks for any help.

 

The store is :  www.Parisfollowme.com/boutique    to see the result after the manual upgrade adviced above.

 

I dit 3 times and I spent2 days to try 3 times. It takes too much time to upload and try to make test and search to find a solution...

 

contact AT winaoo.com

Share this post


Link to post
Share on other sites

  • 2 years later...

Hi,

Would this work for upgrading from 1.1 to 1.6? I have an old store with ~1000 products I''m trying to update it to the latest version. What I mostly care for is being able to export the products into the new version even if I lose the orders and customers.

Is this possible?

Thank you,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More