Jump to content

Recommended Posts

olá pessoal, tenho uma loja prestashop que fiz a alguns anos atrás versao 1.1 estou querendo atualizar a versao e também o layout dela, gostaria de saber se tem alguem ai no forum que tenha experiencia e esteja a fim de fazer esse serviço e quanto cobraria, desejo sucesso a todos!

carlves@hotmail.com

Share this post


Link to post
Share on other sites

Vc. mesmo pode fazer. Atualize somente o Banco de dados com um upgrade manual. O tema e todos os módulos comprados não mais funcionarão.

 

Atualizar manualmente - atualizar somente banco de dados:

PS versões 1.2., PS 1.3., PS 1.4. e também PS 1.5. para a versão mais recente:

 

Pré-upgrade:

a - baixar o pacote de atualização daqui: http://www.prestasho...lopers-versions

 

b - faça um back-up do seu banco de dados

 

c - faça um back-up do seu FTP. Salva ambos de preferência tanto externamente como uma cíopia em seu próprio disco rígido.

 

d - Apague todas as pastas/arquivos e ficheiros da sua loja no seu FTP MENOS: /config (incluindo subpastas e arquivos) e /img (incluindo subpastas e arquivos)

 

e - em seguida, carregue a nova versão para o seu FTP EXCLUÍNDO os ficheiros: /img/p e /img/c inclusive pastas e sub-pastas do pacote download.

 

UPGRADE:

f - Para iniciar a instalação vc. chama o link: oseudomínio/install/upgrade/upgrade.php.

 

g - Após o upgrade estiver completo abrirá uma página XML. Salva esta página para todas as eventualidades (aqui vc. poderá ver mensagens de erro, se houver alguma). Esta XML não tem muita importância, é somente para seu controle.

 

h - feche o seu browser completamente

 

i - Em seguida deleta no seu FTP a pasta /install

 

j - renomear a pasta /admin

 

k - loga como de costume com o seu novo nome admin - (seudomini/novoadmin)

 

l - reinicialize todos as suas imagens na aba: preferências -> imagens

Share this post


Link to post
Share on other sites

olá amigo, obrigado pela dica é que nao estou tendo muito tempo, caso eu não consiga alguém vou por a mão na massa. rs . Obrigado

Share this post


Link to post
Share on other sites
Vc. mesmo pode fazer. Atualize somente o Banco de dados com um upgrade manual. O tema e todos os módulos comprados não mais funcionarão. Atualizar manualmente - atualizar somente banco de dados: PS versões 1.2., PS 1.3., PS 1.4. e também PS 1.5. para a versão mais recente: Pré-upgrade: a - baixar o pacote de atualização daqui: http://www.prestasho...lopers-versions b - faça um back-up do seu banco de dados c - faça um back-up do seu FTP. Salva ambos de preferência tanto externamente como uma cíopia em seu próprio disco rígido. d - Apague todas as pastas/arquivos e ficheiros da sua loja no seu FTP MENOS: /config (incluindo subpastas e arquivos) e /img (incluindo subpastas e arquivos) e - em seguida, carregue a nova versão para o seu FTP EXCLUÍNDO os ficheiros: /img/p e /img/c inclusive pastas e sub-pastas do pacote download. UPGRADE: f - Para iniciar a instalação vc. chama o link: oseudomínio/install/upgrade/upgrade.php. g - Após o upgrade estiver completo abrirá uma página XML. Salva esta página para todas as eventualidades (aqui vc. poderá ver mensagens de erro, se houver alguma). Esta XML não tem muita importância, é somente para seu controle. h - feche o seu browser completamente i - Em seguida deleta no seu FTP a pasta /install j - renomear a pasta /admin k - loga como de costume com o seu novo nome admin - (seudomini/novoadmin) l - reinicialize todos as suas imagens na aba: preferências -> imagens

 

 

O link do pacote de atualização esta quebrado !

Share this post


Link to post
Share on other sites

Já consertei. Por favor tente novamente.

Share this post


Link to post
Share on other sites

tenho uma dúvida básica. Alguém poderia me dizer se ao atualizar o prestashop eu irei perder todas as modificações que fiz (como por exemplo modificaçoes no php.ini, admincarriers .... etc) as traduções de e-mails e etc?? Ou a atualizaçao vai preservar tudo?

 

obrigada

Share this post


Link to post
Share on other sites

Se atualizar para uma versão maior (ex: 1.4.X para 1.5.X) você precisará de um tema novo (compatível com a nova versão) e módulos que não sejam padrão também não serão compatíveis.

Recomendo que faça a atualização em um ambiente separado e quando estiver com tudo funcionando, faça a atualização da loja em produção.

Share this post


Link to post
Share on other sites

Caro amigo Daniel, fiz o backup do bd da minha loja prestashop v 1.5.6.2 seguindo o passo a passo recomendado. Instalei em localhost a versão 1.6. Novo visual, novo admin e tal... Quando fiz a restauração do backup a loja v 1.6 voltou a ter o mesmo visual da loja 1.5.6.2. Aquele template antigo. Como faço pra fazer a restauração do backup da v 1.5.6.2, mas manter o visual da v 1.6? 

Tem como?

 

Valeu!

Share this post


Link to post
Share on other sites

Como o Daniel já escreveu: 

 

Se atualizar para uma versão maior (ex: 1.4.X para 1.5.X) você precisará de um tema novo (compatível com a nova versão) e módulos que não sejam padrão também não serão compatíveis.

 

Nao é possível vc. usar templates PS 1.5. em PS 1.6. Além de PS 1.6. posuir mais features que um template antigo nao contém, os templates codados para PS 1.5. nao sao responsivos, mas sim adaptivos. Vc. vai ter que tomar como base o tempalte PS 1.6. e construir um template próprio ou entao comprar um que tenha como base o template original já retrabalhado.

Muitos webdesigners vendem templates compatíveis de PS 1.3-1.6. Se nao existir para cada versao PS um template próprio neste caso, entao este template conterá erros e um monte de problemas, pois nao é possivel um template só funcionar com todas as versoes ao mesmo tempo.

 

Templates idoneos que funcionam sem problemas e têm suporte gratuíto após a venda vc. encontra nos add-ons oficias do Prestashop. Nao aconselho vc. comprar um template fora ou usar templates gratuítos.

http://addons.prestashop.com

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

Caro amigo Daniel, fiz o backup do bd da minha loja prestashop v 1.5.6.2 seguindo o passo a passo recomendado. Instalei em localhost a versão 1.6. Novo visual, novo admin e tal... Quando fiz a restauração do backup a loja v 1.6 voltou a ter o mesmo visual da loja 1.5.6.2. Aquele template antigo. Como faço pra fazer a restauração do backup da v 1.5.6.2, mas manter o visual da v 1.6? 

Tem como?

 

Valeu!

 

Pelo que disse, acredito que vc não atualizou a loja. Instalou uma nova 1.6 em localhost e depois restaurou o backup da 1.5.

Aí não adiantou nada.

 

Se o seu localhost estiver bem configurado, inclusive com acesso à internet, faça a atualização pelo módulo 1-click upgrade.

Depois de atualizar você pode utilizar o tema padrão (default-bootstrap), ou adquirir um tema que melhor se adapte à sua loja.

 

De outra forma, não ficará 100%.

 

Ao atualizar é fundamental manter um backup completo e saber o que está fazendo, para não ter eventuais problemas com a loja em produção.

 

Boa sorte

Share this post


Link to post
Share on other sites

Pelo que disse, acredito que vc não atualizou a loja. Instalou uma nova 1.6 em localhost e depois restaurou o backup da 1.5.

Aí não adiantou nada.

 

Se o seu localhost estiver bem configurado, inclusive com acesso à internet, faça a atualização pelo módulo 1-click upgrade.

Depois de atualizar você pode utilizar o tema padrão (default-bootstrap), ou adquirir um tema que melhor se adapte à sua loja.

 

De outra forma, não ficará 100%.

 

Ao atualizar é fundamental manter um backup completo e saber o que está fazendo, para não ter eventuais problemas com a loja em produção.

 

Boa sorte

 

Caro amigo Daniel, fiz o upgrade pelo módulo 1-click upgrade.

 

O Prestashop fez todo o passo a passo beleza.

 

O back-end ficou normal, mas minha loja ficou com o Erro 500.

 

O que eu preciso fazer para corrigir isto?

 

Obg...

Edited by gsilvaads (see edit history)

Share this post


Link to post
Share on other sites

Olá sou nova no forum e estou a iniciar no prestashop, tive de actualizar a loja da versão 1.5.4.1 na a mais recente, fiz o upgrade pelo módulo 1-click upgrade.

 

O Prestashop instalou o módulo.

Mas não consigo depois entrar em Config para continuar a configuração.

 

Entro na loja mas qdo tento aceder Parametros Avançados/1-click Upgrade , ficou com o um erro Access denied.

 

O que posso fazer para corrigir isto?para puder fazer o upgrade para a versao 1.6

 

Obg...

Share this post


Link to post
Share on other sites

Vc. também nao tem acesso ao módulo através da aba "módulos -> 1 clique upgrade ?

 

Se nao tem acesso, entao verifique se a sua pasta /modules e as sub-pastas nela possuem direitos de escrita (chmod 755). O módulo 1-clique se chama autoupgrade e se encontra na pasta /modules do seu FTP.

  • Like 1

Share this post


Link to post
Share on other sites

Olá selectshop.at

 

Obrigada pela ajuda, mas o problema continua na mesma, logo quando entro na minha loja tenho a mensagem de erro " Access denied", se tento aceder ao modulo 1 click upgrade acontece o mesmo.

 

Já percorri as pastas e dei permissão 0755 a todas.

 

O que posso fazer para corrigir isto?

para puder fazer o upgrade para a versao 1.6

 

Obrigada :)

Catarina

Share this post


Link to post
Share on other sites

Dirija-se ao seu provedor. Nao sei porque o servidor está vedando o acesso. Ele poderá lendo os logs de erro do servidor constatar melhor o que está dando problema.

Share this post


Link to post
Share on other sites

Olá a todos,seguinte,estou tentando atualizar o PS v1.5.6.2 pra v1.6.1.1 pelo upgrade 1-click pelo arquivo local,mas está aparecendo isto:Unable to generate diff file list between 1.5.6.2 and v1.6.1.1.

 

Verifiquei as permissões e estão 755,alguém poderia me dar um help?

Share this post


Link to post
Share on other sites

Boa noite!
Uso o Prestashop 1.6.0.14
Gostaria de atualizar para a versão mais nova 1.6.1.4
Sendo que modifiquei muito a loja padrão.
Se eu atualizar, perderei todas as modificações que fiz?

Share this post


Link to post
Share on other sites

Se vc. atualizou o tema default-bootstrap e ficheiros php SEM overrides e o tema sem criar um clone do tema nativo renomeando o mesmo e fazendo as alteracoes neste novo tema, entao SIM perderá todas as suas alteracoes.

 

Alteracoes en ficheiros php devem ser feitos através de overrides e alteracoes no tema nativo, somente em um clone com outro nome.

 

Tutoriais:

overrides - http://doc.prestashop.com/display/PS15/Overriding+default+behaviors e

http://build.prestashop.com/howtos/module/how-to-override-modules/

 

clone do tema - https://mypresta.eu/en/art/videos/how-to-duplicate-theme-in-prestashop-16.html e

https://www.prestashop.com/forums/topic/461147-duplicate-default-theme-ps-16/

Share this post


Link to post
Share on other sites

Eu instalei no modo manual porque deu um erro fatal usando esse módulo ai, depois que enviei a nova versão para   internet,da o seguinte erro 

 

Fatal error: Class 'PrestaShopBundle\Install\LanguageList' not found in /home/thewa598/public_html/getnerd.com.br/install/classes/controllerHttp.php on line 135

 

 

Alguém sabe oque é?

Share this post


Link to post
Share on other sites

Eu instalei no modo manual porque deu um erro fatal usando esse módulo ai, depois que enviei a nova versão para   internet,da o seguinte erro 

 

Fatal error: Class 'PrestaShopBundle\Install\LanguageList' not found in /home/thewa598/public_html/getnerd.com.br/install/classes/controllerHttp.php on line 135

 

 

Alguém sabe oque é?

O módulo que está tentando instalar nao é compatível com a versao Prestashop em uso.

 

Versao Prestashop ?

 

Qual módulo está tentando instalar ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More