Jump to content

[solved] Database Server is not found. Please verify the login, password and server fields (DbPDO)


Recommended Posts

Hi guys

really am struggling here, I have been searching the forums and online for a solution to this have tried most solutions.

 

I have created a couple of prestashop online shops before using the same host and have got over all of the issues but this time I am coming up against a brick wall, not sue if it is me.......help

 

So, gets through to the database configuration and all it keeps coming up with is this

 

'Database Server is not found. Please verify the login, password and server fields (DbPDO)'

 

the db is remote on web server, the same as i have done before, although I have noticed that the resolve details now are to https where as before I believe it was just http. I just dont know if I have to enter anything different for the new version 1.5.4 than I have in the past, but I just cant find the db.

 

I know the settings are correct as I can browse to the db and login. If there is someone to help I would really appreciate it,

 

Regards

  • Like 1

Share this post


Link to post
Share on other sites

When exactly do you see this error? During installation, or afterwards?

 

Did you (try to) turn on SSL in your shop? (If you can login into Back office, check Preferences->General?)

Share this post


Link to post
Share on other sites

  • 3 months later...
  • 2 weeks later...

Hi! on the same I'm doing a test of this shop on cpanel hosting, can some one help me how to get  Database server address: before  I have been using a host where getting all these detail is easy.  The whois for the domain is

 

 

Domain Name: EXOTICDESTINATIONSKE.COM
Registrar: GODADDY.COM, LLC
Whois Server: whois.godaddy.com

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hi geolan,

not sure if I understand you right, but do you want to know what to fill in at the database settings page when installing?

If so, do this: go to your cPanel, go to phpMyAdmin, login to the database (remember login name and password) and go to your database. Then at the top your see something like this:

localhost-><full database name>->selected table

post-455771-0-75736900-1379521367_thumb.jpg

 

so,

define('_DB_SERVER_', 'localhost');  (or, if there's something else than localhost in the database line use that)
define('_DB_NAME_', '<full database name from above>');
define('_DB_USER_', 'login name');
define('_DB_PASSWD_', 'password');
 
Hope this helps,
pascal
  • Like 1

Share this post


Link to post
Share on other sites

  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More