Jump to content

[Free Module] Lof Featured Products Carousel


Quang Ha
 Share

Recommended Posts

Hi Quang Ha!

 

I really like you module and it's just what I was looking for. I would like to have the same layout (exept for the carusul thing) in my categories to. Is there any easy way to do this? Can i copy some code or something like that?

 

Thanks for you great work and hope you understand my question.

 

Best regards

Anni

Share this post


Link to post
Share on other sites

Hi Quang Ha!

 

I really like you module and it's just what I was looking for. I would like to have the same layout (exept for the carusul thing) in my categories to. Is there any easy way to do this? Can i copy some code or something like that?

 

Thanks for you great work and hope you understand my question.

 

Best regards

Anni

 

i ve exactly your headache! 

Share this post


Link to post
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
  • 4 weeks later...
  • 2 weeks later...

I need help, show only products have price reduction ( promotion )

 

SOLVED

in \libs\groups\product\product.php

        function getListFeatured( $params ){
            global $cookie, $link;
           	$id_lang = intval($cookie->id_lang);
            $maxDesc = $params->get( 'des_max_chars',100);
			$limit_items = $params->get( 'limit_items',10);
    		$listFeatured = Product::getPricesDrop((int)intval($cookie->id_lang), 0,$limit_items);

            foreach( $listFeatured as &$product ){
                $product['description']=substr(trim(strip_tags($product['description_short'])),0, $maxDesc);
                $product['price']=Tools::displayPrice($product['price']);                 
                $product = $this->parseImages( $product,$params );                
                $product = $this->generateImages( $product, $params );
            }
            return $listFeatured;
        }

and randomize show itens

in \tmpl\default\default.tpl

 

			$('#loffeatured-{$moduleId}').carouFredSel({ldelim}
				responsive:true,
				prev: '#loffprev-{$moduleId}',
				next: '#loffnext-{$moduleId}',
				pagination: "#loffpager-{$moduleId}",
				auto: {$auto_play},
				width: {$slide_width},
				height: {$slide_height},
				scroll: {$scroll_items},
				items:{ldelim}
					width:200,
					start: "random",
					visible:{ldelim}
						min:1,
						max:{$limit_cols}
					{rdelim}
				{rdelim}
			{rdelim});		  

Good luck folks, I hope that helps ;D

Edited by cijop (see edit history)

Share this post


Link to post
Share on other sites

  • 4 weeks later...

I'm having problems with images showing up in it.

I have this for the images:

<img class="responsive-img" alt="Griffin Effects DPDT Relay Switching" src="http://griffineffects.com/store/244-home/griffin-effects-dpdt-relay.jpg">

 

When I need:

<img class="responsive-img" alt="Griffin Effects DPDT Relay Switching" src="http://griffineffects.com/store/244-home_default/griffin-effects-dpdt-relay.jpg">

 

I had to either copy the images and rename them home or I have to add a image class in back office and name it home for the images to show up. Any idea how to change the module to call the home_default so I don't have to create additional images?

 

http://griffineffects.com/store

Edited by bside2234 (see edit history)

Share this post


Link to post
Share on other sites

The modules seems to report a reduced price for products that aren't reduced in price. I've tried resetting but no luck.

Any idea what could be going wrong?

The default featured product module that comes with prestashop does not have this problem. Using the latest version of prestashop.

 

Screen_Shot_2013_12_25_at_13_25_20.png

Edited by jonas87 (see edit history)

Share this post


Link to post
Share on other sites

  • 4 weeks later...

Weird. It starts to auto rotate after I click on one of the arrow. Have you tried it with the default theme just to see if it's something that has to do with your custom theme?

No, In default template its not rotating even if i click on any arrow... but in my website it is getting rotate after i click on the arrow...

Share this post


Link to post
Share on other sites

  • 3 weeks later...

Hi,

When I'm trying to transplant module to content hook it works fine (module is in two places then). But when I unhook from top of pages all style is removed from module and all the featured items are displayed one underneath another (picture attached). Could anyone help with this issue? Thanks.

I have the same issue, can anyone help me with this problem ?

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Tried but this is not this, if I use this, top is disappear.

That's because both the header on top of you site and the space above the featured product are both pulling from the same header css. I would guess you should change the name of the space above the featured products to something else and create it's own css.

Share this post


Link to post
Share on other sites

Its happen only with this module, other modules for home featured are ok.

That's because this module named that header space above your featured slider the same as your main css while the other modules didn't.

Using Firefox Firebug I can change the 185px of the space above the featured header, then I check the header at the top of your page and it also changes because they both use the same CSS which I copied and pasted in the previous post.

 

As long as both the header in the module and the header at the top of your page are both using the same css code, changing one will also change the other. You have to separate them. Has nothing to do with other modules for home featured.

Share this post


Link to post
Share on other sites

Hello guys,

i have little problem with this module. When i instal it, all was is ok but featured product are displayed one under one (image). Can anyone tell me what to do please? Many thanks for answers :)post-780433-0-10059800-1396603807_thumb.jpg

Share this post


Link to post
Share on other sites

Hello guys,

 

i have little problem with this module. When i instal it, all was is ok but featured product are displayed one under one (image). Can anyone tell me what to do please? Many thanks for answers :)attachicon.gifimage.jpg

it looks like your module is without any kind of css and js files

check browser console for potential missing files: css / js  or errors related to these files

(ctrl+shift+j in chrome)

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Hi! 
I have big problem. I can't hook it in the right place.

I want it like here http://demo4coder.com/prestashop/prestashop1.5.x/index.php?id_cms=42&controller=cms&id_lang=1

Under header but above columns. I want it only on home page.

 

When I hook it to home I see products without css. Whent it's in top and home it's on header (on every page), but I can deal with it in css (I'll make header higher). I can't find solution to place it on top and only on home page.

 

Any ideas?

Share this post


Link to post
Share on other sites

  • 2 weeks later...

first, thanks for this great module. it's really cool & very noob-friendly. the only thing i can't get is to change the direction & speed of each module. i use new & featured product slider of your & i need to make them to go to different direction. already looked the jscript but can't find the solutions.

anyway great modules

 

 

Hi! 
I have big problem. I can't hook it in the right place.

I want it like here http://demo4coder.com/prestashop/prestashop1.5.x/index.php?id_cms=42&controller=cms&id_lang=1

Under header but above columns. I want it only on home page.

 

When I hook it to home I see products without css. Whent it's in top and home it's on header (on every page), but I can deal with it in css (I'll make header higher). I can't find solution to place it on top and only on home page.

 

Any ideas?

 

 

like this & this? u need to hook it to header of pages & top pages then edit them. unhook the unwanted pages except index. like this

post-773117-0-59760200-1399372356_thumb.jpg

Edited by Andr3Ace (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

  • 1 month later...

Hi Loaded version 2. for prestashop 1.6 and get this on home page "No template found for module loffeatured" Any ideas

 

 

Hi

 

same problem here... Is there any way to fix it?

 

Thanx!

Share this post


Link to post
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Hi. Is magnific this module.

I like change the title that you see in the web, the title show is "FEATURED PRODUCTS",  How can change the title by "Productos Destacados" ???.

 

You can help me please.

 

Thank you friend.!!!

Share this post


Link to post
Share on other sites

Hi I have your modulew installed on my site and for some reason slider is not sliding or doign anything keeps showing same 6 images please see here

http://iclick-computers.com/


Can you please help me and explain to me how to make it scroll I checked check box where it sais auto play but still on front page all it shows is 6 producs and nothing else please help. Thank you

Share this post


Link to post
Share on other sites

at the moment i dont see there lof featured module, you disabled it?

its there on main page it says

Featured Products

 

And still images of 6 products that are there and they were supose to be scrolling :(

Share this post


Link to post
Share on other sites

its there on main page it says

Featured Products

 

And still images of 6 products that are there and they were supose to be scrolling :(

 

for some rason your web page is missing ALL the javascripts... there is no <script> tag anywhere

 

if you check nothing works, the popular tab button, or category filter, etc..

Share this post


Link to post
Share on other sites

for some rason your web page is missing ALL the javascripts... there is no <script> tag anywhere

 

if you check nothing works, the popular tab button, or category filter, etc..

This looks like the problem. Have you tried using the default bootstrap theme to see if that works?

Share this post


Link to post
Share on other sites

This looks like the problem. Have you tried using the default bootstrap theme to see if that works?

 

for some rason your web page is missing ALL the javascripts... there is no <script> tag anywhere

 

if you check nothing works, the popular tab button, or category filter, etc..

 

 

Thanks guys so you think this is the issue with template ? it self ? as I donwnloaded frrom this forum ?

Thanks for reply

Share this post


Link to post
Share on other sites

Thanks guys so you think this is the issue with template ? it self ? as I donwnloaded frrom this forum ?

Thanks for reply

Anytime there is an issue like this when not using the default template, it's always a good idea to check if the issue goes away when using the default template. That narrows the problem down to the custom template.

Share this post


Link to post
Share on other sites

Anytime there is an issue like this when not using the default template, it's always a good idea to check if the issue goes away when using the default template. That narrows the problem down to the custom template.

Can I not coppy items from default template to this one to make it work ?

Share this post


Link to post
Share on other sites

Can I not coppy items from default template to this one to make it work ?

That depends on your custom template. It may or may not work depending on the custom templates coding. I'm just saying if something non-native to prestashop default doesn't work with a custom theme, you should try it with the default theme to see if it's a theme issue. If it works with the default and not the custom theme, there is something conflicting/wrong with the custom theme. If it doesn't work for either then you most likely have another issue not necessarily related to the themes.

  • Like 1

Share this post


Link to post
Share on other sites

  • 3 weeks later...

Hi 

 

This module is very good!
I installed it in the previous version of PS. 1.5 it works fine.
Now I installed the latest version of PS. 1.6.9 with the default theme, and the new version of the module, but I dont' see the slide with the correct height in the Chrome browser; it's small ( see image), the height of the slides changes when i change the browser, it's very strange and I don't know how to fix it. Help me.
 
anomalia_lofcarousel.jpg
 
 
 
thanks
 
Angela
Edited by afshop (see edit history)

Share this post


Link to post
Share on other sites

 

Hi 

 

This module is very good!
I installed it in the previous version of PS. 1.5 it works fine.
Now I installed the latest version of PS. 1.6.9 with the default theme, and the new version of the module, but I dont' see the slide with the correct height in the Chrome browser; it's small ( see image), the height of the slides changes when i change the browser, it's very strange and I don't know how to fix it. Help me.
 
anomalia_lofcarousel.jpg
 
 
 
thanks
 
Angela

 

 

Yea, I am having the same issue. Playing around with the settings for the image sizes seems to effect it to some degree but still basically the same problem. It happens in IE as well...  I am using 1.6.08

Share this post


Link to post
Share on other sites

Hi Loaded version 2. for prestashop 1.6 and get this on home page "No template found for module loffeatured" Any ideas

Same problem here :( anyone found a solution for this?

 

I also noticed that when I save configuration, and back to the configuration page again nothing saved. It's always look like on picture:

somHIz.png

Share this post


Link to post
Share on other sites

 

Yea, I am having the same issue. Playing around with the settings for the image sizes seems to effect it to some degree but still basically the same problem. It happens in IE as well...  I am using 1.6.08
 
 

 

 

 

I just tested this again, and it seems to happen the most with Chrome but also with firefox and IE as well.... :(

Share this post


Link to post
Share on other sites