Jump to content

Recommended Posts

hello

 

CDATA means that you use tinymce rich text editor to insert code. there is no other way, believe me.

turn it off and paste proper script code, then save (dont turn on rich text editor even for a while)

Share this post


Link to post
Share on other sites

hello

 

CDATA means that you use tinymce rich text editor to insert code. there is no other way, believe me.

turn it off and paste proper script code, then save (dont turn on rich text editor even for a while)

 

spent exeperimental: used 3 different modules for output, of which 2 without a text editor, one of them outputs code Yandex counter - the same result.
The result can be seen in the page code
left column output module: blockhtml (no text editor)
right column output module: htmlbox (have a text editor)
footer output module: blockhtmlcodes (no text editor)
 
This problem associated with smart compilation. On one of the forums recommend: "In such cases, counter code must be inserted in the format:
{literal}
Counter code ... ...
{/ literal} "
 
but it is in the direct insertion, how to apply it in the module - I do not know
Edited by rkoba (see edit history)

Share this post


Link to post
Share on other sites

paste your code to html.tpl file located in module directory

 

use it with {literal}{/literal} tags

Share this post


Link to post
Share on other sites

you're welcome :)

glad to hear that i could help a little with this free addon

if you need any additional features - just let me know, i will try to develop them 

Share this post


Link to post
Share on other sites

new version released!

now html box module supports prestashop 1.6!

enjoy!

  • Like 2

Share this post


Link to post
Share on other sites

new version (1.4.9) released!

finally, module works well with 1.6 release, also tinymce editor works well now too

MBkArZT.png

  • Like 1

Share this post


Link to post
Share on other sites

Hey Vekia,

I am trying the floating Facebook tutorial but failing.

 

I get the text in my top left corner!

 

www.gr8-kitchenware.co.uk 

 

I downloaded the facebook image onto my public_html

 

im doing something wrong? please advise

kind regards,

Lee

UK

 

 

Share this post


Link to post
Share on other sites
several days ago we released new version (1.5.0) of the module.

we added support of new position (new position in prestashop 1.6)

Share this post


Link to post
Share on other sites

Hi Vekia,

 

I am trying to add the "RevolverMaps" widget on my site using the HTML block module but can't get it to work properly.

The module is set up to display on the Right Column but when I input the code for the RevolverMaps, it appears on the footer instead. I am using Prestashop 1.6.0.6.

 

Here is the javascript code to display the map:

<script type="text/javascript" src="http://jj.revolvermaps.com/2/4.js?i=9unk47tnjzg&m=0&h=100&c=ff0000&r=0" async="async"></script>

Any ideas on how to make the "RevolverMaps" widget appears on the right column?

 

Great module by the way...

Multi-language feature would make this module a must have...

 

 

Cheers

Dan

Edited by papagino (see edit history)

Share this post


Link to post
Share on other sites

Hello,

 

I try to use it in PS 1.4.2.5 but nothing happends when I click "save settings". It only shows the text "enter the code here".

Share this post


Link to post
Share on other sites

it doesnt matter what kind of code youre trying to use? for example "TEST" ?

Share this post


Link to post
Share on other sites

do I need to use head or body tags using this? I assume not. Also do I use the javascript and css code directly in the same box says source code?

Share this post


Link to post
Share on other sites

new version released!

- module contains now: extended tinymce editor in prestashop 1.6

- buttons to turn on / off editor in prestashop 1.6

Share this post


Link to post
Share on other sites

Hi, 

 

great modul, but I dont know how to make two columns responsive in this module.

 

Please for hint ...

 

 

 

 

 

Prestashop HTML block module



--- for free ---


works with: 1.2.x + 1.3.x. + 1.4.x + 1.5.x + 1.6.x


This module is great tool for adding to your shop widgets created by other websites like twitter, facebook, pinterest, allegro, etc. Main feature in this module is an ability to add the "client side" code such like HTML, javascript, css for any place you want.




htmlbox-free-big.png





updates of the module
version | date
 

1.5.1 | 19.05.2014

1.5.0 | 01.04.2014

1.4.9 | 10.03.2014

1.4.8 | 19.02.2014

1.4.7 | 18.12.2013

1.4.6 | 11.12.2013

1.4.5 | 30.10.2013

1.4.4 | 23.09.2013

1.4.3 | 27.08.2013
1.4.2 | 13.05.2013
1.4.1 | 29.04.2013
1.3.0 | 07.11.2012

download file:

 

 

 

 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

you have to use code like

<div class="col-sm-3 clearfix">
first
</div>
<div class="col-sm-3 clearfix">
second
</div>

Share this post


Link to post
Share on other sites

Thank you ... and Idea how to make also pictures responsive in your module? For now is like that: http://in-sight.si/

 

 

 

 

you have to use code like

<div class="col-sm-3 clearfix">
first
</div>
<div class="col-sm-3 clearfix">
second
</div>

Share this post


Link to post
Share on other sites

Hello, is it possible to add this module on another page of my website, or only the homepage?

Best regards,

Share this post


Link to post
Share on other sites

module uses hooks (positions) that are a part of other pages as well as the homepage.

Share this post


Link to post
Share on other sites

Hi thanks for your answer. I have already a homepage at http://aw10.fr and I would like to use your module on "Témoignages" page (you can see it on the navigation / menu ).

How could I do that?

 

Best regards,

Share this post


Link to post
Share on other sites

this feedback module is not fully compatibile with your ps version.

it use old way to create pages (you see viewfeedback.php file)

if module will use properway you will be able to define exceptions under modules > positions tab.

 

im affraid that at the moment you will not be able to do it.

Share this post


Link to post
Share on other sites

new version released!

- module supports displayNav hook in prestashop 1.6

  • Like 3

Share this post


Link to post
Share on other sites

hi, i cannot use visit counter javascript in 1.6

 

is it a bug?

Share this post


Link to post
Share on other sites

it's not related to module, but to script you're trying to use

Share this post


Link to post
Share on other sites

Thanks! This module was exactly what I needed for putting some campaign info on our shop page! Simple, straight to the point, no fluff or bloat. Good, fitting set of options. ++!

 

PS 1.5.5.0, using @ right column on default theme.

 

Nice work, keep it up!

Share this post


Link to post
Share on other sites

Hello , how i can added it to hook displayRightColumnProduct?

Share this post


Link to post
Share on other sites

hello - module doesnt support this hook.

Share this post


Link to post
Share on other sites

May be you know a module ( payed)  , supporting this hook , that can add html , per category basis?

 

For example

At your html pro module ( witch i have:) ) .

I would like to  have

► Option to add several html blocks

►add html to each and select hook for each

►select categories and / or products at witch each html will be displayed

 

Thanks !

Share this post


Link to post
Share on other sites

displayRightColumnProduct = extraRight

you can use html box pro and place contents to extraRight hook


 

► Option to add several html blocks

 

module allows to add several blocks :-)

 

 

►add html to each and select hook for each

 

 

hmm don't understand

 

 

 

►select categories and / or products at witch each html will be displayed

module has got this feature :-)

  • Like 1

Share this post


Link to post
Share on other sites

May be i have an older version? I have html box pro 1.5.2

There is no option for adding multiple blocks per hook

For how long i can download updates ? ( I have " Free updates time expired" at my account")

Share this post


Link to post
Share on other sites

Ok , i I bought your module , Product page content blocks ,

It fits my needs :)  .

I wish only to could assign each block also to categories , not only to every individual product

Thanks!

Share this post


Link to post
Share on other sites

May be i have an older version? I have html box pro 1.5.2

There is no option for adding multiple blocks per hook

For how long i can download updates ? ( I have " Free updates time expired" at my account")

 

yes

you've got very very old version ;) at the moment module is in 2.5.89 version and has got so many new features... a lot of!

we offer one year free updates and support time

Ok , i I bought your module , Product page content blocks ,

It fits my needs :)  .

I wish only to could assign each block also to categories , not only to every individual product

Thanks!

 

exactly as we discussen on PM - tommorow morning i will talk about this great feature with my teammates

im more than convinced that it will be possible and available quickly ;-)

  • Like 1

Share this post


Link to post
Share on other sites

Ciao,

sul mio sito ho installato questo modulo http://www.prestashop.com/forums/topic/246765-free-html-block-module/ che ho utilizzato per creare un menù orizzontale come dal sito www.shopdileo.it

 

ho però un piccolo problema: in italiano funziona benissimo ma se seleziono la lingua inglese (ad esempio) cliccando poi sulle immagini si ritorna alla versione italiana.

E' chiaramente un problema di link, ma come faccio a predisporre le diverse versioni? 

C'è un codice html apposito?

 

Grazie

Share this post


Link to post
Share on other sites

hello

any chance to rewrite text in english? :-)

Share this post


Link to post
Share on other sites
Hello, 

on my website I installed this module http://www.prestasho...l-block-module/ that I used to create a horizontal menu like the site www.shopdileo.it 

 

I have a small problem, however: in Italian it works fine but if I select the English language (for example) then clicking on the pictures you will return to the Italian version. 

It 'clearly a problem of links, but how do I set up the different versions? 

There is a special html code? 

 

Thank you

Share this post


Link to post
Share on other sites

hello

free version hasn't got feature to define contents in various languages.

pro version: html box pro has got feature to define different code for each language

it means that you will be able to define new links depending on language version of the website.

 

so, at the moment free version doesnt support this feature.

  • Like 1

Share this post


Link to post
Share on other sites

 

 

but when you enter the code in the module google remarketing 

can you show example of the code, please?

Share this post


Link to post
Share on other sites

Copied exactly by Google replaces only two numbers at symbol (?)

<!-- Código do Google para tag de remarketing --><!--------------------------------------------------As tags de remarketing não podem ser associadas a informações pessoais de identificação nem inseridas em páginas relacionadas a categorias de confidencialidade. Veja mais informações e instruções sobre como configurar a tag em: http://google.com/ads/remarketingsetup---------------------------------------------------><script type="text/javascript">/* <![CDATA[ */var google_conversion_id = 10059626??;var google_custom_params = window.google_tag_params;var google_remarketing_only = true;/* ]]> */</script><script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js"></script><noscript><div style="display:inline;"><img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/10059626??/?value=0&guid=ON&script=0"/></div></noscript>
Edited by franzneves (see edit history)

Share this post


Link to post
Share on other sites

okay so paste this code without tinymce editor (it must be disabled)

after save, do you see the same code in place where you pasted code?

 

how it looks like in front office in page source?

Share this post


Link to post
Share on other sites

try to use code like:

<script type="text/javascript">
var google_conversion_id = 10059626??;
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
</script>
<script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
</script>
<noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/10059626??/?value=0&guid=ON&script=0"/>
</div>
</noscript>

it is splitted because new ps unfortunately works like that (it splits scripts and move them to footer section)

Share this post


Link to post
Share on other sites

strange, because code still has got CDATA code

while you save contents don't use tinymce editor, save block without it

Share this post


Link to post
Share on other sites

I saved without CDATA without tinymce editor, and then appear without me typing.

Share this post


Link to post
Share on other sites

Hi Vekia, great module, thanks for sharing. I used on the right column on www.kamer-stukken.com. However I would like to apply my own CSS style to it, specially designed for this item. How can I do that? I added CSS code to global.css but that did not work. Suggestions are more than welcome. 

Share this post


Link to post
Share on other sites

hello Vekia,
I am trying to test your module, it's not bad, but still I am having display problem, ie, using the 1.6 version of PrestaShop, I stuck my source in the section reserved for that party, before confirming that I visualized here must give the final, here is good, but after the final backup, there is nothing to display, I put a text to make sure that I 'appears in the correct position, and it works. but still nothing in the end.
I saw that you were talking about CDATA outside my code includes this statement, which reads the extract.

<a href="http://www.xiti.com/xiti.asp?s=114900" title="WebAnalytics" target="_top">
<script type = "text / javascript">
<! -
Xt_param = 's = 114900 & p =;
try {Xt_r = top.document.referrer;}
catch (e) {= Xt_r document.referrer; }
Xt_h = new Date ();
Xt_i = '<img width = "80" height = "15" border = "0" alt = "";
Xt_i + = 'src = "http://logv22.xiti.com/vcg.xiti?'+Xt_param;
Xt_i + = '& hl =' + Xt_h.getHours () + 'x' + Xt_h.getMinutes () + 'x' + Xt_h.getSeconds ();
if (parseFloat (navigator.appVersion)> = 4)
{Xt_s = screen; Xt_i + = '& r =' + Xt_s.width + 'x' + Xt_s.height + 'x' + Xt_s.pixelDepth + 'x' + Xt_s.colorDepth;}
document.write (Xt_i + '& ref =' + Xt_r.replace (/ [<> "] / g, '') .replace (/ & / g, '$') + '" title = "Internet Audience">') ;
// ->
</ script>
<noscript>
Audience measurement Social network <img width = "80" height = "15" src = "http://logv22.xiti.com/vcg.xiti?s=114900&p=" alt = "WebAnalytics" />
</ noscript> </a>

 

 

 

And, recording a currently a CDATA code
here it is:

 

 

<p><a title="WebAnalytics" href="http://www.xiti.com/xiti.asp?s=114900" target="_top">
<script>// <![CDATA[
Xt_param = 's=114900&p=; try {Xt_r = top.document.referrer;} catch(e) {Xt_r = document.referrer; } Xt_h = new Date(); Xt_i = '<img width="80" height="15" border="0" alt="" '; Xt_i += 'src="http://logv22.xiti.com/vcg.xiti?'+Xt_param; Xt_i += '&hl='+Xt_h.getHours()+'x'+Xt_h.getMinutes()+'x'+Xt_h.getSeconds(); if(parseFloat(navigator.appVersion)>=4) {Xt_s=screen;Xt_i+='&r='+Xt_s.width+'x'+Xt_s.height+'x'+Xt_s.pixelDepth+'x'+Xt_s.colorDepth;} document.write(Xt_i+'&ref='+Xt_r.replace(/[<&gt]/g, '').replace(/&/g, '$')+'" title="Internet Audience">');
// ]]></script>
</a></p>
<noscript>Mesure d'audience ROI statistique webanalytics par <img width="80" height="15" src="http://logv22.xiti.com/vcg.xiti?s=114900&p=" alt="WebAnalytics" /></noscript><!-- Place this tag where you want the +1 button to render. -->
<div class="g-plusone" data-annotation="inline" data-width="300"> </div>



Or how I have this chance to get things running.
Thank you in advance and congratulations for your work.
best regards
Mytika

Edited by mytika (see edit history)

Share this post


Link to post
Share on other sites

new version released!


- added improvements to installation procedure


- added improvements to appearing of js scripts in code


Share this post


Link to post
Share on other sites

moved

 

 

Hi,

 

Kan ik deze module ook plaatsen in de productpagina op displayRightColumnProduct?

Share this post


Link to post
Share on other sites

Hi vekia, does your HTML block module free version support multi-language?

  • Like 1

Share this post


Link to post
Share on other sites

Hello,

 

It isn't possible to download your module now ?

 

Tetra

 

hello

why it isn't possible? can you shed some more light, on this, pleasE?

Share this post


Link to post
Share on other sites

Nice product but i can't get a picture in it (uploading a picture seems to work,but it shows nothing in the footer), i mean not from my own  domain.

If i use a picture from an other domain it works and is visual in my footer...

 

example site with picture from other domain:

http://www.pliekwebdesign.nl/shop/prestashop/powerbooster-lite-window-7/10-powerbooster-lite-windows-7.html

 

Please show wat to do.

 

My scrip looks like this:

<section id="block_various_links_footer" class="footer-block col-xs-12 col-sm-1">
<h4>Social</h4>
<section id="social_block" style="margin-left: 25px !important;">
<ul>
<li class="twitter"><a href="https://twitter.com/Powerbooster1" target="_blank"> <span> Twitter </span> </a>
<h2></h2>
</li>
<li class="youtube"><a href="https://www.youtube.com/watch?feature=player_embedded&v=Aj5aLhLBXDY" target="_blank"></a></li>
</ul>
</section>
</section>
<section id="block_various_links_footer" class="footer-block col-xs-12 col-sm-7"><img src="http://www.powerboosters.org/wp-content/uploads/Virus2.png" alt="Virus" align="left" height="158" width="168" />In Powerbooster zitten geen virussen en trojan horses, backdoors enz. Omdat er voorheen signalen waren betreffende false positives, bieden we u de mogelijkheid dit meteen te checken na het voltooien van de installatie. PowerBooster is volledig schoon van virussen, rootkits, malware, trojans, al zijn er helaas bestanden die gezien worden als onveilig. Deze melding(en) zijn false positives en kunnen dus genegeerd worden. Melding van Unlocker en WirelessKeyView zijn bekend en zijn niet gevaarlijk!. Eset is een van de beste, zo niet de beste scanner die er is. Microsoft Security Essentials is ook een goede, en voor particulier gebruiker zijn de Security Essentials zelfs gratis. <a class="normal" href="http://windows.microsoft.com/nl-BE/windows/products/security-essentials/download" title="Microsoft Security Essentials downloaden" style="color: #ffffff;">Microsoft Security Essentials downloaden.</a></section>

Thanks in advance

Edited by Powerbooster (see edit history)

Share this post


Link to post
Share on other sites

Hi, for some reason I cannot install this module properly? I was using it poreviously and uninstalled it. Now I am trying to reinstall it again but it shows the option to enable, but wont actually enable when I click on the button. Any ideas? Thanks a lot

Share this post


Link to post
Share on other sites

Nice product but i can't get a picture in it (uploading a picture seems to work,but it shows nothing in the footer), i mean not from my own  domain.

If i use a picture from an other domain it works and is visual in my footer...

 

example site with picture from other domain:

http://www.pliekwebdesign.nl/shop/prestashop/powerbooster-lite-window-7/10-powerbooster-lite-windows-7.html

 

Please show wat to do.

 

My scrip looks like this:

<section id="block_various_links_footer" class="footer-block col-xs-12 col-sm-1">
<h4>Social</h4>
<section id="social_block" style="margin-left: 25px !important;">
<ul>
<li class="twitter"><a href="https://twitter.com/Powerbooster1" target="_blank"> <span> Twitter </span> </a>
<h2></h2>
</li>
<li class="youtube"><a href="https://www.youtube.com/watch?feature=player_embedded&v=Aj5aLhLBXDY" target="_blank"></a></li>
</ul>
</section>
</section>
<section id="block_various_links_footer" class="footer-block col-xs-12 col-sm-7"><img src="http://www.powerboosters.org/wp-content/uploads/Virus2.png" alt="Virus" align="left" height="158" width="168" />In Powerbooster zitten geen virussen en trojan horses, backdoors enz. Omdat er voorheen signalen waren betreffende false positives, bieden we u de mogelijkheid dit meteen te checken na het voltooien van de installatie. PowerBooster is volledig schoon van virussen, rootkits, malware, trojans, al zijn er helaas bestanden die gezien worden als onveilig. Deze melding(en) zijn false positives en kunnen dus genegeerd worden. Melding van Unlocker en WirelessKeyView zijn bekend en zijn niet gevaarlijk!. Eset is een van de beste, zo niet de beste scanner die er is. Microsoft Security Essentials is ook een goede, en voor particulier gebruiker zijn de Security Essentials zelfs gratis. <a class="normal" href="http://windows.microsoft.com/nl-BE/windows/products/security-essentials/download" title="Microsoft Security Essentials downloaden" style="color: #ffffff;">Microsoft Security Essentials downloaden.</a></section>

Thanks in advance

 

how the code looks like after save?

Share this post


Link to post
Share on other sites

Hi, for some reason I cannot install this module properly? I was using it poreviously and uninstalled it. Now I am trying to reinstall it again but it shows the option to enable, but wont actually enable when I click on the button. Any ideas? Thanks a lot

 

the same with other not default modules?

Share this post


Link to post
Share on other sites

how the code looks like after save?

<section id="block_various_links_footer" class="footer-block col-xs-12 col-sm-1">
<h4>Social</h4>
<section id="social_block" style="margin-left: 25px !important;">
<ul>
<li class="twitter"><a href="https://twitter.com/Powerbooster1" target="_blank"> <span> Twitter </span> </a>
<h2></h2>
</li>
<li class="youtube"><a href="https://www.youtube.com/watch?feature=player_embedded&v=Aj5aLhLBXDY" target="_blank"></a></li>
</ul>
</section>
</section>
<section id="block_various_links_footer" class="footer-block col-xs-12 col-sm-7" style="text-align: justify;"><img src="../img/cms/virus.png" alt="Virus" style="margin-right: 10px;" align="left" height="163" width="174" />In Powerbooster zitten geen virussen en trojan horses, backdoors enz. Omdat er voorheen signalen waren betreffende false positives, bieden we u de mogelijkheid dit meteen te checken na het voltooien van de installatie. PowerBooster is volledig schoon van virussen, rootkits, malware, trojans, al zijn er helaas bestanden die gezien worden als onveilig. Deze melding(en) zijn false positives en kunnen dus genegeerd worden. Melding van Unlocker en WirelessKeyView zijn bekend en zijn niet gevaarlijk!. Eset is een van de beste, zo niet de beste scanner die er is. Microsoft Security Essentials is ook een goede, en voor particulier gebruiker zijn de Security Essentials zelfs gratis. <a class="normal" href="http://windows.microsoft.com/nl-BE/windows/products/security-essentials/download" title="Microsoft Security Essentials downloaden" style="color: #ffffff;">Microsoft Security Essentials downloaden.</a></section>

Just dit a new upload to the shop and now it's all working!!!

The code shows the picture form ../img/cms/ and now it shows the picture in the footer!

Don't know why it did'nt work in first place, but i am happy it does now!

 

Sorry for this inconvenience, like your addon though vekia.

 

Greetzzz

Share this post


Link to post
Share on other sites

the same with other not default modules?

 

No, I thought that I had maybe turned non-presta modules off but it is not the case. Any other thoughts? Thanks for the quick reply.

Share this post


Link to post
Share on other sites

turn on error reporting and try to enable this module

do you see some error messages then?

Share this post


Link to post
Share on other sites
<section id="block_various_links_footer" class="footer-block col-xs-12 col-sm-1">
<h4>Social</h4>
<section id="social_block" style="margin-left: 25px !important;">
<ul>
<li class="twitter"><a href="https://twitter.com/Powerbooster1" target="_blank"> <span> Twitter </span> </a>
<h2></h2>
</li>
<li class="youtube"><a href="https://www.youtube.com/watch?feature=player_embedded&v=Aj5aLhLBXDY" target="_blank"></a></li>
</ul>
</section>
</section>
<section id="block_various_links_footer" class="footer-block col-xs-12 col-sm-7" style="text-align: justify;"><img src="../img/cms/virus.png" alt="Virus" style="margin-right: 10px;" align="left" height="163" width="174" />In Powerbooster zitten geen virussen en trojan horses, backdoors enz. Omdat er voorheen signalen waren betreffende false positives, bieden we u de mogelijkheid dit meteen te checken na het voltooien van de installatie. PowerBooster is volledig schoon van virussen, rootkits, malware, trojans, al zijn er helaas bestanden die gezien worden als onveilig. Deze melding(en) zijn false positives en kunnen dus genegeerd worden. Melding van Unlocker en WirelessKeyView zijn bekend en zijn niet gevaarlijk!. Eset is een van de beste, zo niet de beste scanner die er is. Microsoft Security Essentials is ook een goede, en voor particulier gebruiker zijn de Security Essentials zelfs gratis. <a class="normal" href="http://windows.microsoft.com/nl-BE/windows/products/security-essentials/download" title="Microsoft Security Essentials downloaden" style="color: #ffffff;">Microsoft Security Essentials downloaden.</a></section>

Just dit a new upload to the shop and now it's all working!!!

The code shows the picture form ../img/cms/ and now it shows the picture in the footer!

Don't know why it didn't work in first place, but i am happy it does now!

 

Sorry for this inconvenience, like your addon though vekia.

 

Greetzzz

 

Nope this morning i opened the shop and only the text alt="Virus" was shown. I looked at the html properties of the image on my page and it says:

Not Found

The requested URL /shop/img/cms/virus.png was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

This is not correct because the image is in directorie:  /shop/prestashop/img/cms/virus.png.

I see when importing a picture the directorie that is shown is ../img/cms/virus.png

the complete url is: http://www.pliekwebdesign.nl/shop/img/cms/virus.png and should be http://www.pliekwebdesign.nl/shop/prestashop/img/cms/virus.png

 

I adjusted the code myself manually to ../prestashop/img/cms/virus.png and then it al works.

But what is wrong, it seems that the html-add-on writes code that is in one directorie to low, it skips the folder "pretashop".

Is there any way to adjust this in a .tpl file or something?

 

Hope to solve this..

 

Gr. Mark

Edited by Powerbooster (see edit history)

Share this post


Link to post
Share on other sites

html box pro > settings > prevent removing urls from picture urls.

Share this post


Link to post
Share on other sites

html box pro > settings > prevent removing urls from picture urls.

I will surely try this.

right now busy with a new install of ps.

Share this post


Link to post
Share on other sites

thanks for making this for free. Until now I was able to find only similar modules that I have to pay for

Share this post


Link to post
Share on other sites

@vekia, I appreciate you taking the time to build this helpful module.

 

I've successfully added the module to PS 1.6.0.6 and added a link to the footer. Is there a way to make the htmlbox module "resemble and line-up to the other footer area blocks." I've added a photo in this post to illustrate the idea as I've noticed on various screen sizes that htmlbox isn't similar in appearance.

 

Best!

post-840946-0-20704100-1411580313_thumb.jpg

Share this post


Link to post
Share on other sites

Hello vekia!

Installed your modul and trying to ad the adroll smartpixel. where do I have to insert it? header or footer so that it is before the </body>? - I have no idea about java, html or things like that.

Share this post


Link to post
Share on other sites

hy

i have 3 product category, how can i assign 3 different html block for each page?

 

thank you

PS1,5

Share this post


Link to post
Share on other sites

new version released!

added minor improvements related to module installation

  • Like 1

Share this post


Link to post
Share on other sites

Hello,

 

I don't think my problem is related to this module but I got the problems with this module and did not know where to adress my problem. 

 

I am trying to make an simple table with html box one cell 67% the other 33%. I want to add the same text in it and I want the text be left justify and start from the top in booth cells. When I am using the html command <td width="67%" valign="top"> for cell 1 and <td width="33%" valign="top"> for cell 2 everything looks good inte the editor, but in the fronted it does not use the valign command. You can see the result at www.develop3.se. My question is how can I get booth cells starts from top positions. Please give me the right html code to do this.

 

T

Share this post


Link to post
Share on other sites

new version released!

- added improvements to saving block in the database

- minor fixes for installation function

  • Like 1

Share this post


Link to post
Share on other sites

I have a question this module is for editing the presentation of prestashop template ie if I want to change the design of the slider or the menu bar?


thank you very much for your attention.

Share this post


Link to post
Share on other sites

Really cool module and thanks for sharing for free with the comunity.

 

However i have a question. It is possible do get it working with two languages.

 

Doent matter anymore i solved the problem

Edited by TFPtMaster (see edit history)

Share this post


Link to post
Share on other sites

Hello,

i want to use this module for insert script but no result.

I have PS 1.4.8

 

code is:

 

<div id="showHeurekaBadgeHere-12"></div><script type="text/javascript">
//<![CDATA[
var _hwq = _hwq || [];
    _hwq.push(['setKey', '09151F8C4FB34D14C7EC89CEDB2FEA5B']);_hwq.push(['showWidget', '12', '31645', 'HaVita.cz', 'havita-cz']);(function() {
    var ho = document.createElement('script'); ho.type = 'text/javascript'; ho.async = true;
    ho.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.heureka.cz/direct/i/gjs.php?n=wdgt&sak=09151F8C4FB34D14C7EC89CEDB2FEA5B';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ho, s);
})();
//]]>
</script>

 

Do you know anybody where problem is?

Thank for everybody and happy new year : )

Share this post


Link to post
Share on other sites

 

 

for insert script but no result.

what you mean by no result?

code is saved and appears in back office? 

or it just doesnt want to appear in front office?

 

  • Like 1

Share this post


Link to post
Share on other sites

Hello Vekia,

 

Would love to know how to make a responsive image using your html box, I have tried:

 

img class="img-responsive"src="http://my site/my image.jpg

 

but this does not work.

 

I would appreciate your help

 

Paul.

 

Ps. the "New" forum layout is a bit spooky

 

Paul

Share this post


Link to post
Share on other sites

Hello Vekia,

 

Would love to know how to make a responsive image using your html box, I have tried:

 

img class="img-responsive"src="http://my site/my image.jpg

 

but this does not work.

 

I would appreciate your help

 

Paul.

 

Ps. the "New" forum layout is a bit spooky

 

Paul

 

 

your theme uses bootstrap ?

Share this post


Link to post
Share on other sites

Hello Vekia

 

Well, Yes and No. The default theme is PS 1.6.0.8 but the theme I use is for PS 1.5 and 1.6

 

If you look at my signature you will see.

 

I do have a few problems with modules I buy because some will work and some do not.

 

For Instance, the menu will not work on bootstrap

 

Paul

Share this post


Link to post
Share on other sites

class=img-responsive will work only in themes that uses bootstrap.

 

if code that you use in editor will appear in front end - it;s not a problem with module, it's a case of wrong code.

in this case it will be necessary to change code.

Share this post


Link to post
Share on other sites

Hello Vekia, thank you for the reply,

 

I assumed it was my mistake but I am still not sure what the code should be.

 

Hear is an example of four images:

 

<br>
<table border="0" width="1180px">
<tbody>
<tr>
<td><a href="http://aissia.co.uk/19-lingerie"><img class="img-responsive" src="/img/cms/logo lingerie.jpg" alt="Great Lingerie from aissia.co.uk" width="276" height="227"  align="left" /></a></td>
<td><a href="http://aissia.co.uk/16-sex-toys"><img class="img-responsive" src="/img/cms/logo sex toys.jpg" alt=""width="296" height "227" align="left" /></a></td>
<td><a href="http://aissia.co.uk/153-sex-toys-for-men"><img class="img-responsive" src="/img/cms/logo male sex toys.jpg" alt="" width="296" height "227"align="right" /></a>
</td>
<td><a href="http://aissia.co.uk/12-games"><img class="img-responsive" src="/img/cms/logo fun and games.jpg" alt="" width="276" height="227"align="right" /></a>
</td>
</tr>
</tbody>
</table>
 
Any help would be appreciated
 
Paul

Share this post


Link to post
Share on other sites

ok so after installing this module , i created a new menu on the top just right above the Top horizontal menu , it worked really well and perfect on firefox , internet explorer , but on opera and chrome .. it appears to be a BOMB..!!!! please help what should i do ...? thanks in advance and HAPPY NEW YEAR..  :) :)

Share this post


Link to post
Share on other sites

hello

it's not a case of module but a case of code that you use.

you have to be sure that your code is compatibile with opera and other browsers

Share this post


Link to post
Share on other sites

new version ready

download link available in first message of this post (file attached as an attachment)

module supports now prestashop cloud (module is trusted by addons store)

Share this post


Link to post
Share on other sites

I'm using a custom theme. I want to add an image in the right column that resizes as user changes the window size.

 

I have added a heading plus following in HTML Box:

<div class="block_testimonials" style="background: url('../img/cms/testimonies.png');"></div>

 

The image appears, so am assuming link is OK. I then added following to CSS:

.block_testimonials { 

background-repeat: no-repeat;

display: block;

}

 

However, while the text that I added appears, the image doesn't. Any ideas why?

 

Thanks.

Share this post


Link to post
Share on other sites

I can't get the following code to work in this module..

<!-- GeoTrust QuickSSL [tm] Smart  Icon tag. Do not edit. -->
<script language="javascript" type="text/javascript" src="//smarticon.geotrust.com/si.js"></script>
<!-- end  GeoTrust Smart Icon tag -->

any thoughts? Running 1.6.0.12, and v1.5.4 of your module.

 

edit:

welp, I take it back, it is displaying the code, just on the VERY bottom of the footer, below EVERYTHING.  I wanted it right next to the Paypal verified icon in the footer.

 

www.pagankitchen.com

Edited by SLiCK_303 (see edit history)

Share this post


Link to post
Share on other sites

you run option to move js scripts to the bottom of the shop

(preferences > performance)

as long as you will use this option, scripts will be moved to the bottop part of shop

Share this post


Link to post
Share on other sites

hi,

is there any way to use this module plus than once time in a single prestashop site?

maybe is my fail, but many prestashop modules avoid to create istances of the same module (the only i found that allow this function is rev. slider)

any ideas?

thanx in advance.

Share this post


Link to post
Share on other sites

doesn't work at all with javascript. even with a simple code like this:

<html>
<head>
<script type="text/javascript">
function myFunction(){
alert("hello");
}
</script>
</head>
<body>
<input type="submit" onClick="myFunction()">
</body>
</html>

please provide a small example like a hello world function to make it work. sorry im newbie.

Share this post


Link to post
Share on other sites