Jump to content

Prestashop 1.5 Final ahora disponible! (Actualmente 1.5.6.2)


nadie
 Share

Recommended Posts

Estoy haciendo pruebas con la nueva versión 1.5.0.14 y hasta ahora estoy muy contento y gratamente sorprendido. Enhorabuena!

 

El asunto es que me he dado cuenta que al crear varias tiendas, en mi caso he creado 3. Cada tienda está en su grupo de tienda correspondiente y no comparten entre ellas.

 

Pues bien, en una de las tiendas he configurado el módulo "imagen de control deslizante para su página web" y resulta que aparece en todas las tiendas los mismos slides.

 

¿No es posible configurar los slides para cada una de las tiendas por separado?

 

Tal vez he hecho algo mal, a ver si me podéis ayudar.

 

Muchas gracias por todo.

Share this post


Link to post
Share on other sites

Bueno,ante todo felicitaros por el foro,es mi primer mensaje pero os suelo leer bastante,tengo una duda respecto a esta nueva version,y es que estoy utilizando la version 1.4.5 y me disponía a comprar un tema de prestashop addons que dice ser compatible con la 1.4.7,y la cuestión es que veo que aunque aun no se debe usar la version nueva(1.5)en producción en el futuro tendré que realizar las actualizaciones de la version por lo que la duda me surje en cuanto a si el tema después de haberlo comprado en addons me va a dejar de funcionar o no va a funcionar correctamente una vez este en la version 1.5 y superiores,he leído gente que dice que no le funcionan ,otras personas dicen que no actualice(por seguridad no me parece

Correcto)y luego hay otras que dicen que se desactiven ciertas funciones de la version nueva como el smarty3,y las ponga como si fuera la version antigua),lo cual no me

Dejaría aprovechar al máximo la nueva version,la verdad que comprándolo en prestashop addons no pensaba que dieran problemas y presuponía que los temas comprados en addons

Siempre serian compatibles con las nuevas actualizaciones,saludos

Share this post


Link to post
Share on other sites

Bueno,ante todo felicitaros por el foro,es mi primer mensaje pero os suelo leer bastante,tengo una duda respecto a esta nueva version,y es que estoy utilizando la version 1.4.5 y me disponía a comprar un tema de prestashop addons que dice ser compatible con la 1.4.7,y la cuestión es que veo que aunque aun no se debe usar la version nueva(1.5)en producción en el futuro tendré que realizar las actualizaciones de la version por lo que la duda me surje en cuanto a si el tema después de haberlo comprado en addons me va a dejar de funcionar o no va a funcionar correctamente una vez este en la version 1.5 y superiores,he leído gente que dice que no le funcionan ,otras personas dicen que no actualice(por seguridad no me parece

Correcto)y luego hay otras que dicen que se desactiven ciertas funciones de la version nueva como el smarty3,y las ponga como si fuera la version antigua),lo cual no me

Dejaría aprovechar al máximo la nueva version,la verdad que comprándolo en prestashop addons no pensaba que dieran problemas y presuponía que los temas comprados en addons

Siempre serian compatibles con las nuevas actualizaciones,saludos

 

Primero ...

 

La versión que hay ahora es RC, que no es final, es candidata, y solo es recomendable para probarlo, y testearla, sacar errores y comunicarlos, pero nunca, para usar en producción, hasta que saque la versión final.

 

Las plantilla desde la 1.4, deben trabajar sobre smarty 3.

 

Lógicamente prestashop 1.5, no es una excepción, y las plantillas trabajan sobre smarty 3 también, pero eso no quiere decir tu plantilla sea totalmente compatible con la 1.5, pues han cambiado algunas cositas....

 

Cuando compras en addons, compras una plantilla para una versión o rango de versiónes especificas, algunas desarrolladores, ofrecen la actualización gratuita, otros, tendrás que comprar la plantilla de nuevo, para que sea totalmente compatible y funcional con prestashop 1.5.

  • Like 1

Share this post


Link to post
Share on other sites

Muchas gracias nadie,entonces que me aconsejarías?,es que estoy haciendo una pagina que iba a lanzar en septiembre pero me encuentro con esto,voy a preguntar al desarrolladore para ver si realizaría la actualización gratuita,de todas formas,cuanto suele tardar en salir la definitiva 1.5,me imagino que los 2 o 3 meses para solventar errores como mínimo,gracias

Share this post


Link to post
Share on other sites

cuanto suele tardar en salir la definitiva 1.5,me imagino que los 2 o 3 meses para solventar errores como mínimo,gracias

 

Desconozco el día exacto de la salida de la versión 1.5 Final, prestashop dice que esta cerca, pero no hay fecha oficial.

Share this post


Link to post
Share on other sites

Hola, estoy como todos me imagino haciendo pruebas en la 1.5 RC,

he probado a editar el archivo /controllers/admin/AdminOrdersController.php cambiando en la linea 39 para que salga el icono de la papelera que oculta los pedidos pero no funciona.

 

34 $this->table = 'order';

35 $this->className = 'Order';

36 $this->lang = false;

37 $this->addRowAction('view');

38

39 $this->deleted = false; he cambiado este false por un true

40 $this->context = Context::getContext();

 

 

Alguien lo ha probado... ya se que para borrar los pedidos de prueba hay que hacer un borrado de las tablas x en la base de datos pero esta modificación servia para ocultar los pedidos que habían sido cancelados y puestos a 0.

 

Esto se hacia en la 1.3 y la 1.4 para ocultar los pedidos en el panel de administración, pero no se borraban definitivamente, de forma que se podían recuperar desde la base de datos. (Algunos dicen que pueden generar pedidos fantasma pero la verdad que nunca, por lo menos a mi, me ocurrió esto.)

Edited by aqui (see edit history)

Share this post


Link to post
Share on other sites

Buenas noches, les consulto cual es la política de actualización de módulos pagos cuando este estable las versión 1.5, los actualizan gratis ? se tienen que volver a pagar ?

 

Gracias

Share this post


Link to post
Share on other sites

Buenas noches, les consulto cual es la política de actualización de módulos pagos cuando este estable las versión 1.5, los actualizan gratis ? se tienen que volver a pagar ?

 

Gracias

Si te refieres a módulos que has comprado, dependerá del desarrollador, algunos desarrolladores te ofrecerán la actualización gratuita, otros tendrás que comprarla.

 

O te refieres a otro tema?

Share this post


Link to post
Share on other sites

Si te refieres a módulos que has comprado, dependerá del desarrollador, algunos desarrolladores te ofrecerán la actualización gratuita, otros tendrás que comprarla.

 

O te refieres a otro tema?

Si correcto, te agradezco mucho la pronta respuesta.

Share this post


Link to post
Share on other sites

Los modulos de pago de presta seran gratuitos.

Los de terceros pues es muy relativo. Si lo compraste en addons y lo actualizan , accederas gratuitamente

 

Gracias, muy buena informacion.

Share this post


Link to post
Share on other sites

Un placer ayudarte y servirte!

Un saludo y recuerda que estaremos por el foro, para guiarte por este mundo oscuro y tenebroso.

 

Gracias 1000, gente como ustedes hacen que la gente se anime a entrar a este mundo de grandes oportunidades.

Share this post


Link to post
Share on other sites

Gracias 1000, gente como ustedes hacen que la gente se anime a entrar a este mundo de grandes oportunidades.

Gracias a usted, por confiar en la comunidad de prestashop.

Share this post


Link to post
Share on other sites

Nadie. Estoy chequeando la 1.5.13 y me he encontrado un problema que no tenía la 1.4.

En la 1.4 si personalizabas un producto con un campo texto, este te lo incluía en la linea de nombre y atributos del producto en los correos. Tanto en la orden de confirmación como en nuevo pedido. En la versión 1.5 el dato no aparece en ningún correo, está en la pestaña de pedidos de back office, pero en los correos que recibe tanto el cliente como en las alertas de la tienda no está por ningún lado. ¿Hay alguna forma de que se visualice en alguno, por ejemplo en la alerta de nuevo pedido?

Share this post


Link to post
Share on other sites

Eso espero Snacker. Por cierto me encanta la página de onlinersi. Por fin empieza a haber cosas para la 1.5 y además, aparte de todo lo que hay gratis, creo que los precios no son obstáculo para tener una tienda en condiciones.

Share this post


Link to post
Share on other sites

Error en 1.5.

En el bloque de enlaces permanentes hay un error en el enlace de favoritos porque redirecciona mal y en vez de sacar los productos favoritos en pantalla, no hace absolutamente nada.

El enlace de favoritos lo que hace es agregar la pagina al los marcadores de tu navegador, y eso lo hace perfectamente.

 

Un saludo

Share this post


Link to post
Share on other sites

Hola, buenas a todos!

Estoy probando con una plantilla para prestashop 1.5, con la versión RC1 instalada en servidor, pero cuando intento insertar algún producto o añadir alguna imagen, o cambiar precio me salta este error:

"Forbidden

You don't have permission to access /adminxx/index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

 

Imagino que será porque no he cambiado los permisos a ninguna carpeta ni archivo. ¿Hay que modificar las mismas carpetas que para presta 1.4?

 

También me fue imposible acceder al B.O. desde Firefox, tuve que acudir al Opera.

 

Yo esta versión la veo en general bien en cuanto a diseño y prestaciones, pero hasta el momento con bastantes problemas de configuración.

 

Nos tendremos que enseñar de nuevo a manejar un BO que poco tiene que ver con la versión 1.4 o anteriores.

 

Saludos y felicidades por su labor.

Share this post


Link to post
Share on other sites

Hola buenas estoy intentando cambiar los textos del blockreinsudance,por ejemplo el 1 id money back pues dejarlo en devoluciones o no se politica cambios bien lo edito en el panel pues bien en vez de editarlo me crea uno nuevo 6 id y me los añade ha los ya existentes he estado rebuscando por ahi pero no encuentro solucion y seguro que es una tonteria pero no se.

Gracias :)

Share this post


Link to post
Share on other sites

hola a todos yo estaba buscando la opcion de poner el codigo del producto del fabricante o proveedor y no encuentro donde ponerlo en prestashop 1.5, otra cosa mas me parece bien si se puede mostrar la ubicacion del producto en imformaciones del producto el el front office.

 

ejemplo yo hago ventas en mi pagina pero el producto esta en china, usa, japon etc... pero no quiero mostrar en el front office la información del fabricante eso se que es posible en la version 1.4.8.

Share this post


Link to post
Share on other sites

hola a todos yo estaba buscando la opcion de poner el codigo del producto del fabricante o proveedor y no encuentro donde ponerlo en prestashop 1.5, otra cosa mas me parece bien si se puede mostrar la ubicacion del producto en imformaciones del producto el el front office.

 

ejemplo yo hago ventas en mi pagina pero el producto esta en china, usa, japon etc... pero no quiero mostrar en el front office la información del fabricante eso se que es posible en la version 1.4.8.

 

Desde la edición de producto entras en proveedor y ya te sale la opción de poner la referencia del proveedor.

Lo que pasa es que hay un error, resulta que si lo introduces desde aquí, si buscas en el buscador el producto con la referencia del proveedor no lo encontrará. En cambio si esta referencia del proveedor la pones desde una importación de csv si funciona la busqueda con la referencia del proveedor.

 

Esto es debido a que si guardas la referencia del proveedor desde la edición de cada producto, uno a uno, esta referencia la guarda en la tabla ps_product_suplier en el campo product_supplier_reference, pero si se hace desde un csv si funiona bien pues la guarda en ps_product en el campo supplier_reference y asi si funciona busqueda con la referencia del proveedor.

Share this post


Link to post
Share on other sites

En multitienda, al crear la segunda tienda, no me sale la template, solo me salen letras, sin el diseño, me pasaba en la rc1 y continua en la 2.

Gracias y esperemos la estable pronto.

A mi me funcionan varias tiendas sin ningún problema, con distinta o igual plantilla.

Share this post


Link to post
Share on other sites

Estoy de pruebas en una tienda con dos almacenes, es solo una tienda (No multitienda) pero tiene dos almacenes.

 

Estoy probando a meter productos como siempre mediante csv y no veo por ningún lado la opción de asignar los productos mediante csv a un almacen o al otro.

 

Alguien sabe si está previsto poder hacerlo importando productos con un csv la asignación de estos a diferentes almacenes.

Share this post


Link to post
Share on other sites

A mi me funcionan varias tiendas sin ningún problema, con distinta o igual plantilla.

Una pregunta nadie.

 

El otro día estuve trasteando con la multitienda, pero no me quedó del todo claro una cosa. Para que funcione la multitienda, hace falta tener instalada varias tiendas completamente, ¿verdad?.

 

Me imagino que sí, pero lo que pregunto porque con una sóla tienda al activar la opción multitienda, Prestashop me mostraba algo de texto de la segunda tienda, que por supuesto no existía porque no la tenía instalada). Eso sí, lo que es el theme no me lo mostraba :wacko:

 

Un saludo crack.

Edited by jesusruiz (see edit history)

Share this post


Link to post
Share on other sites

No se si os pasa pero da error al actualizar de la r1 a la r2 con el modulo de autoupdate. Error al actualizar la base de datos...

Aparte:

En la r1 hay 2 cosas que me ocurren, una es que si subes productos ... se hacen pedidos y facturas... y luego eliminas los productos de la tienda o los cambias por otros sin mantener los que se habían puesto en esos pedidos, estos desaparecen de los pedidos ya realizados de forma que las facturas de estos pedidos realizados solo sale el total, pero ya no salen los productos que habían en esa factura y/o pedido.

La segunda cosa que me ocurre con la rc1 es que sale como que no esta activado en el server el mod_rewrite cuando si lo está. Creo que esto hace que no funcione bien la redireccion canónica pues si pones el dominio sin las www la respuesta de la página principal sin www es de página no encontrada. En cambio con las www funciona bien.

 

Aun no he podido probar la rc2 limpia ya que intenté actualizar con el método automático y no funciona.... llega casi a actualizar todo, pero da error casi al final, cuando intenta actualizar la base de datos.

 

Espero que en la rc2 estas cosillas estén solucionadas.

Yo la probaré a final de mes

Edited by aqui (see edit history)

Share this post


Link to post
Share on other sites

Hola Aqui,

yo tuve el mismo problema con el mod_rewrite, me salia desactivado cuando realmente no lo estaba, pero no se si era del hosting (godaddy) o del prestashop, lo solucioné poniendo "RewriteBase /" en el htaccess.

El otro problema voy a probarlo, no se me ha dado la situación.

 

Saludos!

Share this post


Link to post
Share on other sites

Una pregunta nadie.

 

El otro día estuve trasteando con la multitienda, pero no me quedó del todo claro una cosa. Para que funcione la multitienda, hace falta tener instalada varias tiendas completamente, ¿verdad?.

 

Me imagino que sí, pero lo que pregunto porque con una sóla tienda al activar la opción multitienda, Prestashop me mostraba algo de texto de la segunda tienda, que por supuesto no existía porque no la tenía instalada). Eso sí, lo que es el theme no me lo mostraba :wacko:

 

Un saludo crack.

No hace falta tener varias tiendas instaladas, para hacer uso de la multi-tienda. (Con la misma tienda y base de datos, prestashop, te da la posibilidad de tener varias tiendas)

Share this post


Link to post
Share on other sites

Hola Aqui,

yo tuve el mismo problema con el mod_rewrite, me salia desactivado cuando realmente no lo estaba, pero no se si era del hosting (godaddy) o del prestashop, lo solucioné poniendo "RewriteBase /" en el htaccess.

El otro problema voy a probarlo, no se me ha dado la situación.

 

Saludos!

 

Gracias, lo he probado y no soluciona el problema en hosting redcoruna, no se si el hosting tendrá algo que ver.

he anadido "RewriteBase /" tal y como me indicas justo detras de la linea "RewriteEngine on" quedando asi:

 

 

RewriteEngine on

RewriteBase /

 

Gracias de todos modos. Me imagino que será por un bug... aquí mencionan lo mismo

http://www.prestashop.com/forums/topic/174295-friendly-url-mod-rewrite/

 

como es una RC y es la 1, ya cuando mire en la RC2 si pasa entonces sacaré conclusiones.

Un saludo.

Edited by aqui (see edit history)

Share this post


Link to post
Share on other sites

No se si os pasa pero da error al actualizar de la r1 a la r2 con el modulo de autoupdate. Error al actualizar la base de datos...

Aparte:

En la r1 hay 2 cosas que me ocurren, una es que si subes productos ... se hacen pedidos y facturas... y luego eliminas los productos de la tienda o los cambias por otros sin mantener los que se habían puesto en esos pedidos, estos desaparecen de los pedidos ya realizados de forma que las facturas de estos pedidos realizados solo sale el total, pero ya no salen los productos que habían en esa factura y/o pedido.

La segunda cosa que me ocurre con la rc1 es que sale como que no esta activado en el server el mod_rewrite cuando si lo está. Creo que esto hace que no funcione bien la redireccion canónica pues si pones el dominio sin las www la respuesta de la página principal sin www es de página no encontrada. En cambio con las www funciona bien.

 

Aun no he podido probar la rc2 limpia ya que intenté actualizar con el método automático y no funciona.... llega casi a actualizar todo, pero da error casi al final, cuando intenta actualizar la base de datos.

 

Espero que en la rc2 estas cosillas estén solucionadas.

Yo la probaré a final de mes

 

Bueno lo del error del autoupdate le pasa a más gente, jejejej me quedo tranquilo : http://www.prestashop.com/forums/topic/182574-1-click-upgrade-de-15013-a-15015-ne-marche-pas/

Share this post


Link to post
Share on other sites

Ya he instalado la r2 y no han solucionado esto:

 

Hay x productos en la tienda... se hacen pedidos y facturas con estos productos... hasta aquí bien... pero si eliminas los productos de la tienda que hay en alguno de los pedidos que ya hay generados y facturados de la tienda o los cambias por otros sin mantener los que se habían puesto en esos pedidos, estos desaparecen de las facturas de estos pedidos realizados, solo sale el total, pero ya no salen los productos que habían en esa factura y/o pedido. esto es un gran bug, pues las facturas antiguas se destrozan cada vez que quites productos.

Share this post


Link to post
Share on other sites

- En mi caso no puedo crear paquetes con productos descargables. Cuando voy a agregar productos en el box de búsqueda no encuentra nada.

- Otro problema es que no encuentro la forma de ordenar los productos dentro de la categoría inicio.

- El LiveEdit no funciona mientras se tenga seleccionada la opción de URL amigables.

- Problemas al intentar entrar en direcciones sin www. al dar erros con el mod_rewrite.

- En la ventana de leer condiciones de uso se filtra una parte del fondo del Front Office.

- El peor de los problemas que he encontrado es que cuando realizo algún cambio en el Back Office me genera como una especie de cache en el navegador no actualizando. Para poder ver los cambios hay que refrescar la pagina y así con todos los cambios que realice. He probado en Mac OS X con varios navegadores (Firefox, Safari, Chrome, Opera), desde Windows, Android, iOs, Linux pasa lo mismo.

- En el Back Office si realizas una actualización en el idioma del propio Back Office se daña el idioma y se queda todo por defecto en inglés.

- El block insurance tiene un bug con el cual no podemos modificar los datos ya que los duplica.

- El Front Office sufre el mismo problema que el Back Office con tener que refrescar la pagina para ver los cambios. Si navegas por la página por los enlaces no cambian... generan cache fija.

 

Estos han sido los errores o detalles más significativos que me he encontrado por el momento.

 

Para más aclaración estoy utilizando la versión RC2 (1.5.0.15) en servidor con PHP 5.3.4

 

Un saludo y a ver si dentro de poco disponemos de una versión final.

Share this post


Link to post
Share on other sites

Pues no han entendido en el bug traker este bug.... lo han puesto en varias ocasiones y lo dan por corregido pensando que se trata de agregar o quitar productos de un pedido. Y no es esto... el problema esta en las facturas de pedidos antiguos cuando un producto ya no esta en la tienda (Producto borrado no apagado). Este producto desaparece de las facturas antiguas dejando solo el importe total de la factura pero estando esta vacia de productos. Si algún moderador que controle bien el Ingles puede explicarlo a los de presta ayudaria a que lo entiendan, pues este error deja la RC2 en una versión Alfa, no apta para nada.

 

Ya he instalado la r2 y no han solucionado esto:

 

Hay x productos en la tienda... se hacen pedidos y facturas con estos productos... hasta aquí bien... pero si eliminas los productos de la tienda que hay en alguno de los pedidos que ya hay generados y facturados de la tienda o los cambias por otros sin mantener los que se habían puesto en esos pedidos, estos desaparecen de las facturas de estos pedidos realizados, solo sale el total, pero ya no salen los productos que habían en esa factura y/o pedido. esto es un gran bug, pues las facturas antiguas se destrozan cada vez que quites productos.

Edited by aqui (see edit history)

Share this post


Link to post
Share on other sites

Hola, en mi caso he mandado un par de bugs que he encontrado y estoy a la espera de que se corrigan o me digan algo.

Por si acaso comento por aquí por si os ha pasado y en todo caso os iré comentando las respuestas uqe nos dan.

 

1- Al poner mi tienda en un server y usar la version 5.5.12 de MySQL no me deja crear categorías. De momento me han dicho que esto estaba corregido, pero a mi solo me pasa con la versión esta de MySQL, en local tengo un Xampp que usa la 5.5.8 y no da problemas.

 

2- Por el fallo anterior probamos con otra version de bbdd 5.0.26 y se soluciona el problema anterior pero no se ve la tienda xq da un error en una query. Parece ser que no le gusta el concat() para crear la uri y falla.

 

En ámbos casos estoy a la espera a ver si me dicen algo.

 

Otro error que he visto y que estoy pendiente de mandar es:

 

3- Al eliminar un producto, aparentemente todo va bien, pero está dando un error cuando intenta borrar de varias tablas. El error no es tal, ya que simplemente intenta borrar, como no existe no borra nada y al devolver la query un 0 lo toma como un error. El usuario no ve nada, pero para posibles ampliaciones como me pasa a mi es un problema.

 

Y una mejora que se me ha ocurrido...habría que ver como implementarla.

 

4- En mi caso al añadir una nueva pestaña al producto, necesito hacer las pertinentes operaciones de guardaro, borrado y demás. Para ello he modificado el AdminProdcutController de la carpeta override. Cuando he llegado a sobreescribir la funcionalidad de duplicar producto, me encuentro con el problema de que no hay posibilidad de recuperar el id del nuevo producto creado, por lo tanto no puedo hacer nada sobre ese nuevo producto.

En este punto aclarar que mis conocimientos de php son muy limitados...a lo mejor hay formas de hacerlo y el problema es que no se yo...

 

Sintiendo esta parrafada, espero vuestra ayuda y poder ayudar a mejorar esta nueva versión.

 

Saludos

Share this post


Link to post
Share on other sites

Hola a todos... Uso 1.5 RC2 y no hallo la manera de poder implementar los gastos de envio fijos ..... O sea quiero que los envios valgan 5€ y solo me aparece el gratuito ..... llevo ya mucho rato dandole vueltas y nada....

Saludos

Share this post


Link to post
Share on other sites

Otra cosa que sigue faltando es el check en el formulario de contacto para aceptar la política de privacidad y condiciones de uso, al igual que está el modulo que lo hace en el formulario de registro del cliente, lo podían integrar en el formulario de contacto.

Edited by aqui (see edit history)

Share this post


Link to post
Share on other sites

Buenas!!

Otro problema q tengo es q al principio pude crear categorías.... pero ahora una vez he añadido unos cuantos productos cada vez que intento crear una categoria esta no aparece por ningun sitio..... es como si no hiciera nada.... a alguien le pasa esto?

saludos

Share this post


Link to post
Share on other sites

Buenas!!

Otro problema q tengo es q al principio pude crear categorías.... pero ahora una vez he añadido unos cuantos productos cada vez que intento crear una categoria esta no aparece por ningun sitio..... es como si no hiciera nada.... a alguien le pasa esto?

saludos

Has cambiado de entorno de trabajo? No se si te ha pasado al subirlo al server o algún otro cambio que hallas hecho.

A mi me pasa lo mismo que no me crea categorías ni imágenes en los productos. Depurando he visto que crea una sentencia INSERT donde incluye el id de la tabla con un valor vacío y a la bbdd no le guta.

Lo he puesto en el bug traker pero no me han dado respuesta todavía. Esto solo me pasa cuando lo monto en el server, en local no me pasa.

Share this post


Link to post
Share on other sites

hola, necesito crear un sitio en donde los propios usuarios puedan vender sus própios productos (C2C) ? que módulo o script me recomiendan para implementar un sitio de este tipo ?

Muchas gracias y saludos desde Uruguay

Share this post


Link to post
Share on other sites

hola, necesito crear un sitio en donde los propios usuarios puedan vender sus própios productos (C2C) ? que módulo o script me recomiendan para implementar un sitio de este tipo ?

Muchas gracias y saludos desde Uruguay

Hola, este post es para dudas puntuales sobre la 1.5 RC.

 

Lo que usted busca, es esto: http://www.prestasho...-prestashop-14/

Share this post


Link to post
Share on other sites

Wuola!!

 

A ver si me podéis ayudar, creo que la he liado parda una vez mas. Tengo instalada la versión 1.5.0.13 y la verdad que funcionaba todo bien, pero por enredar un poco me he puesto a actualizarla a la RC2 con lo de 1-click upgrade, y todo ha ido bien hasta que estaba recuperando el backup anterior para finalizar la actualización, se ha quedado pillado con un error del server... (alguna sobrecarga del apache no sé... )

 

El caso es que sigo teniendo la 1.5.0.13 y todo funciona bien, pero es como si ya no tubiera permisos de escritura, porque no me deja crear ni modificar mis productos. He mirado con el ftp los permisos y los veo todos ok, que es lo que le puede pasar?¿?

He probado a repetir el proceso de actualización, pero siempre me da error al finalizar la copia del backup... :blink:

 

tiene arreglo?¿? :wacko:

 

Graciasssssssss

 

Pd: concretamente lo único que no me deja modificar son los productos, da este error: "Se ha producido un error mientras se actualizaba el objeto product ()"

el resto de cosas si funcionan bien (categorias, idiomas...todo vamos)

Si elimino todo y empiezo una instalación nueva, la base de datos se mantiene en el SQL o se elimina también?? :blink:

 

PD2: Bueno ya por cabezonería, he duplicado la base de datos y he borrado toda la tienda, instalo desde cero el RC2, y todo perfecto, con la base de datos nueva vacía me deja crear productos. Restauro la copia con mySQL, y me lo carga todo bien de nuevo en la tienda, pero me sigue dando el mismo error al cargar o modificar un producto: "Se ha producido un error mientras se actualizaba el objeto product ()"

 

Supongo que debe ser un problema de la base de datos con los permisos de escritura en los productos, me podéis decir cómo lo localizo?¿? :rolleyes:

 

Un saludo!!!!!!! :P

Edited by Gamusino (see edit history)

Share this post


Link to post
Share on other sites

  • 2 weeks later...

A ver si me podéis ayudar. Tengo problemas :-(

Intento actualizar a 1.5 con el módulo 1 click upgrade y cuando está verificando todo lo necesario me falla "Module version up-to-date (0.7)" (y acabo de instalarlo).

 

¿alguna idea?

¡Gracias!

Share this post


Link to post
Share on other sites

Ya está aquí, y de momento error encontrado.... con url amigables activadas, el mismo error que tenia la rc1, sin www no redirecciona bien a www . te manda a pagina no encontrada. Joder esto ya lo habían corregido en la 1.5.0.16 del svn. Pero ahora solo pasa con los idiomas activados.

 

Ejemplo:

 

tudominio.com/es/ ---- te manda a ------ www.tudominio.com/es/pagina-no-encuentra

 

en cambio de tudominio.com ---- a ---- www.tudominio.com si funciona ok

Edited by aqui (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

He actualizado la tienda a la 1.5, pero he tenido que hacer un "Rollback" porque el tema de la misma, uso el prest7a, no funcionaba. Eligiendo el tema por defecto tampoco funcionaba bien. Los productos de la página principal iban a links rotos. Un desastre. Al final he entrado en Panic Kernel y he retrocedido a la versión anterior. Lo que pude ver en el Back Office era impresionante, una pasada, muchas cosas nuevas, algunas mareaban un poco, nueva forma de presentar todo. Me sentía nuevo en esa trastienda. Aún así, si hubiese funcionado el front office hubiese mantenido la nueva versión sin problemas.

 

En fin, media mañana sacando copia de seguridad de todo, leyendo como actualizar, actualizando, para nada.

Para actualizar a la 1.5 (el tutorial que aparece en el forum en inglés te hace ir a la 1.4.9) hay que elegir en el apartado "Channel" del 1-Clic Upgrade (en avanzado) la opción "Major release".

 

Creo que aún falta retocar un poco esta versión. Los que tenemos una tienda en funcionamiento no podemos perder un sólo cliente, que la cosa está muy mal.

Saludos desde www.avatarmugs.com

Share this post


Link to post
Share on other sites

He visto la nueva versión lista para la descarga, pero en mi versión 1.4.9 no me aparece la actualización... hay que hacerla manualmente?

 

Al momento de actualizar, en el módulo 1-clic Upgrade, pincha sobre "Avanzado". Allí verás una pestaña que pone "Channel". Pincha sobre ella y en el cuadro desplegable elige "Major Release". Luego te aparecerá la 1.5.17. Pero vé con cuidado. A mi no me funcionó bien. Si tienes alguna tienda para probar, que no sea activa o te dé pocas pelas, prueba primero en ella. En todo caso, doble backup, te lo recomiendo.

La opción "Rollback" me funcionó estupendamente y no tuve que echar mano de la copia de seguridad, pero nunca se sabe.

Share this post


Link to post
Share on other sites

mi pregunta es: ¿compatible con temas 1.4.9?

 

Yo tengo un tema compatible con la 1.4.9 y en la 1.5.17 no me funcionó. La página de mi tienda aparecía vacía, solamente salía un punto arriba a la izquierda. Y el tema por defecto de Prestashop me funcionaba mal: cuando elegías los productos desde la página de inicio, salía "Página no encontrada". Un desastre.

Share this post


Link to post
Share on other sites

a mi me pasa lo mismo, he actualizado el módulo:

 

1-click Upgrade Instalado

Versión : 0.7.3 pero me dice q lo tengo obsoletoooo :P

 

Yo he usado el mismo y me va bien. A lo mejor se ha corrompido. Desactívalo y elimínalo completamente, bájate un nuevo zip desde aquí: http://addons.prestashop.com/en/administration-tools-prestashop-modules/5496-autoupgrade.html

Y vuélvelo a instalar.

 

- En mi caso no puedo crear paquetes con productos descargables. Cuando voy a agregar productos en el box de búsqueda no encuentra nada.

- Otro problema es que no encuentro la forma de ordenar los productos dentro de la categoría inicio.

- El LiveEdit no funciona mientras se tenga seleccionada la opción de URL amigables.

- Problemas al intentar entrar en direcciones sin www. al dar erros con el mod_rewrite.

- En la ventana de leer condiciones de uso se filtra una parte del fondo del Front Office.

- El peor de los problemas que he encontrado es que cuando realizo algún cambio en el Back Office me genera como una especie de cache en el navegador no actualizando. Para poder ver los cambios hay que refrescar la pagina y así con todos los cambios que realice. He probado en Mac OS X con varios navegadores (Firefox, Safari, Chrome, Opera), desde Windows, Android, iOs, Linux pasa lo mismo.

- En el Back Office si realizas una actualización en el idioma del propio Back Office se daña el idioma y se queda todo por defecto en inglés.

- El block insurance tiene un bug con el cual no podemos modificar los datos ya que los duplica.

- El Front Office sufre el mismo problema que el Back Office con tener que refrescar la pagina para ver los cambios. Si navegas por la página por los enlaces no cambian... generan cache fija.

 

Estos han sido los errores o detalles más significativos que me he encontrado por el momento.

 

Para más aclaración estoy utilizando la versión RC2 (1.5.0.15) en servidor con PHP 5.3.4

 

Un saludo y a ver si dentro de poco disponemos de una versión final.

 

...pues la versión final no me ha ido mucho mejor que digamos...

Share this post


Link to post
Share on other sites