Jump to content

Recommended Posts

Lof Advance Footer Module allow you can easy manager footer of prestashop

We split your footer to 4 parts with 4 position:

Position 1 - Position 2 - Position 3 - Position 4

With each potion you can create many block.

Position 1

- Block 1 - Block 2 - ...

Position 2

In each block you can create many item.

With each item you can create it with type:

custom html + custom text + link + assign module + Gmap + add this

cf4507ae4969876df39b5f798b6f40ce_XL.jpg

Module featured

  • Support prestashop 1.4.x, 1.5.x
  • Support multiple themes
  • Support multiple language
  • Support multiple shop (for prestashop 1.5.x)
  • Easy manager, Easy add block, items
  • Support load module to footer

Demo Link

http://landofcoder.c...ashop/index.php

 

Dowload Link

http://www.landofcod...hop-module.html

 

 

hello, if it is possible - please attach the library with the module to your post

 

regards

Share this post


Link to post
Share on other sites

It is not as difficult as you think, If You Try it, You Will See! I am using it

  • Like 1

Share this post


Link to post
Share on other sites

hello, if it is possible - please attach the library with the module to your post

 

regards

Sorry,

 

I added attachments

  • Like 2

Share this post


Link to post
Share on other sites

Sorry,

 

I added attachments

 

awsum, it's your next brilliant module :-)

Share this post


Link to post
Share on other sites

Hi,

I installed the module today on my shop version 1.4.2.5. and get an an error:

 

Warning: require_once(/home/xxxxxxx/www.xxxxxxx.at/classes/defines.php): failed to open stream: No such file or directory in /home/xxxxxxx/www.xxxxxxx.at/classes/Module.php(547) : eval()'d code on line 20

 

Fatal error: require_once(): Failed opening required '/home/xxxxxxx/www.xxxxxxx.at/classes/defines.php' (include_path='.:/usr/local/pd-admin2/php5-5.4.12/lib/php') in /home/xxxxxxx/www.xxxxxxx.at/classes/Module.php(547) : eval()'d code on line 20

 

Now I see always that error when I go in my back end to modules and I can't open the modules section. Please I need help how i can solve that error. Thanks!

Share this post


Link to post
Share on other sites

Hi DeathGuard,

 

I need web information to check,

Could you send me web information to landofcoder@gmail.com?

Share this post


Link to post
Share on other sites

Hi,

i solved the error already. I delete the modul folder direct on the FTP and it works now.

the 1.5 version works perfect but it looks that with the 1.4 version on prestashop 1.4.2.5 gets some troubles.

Share this post


Link to post
Share on other sites

Hi bagzpain,

 

you need choose "Type" as "addthis".

if you want add link then you need choose type as "link".

Share this post


Link to post
Share on other sites

Nice module!

 

I would to use gmap and tryed it. If i select gmap type, set up the Latitude and Longitude ... on the site on the site i see no gmap visible. Is the gmap API changed?

Share this post


Link to post
Share on other sites

I set width to 100% and height to 100px ... now i have window cca 318px x 100px where i see nothing :)

 

Any other suggestions?

Share this post


Link to post
Share on other sites

 

I don't think so

 

you need to set width and height for li.lof-gmap

 

NOT for lof-gmap :) set it for div "lofmap_canvasXX" and is working for me.

 

Thanks :)

Share this post


Link to post
Share on other sites

NOT for lof-gmap :) set it for div "lofmap_canvasXX" and is working for me.

 

Thanks :)

You are welcome!

Share this post


Link to post
Share on other sites

Hi Guilherme Dutra,

 

Hi quangha, could you teach us how to make this Social Link in your module. So nice in your website.

Thanks..

It's very easy

You need to click "add item" then choose "Type" as "addthis".

if you want add link, you need choose type as "link".

Share this post


Link to post
Share on other sites

Hello,

 

Congras for the module its very helpful for me. But I have a question , how to change the background color of the Position 1 .

 

TNX

Share this post


Link to post
Share on other sites

Hello,

 

Congras for the module its very helpful for me. But I have a question , how to change the background color of the Position 1 .

 

TNX

 

You need edit in css file

tmpl/deafult/assets/style.css

Share this post


Link to post
Share on other sites
Hi DeathGuard, I need web information to check, Could you send me web information to landofcoder@gmail.com?

 

Hello, this module is a demo, can i have the normal version?

Share this post


Link to post
Share on other sites
awsum, it's your next brilliant module :-)

 

hello , i need help for my site. I want to make a nice footer using that module, how is possible cause this is just a demo!

Helo : (

Share this post


Link to post
Share on other sites
i need the full version of this module, not a trial , this doesn't work!!!

 

It's full version of the module.

Share this post


Link to post
Share on other sites

Hello, I tried that footer, it's a very good one , simple to use and as a module, easy to customize,

 

However still i can see my before footer, how can i remove the old one? I want to replace it .

 

Thanks Quang ha

Share this post


Link to post
Share on other sites

Hello, I tried that footer, it's a very good one , simple to use and as a module, easy to customize,

 

However still i can see my before footer, how can i remove the old one? I want to replace it .

 

Thanks Quang ha

 

You can remove block or items in block if you want.

Share this post


Link to post
Share on other sites

If you ask how to remove existing block, then move your mouse over the block and then you see on up left corner red cross. Click it and the block will be removed.

  • Like 1

Share this post


Link to post
Share on other sites

Hi there, your module is excellent thank you, however I am having difficulty getting the social links added in. can you help at all?

 

I understand you can use the "addthis" tool however that adds a row of small icons offset to the left and you cannot alter which social links appear - i would like to have it set up exactly like your demo in the light grey style - only with just twitter and facebook available ?

 

would this be possible , many thanks

Share this post


Link to post
Share on other sites

Hi there, your module is excellent thank you, however I am having difficulty getting the social links added in. can you help at all?

 

I understand you can use the "addthis" tool however that adds a row of small icons offset to the left and you cannot alter which social links appear - i would like to have it set up exactly like your demo in the light grey style - only with just twitter and facebook available ?

 

would this be possible , many thanks

 

You can use text editor that the module support. After that, you use CSS to have looking nice

post-292401-0-84470700-1372301873_thumb.png

Share this post


Link to post
Share on other sites

Hello,

 

I'm having an issue when i translate into french; all characters like é è ê â à etc. in the titles are not being displayed correctly. the text however is displayed as it should.

 

Solved the problem myself. it is the font that apparently doesn't support the characters. if i disable font: 14px 'vni-helve-condense' !important; on line 99 of style.css it shows the characters correctly

Edited by maniot (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Hi. Thank you providing us with such an easy to use and arguably one of the best free modules. Being new to prestashop and the coding language I am however faced with a bit of a predicament. I would love to use your footer but I would like my website to remain responsive. By this I mean what sort of code would I have to place in the .css file (or elsewhere for that matter) to enable the footer to create columns that when the browser width is reduced such as when in a phone, the columns stack up on top of each other instead of being squeezed (like the current configuration)?

Any help would be very much appreciated!! Once again thank you for the footer!

Share this post


Link to post
Share on other sites

I'm using the LOF Advanced Footer Module in the leotheme tshirt template and I'm having a bit of trouble changing the text color, i've been through the css and I cant seem where to find the text color of the headings is. I also have a black background and the text is black with the bg images that are grey and white, and honestly I don't want the images, I just want the text, can you advise me on:

 

1.) How to change the text of the headings from black to the color of my choice (#F4FD21)

 

and

 

2.) How to remove the bg-span.png and the other bg-*** image that goes behind the titles

 

Best Regards,

 

Steven

Share this post


Link to post
Share on other sites

I'm using the LOF Advanced Footer Module in the leotheme tshirt template and I'm having a bit of trouble changing the text color, i've been through the css and I cant seem where to find the text color of the headings is. I also have a black background and the text is black with the bg images that are grey and white, and honestly I don't want the images, I just want the text, can you advise me on:

 

1.) How to change the text of the headings from black to the color of my choice (#F4FD21)

 

and

 

2.) How to remove the bg-span.png and the other bg-*** image that goes behind the titles

 

Best Regards,

 

Steven

You need go to css file and eidt.

Share this post


Link to post
Share on other sites

This is such a nice looking footer but instead of replacing my original footer, it adds an additional footer so now I have 2 footers. How do I remove my original footer and use just Lof Advance Footer? I'm using prestashop 1.5.4.1

Share this post


Link to post
Share on other sites

Go to Positions --> Footer and unhook the other bits leaving only Lof Advance Footer and stats modules if you have them active.

  • Like 2

Share this post


Link to post
Share on other sites

Go to Positions --> Footer and unhook the other bits leaving only Lof Advance Footer and stats modules if you have them active.

 

Exact!

Edited by Quang Ha (see edit history)

Share this post


Link to post
Share on other sites

hello

 

your module really nice, i love it

 

but 1 question, when ever i add a new block, it will appear at the end... and seems there are no way to rearrange the order. if i want to add to the front , i have to delete all the existing one and regenerate them one by one... this make me frustrated

 

any easier way (e.g. by editing data base or files?)

 

thank you for you assistance

Share this post


Link to post
Share on other sites

as far as i know there is no option to change block positions, you can only change items position

Share this post


Link to post
Share on other sites

Hello ohgnow,

 

The module don't support change position for blocks. In next version, we will add this featured.

Edited by Quang Ha (see edit history)

Share this post


Link to post
Share on other sites

Hello ohgnow,

 

The module don't support change position for blocks. In next version, we will add this featured.

 

nice , thank you very much :D

Share this post


Link to post
Share on other sites

Really a nice module !

 

i have a question,

is there any way for me to hook newsletter block to this nice module ? :)

Share this post


Link to post
Share on other sites

Really a nice module !

 

i have a question,

is there any way for me to hook newsletter block to this nice module ? :)

You need choose Type: module, Module: blocknewletter

  • Like 1

Share this post


Link to post
Share on other sites

i can't see the social links on your website, can you turn the module on?

Share this post


Link to post
Share on other sites

hi this perfect modül thanks a lot but l have turkiş problem

What can l make it?

Share this post


Link to post
Share on other sites

Watch in your site header, if u have set following html code:

 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=windows-1254">
<META HTTP-EQUIV="Content-language" CONTENT="tr">

 

or

 

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-9">
<META HTTP-EQUIV="Content-language" CONTENT="tr">

Share this post


Link to post
Share on other sites

Hi There,

 

Just installed this on 1.5.3.1...WORKS GREAT...

 

Is it possible to change the colour to suit my current theme?

 

Thanks!!!

 

of course it is possible, just share the shop url and we will check what you have to change :)

Share this post


Link to post
Share on other sites

www.justclickprint.com.au

 

Please note that this site is currently under construction so I will enable it for a few hours...

 

Also when you navigate to FLYERS ==> DL Flyers (actual product) the footer extends outside the templates boundaries...any thoughts on how to resolve this...

 

Thanks...

Share this post


Link to post
Share on other sites

Hi guys, im hoping you can give me some help/advice.

 

I've installed this and it works perfectly on my site, however I have no idea how to add the facebook, twitter, linked in, etc links along the top of the header as they are in the OP example image. Ideally id just like to have facebook and twitter available if possible.

 

site url: http://goo.gl/VW7rTA

 

Many thanks for any help you can give

Share this post


Link to post
Share on other sites

www.justclickprint.com.au

 

Please note that this site is currently under construction so I will enable it for a few hours...

 

Also when you navigate to FLYERS ==> DL Flyers (actual product) the footer extends outside the templates boundaries...any thoughts on how to resolve this...

 

Thanks...

 

thanks i checked your website and i don't exactly know what you want to change?

header "FAST AFFORDABLE RELIABLE" to blue?

please clarify it a bit i will be greatefull

 

Hi guys, im hoping you can give me some help/advice.

 

I've installed this and it works perfectly on my site, however I have no idea how to add the facebook, twitter, linked in, etc links along the top of the header as they are in the OP example image. Ideally id just like to have facebook and twitter available if possible.

 

site url: http://goo.gl/VW7rTA

 

Many thanks for any help you can give

 

i checked website and unfortunately there is no footer module

you removed it?

Share this post


Link to post
Share on other sites

i checked website and unfortunately there is no footer module

you removed it?

 

It is possible that I could have been trying to edit it at the time, apologies, the footer module should definitely be there and look like the picture below I have positioned it above the customer reassurance block.

Again, thanks for any help you can give its greatly appreciated.

site%20footer.png

Share this post


Link to post
Share on other sites

thanks i checked your website and i don't exactly know what you want to change?

header "FAST AFFORDABLE RELIABLE" to blue?

please clarify it a bit i will be greatefull

 

 

 

i checked website and unfortunately there is no footer module

you removed it?

 

Hi Vekia

 

Yest the "FAST AFFORDABLE RELIABLE" to be changed to blue...

 

Regards

Share this post


Link to post
Share on other sites

Hi Vekia

 

Yest the "FAST AFFORDABLE RELIABLE" to be changed to blue...

 

Regards

 

thanks for clarification,

but i checked your website once again (to find solution) and it is under the maitenance mode :(

Share this post


Link to post
Share on other sites

thanks for clarification,

but i checked your website once again (to find solution) and it is under the maitenance mode :(

 

Hi Vekia

 

I enabled the store for you!

 

In regards to my request to advise me on how to resolve the issue with the footer size...I fixed this by placing some text under each product's "description"...

 

Thanks for your help!

Share this post


Link to post
Share on other sites

after installing your module (1.4) I've got an empty module page?

I had to delete it via ftp to make the module page work again.

Any solution?

Edited by letrof (see edit history)

Share this post


Link to post
Share on other sites

what ps version you use? 1.4? and you downloaded module for 1.4?

Share this post


Link to post
Share on other sites

try to install the module once again, then run store under the "dev" mode how to turn on error reporting in prestashop 1.4

 

then refresh please the "modules" tab in your BO, if any error will appear - paste the error code, it will be really helpfull to debug the issue

Share this post


Link to post
Share on other sites

Any tutorials on this? Links do not appear in footer. Social Buttons do not appear. I've even copied exactly what was done in the template and put in a new block and nothing works.

Share this post


Link to post
Share on other sites

I changed the background of my entire homepage. The footer area color did not change in the LOF adv footer module. It remains white. I was wondering what line in the css file I need to edit. There is a lot of colors and busy work in the text and can't find the appropriate color to change. I'm using Prestashop 1.5.

 

Thanks!

  • Like 1

Share this post


Link to post
Share on other sites

I changed the background of my entire homepage. The footer area color did not change in the LOF adv footer module. It remains white. I was wondering what line in the css file I need to edit. There is a lot of colors and busy work in the text and can't find the appropriate color to change. I'm using Prestashop 1.5.

 

Thanks!

 

hi

you must change (*)

 

style.css (80)

 

background: none repeat scroll 0 0 #FFFFFF; (*)

border: 1px solid #D2D2D2; (*)

border-radius: 0 0 4px 4px;

clear: both;

line-height: 20px;

overflow: hidden;

padding: 20px 0;

Edited by askinjew (see edit history)

Share this post


Link to post
Share on other sites

Hi

 

I've downloaded for 1.4 and it works well except that footer position is left, how to centered in center of the page?

 

Is any help for this problem?

post-347736-0-54512300-1374951591_thumb.jpg

Share this post


Link to post
Share on other sites

except that footer position is left

 

hmm on screen it looks like 100% width footer, not "left position"

can you share the url?

Share this post


Link to post
Share on other sites

instead width:100% use width:980px; for example + margin:auto;

Share this post


Link to post
Share on other sites

vekia, thanks for quick reply.

 

i changed to 980px, margin: auto and it shrunk my footer image to size 980px...

Share this post


Link to post
Share on other sites

hello

 

add code that i mentioned to the lof blocks, not to whole footer:

Tis2V5q.png

 

o replace the code that i circled with width:980px; margin:auto;

Share this post


Link to post
Share on other sites

modules/lofadvancecustom/tmpl/default/default.tpl

Share this post


Link to post
Share on other sites

Hello, thank you for sharing this module. But i have a problem.

 

why the items shows horizontally ? not vertically ?

please help me.

 

thanks.

post-559485-0-98429200-1375066898_thumb.png

Share this post


Link to post
Share on other sites

Hello, thank you for sharing this module. But i have a problem.

 

why the items shows horizontally ? not vertically ?

please help me.

 

thanks.

 

i suppose that it is related to the styles defined for your #footer section

is there any chance to see it live? if so, please share the url

Share this post


Link to post
Share on other sites

try to install the module once again, then run store under the "dev" mode how to turn on error reporting in prestashop 1.4

 

then refresh please the "modules" tab in your BO, if any error will appear - paste the error code, it will be really helpfull to debug the issue

So I did and the error message is:

Warning: require_once(/home/admin/domains/lawendowykredens.pl/public_html/classes/defines.php) [[url="http://lawendowykredens.pl/*my admin*/function.require-once"]function.require-once[/url]]: failed to open stream: No such file or directory in /home/admin/domains/lawendowykredens.pl/public_html/classes/Module.php(551) : eval()'d code on line 20

Fatal error: require_once() [[url="http://lawendowykredens.pl/*my admin*/function.require"]function.require[/url]]: Failed opening required '/home/admin/domains/lawendowykredens.pl/public_html/classes/defines.php' (include_path='.:/usr/local/php5/lib/php') in /home/admin/domains/lawendowykredens.pl/public_html/classes/Module.php(551) : eval()'d code on line 20

 

But now deleting the module directory didn't help, and I'm stuck without whole module page ;/

Share this post


Link to post
Share on other sites

module page trying to include the defines.php file - it's a part of this module

it mean that this module is still there (or maybe it's related to the cache issue)

Share this post


Link to post
Share on other sites

so what should I do? the module catalog is deleted, force compile is on, cache is off, and still module page is missing

 

EDIT:

i had to remove cookies.Everything is working again but I can't still install this module.

Edited by letrof (see edit history)

Share this post


Link to post
Share on other sites

i suppose that it is related to the styles defined for your #footer section

is there any chance to see it live? if so, please share the url

 

i have not been uploaded to the internet, it still in localhost.

Share this post


Link to post
Share on other sites

Hi !

Thanks for your great free module.

But i have just a little problem, could you give the http code for the social bar ?

Cause i have change it, and now the bar is in black, i want it back in white.

Edited by dukofo (see edit history)

Share this post


Link to post
Share on other sites

Thanks for your great module

 

But caractere like é à è ... display wrong

 

An another module like this exist to place it on home editor page or left/right column?

Share this post


Link to post
Share on other sites

have you checked the module .tpl file?

Share this post


Link to post
Share on other sites

Hello everybody,

 

I have the same problem that letrof.

 

Any news ?

 

Thanks

Share this post


Link to post
Share on other sites

while installing the module what kind of message you've got?

Share this post


Link to post
Share on other sites

No module in the list after instalation and this message with the dev mode :

 

Warning: require_once(/homepages/5/d371355888/htdocs/shop/classes/defines.php) [function.require-once]: failed to open stream: No such file or directory in/homepages/5/d371355888/htdocs/shop/classes/Module.php(547) : eval()'d code on line 20

 

Fatal error: require_once() [function.require]: Failed opening required '/homepages/5/d371355888/htdocs/shop/classes/defines.php' (include_path='.:/usr/lib/php5') in/homepages/5/d371355888/htdocs/shop/classes/Module.php(547) : eval()'d code on line 20

Share this post


Link to post
Share on other sites

Hello and thank you for this wounderfull module, it's a must have.

Is it possible to insert the newsletter registration on a single line horizontaly? I've tried but no success.

Share this post


Link to post
Share on other sites

we are in the english section, so please speak here in english language. I will be greatefull, whole community too :)

  • Like 1

Share this post


Link to post
Share on other sites

Anyone know how to get my margins corrected in my footer? I am using the LOF Advance footer module. For some reason something messed up all my margins on my site. I'm having to correct everything 1 by 1. But I've almost got it all fixed. If you could please look at my footer for my site and let me know what I need to do. site is: wwwdotsavvymarinadotcom

 

Thanks!!

Share this post


Link to post
Share on other sites