Jump to content

Recommended Posts

Olá Pessoal!

 

Alguém sabe como habilitar as URLs amigáveis no PrestaShop 1.5?

Encontrei alguns tutoriais na internet, mas todos para versões anteriores...

 

Abraço!!

Fábio R. Campanhol

Share this post


Link to post
Share on other sites

Vc.configura estes na aba: Preferências -> SEO & URL's -> Instalação URLs -> URL = SIM -> Salvar

Share this post


Link to post
Share on other sites

Olá cd2500!

 

Habilitei já essa opção, mas aparece a seguinte mensagem:

 

"Reescrita de URL (mod_rewrite) não está ativo no seu servidor, ou não é possível verificar a configuração do servidor. Se você quiser usar URLs amigáveis ​​você deve ativar este mod".

 

Como faço isso?!..rsrs...

 

Att,

Fábio R. Campanhol

9dadePPG

Share this post


Link to post
Share on other sites

Ah, testei aqui e funciona normalmente, mesmo com essa mensagem de erro...

Pelo que vi aqui, está funcionando normalmente...rsrs

 

Mas aparece o númerdo do ID do produto na frente e o .html no final...

Será que é possível tirar isso pra ficar apenas o nome do produto?

 

Abraço!!

Share this post


Link to post
Share on other sites

1) O problema é que Prestashop foi programado para uma configuracao X. Em servidores com cgi o mod_rewrite é suprimido.

 

Veja aqui o problema no forge:

 

http://forge.prestas...owse/PSCFV-4130

http://forge.prestas...owse/PSCFV-1748

 

2) Editar o link - vc. faz lá mesmo: Preferências -> SEO & URL's -> esquema URL (penúltima opcao)

 

3) Marcar o tópico como resolvido: http://forge.prestas...owse/PSCFV-4130

Share this post


Link to post
Share on other sites

Olá cd2500!

 

Tentei tirar aqui o número do ID que aparece antes da descrição do produto, mas não estou conseguindo...

Fui em PREFERÊNCIAS > SEO & URLS > ESQUEMA DE URL

Mas qual das opções eu altero?!

 

Tentei tirar o ID de "rota para produtos", mas esse campo ID é obrigatório...

Gostaria de tirar o ID da URL das páginas dos produtos e também das páginas das categorias, você pode me ajudar?

 

Obrigado!

Share this post


Link to post
Share on other sites

Olá,

Peço desculpa de desenterrar este tópico, mas o meu problema é semelhante.

Estou a criar uma loja em : http://acessoriostelemovel.com/

E tinha os links sem URL amigável e estava a funcionar tudo bem, entretanto quero mudar para amigável e ao mudar o site fica desconfigurado (não carrega muitas imagens)

As configurações estão assim:
1 - https://www.dropbox.com/s/pvoa6vsvzr9pd7d/Captura%20de%20tela%202014-09-05%2012.06.36.png?dl=0
2 - https://www.dropbox.com/s/zy24aplyaf0tztz/Captura%20de%20tela%202014-09-05%2012.06.58.png?dl=0

Deixei o site com estas configurações para poderem ver.... 
Podem ajudar?

Share this post


Link to post
Share on other sites

O seu servidor é Linux ou Windows ?O módulo mod_rewrite está instalado e configurado para = ON no seu servidor ? Pergunte ao seu provedor, pois isto é um módulo do servidor e nao de Prestashop.

 

Sem mod_rewrite nao poderá usar URL's amigáveis. Servidores Windows nao conhecem mod_rewrite, sendo que deverá traduzir o ficheiro responsável (.htaccess com o IIS manager para um web.config apropriado).

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More