Jump to content
Uchiha

[Ajuda] Links quebrados após migração para servidor Windows IIS7

Recommended Posts

Salve galera.

 

Estou desesperado. No meu servidor antigo, a loja funcionava no WAMP. No novo eu tenho o IIS7. E não importa quantas vezes eu gere o .htaccess, os links estão sempre quebrados (exceto a home e o admin). Assim que eu copiei a pasta e fiz o backup do bd, minha página ficou toda branca. Pesquisando, descobri que poderia desabilitar o cache no settings. Fiz isso, mas agora estou com esse problema supracitado.

 

Como resolver?

 

Valeu!

Share this post


Link to post
Share on other sites

Uchiha

 

O arquivo .htaccess é exclusividade de servidores Apache (Linux).

No IIS você não pode utilizá-lo.

 

Troque o S.O de seu servidor para linux, preferencialmente com cPanel, e seja feliz.

Share this post


Link to post
Share on other sites

Caramba... são servidores da empresa, não posso mudar assim. Conhece alguma forma de fazer o IIS ler os arquivos .htaccess? Estou pesquisando, mas não tive sucesso ainda.

Share this post


Link to post
Share on other sites

IIS não entende .htaccess. Vc. vai ter que traduzir...

 

O IIS vem com um tool chamado IIS Manager. La vc. tem uma função para traduzir ficheiros .htaccess que prestashop gerou no root do shop. Somente copia as linhas do .htaccess no tradutor do IIS Manager e ponha esta web.conifg no root do seu shop.

 

Depois de um ano de sufoco com servidor mircrosoft eu retornei para Linux. Servidores Microsoft somente funcionam em 100% com software microsoft....

O problema é que prestashop gera o ficheiro .htaccess toda vez que vc. for instalar ou deinstalr um modulo ou fizer alterações na configuração do seu shop. Vc. sempre vai ter que dar uma olhada se houve alguma alteração neste ficheiro e traduzir para a web.config novamente.... Apesar de Prestashop tbm. funcionar com IIS não é a opção de primeira escolha para correr um shop estável. Sinto não ter noticia melhor para isso.

Share this post


Link to post
Share on other sites

Titulo do tópico editado de Links quebrados após migração para [Ajuda] Links quebrados após migração para servidor Windows IIS7, de modo a reflectir melhor o conteúdo do tópico.

 

Obrigado pela compreensão !!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More