Jump to content
JamesHetfield

Erreur aprés mise à jour : Notice: Undefined property: Smarty::$deprecation_notices

Recommended Posts

Bonjour

 

Suite à une récente mise à jour de prestashop vers 1.5 qui n'a pas fonctionné,j'ai remis sur le serveur ma copie de sauvegarde du site internet que je crée actuellement .

 

Seulement voila j'ai cette erreur qui apparait aprés avoir fait afficher les défauts.

 

Pourriez vous m'aider ? S'il vous plait

 

Notice: Undefined property: Smarty::$deprecation_notices in /homez.478/goodiesa/www/tools/smarty/Smarty.class.php on line 697

 

Fatal error: Uncaught exception 'SmartyException' with message 'Plugin "secureReferrer" not callable' in /homez.478/goodiesa/www/tools/smarty/sysplugins/smarty_internal_templatebase.php:428 Stack trace: #0 /homez.478/goodiesa/www/config/smarty.config.inc.php(212): Smarty_Internal_TemplateBase->registerPlugin('modifier', 'secureReferrer', Array) #1 /homez.478/goodiesa/www/config/smarty.config.inc.php(66): smartyRegisterFunction(Object(Smarty), 'modifier', 'secureReferrer', Array) #2 /homez.478/goodiesa/www/config/config.inc.php(134): require_once('/homez.478/good...') #3 /homez.478/goodiesa/www/index.php(28): require('/homez.478/good...') #4 {main} thrown in /homez.478/goodiesa/www/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 428

Share this post


Link to post
Share on other sites

Hello,

 

A priori il y a une souci avec la version de smarty utilisé ou le fichier /config/smarty.config.inc.php je dirais.

 

Avec un accès ftp je pourrais vous aider à corriger cela.

 

Cordialement

Share this post


Link to post
Share on other sites

Hello,

 

A priori il faut revérifier que les fichiers dans le dossier /config/ correspondent à votre version de PrestaShop. Ce doit être des fichiers d'une autre vieille version que vous utilisez notamment smarty.config.inc.php / defines.inc.php / smartyadmin.config.inc.php et smartyfront.config.inc.php.

 

Cordialement

Share this post


Link to post
Share on other sites

Merci Gregory pour cette réponse.

J'avais vérifié, tout dans /config correspondait à la version en cours, j'avais remis un répertoire Smarty propre.

Ca merdait quand meme, alors j'ai remis un backup de la version 1.1 (et oui, c'était une migration 1.1 -> 1.5 !), et j'ai tout recommencé

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More