Jump to content

[résolu] thickbox ne marche pas sous PS 1.2 ?


Recommended Posts

Bonjour,
après mise à jour je viens de m'apercevoir que thickbox ne fonctionne pas?

Dans détail produit si je clic sur image rien ne ce passe, et sur miniatures ouvre une nouvelle page blanche avec l'image large?

Quelqu'un à t-il eu ce problème?

Share this post


Link to post
Share on other sites

Salut,

Sur le thème par défaut 1208 aussi ?

[edit]
si ça ne marche pas sur un ancien thème c'est surement parce que dans "Préférences/Produits" le radio "JqZoom" est coché mais un ancien thème n'a pas les JS pour ça...

Share this post


Link to post
Share on other sites

ben en fait en regardant mieux cje vois que le JS est dans \prestashop1208\js\jquery
Donc c'est pas un JS lié au thème (ce qui ne veut pas dire qu'un ancien thème va le gérer soit dit en passant).

Difficile de savoir ce qui déconne :/
peut-être re-uploadé le répertoire jquery (ou au moins jqzoom et thickbox-modified.js

Sinon t'aurais pas un module sur base js qui entrerait en conflit ?

Share this post


Link to post
Share on other sites

Salut,

De quelle ligne tu parles dans le header ? le base href ?

Dans le thème par défaut de PS 1208 il n'y a rien à enlever. C'est quand on veut mettre à jour un thème 1.1 pour 1.2 qu'on est obligé de virer cette ligne :P

Du coup je ne sais plus de quoi on parle lol

Share this post


Link to post
Share on other sites

ok,
en fait j'avais compris que tu avais uploadé l'ancien thème par défaut de la v1.1 sur la 1.2 (vu que tu dis que tu as supprimé une ligne dans le header...)

Or le thème par défaut dois toujours être celui fourni avec la version de PS...

Mais bon j'ai surement mal compris.

Sinon je ne vois pas pourquoi ton thickbox ne fonctionne pas sur un autre thème :/ , faudrait désactiver certains modules additionnels utilisants JS pour trouver une éventuelle imcompatibilité.

Share this post


Link to post
Share on other sites

Ok!

Pour trouver la soluce j'ai regardé dans mon header.tpl, en le comparant au PS d'origine.

Du coups comme j'avais bien travaillé sur mon thème, j'en ai profité pour faire le ménage de façon à ce que mon header ressemble le plus possible à celui de PS , et là pas de résolution pour mon thickbox, mais par contre j'ai beaucoup gagné en rapidité de chargement de mes pages!!!

Moi qui trouvait la version 1.2 plus lente, en fait c'est mon header qui ralentissait!!!

Ensuite j'ai regardé du côte de product.tpl, et j'ai recopié le code de début, et là thickbox remarche o))

Ensuite j'ai voulu modifier pour pouvoir avoir un thickbox plus sympa avec le PrettyPhoto qui à un affichage plus cool,
mais apparemment il n'est pas compatible avec la V1.2 !!

Donc j'espère qu'il y aura bientôt un zoombox compatible !

Voilà donc résolu pour mon problème!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More