Jump to content

Aide à l'installation pour une neewbie?


Recommended Posts

Bonjour,

Je suis consciente d'être une véritable tache (et encore) dans le domaine de l'informatique...et pourtant! J'ai voulu me mettre à prestashop. Me voila donc téléchargeant le tout, empruntant un serveur (un 60GP de chez OVH), et lisant de nombreux topics sur ce même forum.

Mais voila. Htacces, lignes à modifier, etc etc...je n'arrive pas à tout faire, et encore moins à tout faire dans l'ordre.

J'aimerais donc savoir si quelqu'un (d'extremement patient pour pas me mettre des baffes :)) voudrait prendre de son temps pour tenter de m'expliquer. Tout ce qui est FTP, c'est bon, je m'y suis a peu près fait!

Ce que j'aimerais savoir c'est, dans l'ordre, ce que je dois faire après avoir téléchargé prestashop! Je le mets tout de suite sur le serveur? Où trouver le fameux htaccess? Où rajouter les lignes?

Bref, j'ai toute une éducation à faire -_-

Merci à ceux qui viendront m'aider :)

Share this post


Link to post
Share on other sites

Bonjour,

C'est avec ce site-ci (celui que vous m'avez donné en lien) que j'ai tenté d'installer! Mais mon problème ce n'est pas l'installation, c'est avant ça. Toutes les modifications à faire avant.

Et pour le htaccess heu....quel arbo?

Merci pour votre réponse rapide :D

Share this post


Link to post
Share on other sites

bonsoir rhode,

avant toute chose, tu as donc ton abonnement chez ovh...
Tu as déjà créé une base de données?
Tu as donc déjà ton nom de base de données, ton serveur( ex: mysql5-61etc), ton login et un mot de passe utilisateur ...tu en es là ou pas?

Share this post


Link to post
Share on other sites

Désolée je vais peut être paraitre idiote, mais je n'ai rien crée de plus que ce qu'a fait OVH....s'il faut créer soi-même une base de donnée, ce n'est malheureusement pas fait...

Share this post


Link to post
Share on other sites

ok alors upload le repertoire prestashop sur ton serveur et place dans ce repertoire le fichier htaccess que je te joins
chaque chose en son temps lol

attention dézippe le avant!!! tu auras un fichier.htaccess sans extension

htaccess.zip

Share this post


Link to post
Share on other sites

Sur ton interface de chez OVH, il te faut créer une base de données
je ne suis pas chez eux mais je ne pense pas que cela soit compliqué...

Après avoir uploader tes fichiers...
Il te faudra aller sur le web, à l'adresse de ton site, normalement l'installation de Presta va se lancer...

Tu devras quand même renseigner certains champs donc:
le nom de ta base de données
le nom du serveur exemple (mysql5-61)
ton login (user)
ton mot de passe (passwd)

Share this post


Link to post
Share on other sites

D'accord,

Je vais aller voir pour la base de données, merci énormément.

J'ai vu sur le site de prestashop quelque chose à propos de "GD library" ou quelque chose du genre. Tout est en anglais, et déja que j'y comprends pas grand chose en français, c'est assez stressant. D'après eux, il y a tout un tas d'autres modification a faire....

Si quelqu'un peut me rassurer (ou m'effrayer un peu plus XD)...

Share this post


Link to post
Share on other sites

Pas d'adresse de ce genre, mais une adresse pour accéder à un "manager" qui me permet ensuite d'accéder à PHPMyAdmin.

Sinon, j'ai apparemment une base de données vide, avec un nom et une limite de 25Mo.

Share this post


Link to post
Share on other sites

oui c'est cela...
tu peux donc te connecter sur phpmyadmin
tu as donc ton login, ton mot de passe
Une fois connectée, tu verras en haut (en bleue) le nom de ta base de données
dis-moi quand c'est bon

Share this post


Link to post
Share on other sites

si tu veux, j'ai 1/2 heure à brûler lol
on passe sur msn et j'essaye de t'aider?
si ok par pm ton adresse bien sûr!!!
car sinon on risque d'encombrer le forum!

Share this post


Link to post
Share on other sites
  • 2 months later...

+1 je suis sur ovh, je suis bloqué à l'étape 3

Votre serveur de base de données ne supporte pas le jeu de caractère utf-8.


Si vous avez des idées.

J'ai éssayé le AddDefaultCharset UTF-8 dans un htaccess mis dans le repertoire de presta.

Share this post


Link to post
Share on other sites

Bon allez encore une question idiote de ma part, aujourd'hui j'bas les records
ton .htaccess se trouve bien dans www/prestashop/ et non dans www/
Quoi que là j'ai un doute teste les 2 mais pour moi c'est là que le problème se trouve
Tu peux poster ton .htaccess?

Share this post


Link to post
Share on other sites

# merci OVH
SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0
AddDefaultCharset UTF-8
# .htaccess automaticaly generated by PrestaShop e-commerce open-source solution
# http://www.prestashop.com - http://www.prestashop.com/forums
# URL rewriting module activation
RewriteEngine on
# URL rewriting rules
RewriteRule ^([0-9]+)\-([0-9]+)(\-[a-zA-Z0-9-]*)/([a-zA-Z0-9-]*)\.jpg$ /prestashop/img/p/$1-$2$3.jpg [L,E]
RewriteRule ^([0-9]+)(\-[a-zA-Z0-9-]*)/([a-zA-Z0-9-]*)\.jpg$ /prestashop/img/c/$1$2.jpg [L,E]
RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /prestashop/product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /prestashop/product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /prestashop/category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /prestashop/cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ /prestashop/supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ /prestashop/manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]
# Catch 404 errors
ErrorDocument 404 /prestashop/404.php


Tu le reconnais ?

Share this post


Link to post
Share on other sites

grrr malin ça oui bien sûr.... Là je crois que seule la PrestaTeam va pouvoir te venir en aide...désolé...

Edit: je viens de voir une de tes captures sur un autre site ( http://forum.ovh.com) où tu as demandé de l'aide...

Que rentres-tu dans "Database Server Name" à l'étape 3?
Sur la capture je vois que tu as rentré "sql"

Es-tu sûr de ça? Chez OVH pas plutôt du style "mysql5-61.60" ou quelque chose du genre
Quand tu te connectes sur le PhpMyadmin d'OVH

Par exemple chez un ami: Sur PhPMyadmin, dans choix du serveur, il choisis "mysql5-61" mais dans son fichier de config de Prestashop, il mentionne "mysql5-61.90" (Ajout donc du .90...me demande pas pourquoi!!!)

Que les utilisateurs d'OVH t'aident je pense qu'ils sont nombreux ici...
Bon courage
Max

13890_7asR6P0vIJbN2PCeagXa_t

Share this post


Link to post
Share on other sites

Voilà j'ai la réponse enfin merci aux supports OVH pour avoir trouvé le bug.

Dans mon manager OVH, ma base était décrite:
Version
MySQL 4

Dans le phpmyadmin, il était indiqué: Version du client MySQL: 5.0.32 et Francais (utf-8)

La solution donnée par le support fut de deleter la base via le manager et de la recreer.

Lors de la création, cette base devient:
Version
MySQL 5

Suite à cette modif, j'ai réupp les fichiers de prestashop, j'ai remis l'htacces fourni par Maxhome plus haut dans la discution et jackpot ca marche.

En esperant que celà aide les autres utilisateurs qui avaient des soucis sur OVH.

Salutation

Share this post


Link to post
Share on other sites

J'ai à mon tour un soucis au niveau de l'install.

J'ai suivi tous les tuto.

Et maintenant quand je tape www.monsite.com j'obtien une page " Index " avec l'arborescence de mon site..

Que dois je modifier pour règler ce soucis ?
Merci :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More