Jump to content

Maj 1.4/ 1.5 perte des réglages et des références fournisseurs


Recommended Posts

Bonjour,

 

Lors de mes tests de mise à jour de mon prestashop 1.4.1.0 vers la 1.5.4 je rencontre un soucis avec mes réglages et mes références fournisseurs.

 

En effet tous mes produits ne comportant pas de déclinaisons perdent leur réglage fournisseur et la référence qui va avec.

 

En revanche les produits avec déclinaisons gardent leur réglage fournisseur mais affiche une mauvaise référence fournisseurs.

 

Comment puis-je régler ce problème car j'aimerai éviter de devoir repasser sur toutes mes fiches pour remplir à nouveau ces champs.

 

Merci.

 

:D

Edited by kimzey (see edit history)

Share this post


Link to post
Share on other sites

Hello,

 

Effectivement le système 1.5 peut un peu dérouter quand on vient d'une 1.4. A priori c'est un bug de la mise à jour qui a été déjà evoqué. Est ce que tu peux nous faire un google translate et nous mettre ça dans la forge ? avec deux copies d’écran ce serait top.

 

Merci, désolé pour ce contre temps, pour l'instant je n'ai pas grand chose à te proposer a part être patient le temps que l'on se penche sur ce souci.

Share this post


Link to post
Share on other sites

  • 2 months later...

bonjour,

 

sur ps 1.5.4.1

 

j'ai eu ce problème lors de la migration vers la 1.5, que j'ai contourné en reconstruisant la table a la mano.

 

mais maintenant lorsque j'édite la réf fournisseur d'un produit, la réf est bien mise a jour dans la table ps_product_supplier, mais la table ps_product non...

et c'est par exemple ce champ qui est utilisé dans l'affichage des produits en liste dans l'admin...

 

j'ai lu dans le bug tracker que c'etait résolu, avec un lien vers la classe cart.php, hummm je ne vois pas bien le rapport avec le probleme vu que c'est dans l'édition d'un produit et non en rapport avec le panier, et ca ne corrige pas ce souci en tout cas.

 

est ce que les corrections que vous faites pourraient résoudre aussi ce probleme?

est ce qu'il y a un post avec une solution que je n'ai pas vu?

 

merci d'avance pour votre aide.

Share this post


Link to post
Share on other sites

  • 3 weeks later...
  • 2 weeks later...
  • 2 weeks later...

Bonjour Kevin,

 

Désolé pour ce temps de traitement mais nous avons beaucoup de tickets  ;) 

 

Je pense que ces commits d'il y a un peu près un mois doivent corriger ce souci car je viens de tester et je ne reproduis pas sur une 1.5.5.0 venant d'une 1.4. Je vous ai également répondu sur le ticket

 

https://github.com/PrestaShop/PrestaShop/commit/e85ffae69d5d90e3fe42cbf6cb7d65e79f3fcf40

 

https://github.com/PrestaShop/PrestaShop/commit/e85ffae69d5d90e3fe42cbf6cb7d65e79f3fcf40

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour

merci pour la réponse.

La boutique est déjà en 1.5.4

Les tickets corrigent les fichiers pour l'upgrade

Mais comme celui étant déjà fait, que dois je faire ?

Je souhaite au moins pouvoir voir sur la page de commande, la référence fournisseur du produit commandé.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More