Jump to content

Recommended Posts

Ola,

 

Acabei de atualizar a minha loja para a nova versão do prestashop..

 

Instalou tudo direitinho, base de dados, configurações etc......

 

Na hora de testar a minha loja em http://lojamundial.net/ mostra um erro e não abre..

 

O erro é o seguinte:

 

Couldnt execute query2

 

Já aconteceu alguem?como corrigir?

 

Obrigado

Share this post


Link to post
Share on other sites

Movi a sua pergunta para instalação e configuração que é a categoria correta do forum. ;)

 

O seu banco de dados parece estar corrupto. Vc. fez um back-up manual antes de atualizar ? Restaure a sua loja manualmente, não através da opção "roll back" do módulo 1-click-upgrade.

Share this post


Link to post
Share on other sites

eu fiz o upgrade td ok, excepto um modulo (acho eu que é um modulo) jirafe.zip que deu erro

 

 

tenho acesso ao admin, mas a pagina principal dá o erro Couldnt execute query2

 

 

o que será

 

Estou em Local Server.... posso "estragar à vontade)

Share this post


Link to post
Share on other sites

Desativa o módulo ou deleta da lista de módulos. Se nao possível entao deleta diretamente no FTP /modules/jirafe

Share this post


Link to post
Share on other sites

tentei outras formas e parece-me que seja algum problema com o tema.

 

no entanto meti um tema default limpo e continua igual.

Share this post


Link to post
Share on other sites

Ativa o modo debug e limpe os erros lá mostrados:

 

Altere no FTP o seu ficheiro /config/config.defines.inc.php estas linhas:

 

/* Debug only */
define('_PS_MODE_DEV_', true);
if (_PS_MODE_DEV_)
{
@ini_set('display_errors', 'on');
define('_PS_DEBUG_SQL_', true);
/* Compatibility warning */
define('_PS_DISPLAY_COMPATIBILITY_WARNING_', true);
}

Share this post


Link to post
Share on other sites

Jejus tantos erros

 

 

Warning: Function addCSS() is deprecated in /Applications/MAMP/htdocs/modules/blockpermanentlinks2/blockpermanentlinks2.php on line 87

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: Function hookExec() is deprecated in /Applications/MAMP/htdocs/modules/blocksearchcenter/blocksearchcenter.php on line 56

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: Function addCSS() is deprecated in /Applications/MAMP/htdocs/modules/blocksearchcenter/blocksearchcenter.php on line 73

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: Function addJS() is deprecated in /Applications/MAMP/htdocs/modules/blocksearchcenter/blocksearchcenter.php on line 74

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: Function addCSS() is deprecated in /Applications/MAMP/htdocs/modules/blocksearchcenter/blocksearchcenter.php on line 76

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: Function addCSS() is deprecated in /Applications/MAMP/htdocs/modules/blocksearchcenter/blocksearchcenter.php on line 77

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: Function addCSS() is deprecated in /Applications/MAMP/htdocs/modules/blockbestsellers2/blockbestsellers2.php on line 132

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: Function addCSS() is deprecated in /Applications/MAMP/htdocs/modules/blockcart2/blockcart2.php on line 189

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: Function addJS() is deprecated in /Applications/MAMP/htdocs/modules/blockcart2/blockcart2.php on line 191

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: Function addCSS() is deprecated in /Applications/MAMP/htdocs/modules/sendtoafriend2/sendtoafriend2.php on line 57

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: Function addCSS() is deprecated in /Applications/MAMP/htdocs/modules/blockadvertmulti/blockadvertmulti.php on line 260

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Strict Standards: Declaration of Mobile_Theme::disable() should be compatible with ModuleCore::disable($forceAll = false) in/Applications/MAMP/htdocs/modules/mobile_theme/mobile_theme.php on line 802

 

Warning: Function addJS() is deprecated in /Applications/MAMP/htdocs/modules/mobile_theme/mobile_theme.php on line 323

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: Function addCSS() is deprecated in /Applications/MAMP/htdocs/modules/blocktestimonial/blocktestimonial.php on line 278

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: Function getDiscounts() is deprecated in /Applications/MAMP/htdocs/modules/blockcart2/blockcart2.php on line 88

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in /Applications/MAMP/htdocs/modules/blocktestimonial/blocktestimonial.php on line 251

Couldnt execute query2

Share this post


Link to post
Share on other sites

Todos estes módulos estao causando problemas com PS 1.5. vc. deverá desativá-los. blockcart2 deve vir to seu thema. Themas para PS 1.4. nao funcionam com PS 1.5.X

Share this post


Link to post
Share on other sites

fiz outra coisa...

 

o Couldnt execute query2 ficou resolvido. Solved

 

Removi todos os modulos da pagina antiga (tive de "esquecer" o autoupgrade) e meti tds os modulos do 1.5....

 

aparentemente já está melhor... ja aparece qualquer coisa... ligeiramente diferente do tema original... tenho agora de corrigir.

Share this post


Link to post
Share on other sites

Estou com configurações do tema diferentes do tema default. Ele parece que tem definições no sql do tema antigo.

 

Estarei correcto? Existe conf de sql do tema que eu possa importar ?

Share this post


Link to post
Share on other sites

Não. Vc. vai ter que comprar um tema novo para PS 1.5.

Share this post


Link to post
Share on other sites

Bom dia

 

Eu estive a comparar o tema default do que tenho na pagina antiga e na pagina nova. E deparei-me com o seguinte:

 

Original:

 

 

 

A minha pagina atualizada com o tema original do prestashop (default):

 

 

 

 

 

Depois de tentar ver diferenças tentei ir ao modulo Top Horizontal Menu e configurar e obtenho o seguinte (relembro que os modulos sao todos da ultima versão):

 

[PrestaShopDatabaseException]

Unknown column 'll.link' in 'field list'

SELECT l.id_linksmenutop, l.new_window, ll.link, ll.label

FROM ps_linksmenutop l

LEFT JOIN ps_linksmenutop_lang ll ON (l.id_linksmenutop = ll.id_linksmenutop AND ll.id_lang = 6 AND ll.id_shop=1)

WHERE 1

AND l.id_shop IN (0, 1)

 

at line 607 in file classes/db/Db.php

 

601. WebserviceRequest::getInstance()->setError(500, '

 '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97);

602. }

603. else if (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS'))

604. {

605. if ($sql)

[color=#F20000][b]606. throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>');

[/b][/color]607. throw new PrestaShopDatabaseException($this->getMsgError());

608. }

609. }

610.

611. /**

[/font][/color]

Edited by jose_rui_sa (see edit history)

Share this post


Link to post
Share on other sites

Booas

 

O erro que relata tem pouco haver com o tema. Verifica mais erros em outros sítios?

 

Cumps

Share this post


Link to post
Share on other sites

não me parece...

 

agora tenho o erro

 

Warning: Function display() is deprecated in /Applications/MAMP/htdocs/classes/controller/Controller.php on line 185

in /Applications/MAMP/htdocs/classes/Tools.php on line 1845

 

 

E já tenho a pagina a parecer assim.

Creio mesmo ser definições no sql (por exemplo onde fica guardada a informação que um determinado modulo está ativo ou nao?)

Share this post


Link to post
Share on other sites

Verifique os logs na raiz de ficheiros do prestashop para ver se aparece mais detalhes sobre esses problemas.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More