Jump to content

[Module] Statstrackvisits, See detail tracking of your visitors for period chosen


Recommended Posts

statstrackvisits.php

Just look for the form tag


"AdminStatsModules" appears on lines 46 and 311 of statstracksvisits.php. "Adminstats" appears in several places - what needs to be changed ?

Share this post


Link to post
Share on other sites
  • Replies 254
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi!   Well this is my first module under PrestaShop, i hope it will be useful for you!   Statstrackvisits allows you see details tracking of your members and visitors, online or offline for period

Is it possible to use the module with GeoLiteCity.dat? It's very interesting to know the places where the customers come from.

probably yes, I watch it the next update too;)

Posted Images

Warning: array_sum() [function.array-sum]: The argument should be an array in /home/lucid/ftp/xxxxxxxx/modules/statstrackvisits/statstrackvisits.php on line 561

Warning: array_sum() [function.array-sum]: The argument should be an array in /home/lucid/ftp/xxxxxxxx/modules/statstrackvisits/statstrackvisits.php on line 562

Warning: array_sum() [function.array-sum]: The argument should be an array in /home/lucid/ftp/xxxxxxxxx/modules/statstrackvisits/statstrackvisits.php on line 563


Please help. how to solve this problem.


This error apears in Stats >> Tracking visitors

Share this post


Link to post
Share on other sites
statstrackvisits.php

Just look for the form tag


"AdminStatsModules" appears on lines 46 and 311 of statstracksvisits.php. "Adminstats" appears in several places - what needs to be changed ?


Bump - anyone ?

Share this post


Link to post
Share on other sites
statstrackvisits.php

Just look for the form tag


"AdminStatsModules" appears on lines 46 and 311 of statstracksvisits.php. "Adminstats" appears in several places - what needs to be changed ?


Bump - anyone ?


Bump, bump ? ;o))

Share this post


Link to post
Share on other sites

Hi:
I’m using the module 1.3 in PrestaShop 1.2.5 from the beginning without problems, yesterday I decide to use a SSL certificate for my shop and after installing the SSL certificate I have a few warning when I try to see the IP’s of the visitors, (Monitored Member) please find attached to see the warning I receive.
Somebody can please help me with? I don’t have any idea about programming.
I’m hosted in 1and1.com
Prestashop version 1.2.5
Thank for advance.

49066_OObpDjw2dxp15csEFmbc_t

Share this post


Link to post
Share on other sites

Hi,

Installed and activated the module in the BO, changed the folder permission to 777 so everything should work BUT when i go into the BO Stats and select the "Tracking visitors" option it says "Calender disabled" and if I click on one of the options above like "connected" it displays "Tab cannot be found"....... Am I missing something somewhere? Using 1.4.3

Share this post


Link to post
Share on other sites
  • 5 weeks later...

Bonjour

J'ai installé la version 1.3.0 du module (sur prestashop 1.4.4).

Le problème est que lorsque je veux modifier une option, en cliquant sur "sauvegarder ces options comme options par défaut", j'ai un message : "l'onglet ne peut être trouvé"...

 

Avec vous ce problème ?

Share this post


Link to post
Share on other sites

Bonjour,

 

@Sam59 : vous avez réussi à faire une installation de ce module sur une version PS 1.4.4 ? Je suis fortement intéressée de savoir comment vous avez fait....

 

J'ai une erreur :

Warning: array_sum() [function.array-sum]: The argument should be an array in/homepages.../modules/statstrackvisits/statstrackvisits.php on line 558 et 559 et 560

[/b][/font]$ipmonitored = array_sum($ipmonitored) == 0 ? false : $ipmonitored;
	$idmembermonitored = array_sum($idmembermonitored) == 0 ? false : $idmembermonitored;
	$ipfilter = array_sum($ipfilter) == 0 ? false : $ipfilter;[font=Arial, Verdana, Helvetica, sans-serif][b]

Ainsi qu'un calendrier désactivé

Share this post


Link to post
Share on other sites
Worked fine for a month but now it has stoped saving the details of the visitors, how do I fix it?
<br/>Here too. Getting the message "No Visitor has connected during the period chosen or with the criteria you selected."<br/>It allways worked fine till yesterday. Can anyone help us out?

 

I got the same problem, could anyone help me fix this

Share this post


Link to post
Share on other sites

I am using this on 1.4.3 right now. No problems

 

Hello,

What did you change on this module ?

I always have errors on line 561, 562 et 563.

Can you send me your module ?

Share this post


Link to post
Share on other sites

Bonjour

J'ai installé la version 1.3.0 du module (sur prestashop 1.4.4).

Le problème est que lorsque je veux modifier une option, en cliquant sur "sauvegarder ces options comme options par défaut", j'ai un message : "l'onglet ne peut être trouvé"...

 

Avec vous ce problème ?

 

J'ai installé ce fichier qui a résolu ce problème.

statstrackvisits.zip

  • Like 1

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Many some hours ago ...

I see nothing - blank statistic page.

Prestashop 1.4.4.1

 

I think you need to find the module DATA MINING and then click in the first option, I think I did that for it to start working.

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 1 month later...
  • 1 month later...

PHP Warning: Cannot modify header information - headers already sent by

PHP Warning: imagestring(): supplied argument is not a valid Image resource

PHP Warning: imagecopy(): supplied argument is not a valid Image resource

PHP Warning: imagecolorallocate(): supplied argument is not a valid Image resource

PHP Warning: imagecolortransparent(): supplied argument is not a valid Image resource

PHP Warning: imagecolorallocate(): supplied argument is not a valid Image resource

PHP Warning: imagecreate() [<a href='function.imagecreate'>function.imagecreate</a>]: Invalid image dimensions in

PHP Warning: imagesy(): supplied argument is not a valid Image resource in

PHP Warning: imagesx(): supplied argument is not a valid Image resource in

PHP Warning: imagecreatefromgif() [<a href='function.imagecreatefromgif'>function.imagecreatefromgif</a>]:is not a valid GIF file

PHP Warning: imagedestroy(): supplied argument is not a valid Image resource

PHP Warning: imagedestroy(): supplied argument is not a valid Image resource

PHP Warning: imagepng(): supplied argument is not a valid Image resource in

 

 

GOOD !

 

View yours logs server ;)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Not wotkin on 1.4.6.2....

 

Keep getting a message that says "Tab cannot be found"?

 

Anyone able to help ?

 

Thanks ...

 

Regards,

Doug

 

See the sollution of monvidedressing ....Copy paste inside folder the file statstrackinvisits.php that he uploaded...

 

It still doesn't show the right online time though to me.... too many 00:00:00 for visitors.. i tried it bymyself in our page and it didnt' show me the right online time (Again 00.00.00 )

 

 

I think a great idea would be to show and City of origin like Greece / Athens ... Great module in anyway.. thanks to Raph59 (How can i sent you an apreciation amount of money ?)

Share this post


Link to post
Share on other sites
  • 3 months later...

Good module, except I get these three errors using the updated php file:

 

Warning: array_sum() [function.array-sum]: The argument should be an array in /home/gamesfro/public_html/modules/statstrackvisits/statstrackvisits.php on line 561

 

Warning: array_sum() [function.array-sum]: The argument should be an array in /home/gamesfro/public_html/modules/statstrackvisits/statstrackvisits.php on line 562

 

Warning: array_sum() [function.array-sum]: The argument should be an array in /home/gamesfro/public_html/modules/statstrackvisits/statstrackvisits.php on line 563

 

Any one found a solution to this?

 

Thanks.

Share this post


Link to post
Share on other sites
  • 6 months later...

Hello,

 

I just published a minor updates, which makes it compatible with version 1.4.9.0, I have not tested with the 1.5 because I do not have , some could give us some feedback?

 

I also clear errors, you should not be in error logs

 

To download it, it goes on the front page of the subject, careful to download the 1.3.1 and not 1.3.0 I can not delete, if moderator can delete the 1.3.0 file because I can not delete it, made ​​a error ...

 

Do not hesitate to give me your feedback

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Two PHP notices still showing ...

 

Notice: Undefined index: showcart in /modules/statstrackvisits/statstrackvisits.php on line 380

 

Notice: Undefined index: showipmember in /modules/statstrackvisits/statstrackvisits.php on line 383

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 1 month later...
  • 2 weeks later...
  • 2 weeks later...

I get the problem on the first page which says:

Calendar disabled

 

 

Once i press visitors and members it says activated but not showing up any visitors when there are visitors on ym site.

Share this post


Link to post
Share on other sites

I get the problem on the first page which says:

Calendar disabled

 

 

Once i press visitors and members it says activated but not showing up any visitors when there are visitors on ym site.

 

The same problem here, too

Share this post


Link to post
Share on other sites

Hi Raph59!

 

Thanks for a great module!

First, I used it on PS1.2.4, and later on PS1.4.4.1 on OVH hosting and everything was fine.

Now a have PS1.4.4.1 on linux.pl hosting and I have little problem with iplocator.

http://www.mat-hurtownia.com.pl/modules/statstrackvisits/iplocator.php?visitorip=91.240.109.108 give error 500.

The problem is with this:

$logVisitor = findCountryFromIP($_GET['visitorip']);

 

my cofig:

 

Wersja Prestashop: 1.4.4.1

Informacja o serwerze: Linux #1 SMP Sun Sep 23 10:07:46 UTC 2012 x86_64

Wersja oprogramowania serwera: Apache/2.2.16 (Debian)

Wersja PHP: 5.3.3-7+squeeze14

Wersja MySQL: 5.1.66-0+squeeze1

 

Please help me.

 

Sorry for my woodish english.

Share this post


Link to post
Share on other sites
  • 1 month later...

Hi Ralph,

 

i realy do like your track visitors module.

I have setup a site long time ago and used your module.

Version of Presta:

PrestaShop™ [ forum & contact ] - Version 1.3.7.0 - 0.075s

 

Now i have setup a new server with new ubuntu version 12.04, before i used ubuntu 8

I have copied the database and the prestashop folder to the new server all rights and files are identical to the old environment

All ok so far, all is running

I used the Tracking visitors v1.2.3

 

Worked allways fine, however in the new environment i don't see the flags anymore.

I have tried your newest 1.3.1 and 1.3.0 and i got the same problem, no flags.

When i ping to google.com i do get reply , so dns is working.

 

I have set the ubuntu on a virtual environment

PHP version is now

php -v

PHP 5.3.10-1ubuntu3.6 with Suhosin-Patch (cli) (built: Mar 11 2013 14:31:48)

Copyright © 1997-2012 The PHP Group

Zend Engine v2.3.0, Copyright © 1998-2012 Zend Technologies

 

Any ideas

Thanks you for aby suggestions.

 

Tellme

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 1 month later...

Thank you for this useful module. I really like the idea behind it. it's very very useful to me.

I installed it smoothly on my PS 1.5.3.1 but when accessed it says calendar disabled in the main screen. On the Monitoring, Visitors and Members tab in says Calendar Activated, but it shows no visitors online. i'm sure there are visitors on my site because I have also installed the Zopim chat module.

I'd really love to have this module. Any help it's appreciated.

 

Bests to all of you !

Share this post


Link to post
Share on other sites

Hello fuskoz,

 

The module is not updated anymore and is not working correct anymore on PS 1.5.4.1. It shows only things as product not found and you can't see anymore what pages customers has visited.

I have enjoy this module for many years but now i have buy a great who is online module from prestaspirit that is worth every penny ;)

 

Regards,

 

ysco..

Share this post


Link to post
Share on other sites
  • 3 months later...

Thank you for the updates for PS 1.5.3 it was working perfectly.
Now i updated to 1.5.5. Can you please help me to make this module work?
thank you for your useful module.

Share this post


Link to post
Share on other sites
  • 5 weeks later...

Hi Raph59!

 

Thanks for a great module!

First, I used it on PS1.2.4, and later on PS1.4.4.1 on OVH hosting and everything was fine.

Now a have PS1.4.4.1 on linux.pl hosting and I have little problem with iplocator.

http://www.mat-hurtownia.com.pl/modules/statstrackvisits/iplocator.php?visitorip=91.240.109.108 give error 500.

The problem is with this:

 

 

my cofig:

 

 

 

Please help me.

 

Sorry for my woodish english.

 

I found the fix for no flag problem (server error 500).

 

In file geoip.inc on line 348 replace:

function geoip_country_code_by_name($gi, $name) {
  $country_id = geoip_country_id_by_name($gi,$name);
  if ($country_id !== false) {
        return $gi->GEOIP_COUNTRY_CODES[$country_id];
  }
  return false;
}
function geoip_country_name_by_name($gi, $name) {
  $country_id = geoip_country_id_by_name($gi,$name);
  if ($country_id !== false) {
        return $gi->GEOIP_COUNTRY_NAMES[$country_id];
  }
  return false;
}

with

if (!function_exists('geoip_country_code_by_name')){
    function geoip_country_code_by_name($gi, $name) {
      $country_id = geoip_country_id_by_name($gi,$name);
      if ($country_id !== false) {
            return $gi->GEOIP_COUNTRY_CODES[$country_id];
      }
      return false;
    }
}
if (!function_exists('geoip_country_name_by_name')){
    function geoip_country_name_by_name($gi, $name) {
      $country_id = geoip_country_id_by_name($gi,$name);
      if ($country_id !== false) {
            return $gi->GEOIP_COUNTRY_NAMES[$country_id];
      }
      return false;
    }
}

Share this post


Link to post
Share on other sites
  • 3 months later...
  • 1 month later...
  • 1 year later...
  • 6 months later...
  • 3 months later...
  • 2 months later...
  • 1 year later...

Amazingly, it works fine in 1.6.1.8, although it no longer gives much information about the page the customer is on - it now simply says 'Product' or 'Category'.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More