Jump to content

[Solved] Can't enable SSL


adamdp
 Share

Recommended Posts

I moved hosts, had my site working fine without an SSL certificate. I disabled SSL for the period that it didn't exist - I'd had an SSL certificate with the previous hosts and it was enabled fine.

 

Today I bought the SSL and hosts installed it, however when I went to renable SSL in Back Office I am faced with:

 

"Please click here to use HTTPS protocol before enabling SSL."

 

If I click it reloads the page with https if it wasn't before but the option to enable SSL remains unavailable.

 

The site loads on https with a warning about 'script from unauthenticated sources'.

 

 

Site is coolvape.co.uk

 

[uPDATE]: My web host managed to fix this for me, the issue was caused by their 'SSL load balancer'.

 

Hope this helps anyone else with this issue.

Edited by adamdp (see edit history)

Share this post


Link to post
Share on other sites

  • 2 months later...

I'm having a similar problem, although for me this is a 'first time of trying' situation.

 

The site I'm working on is set up as follows:

 

Shared hosting.

Shared SSL

 

Prestashop installed in:

domainname.co.uk/shopfront

(hosting package required a folder to be specified for SSL (slightly annoying)).

 

In Preferences>SEO/URLs, the default details are:

Shop domain - domainname.co.uk

SSL domain - domainname.co.uk

Base URI - /shopfront/

 

If I click on "Please click here to use HTTPS protocol before enabling SSL", I get the same basic problem that Adam descibes above; the https appears in the address bar on that page but the option to "Enable SSL" doesn't appear. The admin remains in https but the site stays 'normal'. If I manually add the "S" the site simply refreshes to 'normal' status.

 

Just as a sanity test, I threw some things in the basket and went to Checkout, but no change to https is happening. I need to get this sorted out before spending any time on styling and filling the shop with goods, so any help would be most appreciated.

 

Adam, are you able to expand upon the solution your hosting company provided? I'd just like to be armed with a bit more information if it comes to me having to call the host in this case.

 

Are there other reasons why this might happen?

 

Many thanks for all assistance offered.

Frank

Share this post


Link to post
Share on other sites

 

Adam, are you able to expand upon the solution your hosting company provided? I'd just like to be armed with a bit more information if it comes to me having to call the host in this case.

 

Are there other reasons why this might happen?

 

Many thanks for all assistance offered.

Frank

 

Hi, after some trying myself I contacted the host and they seemed to know straight away what the issue was.

 

Their response was:

 

"now fixed - I've added a couple of lines to the top of config/settings.inc.php to let Prestashop recognise our SSL load balancer."

 

 

Hope that helps, that's all the info they gave.

  • Like 1

Share this post


Link to post
Share on other sites

  • 7 months later...

same problem here.

 

What did they add in settings.inc.php ?

 

thanks for the help

this is what is now at the top of settings.inc.php
 
if( isset($_SERVER['HTTP_X_FORWARDED_PROTO']) ) {
    $_SERVER['HTTPS'] = 'on';
    $_SERVER['SERVER_PORT'] = 443;
}

 

not sure what they actually changed/what was there before, hope that helps.

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More