Jump to content

Update Prestashop, pourquoi est-ce que mon thème personnalisé est tout chamboulé?


Recommended Posts

Bonjour à tous!

Pour des raisons d'import d'images par CSV, je suis en train de faire une update de mon prestashop. Un personne tierce avait fait l'intégration du design de ma boutique qui tourne sur la dernière version de Prestashop stable.

J'ai installé un autre Prestashop (stable tjs) sur un autre hébergement pour faire des tests. J'ai copié le dossier de mon thème personnalisé, l'ai collé dans ce nouveau Prestashop. A quelques détails près ça fonctionnait. Je me suis donc lancé dans l'update, et là c'est devenu le gros B%*&L;.

Vous pouvez voir la version stable officielle (encore en construction) ici avec mon template personnalisé:
www.shopcoiffure.net/index.php

et mon deuxième Prestashop test, upgradé, avec le même template:
www.lovcard.ch

Avez vous une idée d'où viennent ces chamboulements? A commencer par le message d'erreur "This page requires AC_RunActiveContent.js" ?

Merci d'avance!

Share this post


Link to post
Share on other sites

Salut,

Déjà pour AC_RunActiveContent.js ça viens de flash, si tu as exporter ton animation flash te fournis ce code (que tu as d'ailleurs sur http://www.shopcoiffure.net/index.php) sur http://www.lovcard.ch il manque semble-t-il un dossier "flash" avec le flash et le fichier js ;)

Ceci dit tu as une 2eme erreur sur tes deux site:
il manque jquery-ui-1.6.custom.min.jsX -> http://www.lovcard.ch/themes/shopcoiffure/js/jquery-ui-1.6.custom.min.jsX -> 404 Not Found

Vu avec firebug ;)

Share this post


Link to post
Share on other sites

Merci pour ton aide!

Ok super pour le flash j'ai complétement oublié de copier le dossier :)

Par contre concernant le deuxième élément, alors là je n'en ai aucune idée... En fait j'ai fait le design, le cahier des charges du site, etc, mais l'intégration c'est une autre personne. Et mtn je dois me débrouiller tout seul, je suis donc un pur débutant dans l'intégration d'un thème Presta... :(

Share this post


Link to post
Share on other sites

Salut,

Alors pour la 2nd erreur, il suffit que tu regardes dans le fichier header.tpl de ta template et tu recherche "jquery-ui-1.6.custom.min.jsX"

Il suffira alors de supprimer la ligne, ça évitera d'avoir des erreurs dans le logs ;)

Edit:
Il faut que tu trouve la ligne:

[removed][removed]

Share this post


Link to post
Share on other sites

Hmmm, une de tes css est mal renseignée dans le header.tpl dans la partie <head>


OK-->http://www.lovcard.ch/themes/shopcoiffure/css/grid.css
NON OK--> /themes/shopcoiffure/css/global.css

Tu es sure d'avoir installé les mêmes versions de Prestashop ? 1.1 =stable / 1.2=béta

Sinon corrige le chemin d'acces de ta feuille de style global.css et une grande partie de ton site reviendra.

v++

Atch

Share this post


Link to post
Share on other sites

Merci bcp Atch, j'ai en effet changé et c'est déjà bien mieux!

Je suis mtn en train de comprendre la structure d'un thème, vu par un débutant, je vais poster quelques question dans un nouveau topic.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More