Jump to content

[Résolu] Divers problèmes après un passage de 1.4.10 vers 1.5.4


Recommended Posts

Bonjour,

J'ai effectué des tests de mise à jour d'un site en local et je me heurte à quelques difficultés.

 

Le site est actuellement en version 1.4.6, en utilisant le module 1-Click-Updgrade pour passer en 1.4.10 la mise à jour ce déroule parfaitement et je n'ai rencontré aucun soucis particulier tout s'affiche correctement :)

 

Après, je tente la mise à jour vers une autre version majeur, la 1.5.4, toujours avec 1-Click-Updgrade la mise à jour ce déroule correctement, mais je me retrouve confronté à plusieurs problèmes.

Et comme je suis un peu perdu avec cette nouvelle interface, peut-être que je vais trouvé la solution à mes problème avec votre aide.

  • Quelque soit le thème que j'utilise, je n'ai accès qu'a la page d'accueil, impossible d'aller sur une page produit, je voudrais re-générer le .htacces mais je ne trouve pas l'option.

  • Avec le thème que j'avais avant la mise à jour, le thème classique nommé "prestashop" j'ai des blocs qui disparaissent, ce sont des blocs qui regroupait des informations générales (contact, mentions légales, conditions de livraison...) fait avec le module Bloc CMS, et mon bloc meilleurs vente ce retrouve complètement planté (voir image)
  • blocme10.png

  • Avec le nouveau thème, nommé "default", j'ai un problème d'affichage de mes produits phares, ils sont 4, 2 sur 2 lignes, ils sont aligné sur la gauche c'est assez étrange, est-il possible de configurer ça et si oui comment ?

Merci d'avance pour votre aide.

 

Edit : J'ai trouvé pour le Menu horizontal et pour le slider et j'ai aussi trouvé pour mon footer

Edited by Vectorus (see edit history)

Share this post


Link to post
Share on other sites

Merci, cependant ça ne semble pas fonctionner, je n'arrive pas à accéder à cette page, j'ai le message suivant qui s'affiche :

La page admingenerator est introuvable.

ce ne doit pas être à la même adresse qu'avec les version 1.4

Edited by Vectorus (see edit history)

Share this post


Link to post
Share on other sites

Oui c'était la version 1.4.

Je ne retrouve pas le lien exact (je viens de faire la mise à jour en local, et j'ai le site français/anglais) dans 1.5., voir ici : index.php?controller=AdminMeta

Share this post


Link to post
Share on other sites

Cela me renvoi sur la page "préférences > SEO & URLs" , je pensais également que c'était ici mais j'ai seulement le générateur de robots.txt en bas de la page, pas de de générateur de .htaccess.

Share this post


Link to post
Share on other sites

Bonjour,

 

Alors moi j'ai la version 1.4.73 et je veux passer en 1.5.4.0

J'ai enfin réussi hier avec le module autoupgrade. (même si eu pas mal de soucis)

 

- Faire la mise à jour vers 1.4.10 (si erreur sql essayer de les résoudre dans phpmyadmin)

- Vider cacher smarty + désactiver la boutique

- Faire la mise à jour vers 1.5.4

 

Je bosse en local avec EasyPhp et j'ai du modifier les fichiers php.ini, config.default.php pour pouvoir importer...

Share this post


Link to post
Share on other sites

Bonjour, merci pour cette réponse :)

J'ai fait toutes les mises à jour avec le module autoupgrade, et je suis bien passé par l'intermédiaire de la 1.4.10 sans soucis.

La boutique était bien désactivé, par contre, je n'ai pas vidé le cache smarty, où est placé cette option, j'ai du passé à coté.

Share this post


Link to post
Share on other sites

Je sais pas si ça change quelques choses mais moi je l'ai fais manuellement entre les 2 mises à jour.

Tu vas dans tools/smarty/ (ou alors dans tools/smarty_v2) et dans les fichiers cache et compile, tu supprime tout sauf le fichier index.php

Share this post


Link to post
Share on other sites

J'ai essayé et j'ai toujours le même problème :wacko:

Sur chrome quand je tente d'accéder à une autre page que la page d'accueil j'ai le message suivant :

Cette page Web présente une boncle de redirection.

La page Web à l'adresse http://localhost/pre...op154/1-produit a déclenché trop de redirection. Pour résoudre le problème, effacez les cookies de ce site ou autorisez les cookies tiers. Si le problème persiste, il peut-être dû à une mauvaise configuration du serveur et n'être aucunement lié à votre ordinateur.

J'ai essayé de vider mes cookies rien n'y fait

Edited by Vectorus (see edit history)

Share this post


Link to post
Share on other sites

Préférences separator_breadcrumb.png SEO & URLs

 

AdminMeta.gif Set up URLs

Friendly URL

enabled.gif Yes

Enable only if your server allows URL rewriting (recommended).

 

Accented URL

disabled.gif No

Enable if you want to allow accented characters in your friendly URLs.

 

Automatically redirect to the canonical URL

enabled.gif Yes

Recommended, but your theme must be compliant.

 

Disable apache multiviews

disabled.gif No

Enable this option only if you have problems with URL rewriting.

 

Disable apache mod security

disabled.gif No

Some features could not work correctly with a specific configuration of apache mod security. We recommend to turn it off.

 

 

AdminMeta.gif Set shop URL

Here you can set the URL for your shop. If you migrate your shop to a new URL, remember to change the values bellow.

 

Shop domain : localhost

 

SSL domain : localhost

 

Base URI : /prestashop/

 

 

 

 

Voila ma config si ça peut aider.

Edited by lucie62140 (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Merci, j'ai vérifié et j'ai exactement les mêmes réglages, du coup ça veut dire que le problème ne vient pas de mon .htaccess?

D'où ça peut venir alors ?

 

Edit: en désactivant et réactivant la redirection vers l'URL canonique, il semble que mon problème ce soit résolue, probablement que le .htaccess ne s'était pas mis à jour tout seul et qu'il fallait que je lui apporte une modification pour qu'il le fasse.

 

Merci beaucoup pour votre aide, c'est vraiment étrange comme problème.

Edited by Vectorus (see edit history)

Share this post


Link to post
Share on other sites

En repassant en mode "dev" activé, j'ai le message suivant qui s'affiche :

 

Je pense que le problème vient bien du .htaccess.

 

Hello,

 

c'est le mode dev. Avant de rediriger vers une url canonique il te le dit. C'est pas un bug !

Share this post


Link to post
Share on other sites

Activer ou désactiver la re écriture force le re génération du htacces en 1.5.

 

A priori vous n'arrivez pas à accèdre à un produit quand cette re ecriture est à on. En 1.4 vous aviez la re écriture d'url car cela ressemble fortement à un mod_rewrite non activé sur votre serveur local. Boucle de redirection, il faudrait plutôt regarder du coté des logs d'Apache....

 

Pour le thème, j'ai fait une passe de correction récemment sur le thème 1.4.10 pour qu'il passe mieux sur un moteur 1.5

https://github.com/PrestaShop/PrestaShop-1.4/commit/e59e8f2450c9dd37c15620c78b1c443f61392096

 

masi il est toutefois plus simple d'utiliser le template 1.5 defaut. Ensuite probablement reinstaller un module ou deux est souvent necessaire en venant d'une 1.4. Pour les favoris sur la page d'accueil, il me semble que cela se configure dans le module.

 

Bon courage à vous tous

Share this post


Link to post
Share on other sites

 

Edit: en désactivant et réactivant la redirection vers l'URL canonique, il semble que mon problème ce soit résolue, probablement que le .htaccess ne s'était pas mis à jour tout seul et qu'il fallait que je lui apporte une modification pour qu'il le fasse.

 

 

A priori il vous laisse juste voir la page avec une mauvaise url, c'est tout.

Share this post


Link to post
Share on other sites

Globalement ça fonctionne assez bien, mais si ça me laisse voir " la page avec une mauvaise url " c'est quand même pas terrible, en particulier pour le référencement, alors j'aimerai y remédier. Si c'est un problème uniquement causé par le fait que ce soit en local ce n'est pas gênant mais je veux pas prendre le risque que ça se produise en ligne.

Sinon j'ai accès à toute les pages, j'ai apporté les modifications que je souhaitais et tout semble fonctionnel, sauf que je viens de tester avec un autre site et j'ai un nouveau problème, je n'arrive pas à accéder à la page des modules dans le Back Office :unsure:

Le site Web a rencontré une erreur lors de l'extraction de http://localhost/.... Cela peut être dû à une opération de maintenance ou à une configuration incorrecte.
Edited by Vectorus (see edit history)

Share this post


Link to post
Share on other sites

Pour le problème de la page de module inaccéssible, il semble que ça vienne de mon fichier translate.php du dossier classes, je vais voir si je trouve une solution.

Edit : je ne trouve pas la solution, mais je vais ouvrir un nouveau post pour ça.

Edited by Vectorus (see edit history)

Share this post


Link to post
Share on other sites

J'ai eu le même soucis à un moment, mais je sais plus comment je l'ai résolu.

Il me semble que j'ai supprimé le module jc_ean_upc, mais tu l'as peut être pas.

Essaye de faire : Localisation > traduction > Langue que vous souhaitez ajouter ou mettre à jour : French

Share this post


Link to post
Share on other sites

Bonjour, merci pour la réponse :)

Mon problème vient en faite du modules "IciRelais" en le supprimant simplement ça fonctionne mais c'est pas terrible puisque je n'ai plus le module, et par la méthode de la traduction, la traduction est un succès mais ça ne résout pas le problème.

Je vais tenter de supprimer le module et de le réinstaller après voir ce que ça donne.

Edit: impossible de retrouver le module sur le net, je vais peut-être le remplacer par so colissimo

Edited by Vectorus (see edit history)

Share this post


Link to post
Share on other sites
  • 9 months later...

Même si ce post est assez vieux, pour ceux qui sont encore à savoir comment régénérer de nouveau le fichier htaccess sur la 1.5.X, il suffit tout simplement d'aller dans : => préférences => SEO & URLs.

 

Une fois sur la page, il ne vous reste plus qu'à descendre tout en bas et de faire enregistrer en haut à droite et cela va régénérer le fichier htaccess

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More