Jump to content

Recommended Posts

I have been trying to change the language of this page to Spanish. http://elektrozales.com/es/

I can’t change "ADD TO CART" to "AÑADIR AL CARRITO". I have been trying for days, I have translated and all, but when i click on "translate back-Office" it says 1000 de max_input_vars.

and you need 4654, ask your hosting provider to increases it.

 

I just called godaddy, but they said me they don’t have that file, and I should create it, but I don’t know how.

 

I just printed my phpinfo and it said that it already exists in this place: /web/conf/php5.ini but I can’t find it, can some 1 help me?

 

I will appreciate any help, thank so much and sorry for my English, I am not native English speaker

there is my php info: http://elektrozales.com/phpinfo.php

Edited by elektrozales (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

This should be in your php.ini file under resource limits:

Here is an example:

 

max_execution_time = 1000	 ; Maximum execution time of each script, in seconds
max_input_time = -1 ; Maximum amount of time each script may spend parsing request data
memory_limit = 1024M	  ; Maximum amount of memory a script may consume (32MB)
max_input_vars = 10000;

  • Like 2

Share this post


Link to post
Share on other sites

That may be a hidden file call Go Daady back and tell them you need the max_input_vars increased in your PHP,ini file.

In the root folder of your FTP account do you see a web folder.

Funny how some host are, with mine I am able to edit my PHP.ini file right from the control panel and even switch between 5.2 and 5.3.

Funny thing was though with PHP 5.3 even when I changed the max_input I still received this message I switched back to 5.2 and no more errors.

Here is why 5.2 has no such variable that started with 5.3.

 

 

You can create a file named php5.ini and place this code inside then upload to the root of your domain.and see if it helps

 

 

; How many GET/POST/COOKIE input variables may be accepted

max_input_vars = 5000

 

 

OR

 

You could also try adding this to your .htaccess file: (do one or the other)

[color=#3F3E29][font=Arial, Helvetica, sans-serif]php_value max_input_vars 5000[/font][/color]

  • Like 6

Share this post


Link to post
Share on other sites

That may be a hidden file call Go Daady back and tell them you need the max_input_vars increased in your PHP,ini file.

In the root folder of your FTP account do you see a web folder.

Funny how some host are, with mine I am able to edit my PHP.ini file right from the control panel and even switch between 5.2 and 5.3.

Funny thing was though with PHP 5.3 even when I changed the max_input I still received this message I switched back to 5.2 and no more errors.

Here is why 5.2 has no such variable that started with 5.3.

 

 

You can create a file named php5.ini and place this code inside then upload to the root of your domain.and see if it helps

 

 

; How many GET/POST/COOKIE input variables may be accepted

max_input_vars = 5000

 

 

OR

 

You could also try adding this to your .htaccess file: (do one or the other)

[color=#3F3E29][font=Arial, Helvetica, sans-serif]php_value max_input_vars 5000[/font][/color]

 

I called back to Godaddy, they said me they dont know PHP so well, and they are not able to code anything...

what i should do?

 

I added the code that u said to the .htaccess file, but still dont work, i think i should create this file, but how i can i do that? and should i place it in the root? or where?

 

thanks for your fast replys

Share this post


Link to post
Share on other sites

I made the file for you just download to your computer then upload to the root folder of your shop.

 

before uploading change the name to php5.ini, the forum does not allow .ini files to be uploaded.

 

 

 

 

Thank you so much now i can translate, =D

Share this post


Link to post
Share on other sites

So I will assume this fixed your issue, please mark the post as solved.

How to - edit your original post click Use full editor at the bottom then add [sOLVED] in front of your original title.

Edited by tdr170 (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Hi,

I have the same problem.

I have uploaded the file php5.ini in the root of the shop but I have the same error.

Warning: Your PHP configuration limits the number of fields in the form of post:

1000 max_input_vars.

Please ask your provider to increase this limit to a minimum of 1632 or translate the file manually ..

what's wrong ?

My php version is PHP 5.3

my shop is hosted on go daddy.

Thank you in advance

Have a nice day

MAXC

Edited by makuweb (see edit history)

Share this post


Link to post
Share on other sites

and if you try with php.ini (not php5.ini) ?

  • Like 1

Share this post


Link to post
Share on other sites

i don't know specification of godaddy, but you should send PM to @Ken_GoDaddy - he is a member of godaddy team here, im convinced that he will help you!

Share this post


Link to post
Share on other sites

That may be a hidden file call Go Daady back and tell them you need the max_input_vars increased in your PHP,ini file.

In the root folder of your FTP account do you see a web folder.

Funny how some host are, with mine I am able to edit my PHP.ini file right from the control panel and even switch between 5.2 and 5.3.

Funny thing was though with PHP 5.3 even when I changed the max_input I still received this message I switched back to 5.2 and no more errors.

Here is why 5.2 has no such variable that started with 5.3.

 

 

You can create a file named php5.ini and place this code inside then upload to the root of your domain.and see if it helps

 

 

; How many GET/POST/COOKIE input variables may be accepted

max_input_vars = 5000

 

 

OR

 

You could also try adding this to your .htaccess file: (do one or the other)

[color=#3F3E29][font=Arial, Helvetica, sans-serif]php_value max_input_vars 5000[/font][/color]

hi presta

i registered myself just because to say thank you.this peice of code helped me in increasing variables in menu items in word press.i will definately share your link on wordpress platform.thanks and i will follow this forum onwards............

  • Like 1

Share this post


Link to post
Share on other sites

Thank you so much now i can translate, =D

 

Please, I need this file!!!

Share this post


Link to post
Share on other sites

Please, I need this file!!!

 

I have re-attached the file to post 5.

  • Like 2

Share this post


Link to post
Share on other sites

Hello everyone. Thanks for sharing this topic. I have the same problem with translations, but my provider told me that it is not possible to increase the value!! What do I do now? 

Share this post


Link to post
Share on other sites

Hello everyone. Thanks for sharing this topic. I have the same problem with translations, but my provider told me that it is not possible to increase the value!! What do I do now? 

 

Probably the only workable solution is to replicate your shop on a localhost running on your computer.  (search forum on how to do this or open a new topic).  This will allow you to set you localhost values so that you can make the changes, then you  would ftp  those changes to your remote..

 

The better option is to find another hosting company.

  • Like 1

Share this post


Link to post
Share on other sites

Dear tdr170

Thank you so much for sharing your knowledge with this forum members.

 

its worked.

 

wish you all the best.

 

:)

Share this post


Link to post
Share on other sites

Probably the only workable solution is to replicate your shop on a localhost running on your computer.  (search forum on how to do this or open a new topic).  This will allow you to set you localhost values so that you can make the changes, then you  would ftp  those changes to your remote..

 

The better option is to find another hosting company.

 

Thank you El Patron for advice. I replicated the shop on localhost as you suggested. I had done that before, so it wasn't such a big problem. Now I can access all my translations. So thanks again. 

  • Like 1

Share this post


Link to post
Share on other sites

I have been through this problem  with a number of different hosts. With different host companies, one of the following always worked for me:

 

  • Ask your hosting panel to make the change to the php
  • Or add the following line to your htaccess (without quotes): "php_value max_input_vars 4000"
  • Or add the following line to your htaccess (without quotes): "php_flag max_input_vars 4000

However, I am currently working on a site hosted on GoDaddy (helpful support but absolutely useless hosting) and the issue is not resolving.

Share this post


Link to post
Share on other sites

php.ini helped! Thnx!

 

you're on godaddy?

Share this post


Link to post
Share on other sites

Just wanted to add this: For me the solution was to edit the php.ini file located in the etc/php5/apache2-folder. I guess the location can be different from host to host. I have a cloud-vps server btw.

Edited by nienha (see edit history)

Share this post


Link to post
Share on other sites

Just wanted to add this: For me the solution was to edit the php.ini file located in the etc/php5/apache2-folder. I guess the location can be different from host to host. I have a cloud-vps server btw.

 

this is a very good point...it's all about location location location...oh, and putty....

 

for anyone that wants to know where their php.ini is located and/or pathing to any and all .ini's, get this free module...

 

http://www.prestashop.com/forums/topic/278164-free-module-display-php-environment-13-14-15/

Share this post


Link to post
Share on other sites

I made the file for you just download to your computer then upload to the root folder of your shop.

 

before uploading change the name to php5.ini or php.ini the forum does not allow .ini files to be uploaded.

 

 

attachicon.gifphp.txt

 

 

 

I would like to thank and inform you that the above file on this date still is working very well.

I put the file in / public_html as the name php.ini

very sheltered by tdr170 file

sorry my english.

 
I forgot to mention. xD
my hosting is godaddy linux
Edited by psycki (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

Hello,

 

In my case I had to put the php.ini file in the administration folder,  /public_html folder didn´t worked for me.

 

Thank you everyone for all the solutions posted.

  • Like 1

Share this post


Link to post
Share on other sites

What filename does my PHP initialization file (php.ini) need to use?

Date Submitted: 1-31-2014

PHP initialization files can manage form, server, and environmental variables as well as server-side cookies, temporary directories, error display, and error logging.

The file name your PHP initialization must use depends on the type of hosting account you have. For more information, see What type of hosting account do I have?

Type

Filename

 

Web Hosting - Windows
with PHP 5.4 (info) .user.ini

 

 All Other Web Hosting php5.ini

 

*cPanel .user.ini

 

Plesk .user.ini

 

Managed WordPress php.ini

 

* You must have a .user.ini file in the Web root of each domain to modify its PHP settings.

Web Hosting accounts running Windows with IIS 6 do not support PHP and therefore do not support PHP initialization files.

Edited by jose266x (see edit history)

Share this post


Link to post
Share on other sites

i fix finaly in godaddy , 1 first - you should put file named php.ini to /public_html

2 -  put this variable      (suhosin.post.max_vars = 4252

suhosin.request.max_vars = 4252
max_input_vars = 10000)
 
 
 
have fun :)
  • Like 2

Share this post


Link to post
Share on other sites

Just be aware that in PHP 5.2.38 there is no such option "max_input_vars" to change, at least do a search and look into the resource limits category... any idea?

 

Try to add it on, no change at all, I am hosting my own server and have full access to it, and I am running on Windows Server 2012 R2 version newest. with IIS 8.0

Share this post


Link to post
Share on other sites

Sorry to raise that issue again. I'm having a hard time here.  Tried them all: change the .haccess, php.ini, so forth. 

 

I use PHP2 (changed from PHP3 as suggested in some forums) and the configuration is there as max_input_vars=1000

 

Question is: Is that possible that the host prevent me from overriding this parameter in anyway?

 

In times, there was no php.ini file in my directories, coming from the host. I created my own. 

 

Thanks in advance.... Really needing to solve this.

Share this post


Link to post
Share on other sites

Sorry to raise that issue again. I'm having a hard time here.  Tried them all: change the .haccess, php.ini, so forth. 

 

I use PHP2 (changed from PHP3 as suggested in some forums) and the configuration is there as max_input_vars=1000

 

Question is: Is that possible that the host prevent me from overriding this parameter in anyway?

 

In times, there was no php.ini file in my directories, coming from the host. I created my own. 

 

Thanks in advance.... Really needing to solve this.

 

yes, it's very possible that your hosting is limiting this.

 

use this free module to see what if any affects your changes have made

 

http://www.prestashop.com/forums/topic/278164-free-module-display-php-environment-phpinfo-back-office/

 

if your changes are not seen, then contact your hosting company.  If they can not change then move to new hosting as having xlate (in fact control of all content) is very important.

Share this post


Link to post
Share on other sites

yes, it's very possible that your hosting is limiting this.

 

use this free module to see what if any affects your changes have made

 

http://www.prestashop.com/forums/topic/278164-free-module-display-php-environment-phpinfo-back-office/

 

if your changes are not seen, then contact your hosting company.  If they can not change then move to new hosting as having xlate (in fact control of all content) is very important.

 

Run it and still 1000 even with php.ini set at 5000 at the admin folder.... 

 

This means I'm moving?  :(

Share this post


Link to post
Share on other sites

Run it and still 1000 even with php.ini set at 5000 at the admin folder.... 

 

This means I'm moving?  :(

Did you contact your hosting company?

Share this post


Link to post
Share on other sites

Did you contact your hosting company?

Yes, they said they "can't change" the configuration. I should try via .htaccess. But I don`t even know if they know what I was talking about. 

 

Just submitted another request, maybe I get a better "tech" guy over there. I never used this host before. And I always managed to correct this input var issue quite easily before. 

 

Any ways, gracias El Patron!

  • Like 1

Share this post


Link to post
Share on other sites

Yes, they said they "can't change" the configuration. I should try via .htaccess. But I don`t even know if they know what I was talking about. 

 

Just submitted another request, maybe I get a better "tech" guy over there. I never used this host before. And I always managed to correct this input var issue quite easily before. 

 

Any ways, gracias El Patron!

 

con mucho gusto, please let us know how this works out for you.

Share this post


Link to post
Share on other sites

El Patron, 

 

I found another host and asked them about this issue. The answer was "you can change most of the settings blah blah blahb via .htaccess"

 

Is there a way that I can "test" this before uploading the entire store? The module you suggested worked like a charm, but only under prestashop's environment. 

 

Thanks for you help.... 

Share this post


Link to post
Share on other sites

Never mind, I found the solution with phpinfo()

 

I'm resistent to changing host right now.... Maybe you can give me some light here. 

 

My .htaccess file has this solely info:

 

# Do not remove this line or mod_rewrite rules and search engine friendly URLs will stop working
RewriteBase /
 
*then I would have to add:*
 
php_flag max_input_vars 4000
 
I wonder whether or not I'm missing some "/" or ";" in this thing. What about that slash in the end of the line? Does it stop the following commands?

Share this post


Link to post
Share on other sites

Hi All,

I've tried all the options described in that post and none is working with my Hostinger host provider.

I would appreciate any other suggestions.

Share this post


Link to post
Share on other sites

we don't know your hosting environment configuration

some hosts blocks possibiltiy to deal with php configuration via php.ini / htaccess file

in cases like that it's worth to contact with host and ask about possibilities in php environment configuraiton

Share this post


Link to post
Share on other sites

I've contacted them. They say I could "try" to change it via the .htaccess. I tried and it didn't work. 

 

No candy for us there. :(

Share this post


Link to post
Share on other sites

thay said you how to do that? or just said that you have to change .htaccess ?

Share this post


Link to post
Share on other sites

The guy said I could "try". Either he didn't want to say no or he didn't know what I was talking about LOL

Share this post


Link to post
Share on other sites

I have just solve this problem using solution from here: http://lessons-joomla.ru/uroki/khosting-i-domeny/97-ustanovka-i-nastrojka-lokalnogo-servera-denver-denwer.html. Add the following code to the end of .htaccess file in Prestashop folder:

 

<IfModule php5_module>
php_value max_input_vars 50000
php_value suhosin.request.max_vars 50000
php_value suhosin.post.max_vars 50000
</IfModule>

  • Like 3

Share this post


Link to post
Share on other sites

The guy said I could "try". Either he didn't want to say no or he didn't know what I was talking about LOL

 

hello

check one post above

perhaps it will work for you too :-)

Share this post


Link to post
Share on other sites

I have just solve this problem using solution from here: http://lessons-joomla.ru/uroki/khosting-i-domeny/97-ustanovka-i-nastrojka-lokalnogo-servera-denver-denwer.html. Add the following code to the end of .htaccess file in Prestashop folder:

 

<IfModule php5_module>

php_value max_input_vars 50000

php_value suhosin.request.max_vars 50000

php_value suhosin.post.max_vars 50000

</IfModule>

 

Thanks !

 

Works fine.

Share this post


Link to post
Share on other sites

I used the above method on my Hostinger.com server, unfortunatelly it doesn't work.

I contacted with hostinger service and they confirmed that it's possible by .htaccess modification.

Any suggestions, please?

Share this post


Link to post
Share on other sites

Already given by @rumit

 

Try to add to the top of your .htaccess (inside prestashop folder)

##

# max_imput_var = 1000 default. Increased to 5000
<IfModule php5_module>
 php_value max_input_vars 5000
 php_value suhosin.request.max_vars 5000
 php_value suhosin.post.max_vars 5000
</IfModule>

## END ##

etc...
Edited by myselfidem (see edit history)

Share this post


Link to post
Share on other sites

still doesn't work...

I asked one more time the hostinger service since I think it's impossible to change this parameter

Share this post


Link to post
Share on other sites

I've tried this script before and it didn't work at Hostinger. 

Share this post


Link to post
Share on other sites

You're right !

 

Tested on my Computer with PrestaShop installed on local mode works fine ...But not on line !!! :blink:

Share this post


Link to post
Share on other sites

You're right !

 

Tested on my Computer with PrestaShop installed on local mode works fine ...But not on line !!! :blink:

 

and you're also on the same hosting account?

 

 

btw. why not to ask hoster about that? i mean, if it is possible to alter php configuration via htaccess

why not to ask them HOW TO DO THAT? it's worth to because you use solution that works on local, but it doesnt work on remote

 

so it's something wrong with hosting, not local installation ;)

Share this post


Link to post
Share on other sites

Well vekia. Thanks for your reply...I will ask to the hoster by "ticket" and wait his answer.

Share this post


Link to post
Share on other sites

and you're also on the same hosting account?

 

 

btw. why not to ask hoster about that? i mean, if it is possible to alter php configuration via htaccess

why not to ask them HOW TO DO THAT? it's worth to because you use solution that works on local, but it doesnt work on remote

 

so it's something wrong with hosting, not local installation ;)

 

My "feeling" is that the people in charge of the tickets don't know much. The answer they gave me that "I could try" to change on .htaccess. 

 

Possibly there are other variables that can be changed that way. And, very likely, they don't know which and how LOL. 

 

Oh, and of course, I was using their free hosting. Meybe you can change these things under a paid hosting. 

Share this post


Link to post
Share on other sites

i will be honest: free hosting?

i don't think so that free hosting is a great idea to run prestashop store

free hostings are highly limited... 

 

and this is probably why it doesnt want to work

Share this post


Link to post
Share on other sites

Took me a while to figure out the exact steps to get this to work.  

I'm using a godaddy shared Linux hosting account (Deluxe in case you were wondering)

 

1) I have multiple domain names as add on domains to my hosting account.  The current domain that I am working on is not the primary domain on the hosting account, but an add-on which has it's own root folder in my file manager (ex. webroot/domain.com/)  

2) I spent quite a bit of time dropping in php.ini as well as php5.ini into my domain's root folder with none of them working.  Furthermore, I installed prestashop into "webroot/domain.com/shop/" which is where prestashops .htaccess file is located.

3) In order for me to get this to work i had to go back to my webroot folder (which is outside of my domain.com's root folder) and put my php5.ini there.  Note: php.ini will not work 

4) I then needed to go into my hosting account and click on "System Processes" then click the button "End Web" for my php5.ini file to take effect.  

 

And in case you were wondering which values I added to my php5.ini file... 

 

suhosin.post.max_vars = 4252;
suhosin.request.max_vars = 4252;
max_input_vars = 10000;
 
That was it.  I verified that the changes took place by using a phpinfo() file and everything now seems to work.
 
Hope this helps someone!

Share this post


Link to post
Share on other sites

I made the file for you just download to your computer then upload to the root folder of your shop.

 

before uploading change the name to php5.ini or php.ini the forum does not allow .ini files to be uploaded.

 

 

attachicon.gifphp.txt

Worked like a charm thank you!!! 

  • Like 1

Share this post


Link to post
Share on other sites

I have just solve this problem using solution from here: http://lessons-joomla.ru/uroki/khosting-i-domeny/97-ustanovka-i-nastrojka-lokalnogo-servera-denver-denwer.html. Add the following code to the end of .htaccess file in Prestashop folder:

 

<IfModule php5_module>

php_value max_input_vars 50000

php_value suhosin.request.max_vars 50000

php_value suhosin.post.max_vars 50000

</IfModule>

 

Thank You for this solution. Works perfect :)

Highly recomended solution for polish hosting provider nazwa.pl

Share this post


Link to post
Share on other sites

you should be very careful with allowing those large post sizes to hit your server.  there is a reason ( a good one) that most hosts restrict allowing high values here.  50,000 would be a very high number.

Share this post


Link to post
Share on other sites

Hi, same problem here. I am on inmotion hosting

I made following changes on ph.ini file, but still not working.

 

max_execution_time = 30     ; Maximum execution time of each script, in seconds
max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
memory_limit = 512M      ; Maximum amount of memory a script may consume (32MB)
max_input_vars = 5000
suhosin.post.max_vars = 5000
suhosin.request.max_vars = 5000
 
Should I try to increase it?

Share this post


Link to post
Share on other sites

what message you see? how many inputs you have there, where you see message about max input vars? you should be able to see message about that under localization > translations > installed modules translations

Share this post


Link to post
Share on other sites

Hi Vekia,

The following message is displaying under localization > translations > installed modules translations

 

Warning! Your PHP configuration limits the maximum number of fields allowed in a form
1000 for max_input_vars.
Please ask your hosting provider to increase this limit to 3725 at least, or you will have to edit the translation files.

Share this post


Link to post
Share on other sites

Hi All,

 

I've had the same issue and have a provider that is very cooperative to change the value.

However: I was told that increasing the value also has a downside in performance!

 

I have noticed that if I get the message in Translation and I restart my computer, the message is gone and I can do the translations.

So it's sometimes caused because of full cach. My value is at 4000!

Share this post


Link to post
Share on other sites

It becomes a performance and security issue, since your server will now allow form submissions to contain 4000 parameters.  Hackers will try to use that as an opportunity to DDOS your server or find a way in.

 

Therefore you should not allow this globally.  You should configure it in a way that it will only apply to your back office folder.  Tell that to your hosting provider and they should understand.

Share this post


Link to post
Share on other sites

Thanks for your explanation. Still it is also the fact that it is not always necessary and can be solved by a restart of your computer ;-)

Share this post


Link to post
Share on other sites

Unfortunately none of solutions above worked for me. I've almost copy entire database into localhost and try there my luck, but i found solution here:
 
http://dh42.com/blog/speed-prestashop-php-ini/
 
I still can't belive it works, after hours and hours of trying to solve this up.
I have GoDaddy hosting and i've tried this method:
 
- put info.php in root folder
- put php.ini file in same root folder (you need to create it from blank, detailed information in link i've posted):

[PHP]
memory_limit = 2048M
max_execution_time = 1000;
max_input_time = -1;
post_max_size = 15M;
upload_max_filesize = 15M;
max_input_vars = 10000;
suhosin.get.max_vars = 10000;
suhosin.post.max_vars = 10000;

(you can change vars form 10000 to your number)

- kill all php processes in GoDaddy cPanel !!!

WOOOOOHAAA works like a german car :P

Share this post


Link to post
Share on other sites

Have same problem,  but not able to edit php.ini
 

After edit .htaccess   i get a 404 page.

 

below  part of htaccess   what do I do wrong ?
 

#blockguestbook - not remove this comment 
RewriteRule ^(.*)guestbook/?$ /webshop/modules/blockguestbook/blockguestbook-form.php [QSA,L] 
#blockguestbook
 
# ~~start~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again
# .htaccess automaticaly generated by PrestaShop e-commerce open-source solution
 
<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>
 
<IfModule mod_rewrite.c>
<IfModule mod_env.c>
SetEnv HTTP_MOD_REWRITE On
</IfModule>
 
RewriteEngine on
 
# aangepast prestashop 28-6-2015
php_flag max_input_vars 4000
 
 
#Domain: www.hobby-benodigdheden.nl
RewriteRule . - [E=REWRITEBASE:/webshop/]
RewriteRule ^api$ api/ [L]
 
RewriteRule ^api/(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L]

Share this post


Link to post
Share on other sites

your host may not allow for you to alter this setting, and is probably trying to redirect you to an error page, which it cannot find so you are getting a 404 page not found for the error page.

Share this post


Link to post
Share on other sites

Ok,  tnx.  Ive reported it to my hosting-provider.

Hope they can fix it

 

In the meanwhile,  solutions are welcome  ;)

Share this post


Link to post
Share on other sites

Hello,

 

I am getting same issue on translation page.

I tried with .htaccess file as

php_value max_input_vars 5000

 

but it gives me 500 internal server error.

 

Is there any special for mat to do it?

Share this post


Link to post
Share on other sites

your hosting provider has likely restricted you from doing this.  you should contact them and request that they increase this value for you.  if you are on a shared hosting platform, they will likely say no

Share this post


Link to post
Share on other sites

My provider did the nessesary changes. ( all of them because after changing the mentioned errors there were several other which occured)
 

everything works fine now

Share this post


Link to post
Share on other sites

Hi 

 

I made the file for you just download to your computer then upload to the root folder of your shop.

before uploading change the name to php5.ini or php.ini the forum does not allow .ini files to be uploaded.


attachicon.gifphp.txt

Is is posible to attach the file again?

  • Like 1

Share this post


Link to post
Share on other sites

I made the file for you just download to your computer then upload to the root folder of your shop.

 

before uploading change the name to php5.ini or php.ini the forum does not allow .ini files to be uploaded.

 

 

attachicon.gifphp.txt

Hello I am having this same issue. My provider told me I can "increase this by creating your own php.ini file in the public_html folder."

 

I tried to download the file you attached but I don't think it is there anymore.

Share this post


Link to post
Share on other sites

hello can i get tht file because it seem i cannot change my cod module name cause of tht var problem

Share this post


Link to post
Share on other sites

Hello,

 

I have the same problem. I am using prestashop 1.6.1.4., php 5.4 on my server, and I am using polish hosting provider home.pl 'Business Cloud Starter'

after editing my file /public_html/prestashop/.htaccess (atributes777) and adding these lines to this file:

<IfModule php5_module>
php_value max_input_vars 2000
php_value suhosin.request.max_vars 2000
php_value suhosin.post.max_vars 2000
</IfModule>

nothing happends and still i cant translate my site.

 

Does anyone from Poland(home.pl) had the same situation? Many thanks for the reply. Greetings.

Edited by Nieuchwytny_Uchwyt (see edit history)

Share this post


Link to post
Share on other sites

i would suggest you reach out to your hosting provider directly and ask them to help support you to increase these settings.  The likely answer you are going to find out, is that they will not allow you to, but start first by asking them

Share this post


Link to post
Share on other sites

I made the file for you just download to your computer then upload to the root folder of your shop.

 

before uploading change the name to php5.ini or php.ini the forum does not allow .ini files to be uploaded.

 

 

attachicon.gifphp.txt

Hi 

I have tryed to download this file as i could be doing with the info from it...... The file wont let me download as if says i do not have permission. can you help!??

Share this post


Link to post
Share on other sites

Please help somebody with this issue. In php.ini I have changed but to no avail

Share this post


Link to post
Share on other sites

Please help somebody with this issue. In php.ini I have changed but to no avail

contact your hosting provider for support

Share this post


Link to post
Share on other sites

Solution for online store ( cpanel ) not for localhost 

 

1. Create file .user.ini

 

; How many GET/POST/COOKIE input variables may be accepted
max_input_vars = 5000;

 

2. Create file php.ini

 

; How many GET/POST/COOKIE input variables may be accepted
max_input_vars = 5000;

 

Upload them into http://www.example.com/public_html

 

Cheers!

Edited by straleboni (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Hello Everyone, 

 

Thank you for all your posts.  I tried everything and it wasn't working.  Finally I called Godaddy again and I used this in a php.ini file, thanks to an earlier post:

[PHP]
memory_limit = 2048M
max_execution_time = 1000;
max_input_time = -1;
post_max_size = 15M;
upload_max_filesize = 15M;
max_input_vars = 4000;
suhosin.get.max_vars = 4000;
suhosin.post.max_vars = 4000;

I put the file in the public_html root and another copy in the prestashop root.  In the cPanel, I went to php processes then I killed the processes.  At that point it still was not working.  The godaddy rep said to go again in cpanel to select php version and changed the version from native 5.4 to 5.4.  I then went to PHP options and there you can change the individual settings, all the lines were there except max_input_vars (great! /sarcasm).  However, at that point I refreshed the translations page, and it was working!.  HAHA, not sure what updated it.  But it worked.

 

I had this issue few years ago also with Godaddy and I remember that I resolved it in a different way.  I guess the changes vary from system to sytem and versions.

 

Thank you all for your help!

  • Like 1

Share this post


Link to post
Share on other sites

 

I would like to thank and inform you that the above file on this date still is working very well.

I put the file in / public_html as the name php.ini

very sheltered by tdr170 file

sorry my english.

 
I forgot to mention. xD
my hosting is godaddy linux

 

Thank you very much, this worked for me!

 

I created a php.ini file and add those 2 lines:

[PHP]
max_input_vars = 5000

Then I uploaded the file to my public_html directory then it worked right after that..thanks!!!

I am using GoDaddy hosting and I couldn't find php.ini anywhere, and I also tried to add the max vars code in my .htaccess file but that didn't work for me and I get 500 Internal Error message. But the solution above worked great.

Share this post


Link to post
Share on other sites

I made the file for you just download to your computer then upload to the root folder of your shop.

 

before uploading change the name to php5.ini or php.ini the forum does not allow .ini files to be uploaded.

 

 

attachicon.gifphp.txt

 

 

 

It says I don't have permission to access the file. Can you please copy and paste the content... anyone

 

regarfd

Share this post


Link to post
Share on other sites

Hi all,

 

I edited php.ini file as max_input_vars 5000. After modification I'm not able to sign in my prestashop admin. It says the password is incorrect. I tried to use "forgot password" function but I didn't receive any reset mail form prestashop. After that I contacted with Hostgator support. They said me that "your edits changed some core files" and we can't fix this issue, you can restore or can contact with developer.

 

Do you have any idea how can I solve this issue?

 

Best!

Share this post


Link to post
Share on other sites