Jump to content
jhb13

[Resolu] Problème d'inscription client sur module mon Compte

Recommended Posts

Bonjour,

 

Je prépare actuellement une boutique avec le Thème de base de Prestashop, version 1.4.10.0, avec un hébergement mutualisé chez OVH, et je rencontre un problème d'inscription client sur le module Mon Compte de Prestashop.

 

Lors de la simulation de l'inscription d'un client (en phase de test actuellement), la boutique étant en préparation et fermée au public, je n'arrive pas à enregistrer de client.

A la fin du remplissage du formulaire, et après avoir cliqué sur le bouton pour l'enregistrement, apparaît un message d'erreur :

<

Il y a 8 erreurs :

- 01. id_default_group requis

- 02. last_passwd_gen requis

- 03. ip_registration_newsletter requis

- 04. newsletter_date_add requis

- 05. clef de sécurité requis

- 06. note requis

- 07. date_add requis

- 08. date_upd requis

>

Après de multiples essais, rien, impossible.

 

Tous les messages d'erreurs ont l'air de venir du module "pss_customer" de la base de données SQL.

 

J'ai tenté une réparation de la base de données "pss_customer" sans succès.

 

J'ai effectué la désinstallation puis une nouvelle installation du module Mon Compte sur le BO, rien n'y fait.

 

J'hésite à recréer une nouvelle base de données SQL, pour ne pas à avoir à reconstruire l'ensemble de l'architecture et des données du site.

 

Avez-vous une solution pour réparer le module Mon Compte de Prestashop ou le module "pss_customer" de la base SQL de OVH sans tout refaire.

 

D'avance merci

 

Ci-après, capture d'écran du message d'erreur.

post-183428-0-21244700-1364233200_thumb.jpg

Share this post


Link to post
Share on other sites

Bonjour,

 

Le module "pss_customer" c'est le module de la BDD sur SQL de OVH.

 

En fait, les données des champs de formulaires d'inscription du compte client, ne s'enregistre pas sur la BDD SQL, dans le "pss_customer" d'où le message d'erreur.

 

J'ai vérifié la BDD, elle est OK. J'ai demandé à OVH de vérifier de leur côté, c'est OK. Ils m'ont conseillé de voir le module "myaccount" avec Prestashop.

 

J'ai épuisé toutes les solutions à ma portée. Merci de votre aide.

 

Cordialement

 

jhb13

Share this post


Link to post
Share on other sites

Hello,

 

Désolé mais je ne vois pas trop le rapport entre le module "myaccount" standard et l'inscription (ta copie d'ecran).

 

Si tu désactives le module "pss_customer", tu peux t'inscrire normalement ?

Share this post


Link to post
Share on other sites

Bonjour,

 

"pss_customer" n'est pas un module de PS, mais un fichier sql de la BDD où doit s'inscrire les données venant du module "mon compte" de PS sur le serveur de OVH (PHP myadmin et base SQL)

 

Le message d'erreur reprend les différents champs du fichier "pss_customer.sql" de la BDD SQL de OVH où ne s'inscrivent pas les données des champs du formulaire "mon compte" de PS.

 

OVH me dit que tout est OK de leur côté et que cela vient de PS.

 

J'ai peut être créé cette erreur par les différentes installations et désinstallations de ce module 'blockmyaccount" pour tenter de réparer, je ne sais pas.

 

Merci de votre aide.

 

Cordialement

 

jhb13

Share this post


Link to post
Share on other sites

Hello,

 

ps_customer est la table des customer

 

Le module mon compte n'est pas impliqué. On dirait plutôt un souci de contrôleur, ou sur la classe Customer.

 

Il faut debugguer, je suis étonné car cela ne ressemble pas à la 1.4.10 ce genre de souci.

 

Je ne suis sur le forum qu’occasionnellement, si vous etes pressé vous pouver contacter notre service de support pour debugguer.

 

Essayez de re uploader ce fichier https://github.com/PrestaShop/PrestaShop-1.4/blob/master/controllers/AuthController.php car sinon je sèche.

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai uploader et installé le fichier, mais sans résultat, c'est pareil, même message d'erreur.

 

Merci quand même.

 

Je vais contacter le service support en parallèle du forum.

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour Grégory,

 

J'ai changé de thème carrément, mais j'ai le même message d'erreur.

 

Ensuite, je suis revenu au thème par défaut, même erreur.

 

J'ai laissé un message au support PS, il y a maintenant 10 jours environ, le 29.03.2013, mais aucune réponse de leur part à ce jour, pas de devis, rien.

 

Je suis arrêté dans le développement, j'hésite à continuer la rédaction des fiches produits, des textes, et diverses clauses, de peur d'être obligé de recommencer.

 

A bientôt de te lire.

 

Cordialement

 

jhb13

Share this post


Link to post
Share on other sites

Bonjour Grégory,

 

Merci beaucoup de ton aide, c'est parfait.

 

Par contre, je ne comprend pas le problème, cette section était paramétrée par défaut dans PS, je ne suis pas intervenu pour cocher ces cases, à quoi servent-elles ?

 

J'ignorais même l'existence de ce tableau, je n'y avais pas prêté attention.

 

De toute manière, ça fonctionne et c'est parfait...

 

Encore merci.

 

Cordialement

 

jhb13

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More