Jump to content

[module] Hot Info - bottom sidebar banner


Recommended Posts

Hi Vekia

 

I installed this module on my store with Prestashop 1.4.0, I am unable to see the Editor for the message box, any idea what could be the issue, Thanks in advance.

 

 

post-218714-0-76137400-1396358464_thumb.jpg

Share this post


Link to post
Share on other sites
  • 1 month later...

new version released

- module supports prestashop 1.6

- i added full featured tinyMCE rich text editor

Hi Vekia,

Thanks for the great module.

I have a problem though, it is not looking right on mobiles and tablets.

Can you please take a look and advise?

The URL is www.electronica-auto.ro

 

Thank you!

Share this post


Link to post
Share on other sites

contents visible in module depends on code that you use in it.

you use code like:
 

<div style="padding-left: 270px;"><span style="font-size: 10pt; color: #fcfcfc;"><strong>Telefon: <span>0722 160 666.</span> Adresa noastra este: Str. Luica nr. 6, Sector 4 - Bucuresti. Suntem aproape de intersectia cu Sos. Giurgiului, langa benzinaria Rompetrol. <span style="font-size: 14pt;">Click -> <a href="https://mapsengine.google.com/map/edit?mid=z6ZUlM8qXHdc.k5HCPjZm4-Ic" target="_blank" class="btn btn-default">Harta</a></span></strong></span></div>

it's wrong.

Share this post


Link to post
Share on other sites

contents visible in module depends on code that you use in it.

you use code like:

 

<div style="padding-left: 270px;"><span style="font-size: 10pt; color: #fcfcfc;"><strong>Telefon: <span>0722 160 666.</span> Adresa noastra este: Str. Luica nr. 6, Sector 4 - Bucuresti. Suntem aproape de intersectia cu Sos. Giurgiului, langa benzinaria Rompetrol. <span style="font-size: 14pt;">Click -> <a href="https://mapsengine.google.com/map/edit?mid=z6ZUlM8qXHdc.k5HCPjZm4-Ic" target="_blank" class="btn btn-default">Harta</a></span></strong></span></div>

it's wrong.

 

It seems that I have used too much left padding (for the purpose of centering the text).

I have replaced that with align:left and now it looks ok.

Thank you again!

Share this post


Link to post
Share on other sites

you're welcome :)

in addition, you can use media queries to change font size etc.

you can paste css styles to the html window too :-)

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 1 month later...

I want to change sidebar height but it doesn't change anything.

 

 

Hello Vekia :)

 

Same thing for me on PS 1.5.4.1 the sidebar height setting doesn't change the height.

 

Can you take a look please ?

Share this post


Link to post
Share on other sites

both of them , text and html but dosnt work

Hello try this code.

 

 <p style=\"margin-top: 0; margin-bottom: 0\"> <marquee onmouseout="this.start();" onmouseover="this.stop();" scrollamount=15 direction=\"left\"><span style=\"color:#fff; font-weight:bold; font-size:14px;font-family:Arial;\"> This is an basic example of marqee effect</span></marquee>

Share this post


Link to post
Share on other sites

Hello Vekia :)

 

Same thing for me on PS 1.5.4.1 the sidebar height setting doesn't change the height.

 

Can you take a look please ?

 

what theme you use? some of the theme styles can affect this bar

Share this post


Link to post
Share on other sites
  • 2 weeks later...

After install this module I dont have button configure..? on old ver.presta 1.5.6.x everything work fine..

 

Ill try several times to reinstall it and then install again ..but same ..

 

again message modul is alreddy installed..

 

 

Ovaj modul je već instaliran: hotinfo

 

any idea? thanx

Edited by mstevanic (see edit history)

Share this post


Link to post
Share on other sites

After install this module I dont have button configure..? on old ver.presta 1.5.6.x everything work fine..

 

Ill try several times to reinstall it and then install again ..but same ..

 

again message modul is alreddy installed..

 

 

any idea? thanx

 

what is your prestashop version?

Share this post


Link to post
Share on other sites
  • 1 month later...
  • 4 weeks later...

iam on PS 1.6.9,  installed the module but I had to take it off, it goes straight in the header before </head> which is not normal as it gives something like

 

<div class="hotinfo_top" align="center" style="text-align:center; background:#000000; border-top:1px solid #000000;"><table style="width:100%; height:50px; text-align:center;"><tr><td><div style="text-align: center;"><span style="font-size: 14pt; color: #fbe329;">Bonjour ! Nous vous souhaitons la bienvenue !</span></div></tr></td></table></div><!--[if IE 8]> <script src="https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js"></script> <script src="https://oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script> <![endif]--></head>

Share this post


Link to post
Share on other sites

what theme you use? some of the theme styles can affect this bar

 

Damn no way to subscribe to the thread, I missed your answer, sorry :(

 

I am on standard PS 1.5.4.1 theme, with some customizations with your great tips at your website ;)

Share this post


Link to post
Share on other sites
  • 3 months later...

Hello try this code.

 

 <p style=\"margin-top: 0; margin-bottom: 0\"> <marquee onmouseout="this.start();" onmouseover="this.stop();" scrollamount=15 direction=\"left\"><span style=\"color:#fff; font-weight:bold; font-size:14px;font-family:Arial;\"> This is an basic example of marqee effect</span></marquee>

 

 

hallo i dont know if anybody can answer,

but i am wondering in which file this code could be add it and where?

i am afraid that i may put it in a wrong place :)

Share this post


Link to post
Share on other sites
  • 4 weeks later...
  • 3 weeks later...
  • 4 weeks later...

For language edit hotinfo.tpl

<!-- Block HOTINFO module -->
<link rel="stylesheet" href="{$modules_dir}hotinfo/css/hotinfo.css"/>
<div class="hotinfo_top" align="center" style="text-align:center; background:#{$array->bg_color}; border-top:{$array->br_size}px solid #{$array->br_color};">
    <table style="width:100%; height:{$array->height}px; text-align:center;"><td>{$array->body}</td></table>
</div>
<!-- /Block HOTINFO module -->

Replace with this:

<!-- Block HOTINFO module -->
<link rel="stylesheet" href="{$modules_dir}hotinfo/css/hotinfo.css"/>
<div class="hotinfo_top" align="center" style="text-align:center; background:#{$array->bg_color}; border-top:{$array->br_size}px solid #{$array->br_color};">
    <table style="width:100%; height:{$array->height}px; text-align:center;">
		<td>
			<!-- IT -->
			{if $smarty.get.id_lang==1}{$array->body} <!-- Or IT Text -->
			<!-- EN -->
			{elseif $smarty.get.id_lang==9}<span class="hotinfo_top">EN TEXT</span></a>
			<!-- DE -->
			{elseif $smarty.get.id_lang==8}<span class="hotinfo_top">DE TEXT</span></a>
			<!-- FR -->
			{elseif $smarty.get.id_lang==4}<span class="hotinfo_top">FR TEXT</span></a>
			<!-- ES -->
			{elseif $smarty.get.id_lang==6}<span class="hotinfo_top">ES TEXT</span></a>
			{/if}
		</td>
	</table>
</div>
<!-- /Block HOTINFO module -->

Edit the lang id with your lang id.

Edited by ubereizen (see edit history)

Share this post


Link to post
Share on other sites
  • 4 months later...

About your hollidays banner, Does it work in PS 1.6.0.9 ???, because I instaled this modul and warns me an error in back office:

 

 
Notice on line 212 in file /var/www/vhosts/mysite.com/httpdocs/modules/hotinfo/hotinfo.php
[8] Undefined variable: actual_version
 
Notice on line 213 in file /var/www/vhosts/mysite.com/httpdocs/modules/hotinfo/hotinfo.php
[8] Undefined variable: actual_version
Edited by jonysi_d (see edit history)

Share this post


Link to post
Share on other sites
  • 2 months later...
  • 5 months later...
  • 2 weeks later...

Hi everybody,

 

first, sorry for my bad english. :unsure: I'm german.

 

I hope you can help me.

Everytime I try to set the link in a href="" it reset into ../ instantly I click on "ok" in the html-mode.

 

I write this ("myshop" is not the real name. if it's possible I don't want to show it):

<a href="http://myshop.de/"><img src="../img/cms/deutsche_flagge.jpg" width="50" height="38" alt="Exklusive_Rahmen_DE.jpg" /></a>

Then I click on "ok" and it shows me this:

<a href="../"><img src="../img/cms/deutsche_flagge.jpg" width="50" height="38" alt="Exklusive_Rahmen_DE.jpg" /></a>

Don't understand....please help.

 

 

Regards,

 

Lukas

 

 

EDIT: Solved! I wrote www. in front of myshop and now it works.

Edited by Lukas-Shop (see edit history)

Share this post


Link to post
Share on other sites
  • 1 month later...

i updated this free module

- added some improvements to module installation process

- added better module updates notifications

 

you can download updated version of the addon from first post here.

  • Like 1

Share this post


Link to post
Share on other sites
  • 1 year later...

Hi @vekia,

 

I have a problem with text editor. It looks like:

post-1404820-0-78915500-1498123100_thumb.jpg

 

Once it worked good, but only once. Do u have any idea where is a problem?

 

PrestaShop 1.6.1.11

 

thx a lot.

Share this post


Link to post
Share on other sites
  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More