Jump to content
lucie62140

[Resolu] Mise à jour 1.4.7.3 -> 1.5.1.3 = Grosse galère

Recommended Posts

Bonjour,

 

Je cherches actuellement à mettre à jours mon site prestashop 1.4.7.3 vers la dernière version.

 

J'ai testé la maj en automatique et en local, erreur sql, il manque pleins de données et difficultés pour accéder au panneau de gestion.

 

Idem pour la mise à jour en manuel et en local, erreur 28 lors de l'update...

 

Je cherche donc comment faire depuis plusieurs jours sans succés.

 

 

Si vous avez des infos sur la marche à suivre, je suis préneuse ;)

Merci d'avance.

Share this post


Link to post
Share on other sites

Bonjour,

 

Est ce que eventuellement je peux avoir une copie de votre base par email (un lien de telechargement d'un zip du dump serait parfait)? gregory@prestashop.com

 

Merci.

Share this post


Link to post
Share on other sites

Je utilises bien la dernière version d'autoupgrade.

Est ce que le procédé peut être plus difficile en local que sur le serveur ?

Share this post


Link to post
Share on other sites

Bonjour,

 

As tu essayée de passer en 1.4.10 ?

 

Tu devrais patienter pour les 1.5.x trop de problèmes...

 

bye

Share this post


Link to post
Share on other sites

Bonjour,

 

Je confirme...restez en 1.4.10 ! (on entend jamais parlé de cette version...ben oui elle est stable)

 

Attendez une version 1.5.4.x stable (il suffit de venir sur le forum pour en avoir la température)

Si on vous déconseille la version 1.5.x.x c'est que l'on est passé par là !

Share this post


Link to post
Share on other sites

Merci pour ce conseil.

Je suis acctuellement en stage, et un de mes objectifs est de passé leur site internet de 1.4.7.3 vers 1.5.3.1 donc c'est nécessaire que j'y arrive si possible.

Share this post


Link to post
Share on other sites

Bonjour,

 

je remonte ce topic car depuis quelques semaines j'essaye tant bien que mal de passer mon site de la 1.4.7 à la 1.5.X.

 

Après plusieurs tests en local, je parviens à faire des mises à jour incrémentales jusqu'à la 1.4.9, mais impossible d'aller plus loin.

 

Plus problématique, en faisant la mise à jour vers la 1.5, la base SQL se retrouve avec de nouvelles tables qui ne trouvent pas écho dans la 1.4.7. Résultat: impossible d'avoir le suivi des stock dans prestashop avec la 1.4.7 et pas de mise à jour vers la 1.5.

 

Je lis de part et d'autres qu'il faut passer de la 1.4.7 vers la 1.4.1 puis vers la 1.5.4... Mais cela ne va-t-il pas occasionner encore plus d'erreurs dans la base de donnée?

 

Merci

Share this post


Link to post
Share on other sites

Bonjour,

 

Dans mon cas la mise à jour 1.4.7.3 en local vers la 1.5.3 n'a pas fonctionnée.

J'ai ensuite fait la mise à jour 1.4.7.3 vers 1.4.10 (1erreur sql).

Puis de là j'ai fais la mise à jour vers 1.5.4.0 qui marche presque, encore un peu d'erreur puis je dois modifier mon thème perso.

J'attends toujours avant de le faire sur le site en ligne.

Share this post


Link to post
Share on other sites

Merci Lucie,

 

je vais tester ça donc, en espérant que je ne rajoute pas de nouvelles erreurs SQL.

 

Edit: Bon je ne parviens pas à réaliser le downgrade vers la 1.4.1, je regarderai ça ce soir :/

Edited by nanotechnos (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More