Jump to content

[module] Zopim Chat - build own widget for free


Recommended Posts

all of problems that you've got with zopim chat depends on zopim service, it's not related to module

i tried to reproduce this issue but... i just can't :|

Share this post


Link to post
Share on other sites
  • Replies 397
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Zopim Chat Free for prestashop In simple terms, Zopim is a web-based software that allows you to monitor visitors who are on your website and engage them in a chat. This industry is also commonly kno

lol my bad, please download module once again. i added this feature only to old widget, i forgot about new one

Thanks a lot joseantgv, i really appreciate your time and advice. It is working great now finally got Tawk.to on my Prestashop cloud. Thanks alot              

Posted Images

hello vekia, always going to do now with this update?

greetings

first option - it's impossible with module only. changes like that needs modification of admin template files.

second image - of course, it's possible to create new admin menu item with dashboard.

i will create this feature :)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

works fine with 1.5.4.1, tested second ago

 

can you share more informations, what exactly goes on? some error appears?

I wonder where I have to put below code.

Fore example, product.tpl file, can you tell me where to insert the code?

I tried some but page went blank.

 

 

<!--Start of Zopim Live Chat Script-->
<script type="text/javascript">
window.$zopim||(function(d,s){var z=$zopim=function©{z._.push©},$=z.s=
d.createElement(s),e=d.getElementsByTagName(s)[0];z.set=function(o){z.set.
_.push(o)};z._=[];z.set._=[];$.async=!0;$.setAttribute('charset','utf-8');
$.src='//v2.zopim.com/?1uTPrqZ4HJFHw7y3msTOUqDkCS3UsWrG';z.t=+new Date;$.
type='text/javascript';e.parentNode.insertBefore($,e)})(document,'script');
</script>
<!--End of Zopim Live Chat Script-->

Share this post


Link to post
Share on other sites

if you installing widget manually, its not related to zopim module that is the main case in this thread.

you have to use {literal}{/literal} tags because your code uses brackets } {

Share this post


Link to post
Share on other sites

Hi Vekia,

 

This module was very fantastic and easy to use, thanks for that!

 

I have a question, by new beta widget, will it work on responsive web? i mean will the widget be a small buble ?

 

thanks before :)

Share this post


Link to post
Share on other sites

Hi Vekia,

I have 2 question 

1) I have added "Chat Widget" code correctly to module "Zopim Widget ID" but still chat window not showing in my web site.

    url -> "http://www.softtechnologiessolution.com/"

 

2) In Free Version (After 14 days) , Whether I will get all widget customization options like Forms, Settings & Appearance. If no, then what "widget customization options"  available for free.

 

Thanks! 

Share this post


Link to post
Share on other sites

you haven't got widget id

i checked source of your website:
 


window.$zopim||(function(d,s){var z=$zopim=function(c){z._.push(c)},$=z.s=
d.createElement(s),e=d.getElementsByTagName(s)[0];z.set=function(o){z.set.
_.push(o)};z._=[];z.set._=[];$.async=!0;$.setAttribute('charset','utf-8');
$.src='//v2.zopim.com/?  window.$zopim||(function(d,s){var z=$zopim=function(c){z._.push(c)},$=z.s= d.createElement(s),e=d.getElementsByTagName(s)[0];z.set=function(o){z.set. _.push(o)};z._=[];z.set._=[];$.async=!0;$.setAttribute('charset','utf-8'); $.src='//v2.zopim.com/?1vWCGMQk4Q45hgGcVQyKpOeZ2U8i9rNF';z.t=+new Date;$. type='text/javascript';e.parentNode.insertBefore($,e)})(document,'script');  ';z.t=+new Date;$.
type='text/javascript';e.parentNode.insertBefore($,e)})(document,'script');

you copied whole widget code, not only widget id

Share this post


Link to post
Share on other sites

Thanks a lot Vekia. If I read your document properly I have not encountered with this problem. 

Document link -> "http://mypresta.eu/en/art/know-how/how-to-get-zopim-widget-id-for-our-free-prestashop-module.html

 

Instead of pasting ACCOUNTCODE or widget ID in module. I have pasted entire javascript provided in zopim  :( .

Thanks for your help.

 

Could you please provide answer for my second question.

2) In Free Version (After 14 days) , Whether I will get all widget customization options like Forms, Settings & Appearance. If no, then what "widget customization options"  available for free.

Share this post


Link to post
Share on other sites
  • 1 month later...

I installed this module and got an ID but where exactly do i need to copy / paste the code ? which file ?

 

on module configuration page (modules > modules > search for: zopim > click on configure button)

gpwiHSj.png

Share this post


Link to post
Share on other sites

hi,

i have install zopim in the new prestashop 1.6 but the module dont show in the FrontPage

any solution?

 

use correct widget id. without correct widget id module will not appear.

Share this post


Link to post
Share on other sites

use correct widget id. without correct widget id module will not appear.

sorry , when i use prestashop 1.5 the zopim works good , the problem exist when i upgrade to prestashop 1.6

Share this post


Link to post
Share on other sites

Hello everybody,

 

i recently discover a new live chat software like zopim I find it really easy to use and all the devices are included in the price. You can use click to chat, click to call and click to video.  You have 60 days free on Prestashop following this link :

 

MODERATED

 

I hope this post will be useful for you ;)

Share this post


Link to post
Share on other sites

i appreciate your feedback but this behaviour is not allowed on this board.

for now only notification: next time it will be warn.

Share this post


Link to post
Share on other sites

Thank you vary much for the fantastic module.

I installed the module and got zopim working.

With all the features during the 14-days trial period this extension is amazing.

Can someone tell me what are the restrictions after the free full version trial period?

 

I wanna know this too.

Share this post


Link to post
Share on other sites

after free trial period you can:

- still use zopim for free

- you can still chat with your customers

 

limitations:

- one concurent chat

- 1 agent

- 14 days chat history (it's not true i've got history for chats 1 year before)

 

 

here are comparision of zopim packets:

5GxD2RP.png

 

in my customers shop, they have about 20-25 online users, and free version is enough for them.

Share this post


Link to post
Share on other sites
  • 4 weeks later...

 

Zopim Chat Free for prestashop

In simple terms, Zopim is a web-based software that allows you to monitor visitors who are on your website and engage them in a chat. This industry is also commonly known as Live Chat or Live Support Software. Here's a wikipedia link with more information. With our free module you can add Zopim widget to your prestashop store

zopim-free-cover-big.png

translations available

en.pnges.pngde.pngpl.pngfr.pngit.png

our module supports all prestashop versions!

You can download module from this topic (attached file below) or from official module website.

More informations and screenshots / videos are available here: Zopim Chat Free - prestashop module

 

Um aplicativo fabuloso, funciona lindamente, obrigado.

Este app é o melhor que já vi, funciona lindamente em minha lojanatural.com.pt

Share this post


Link to post
Share on other sites

Hi. Pls help me to manage that issue. Prestashop 1.5.4.1. Error received:

 

Fatal error: Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "C:\xampp\htdocs\brishop\themes\default\header.tpl" on line 50 "window.$zopim||(function(d,s){var z=$zopim=function©{z._.push©},$=z.s=" - Unexpected "=", expected one of: "}" , " " , ATTR' in C:\xampp\htdocs\brishop\tools\smarty\sysplugins\smarty_internal_templatecompilerbase.php:665 Stack trace: #0 C:\xampp\htdocs\brishop\tools\smarty\sysplugins\smarty_internal_templateparser.php(3144): Smarty_Internal_TemplateCompilerBase->trigger_template_error() #1 C:\xampp\htdocs\brishop\tools\smarty\sysplugins\smarty_internal_templateparser.php(3209): Smarty_Internal_Templateparser->yy_syntax_error(20, '=') #2 C:\xampp\htdocs\brishop\tools\smarty\sysplugins\smarty_internal_smartytemplatecompiler.php(105): Smarty_Internal_Templateparser->doParse(20, '=') #3 C:\xampp\htdocs\brishop\tools\smarty\sysplugins\smarty_internal_templatecompilerbase.php(200): Smarty_Internal_SmartyTemplateCom in C:\xampp\htdocs\brishop\tools\smarty\sysplugins\smarty_internal_templatecompilerbase.php on line 665

 

Thank you.

Wrap the code inside {literal}{/literal} tags

Share this post


Link to post
Share on other sites

Wrap the code inside {literal}{/literal} tags

 

it's not a problem related to this module because there, in header.tpl you can find {literal} {/literal} tags.

problem already solved.

Share this post


Link to post
Share on other sites
  • 2 weeks later...

I have an issue with the quick view mode. When I enable the zopim widget it appears on the bottom right as promised. However, when I press on the 'quick view' button at a product and the fancybox pop ups, the widget also appears on the bottom right of the fancybox. In other words, you will see the widget chat box twice on the page.

I have tried to shut it off with CSS, like .fancybox-wrapper .zopim { display: none !important; } (and similar classes), but that doesn't work. When I use #product .zopim { display: none !important;} it does work, but it also disappears on the product page itself :-)

Anyone know a solution perhaps? Thanks!

Share this post


Link to post
Share on other sites

in module tpl file add if condition like:

{if isset(smarty.post.ajax)}
{if $smarty.post.ajax!="true"}

CONTENTS OF MODULE TPL FILE HERE

{/if}
{/if}

i never tested it ;)

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Thanks Vekia

 

your modul is even better than original Zopim code. Their code is slowing down our site (FO) and takes 2,5 sec to load, now with your module it takes around 710 milisecond to load :)

 

best regards Martin

Share this post


Link to post
Share on other sites

thank you all guys for kind words and for all sugestions :-)

without all of you module will not be the same as it is right now

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Thanks for every one who works hard to solve each n every issues. Thanks PS team. (After breaking my head in Magento, I am in Prestashop now). Today I installed Zopim module and I must say it is wonderful. I am running my store in localhost.

 

http://localhost:8888/prestashop/admin1/

http://localhost:8888/prestashop/

 

whenever I load my front office store it says Leave a message  but everything works fine like chatting to front office to back office and vice versa. Again when I open Leave a message window it says a message "Sorry, we aren't online at the moment. Leave a message and we'll get back to you." . Still chat works fine.

 

Is this because I am hosting this site in localhost??

 

Please clarify. Attached are screenshots to get u guys more ideas.

 

Thanks,

 

 

 

post-805426-0-77924900-1403714509_thumb.png

post-805426-0-51006100-1403714518_thumb.png

Share this post


Link to post
Share on other sites
  • 4 weeks later...

Thanks for the module Vekia.

 

I just installed it and it looks great, one issue i found is that when enabled on mobile theme the page does not scroll.

 

Regards.

Share this post


Link to post
Share on other sites

strange that you can't scroll page when widget is active

is there any chance to see your website (where the problem appears) live?

Share this post


Link to post
Share on other sites

Prestashop 1.6

 

Fui inslalar o módulo shopgate para experimentar e tive sérios problemas, inclusive não consigo fazer traduções etc...

escrevo neste tópico porque tenho o zopim instalado e não funciona em minha loja.

Já desinstalei e instalei por várias vezes, sem sucesso.

Alguem pode ajudar??

Obrigado.

Share this post


Link to post
Share on other sites

Hi Vekia,

How can I upgrade to new chat widget, optimized for mobile?

 

module allows to use two type of widgets:

standard (old)

modern (new)

you can select what kind of widget you want to display.

 

 

in addition from 1 august zopim will work only with moder widget

so you can wait 3 days and it will be changed to modern :P

Share this post


Link to post
Share on other sites

Prestashop 1.6

 

Fui inslalar o módulo shopgate para experimentar e tive sérios problemas, inclusive não consigo fazer traduções etc...

escrevo neste tópico porque tenho o zopim instalado e não funciona em minha loja.

Já desinstalei e instalei por várias vezes, sem sucesso.

Alguem pode ajudar??

Obrigado.

hat kind of issues you've got? (use english please, we are in english section on forum - thanks)

Share this post


Link to post
Share on other sites

yess, this is also the way to change it...

well 2 days and everyone of us will have modern widget

im unhappy with that fact because i like old widget :(

Share this post


Link to post
Share on other sites

hi is it work with PrestaShop version 1.6.0.9

 

i embed it to my web and not work www.biblash.com

 

what you mean by "embed" ?

you use module that i provided here? or you trying to install zopim widget by different solutions?

Share this post


Link to post
Share on other sites
  • 4 weeks later...

Hi, since I installed this module, my Revolution Slider doesn't display anymore and ZOPIM either. I need help please.

 

you have to use correct widget id. 

at the moment you use this:

  window.$zopim||(function(d,s){var z=$zopim=function(c){z._.push(c)},$=z.s= d.createElement(s),e=d.getElementsByTagName(s)[0];z.set=function(o){z.set. _.push(o)};z._=[];z.set._=[];$.async=!0;$.setAttribute('charset','utf-8'); $.src='//v2.zopim.com/?2O48zlrWSJCndfAihsekq11QIx8utDmq';z.t=+new Date;$. type='text/javascript';e.parentNode.insertBefore($,e)})(document,'script');  

instead of it you have to use just this:

2O48zlrWSJCndfAihsekq11QIx8utDmq

i already changed it in your back office :-) verify it, it works! :)

Share this post


Link to post
Share on other sites

hello

yes, zopim chat module works with prestasop 1.6.0.8

 

Hi!

 

I have a problem in 1.6.0.9. Screenshot: http://ctrlv.in/419414

 

At the ordering process Zopim widget shows up at the terms and conditions fancybox iframe.. Maybe the module should know that in iframes it shouldnt activate.. :) Please note, that the seo link for the terms and conditions is changed..

 

Thank You for Your help in advance!

Share this post


Link to post
Share on other sites
  • 3 weeks later...

zopim chat widget not coming up whereas id is correct veka can you help .

 

pmed you the website name also :(

 

turn off ccc for js files, turn off minify js and i will see then what's going on there

i don't provide private help (only for paid modules)

Share this post


Link to post
Share on other sites

Hi Vekia,

 

I'm trying to install your free Zopim module and it requires for "Zopim Widget Id".....where and how do I find this? I have created a Zopim account but can find anything about a "Widget id".

 

I've looked at your setup guide but I cannot see any reference to Account.

 

oh, I kept looking and found what I think may be the Widget code and pasted that in and saved it but still not working.

 

I tested to see if the Zopim website could "see" the configuration on my web site but it can't....

 

What am I doing wrong?

 

Thanks

Edited by lateral (see edit history)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hi Vekia,

 

Is there some "code" that needs to be inserting into Prestashop pages?

 

If so, how is this actually done???

 

I tried to use your HTML module but it "broke" my web site...

Share this post


Link to post
Share on other sites

Hi Kevin,

 

I've got it all working but I want it not to start maximised as this is too intrusive.

 

Is there a way to set it to always have it minimised by default and the user then decides to maximize it when required?

Edited by lateral (see edit history)

Share this post


Link to post
Share on other sites

Do you plan to update the module to better support the new Zopim mobile widget / API  they rolled out today?

The auto-detect language according to page language does not fully work anymore.

Share this post


Link to post
Share on other sites

I just installed it and it looks great, one issue Login page can not enter.

My Website  www.selleu.com

 

I Can not add to cart

 

Impossible to add the product to the cart.
textStatus: 'parsererror'
errorThrown: 'SyntaxError: Unexpected token <'
responseText:
{"hasError":true,"errors":["\u5e93\u5b58\u6ca1\u6709\u8db3\u591f\u7684\u5546\u54c1\u3002"]}

Edited by webgo (see edit history)

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Hello Vekia

 

I'm having problem with zopim module on mobile devices. When you access our site with mobile devices it won't scroll down and you are stuck on first site. I see a lot of visitors leaving on first page. When I disable  zopim module everything is working fine. I have latest version of Zopim module.

 

can you give advice why is that?

 

my site is www.trgovina-figura.si

 

best regards

 

Martin

Share this post


Link to post
Share on other sites

HI

 

I found out that this module work on many version of Android and iOS, but won't work on GINGERBREAD.

 

Vekia, do you have possability to test this?

 

best regards 

 

Martin

Share this post


Link to post
Share on other sites

Hi Vekia,

 

First of all, thankyou for your great module... I've been using this module for a long time on PS 1.6 and it Works fine. However I have a question.

 

When testint my site speed I always see this (pingdomtools test speed site):

 

thump_9190835zopim.png

 

If you take a look at the picture, the test indicates that the there are two different items from the zopim module that take a lot to load... Not because they are heavy, but because they start downloading very late..

 

I've seen that one of the items is an "avatar picture" that the module is trying to show from zopim servers... If it was a paralel downloading, that may improve performance, but in this case it isn't. So maybe you can modify the code to load this picture from the own server of the shop instead of download it from the Zopim servers. That would improve a lot the performance of this ítem.

 

The second ítem is related with a Font that maybe can also be changed by a standard Font that doesn't need to be download, that also will improve performance...

 

I've been looking at the module's code to chage it by myself with no luck....

 

 

Can you help with that?

 

thanks!

Edited by Antakarana (see edit history)

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Hi again,

 

This is the file that take more time to download:

 

http://v2.zopim.com/widget/images/avatar_simple_visitor.png

 

Is there any way to modify the module to change the URL for this file to be loaded from my own server instead of zopim servers which seems to have a low answer speed?

 

I've looked at the php files from the module but I can't see any reference to that image.

 

 

Thanks

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Hi,
 

thanks for great module.

 

If possible, I would like your help with this:

As on screenshot, there is a duplicate of zopim chat in the quickview-preview window of products with combinations -  I would really like get rid of it.

Any ideas?

 

eshop: http://lardon.cz
module: 1.5.1

post-720390-0-81885600-1421077194_thumb.jpg

Edited by Lardon (see edit history)

Share this post


Link to post
Share on other sites

Hi,

 

thanks for great module.

 

If possible, I would like your help with this:

 

As on screenshot, there is a duplicate of zopim chat in the quickview-preview window of products with combinations -  I would really like get rid of it.

 

Any ideas?

 

eshop: http://lardon.cz

module: 1.5.1

 

you module is outdated.

use new version, will work as you want :-)