Jump to content

Fordítás


gyula21
 Share

Recommended Posts

Sziasztok

Le szeretném fordítani a rendeléskezelő felület egyes elemeit, de nem találom egyik fordítási menüpont alatt se őket.

(Pl.: a rendelési állapotok: "waiting for bank wire pacment", "preparation in progress" és társai)

Merre találom ezeket?

Share this post


Link to post
Share on other sites

Sziasztok,

 

A fordításoknál ezt a hibaüzenetet kapom:

 

Nyelv : HU - Translations of installed modules

Összes kifejezés : 2262. Klikkelj a mező címre a bezáráshoz/kiterjesztéshez.

Warning, your hosting provider limits the maximum number of fields to post in a form:

5000 for suhosin.post.max_vars

5000 for suhosin.request.max_vars

1000 for max_input_vars

Please ask your hosting provider to increase the post and request limit to 2362 mértékkel növeljék meg a limitet. vagy szerkeszd kézileg a nyelvi fájlokat.

 

Mi lehet a gond? A Szolgáltatóm azt monda, hogy a 5.3 php a gond, de azt nekem kellene valahol frissítenem. Azt hol tudom megtenni? Frissítsem a prestámat? Most 1.4.10.0 van fent.

 

Köszönöm

Gábor

Share this post


Link to post
Share on other sites

A szolgáltatónak jeleztem és pontosan leírtam neki mi a gondom és ezt a választ kaptam.

 

Akkor nem ez a gond, hanem az 5.3-as PHP. Frissíteni kell a rendszert, ahogyan azt előzetesen jeleztük az értesítőnkben, a ...... nem áll módunkban tovább állítgatni.

Nem csak a Magyar nyelv aktív benne.

Ezért gondoltam.

Most akkor bepaliztak?

Share this post


Link to post
Share on other sites

Tehát most akkor "nem csak a magyar nyelv aktív benne" vagy csak a magyar nyelv? :)

Hangsúlytól függően kétértelmű :)

Ha csak a magyart használod akkor mondd meg hogy a pay-pal melyik verzióját akarod magyarítani, vagy az is jó ha a modules mappából be zip-elve felteszed ide csatolmányként hogy megnézhessem.

 

A php 5.3-as verzióját a szolgáltatónak kell frissítenie, Neked nincs is jogosultságod ilyet tenni. Annyit szoktak engedni néha a felhasználóknak hogy admin felületen lenyílómenüben megadják melyik php verziót akarják használni... de telepíteni :D nevetséges. Ha azt mondják hogy Neked kell ezt megcsinálnod akkor kérdezd meg hogyan. Hogyan férsz hozzá a szerverhez, hogyan adod ki terminálból a parancsokat linux alatt. sudo apt-get install php5? Vagy mi?

 

Ne foglalkozz tovább velük, Ők sem akarnak Veled ez a véleményem. Szóval ha van időd dobd fel ide a paypal mappát had vessek rá egy pillantást.

Share this post


Link to post
Share on other sites

Bocsánat igen kétértelműen írtam.

Csak a Magyar nyelvet haszánolom az Angol deaktíválva van. A többi nem is szerepel a listában.

Fordítani szeretném a mezőket és pl. Adminisztrációs felület fordításánál dobja ki ezt a hibát.

Köszönöm

Share this post


Link to post
Share on other sites

2.8.7-eset találtam, nézd meg hogy fájl ugyanaz-e:

 

a mappában lévő confirmation.tpl-t nyisd meg, és az angol szövegeket cseréld le magyarra ott, ahol ezt a szintaktikát látod:

l s='Angolszoveg'

 

majd töltsd vissza a szerverre. Nézd meg hogy jó-e. Mentést csinálj mindenképp az eredeti fájlról!

Ha nem látod a változást akkor kapcsold be a force compile-t a performance-ben.

 

Meg kell nézni hogy mit mutat, ha minden gond nélkül működik akkor így folytathatod a fordítást.

Edited by pattila01 (see edit history)

Share this post


Link to post
Share on other sites

Ó basszus most nézem csak hogy nem te írtad a paypal modult, ne haragudj!

Összekötöttem a kettőt!

:D

Szépen vagyunk.

Igen, a php.ini-ben kellene az értéket állítani, de mivel a szolgáltatód nem segít így ez az út nem járható.

Két lehetőséged van:

vagy a fent említett módszerrel Te nyúlsz bele a kellő .tpl-ekbe és magyarosítod ami kell,

vagy a shopodból készítesz egy mentést, felállítod localhoston mondjuk Xampp alatt és ott menni fog a fordítás adminból :)

Elnézést kérek a fentiért, benéztem a paypal-t. Nem Neked kellett.

Share this post


Link to post
Share on other sites

Semmi gond csak annyira rutintalan vagyok még ebben azt hittem ez kell hozzá. :D :D :D

Megnézem mit is tehetek a tpl fájlokban.

Köszönöm.

Ha már itt vagyok. Nektek melyik szolgáltató jött be a legjobban. Van egy pár domain nevem és két presta áruházam.

Üdv

Share this post


Link to post
Share on other sites

persze. A szolgáltató állítólagezt beállította 4000-re.

1000 for max_input_vars

presta.jpg

Most kaptam a szolgáltatótol lehet nektek mond valamit.

 

Php infóban - input nevű változó nincs, csak ezek, az input = post. Egyeztetni kell a fejlesztőkkel, php-infót kell nekik küldeni.

suhosin.post.max_vars

5000

5000

 

suhosin.request.max_vars

5000

5000

Edited by hellovelo (see edit history)

Share this post


Link to post
Share on other sites

Megnéztem és az értékek módosítva vannak valóban.

 

Én ezek után localhoston nézném meg. Ha ott is gond van akkor nem velük van a hiba. Ha ott nincs ilyen probléma akkor vissza kell térni a php.ini beállításokhoz.

  • Like 1

Share this post


Link to post
Share on other sites

Ha nem jó localhoston akkor a php.ini-ben kell ugyanazokat az értékeket módosítani amit a szolgáltatók munkatársai is megtettek.

Ha megvan, restartolni kell az apache-ot.

Az hogy hol van attól függ mit telepítettél fel.

Xampp esetén:

c:\xampp\php\php.ini

Nyisd meg, keresd meg a kellő sort és módosítsd az értéket. Mentsd el és apache restart.

Utána próba.

Edited by pattila01 (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Én Wamp szervert haszánlok. találtam php.ini fájlt.

feltöltöttem ide:

http://hellovelo.hu/php.ini

ebbe melyik sor lehet amit át kellene írnom. Találtam olyan sorokat amik 1000 értékkel voltak de azokáat átírtam majd apache service restart és nem jó.

Tudom ,hogy én csinálok valamit bénán és még halmozom a bajt mert az írányt sem tudom :-)

 

ez nem okozhatja ezt a problémát?

 

Please turn on the "allow_url_fopen" option in your php.ini config file.

 

írtam a szolgáltatónak és ezt írta:

fopent biztonsági okok miatt nem áll mdunkban bekapcsolni, cURL viszont hazsnálható alternatívaként.

Edited by hellovelo (see edit history)

Share this post


Link to post
Share on other sites

köszi csak turkálok és próbálok minden olyan infot megadni ami kelhet.

 

silihostnál vagyok. Nem tartom őket túl segítőkésznek. Most szeretnék majd váltani, mert én mint felhaszánló a tőmondatokat nem nagyon értem. :-)

Share this post


Link to post
Share on other sites

Szerintem ezt a szolgáltatót felejtsd el. Ennyi pénzért sokkal jobb és profibb szolgáltatást kapsz máshol, tapasztalat.

Válts át másikra és megszűnnek ezek a gondok.

Megnéztem a php.ini-t de nem látok benne olyat amit módosítani kéne. Ugyanaz a hiba localhoston is? Ugyanazt írja ki?

  • Like 1

Share this post


Link to post
Share on other sites

És egy nagy hurrráááááááá!!!!!

Hosszas keresgélés és ötletböze után találtam megoldást a problémámra ami müködik.

 

Szóval generáltattni kell a .htaccess fájlt amiben megadom a következő paramétert:

 

php_value max_input_vars 10000

 

Ettől megjavult a dolog.

 

Köszönöm mindenki segítségét. Annyira kedvet kaptam, hogy jövök még vissza tanulni hozzátok. :-)

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More