Jump to content
vekia

[module] Facebook Comments for free - PrestaShop 1.7 / 1.6 / 1.5 / 1.4

Recommended Posts

Yes, i have verifyed, but somethings very strange with my shop settings.

When i want to add a new module, it's work well only in my BackOffice.

In Front Office don't show.

I have 9 or 10 modules from MyPresta. And i can't make it to work in Front Office.

Share this post


Link to post
Share on other sites

HI!

 

I found that the module adds html in the head:

<meta property="fb:app_id" content="276212249177933"/><meta property="fb:admins" content="xxx"/>
<div id="fb-root"></div>
<script></script>
<div id="fb-root"></div>

Shouldn't be in the head section of HTML, probably this causes errors on page. Please check.

It's in the header.tpl

Edited by iggywebprom

Share this post


Link to post
Share on other sites

Yes, i have verifyed, but somethings very strange with my shop settings.

When i want to add a new module, it's work well only in my BackOffice.

In Front Office don't show.

I have 9 or 10 modules from MyPresta. And i can't make it to work in Front Office.

 

it sounds like caching problem, i mean, that it can be related to caching of your hosting account, maybe they use some caching software and this is why we still don't see new modules in FO. if you're interested i can investigate a bit, but i will need an access to BO

HI!

 

I found that the module adds html in the head:

<meta property="fb:app_id" content="276212249177933"/><meta property="fb:admins" content="xxx"/>
<div id="fb-root"></div>
<script></script>
<div id="fb-root"></div>

Shouldn't be in the head section of HTML, probably this causes errors on page. Please check.

It's in the header.tpl

it doesn't causing any errors, 

it's simple html code, so it can "crash" website.

Share this post


Link to post
Share on other sites

module updated!

added possibility to define different language versions of comment block for each language in your shop

Share this post


Link to post
Share on other sites

I have this error in Google Chrome console:

 

FB.getLoginStatus() called before calling FB.init().

Share this post


Link to post
Share on other sites

it's not related to module, you've got probably some other module (like facebook login)

if so, move it before facebook somments under modules > positions tab.

 

i will contact with you tommorow morning (regarding to other problems)

Share this post


Link to post
Share on other sites

it's not possible to remove this link, this is a part of plugin, we can't do it because it's on facebook side.

Share this post


Link to post
Share on other sites

perhaps you posted it when your friendly urls was disabled?

Share this post


Link to post
Share on other sites

Hi,

 

I am getting empty tab. Please help me to resolve this. Find the attached for your reference.

 

 

Thanks,

Laks

post-365341-0-35728200-1393477886_thumb.png

Share this post


Link to post
Share on other sites

Hi,

 

I am getting empty tab. Please help me to resolve this. Find the attached for your reference.

 

 

Thanks,

Laks

any chance to see it live? if so, please share url

i have to inspect your website

Share this post


Link to post
Share on other sites

Hi

Tks for this

 

its possible to make 100% fluid ?

 

regards

Share this post


Link to post
Share on other sites

as in other topic, may i know what you mean by 100% fluid? :)

Share this post


Link to post
Share on other sites

you can change width param in .tpl file to 100%

Share this post


Link to post
Share on other sites

 

Object at URL 'http://www.diy-alarms.co.uk/pscatalog/en/texecom-premier-elite-kits/932-tpek04-texecom-premier-elite-24-poly-kit-no-cable-no-pirs.html' of type 'product' is invalid because the given value '' for property 'fb:app_id' could not be parsed as type 'fbid'.

 

 

I installed the module, and I get the comment tab on the product pages but i get the 'unreachable' message and the debug shows the above message.

 

please, how do I fix this.

 

Lee

Share this post


Link to post
Share on other sites

I installed the module, and I get the comment tab on the product pages but i get the 'unreachable' message and the debug shows the above message.

 

please, how do I fix this.

 

Lee

just refres refresh website several times.

right after install module can display "unreachable" message due to the fact that it is "frash" installation of plugin.

after refresh facebook crawler will be able to connect to your website, and then - everything will work well

Share this post


Link to post
Share on other sites

sapphal, on 15 Apr 2014 - 09:17 AM, said:snapback.png

I installed the module, and I get the comment tab on the product pages but i get the 'unreachable' message and the debug shows the above message.

 

please, how do I fix this.

 

Lee

just refres refresh website several times.

right after install module can display "unreachable" message due to the fact that it is "frash" installation of plugin.

after refresh facebook crawler will be able to connect to your website, and then - everything will work well

 

 

after refreshing several times the 'unreachable' disappears.  But the comment is not added to the comments tab.

 

Lee

Share this post


Link to post
Share on other sites

glad to hear that it works

you changed something or it just started to work without any reason?

Share this post


Link to post
Share on other sites

Gee, I wish I understood facebook.

 

Anyway, got it working and created an app in fb and i can moderate the comments.

 

What would be really nice is to have a notification of a new comment via email, rather than having to look at facebook regularly.

 

regards

 

Lee

Edited by sapphal

Share this post


Link to post
Share on other sites

at the moment facebook plugin hasn't got feature to inform about new comment, unfortunately :(

Share this post


Link to post
Share on other sites

Hi there, I can't even pass the setup!

 

When I hit Save Settings, I receive a "Notice on line 101 in file /var/www/prestashop/modules/facebookcomments/facebookcomments.php
[8] Undefined index: fcbc_visfix"

 

And I can see no facebook comments anywhere....

When I click on a product I see a "NetworkError: 404 Not Found - http://connect.facebook.net//all.js#xfbml=1&appId=" error on console.

 

What am I doing wrong?

 

PrestaShop version: 1.6.0.6

 

thanks in advance!

 

Hugo

Share this post


Link to post
Share on other sites

can you share url to yur website please?

Share this post


Link to post
Share on other sites

you ahve to define language. it looks like it's not defined.

qcHmy3d.png

use code from this website:

http://mypresta.eu/en/art/know-how/facebook-list-of-local-language-codes.html

 

Yeap, I had two flags below the language editbox, I though I just had to click one of them, but the editbox stayed empty. Now it's working, but the warning when saving settings stiil apears

 

thanks

 

keep up te good work

Edited by venereo

Share this post


Link to post
Share on other sites

thank you for information

im testing it right now but i can't reproduce issue

if i will reproduce it - then i will fix it asap :)

i will inform in this thread

Share this post


Link to post
Share on other sites

I steped in another issue. The tab <h3> block is not correctly placed, it became child of the other <h3> elements instead of becoming sibling....

<div class="tab-titles">
    <h3 class="active-tab" data-title="1">More info</h3>
    <h3 data-title="2">Data sheet</h3>
    <h3 data-title="10">Comentários</h3>
    <section class="page-product-box">
         <h3 class="page-product-heading">
         Comments (
        <fb:comments-count class="" href="http://venereo.no-ip.org/prestashop/evening-dresses/4-printed-dress.html" fb-xfbml-state="rendered">
(...)

cheers

Share this post


Link to post
Share on other sites

thanks very much, but why i cant see table comments, how to delete comments that i dont like

my site: www.diy4vn.com

 

prestashop 1.6.0.6

 

thanks

Edited by minhtailieu

Share this post


Link to post
Share on other sites

use own facebook ID in admin field in back office, then you will be able to manage these comments.

  • Like 1

Share this post


Link to post
Share on other sites

Hola Vekia puedes ayudarme por favor instale la versión en mi pagina www.tytperu.com pero no me llegan las notificaciones cuando alguien deja un comentario puedes ayudarme por favor.Gracias

Share this post


Link to post
Share on other sites

open module configuration page, and in field "admins" eneter your facebook profile ID

lPyvKss.png

(id above is mine, so use your own instead of it)

Share this post


Link to post
Share on other sites

No comprendo en necesario usar una aplicación de facebook? ya tengo mi perfil de ID estoy usando el ID de mi fan page o es que se tiene que usar una pagina persona de facebook?

Share this post


Link to post
Share on other sites

app id is not necessary.

you can't use fanpage profile ID there, you have to use person id

Share this post


Link to post
Share on other sites

i have a problem:

when i tag my friends to your facebookcomments in link :

http://diy4vn.com/index.php?id_product=19&controller=product&id_lang=2

my friends is received with this link :

http://diy4vn.com/index.php?id_product=19&controller=product&id_lang=2&fb_comment_id=fbc_500388686750773_500388853417423_500388853417423#f17df682 

so that my friend cant view my commentfacebook, so how to delete lettre with color red in link when i tag my friend

thanks

Share this post


Link to post
Share on other sites

its not related to my module, this is how facebook works.

this link is generated on facebook side so you, and also me can't change it.

everything what you see inside comment feature window - it's a part of facebook.com website

  • Like 1

Share this post


Link to post
Share on other sites

im glad that i can help :-) If you've got any suggestion about the module - feel free to write :)

Thanks -makasih-matur nuwun,,regard from indonesia, :) :) :) very helpful :)

Share this post


Link to post
Share on other sites

hi vekia,

i tagged my friend into comment facebook, my friend receive 1 link to view but why this link dont show old comments. I had test plug fb in other site (not prestashop) , it shows old comments.

do you have same problem like this?

my site : http://diy4vn.com

Edited by minhtailieu

Share this post


Link to post
Share on other sites
new version released!

- added minor fixes to prestashop 1.6.0.8  module installation process

Share this post


Link to post
Share on other sites

at the moment no - it's not possible

wait about 1hour and new version with this possibility will be released.

 

note that module will work only on product pages! because it's product comments.

Share this post


Link to post
Share on other sites
new version released!

possibility to display comment box in:

- left column

- right column

  • Like 1

Share this post


Link to post
Share on other sites

your theme doesnt use tabs from 1.6

it usees tabs from 1.5

Share this post


Link to post
Share on other sites

Hello, I want to ask a question. First of all, thanks, your module is great. I have a strange issue when I combine your module with another addthis module. When comments module is in tabs, the addthis suffers some modification, but in footer, it works right. I think this is not related to a problem of your module, but, any idea? I send two pictures

2.jpg

1.jpg

Edited by Syd

Share this post


Link to post
Share on other sites

Hello, I want to ask a question. First of all, thanks, your module is great. I have a strange issue when I combine your module with another addthis module. When comments module is in tabs, the addthis suffers some modification, but in footer, it works right. I think this is not related to a problem of your module, but, any idea? I send two pictures

2.jpg

1.jpg

 

cases like that needs an inspection

is there any chance to see it live?

damn... so no solution for your module to work on my site ?

 

no :D download new version i applied there feature to decide what kind of tabs you want to display,

at the moment new version is available on my website

Share this post


Link to post
Share on other sites

new version released!

- added feature to select type of tabs you want to display (wide horizontal bars in ps 1.6, standard tabs like it was in ps 1.5 and older)

Share this post


Link to post
Share on other sites

cases like that needs an inspection

is there any chance to see it live?

 

no :D download new version i applied there feature to decide what kind of tabs you want to display,

at the moment new version is available on my website

Hello,

 

there is an instance at this link:

http://www.asianexoticdream.com/en/shiva-statues/50-brass-shiva-nataraja-statue-1-kg.html

 

Thank you

Share this post


Link to post
Share on other sites

from module .tpl file please remove this:

<style>.fb_ltr, .fb_iframe_widget, .fb_iframe_widget span {width: 100%!important}</style>

  • Like 1

Share this post


Link to post
Share on other sites

from module .tpl file please remove this:

<style>.fb_ltr, .fb_iframe_widget, .fb_iframe_widget span {width: 100%!important}</style>

Fantastic! Now it is fixed. You are great, as always

 

Thanks a lot!

Share this post


Link to post
Share on other sites

thank you for your kind words

im glad to hear that i could help

 

when i added this code to the module i never tested it with addthis module

Share this post


Link to post
Share on other sites

Bonjour

Merci Vekia, chez moi le module bug le footer a changer de couleur "Blanc" Suivez-nous sur Facebook a disparu ? c'est normal cette image ? ci-joint capture. Merci

Amitiés

post-475475-0-83562100-1407913167_thumb.png

Edited by G.Solidarité

Share this post


Link to post
Share on other sites

can you share url to page where the problem appears?

Share this post


Link to post
Share on other sites

Hi vekia,

I post a tip that maybe could be usefull.

 

I'm using your module on a responsive theme, so I made this changes:

<div data-href="http://{$smarty.server.HTTP_HOST}{$smarty.server.REQUEST_URI}" class="fb-comments" data-width="{$fcbc_width}" data-num-posts="{$fcbc_nbp}"  data-colorscheme="{$fcbc_scheme}">

I changed data-width="{$fcbc_width}" to data-width="100%"

 

And then I added this to my css:

.fb_iframe_widget,
.fb_iframe_widget span,
.fb_iframe_widget span iframe[style] {
  min-width: 100% !important;
  width: 100% !important;
}
 
In this way the facebook comment box automatically adapt it's size to the window size.
Edited by DARKF3D3
  • Like 1

Share this post


Link to post
Share on other sites

Yeay.. thanks @DARKF3D3
I've been searching this trick to make it responsive, works like a charm  :)

Share this post


Link to post
Share on other sites

i will include this modification to nearest update

it will work with responsive themes :-)

thanks for code,

with regards,

Milos

Share this post


Link to post
Share on other sites

the review comment is below fb comment? how do i put it at the right position? like in picture attachment.

post-575348-0-30595900-1409492304_thumb.jpg

Share this post


Link to post
Share on other sites

go to modules > positions and try to move facebook comments or product reviews to the end of modules list named displayProductTab

what's going on then?

Share this post


Link to post
Share on other sites

@darkf3d3 the website is not open for public yet.

 

@vekia its already on the bottom of displayproducttab, only 2 modules there.

Share this post


Link to post
Share on other sites

I also have some problem with comment posting, but I think this could be because I'm testing the website in local on WAMP.

 

One thing in notice inspecting code on Chrome is this error:

Uncaught TypeError: Cannot read property 'handleServerJS' of undefined 

Share this post


Link to post
Share on other sites

if your website is under maintenance mode it's normal.

facebook can't open this website due to the maintenance mode

Share this post


Link to post
Share on other sites

EDIT: It was a PS settings problem

 

 

I have another question, i notice that prestashop sometimes add to the page link something like:

www.store-url.com/tech/95-iphone.html?search_query=tetris&results=10

 

So from this pay you don't see the comment of that products. There's no way to show always comment referring only to the product url without the added variables?

Edited by DARKF3D3

Share this post


Link to post
Share on other sites

After go live with my website I notice that the error it's still prestent:

Uncaught TypeError: Cannot read property 'handleServerJS' of undefined (comments.php:20)

Link to the shop in signature.

Share this post


Link to post
Share on other sites

I get one warning when I set two admins id, this is from facebook debugger:

The parser's result for this metadata did not match the input metadata. Likely, this was caused by the data being ordered in an unexpected way, multiple values being given for a property only expecting a single value, or property values for a given property being mismatched. Here are the input properties that were not seen in the parsed result: 'fb:admins' 
example, instead of
<meta property="fb:admins" content="1301085319,1484305492"/>

I use these

<meta property="fb:admins" content="1301085319"/>
<meta property="fb:admins" content="1484305492"/>

 

For temporary fix, I edit manually /modules/facebookcomments/header.tpl

Share this post


Link to post
Share on other sites

After go live with my website I notice that the error it's still prestent:

Uncaught TypeError: Cannot read property 'handleServerJS' of undefined (comments.php:20)

Link to the shop in signature.

 

I get this error too, then I realize this error occured when I login facebook as admin. so, I just ignore this error as long it doesn't impact anything

Share this post


Link to post
Share on other sites

I download the facebook comment but unable upload to my prestashop. It look like something missing on the file. Can you send me the complete file for the facebook comment module?

Share this post


Link to post
Share on other sites

module is complete.

please show what exactly you see when you upload module to your shop.

Share this post


Link to post
Share on other sites

Suddenly the module appear on my module list and working fine.

Edited by vivianlwy
  • Like 1

Share this post


Link to post
Share on other sites

Hi,

 

Is it possible to have multiple facebook page depending on the product?

 

Thanks.

Share this post


Link to post
Share on other sites

Hi,

 

Is it possible to have multiple facebook page depending on the product?

 

Thanks.

 

hello

i don't understand the question

 

you can create as many facebook fanpages as you want... but how it is related to this module ? :-)

Share this post


Link to post
Share on other sites

Hi,

 

What I did is instead of product list I created a list of restaurants. So everytime you click a restaurant it will display their facebook page

Share this post


Link to post
Share on other sites

new version released

- added improvements to module installation / upgrade process, it doesnt affect default upgrades feature.

Share this post


Link to post
Share on other sites

Hi.

I need to adopt this module to my theme. Can anybody help? I'll pay.

Share this post


Link to post
Share on other sites

Hello

thank you for your module !

i have this erroer on my product page :

 

 

 

any idee ?

i see just nothing

can you reattach it (image?) please?

Share this post


Link to post
Share on other sites

I have installed it and it works, except on the left column hook, when I run live edit I see the module there. But, there are no comments, or cannot make a comment. 

 

page is vidaom.com

Edited by photographer

Share this post


Link to post
Share on other sites

module is for product pages only, and it can be attached only to:

productFooter

productTab

productTabContents

 

left column isn't a right place for this addon.


btw. url doesnt work http://www.vidaom.com/vidaom/

Share this post


Link to post
Share on other sites
Hello, the module works very well, as I know when someone makes any comments?

Regards

Share this post


Link to post
Share on other sites

if you will use id of administrator (your personal account on facebook) you will receive facebook notifications

Share this post


Link to post
Share on other sites

Hi, I configure my facebook account, and I do not get notifications that might be?

Share this post


Link to post
Share on other sites

you entered your private profile id to module configuration ?

Share this post


Link to post
Share on other sites