Jump to content
Trad-Archerie

[Resolu] Maj 1.4.8.2 --> 1.4.10 - Bo: Pb Affichage Liste Des Modules

Recommended Posts

Bonjour,

la mise à jour s'est bien passée, sans message d'erreur, mais apparemment je n'ai qu'un seul plantage, mais bloquant: les modules ne sont plus listés dans l'onglet modules du back-office.

Est-ce que quelqu'un a le même problème? et mieux, une solution?

Merci pour votre aide

Edited by Trad-Archerie (see edit history)

Share this post


Link to post
Share on other sites

HELP!!

 

voici la copie d'écran

 

PS1_4_10_0_plantage_modules.jpg

 

J'ai essayé de remettre la page AdminModules.php d'avant la mise à jour, mais ça ne change rien.

J'ai essayé de mettre des messages de debug dans la page index.php de mon BO et à priori ça bug dans la fonction "display()" (l.113)

Mais je ne trouve pas cette fameuse fonction, je n'ai donc pas pu aller plus loin.

J'ai comparé la table "ps_module" avant et après maj, et là aussi, je ne vois pas de différence...

Merci d'avance pour votre aide.

Share this post


Link to post
Share on other sites

Bonsoir

 

Essayez de voir si il ne manque pas le dossier backward_compatibility dans le module themeinstallator.

 

Si oui telechargez le zip http://www.prestashop.com/download/old/prestashop_1.4.10.0.zip et uploadez ce dossier.

 

Je cherche la source de cette erreur, a priori il y a un problème avec un zip d'une channel de telechargement.

 

Sinon

dans /config/config.inc.php

et /config/defines.inc.php

 

@ini_set('display_errors', 'off');

 

à

 

@ini_set('display_errors', 'on');

 

et

 

define('_PS_MODE_DEV_', false);

 

à

 

define('_PS_MODE_DEV_', true);

 

et au moins vous avez l'erreur qui s'affiche dans la page blanche.

Cordialement

  • Like 1

Share this post


Link to post
Share on other sites

Oui ca marche une fois copié, dans le module la page s'ouvre. Merci pour votre réactivité !

Share this post


Link to post
Share on other sites

Heu oui, il me semble qu'il faisait partie du précédent package, je ne me souviens pas de l'avoir ajouté "en plus"...

Quand aux droits sur le module, vous voulez parler des droits en lecture/écriture du répertoire?

Edited by Trad-Archerie (see edit history)

Share this post


Link to post
Share on other sites

Hello,

 

Des fois même avec l'affichage des erreurs la page html ne la fait pas ressortir. Affichez les erreurs et afficher la source de la page avec la naviguateur, en bas du code souvent on trouve l'erreur.

 

A bientôt

Share this post


Link to post
Share on other sites

Bonjour je re lance mon post

 

Moi c'est dans la page position des module que j'ai plus rien.

 

merci d'avance

Share this post


Link to post
Share on other sites

L'affichage des erreurs se fera dans le code source de la page. Parfois même avec l'affichage des erreurs la page html ne la fait pas ressortir. Affichez les erreurs et afficher la source de la page avec la naviguateur, en bas du code de la page souvent on trouve l'erreur.

 

Cordialement

Share this post


Link to post
Share on other sites

Rebonjour,

 

Je suis etonné que le code source s'arrete sans aucune erreur php.

 

Juste avant de vous demander votre ftp:

 

- dans /config/config.inc.php ligne 28 vous avez bien @ini_set('display_errors', 'on');

 

- dans /config/defines.inc.php ligne 27 vous avez bien define('_PS_MODE_DEV_', true);

 

Sinon il faudra regarder d'ou vient l'erreur dans les logs d'Apache mais cela m'etonne.

 

Cordialement

Share this post


Link to post
Share on other sites

<b>Deprecated</b>: Assigning the return value of new by reference is deprecated in <b>/homez.13/huilletp/www/boutique/modules/googleshopping/class/myTools.php</b> on line <b>56</b><br /> <br /> <b>Deprecated</b>: Assigning the return value of new by reference is deprecated in <b>/homez.13/huilletp/www/boutique/modules/googleshopping/fonctions.php</b> on line <b>55</b><br />  <br /> <b>Warning</b>: require(/homez.13/huilletp/www/boutique/modules/themeinstallator/backward_compatibility/backward.php) [<a href=function.require'>function.require</a>]: failed to open stream: No such file or directory in <b>/homez.13/huilletp/www/boutique/modules/themeinstallator/themeinstallator.php</b> on line <b>94</b><br /> <br /> <b>Fatal error</b>: require() [<a href=function.require'>function.require</a>]: Failed opening required '/homez.13/huilletp/www/boutique/modules/themeinstallator/backward_compatibility/backward.php' (include_path='.:/usr/local/lib/php') in <b>/homez.13/huilletp/www/boutique/modules/themeinstallator/themeinstallator.php</b> on line <b>94</b><br />

Share this post


Link to post
Share on other sites

Hello,

 

Essayez de voir si il ne manque pas le dossier backward_compatibility dans le module themeinstallator.

 

Si oui telechargez le zip http://www.prestashop.com/download/old/prestashop_1.4.10.0.zip et uploadez ce dossier.

 

Il ya egalement un souci avec le module googleshopping qui je crois n'est pas natif dans prestashop. Il faut le mettre à jour.

Share this post


Link to post
Share on other sites

J'ai trouvé la source de l'erreur. Le module theminstallator sur addons n'est pas à jour par rapport au zip d'une 1.4.10.

 

 

Télécharger le zip d'une 1.4.10 pour recuperer le dossier dans le module themeinstallator.

 

http://www.prestashop.com/download/old/prestashop_1.4.10.0.zip

 

Sinon dispo ici

 

http://addons.prestashop.com/en/front-office-features-prestashop-modules/1713-template-installer.html

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai le même problème après avoir changé d'offre d’hébergement chez OVH. 

 

J'ai cette erreur  : Fatal error: Cannot re-assign auto-global variable _POST in /www/classes/Module.php(573) : eval()'d code on line 464

 

Je  n'ai pas d'autre problèmes sur le back comme sur le front office.

 

MERCI

Share this post


Link to post
Share on other sites

Bonjour et bienvenue,

 

Ce post date un peu, vous pouvez créer un nouveau post maintenant.

 

Vous ne dites pas votre version donc c'est un peu dur à dire mais il y a un module qu'il n'arrive pas à lire. Essayez de supprimer sur le ftp les modules dernièrement ajoutés.

 

Cordialement

Share this post


Link to post
Share on other sites

bonjour j ai le meme souci la page module ne s affiche pas 

 

par contre je ne trouve pas l erreur dans le code source

 

j ai bien mis true et on

 

merci

post-319366-0-38812600-1406843629_thumb.png

Edited by kidoshop (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More