Jump to content
Dani243

[Solucionado]Problema Con Integración De Wordpress En Prestashop

Recommended Posts

Buenas foreros,

 

Estaba haciendo unos retoques en la web para añadirle un blog y intentar ganar algo de posicionamiento.

 

El problema es el siguiente. He insertado unos archivos que he encontrado por ahí para integrar un wordpress casi perfectamente con nuestra tienda. Aprovecho para contar como he hecho la media integración por si a alguien puede interesarle.

 

Primero me he descargado los archivos de esta web que no es mía http://www.b-shop.es...op-y-wordpress/

 

Creamos en nuestro directorio de prestashop una carpeta que la llamaremos blog y ahí introducimos los archivos de nuestro blog.

Realizamos la instalación completa de nuestro blog.

Una vez instalado correctamente nuestro blog nos dirigimos a la carpeta /wp-content/themes/ y el tema que tengamos seleccionado.

Ahí seleccionamos el archivo header.php y el footer.php por los que nos hemos descargado de la otra página.

Así de sencillo seria realizar la integración.

 

El único problema es que a la hora de mostrar el blog todo el contenido se muestra en la columna central quedando un hueco a la derecha quedando así: http://regaloland.es/blog/

Lo que estoy tratando de hacer es eliminar la columna derecha del prestashop pero solo del apartado blog... estilo la pagina de inicio que en mi caso no la lleva.

 

¿Sugerencias?

 

Un saludo.

Edited by Dani243 (see edit history)

Share this post


Link to post
Share on other sites

Estoy con el móvil, en este momento no puedo contestarte, cuando vuelva te comento los pasos a realizar. "Es relativamente sencillo"

Share this post


Link to post
Share on other sites

UMm lo estoy probando y no consigo nada :S Que theme de wordpress usas? el twentytwelve?

Share this post


Link to post
Share on other sites

Si, el twentytwelve. ¿Qué versión de prestashop tienes? ¿Has creado el blog en una carpeta dentro del directorio raiz de prestashop? Mandame un enlace para ver como te queda a ver que puede ser.

Por cierto Nadie todavía sigo a la espera jajajaja

Share this post


Link to post
Share on other sites

Si, el blog está creado en una carpeta en el directorio raíz de Prestashop. Mi versión de Prestashop es la 1.5 y he usado el twentytwelve...y nada. No puedo darte una url porque estoy trabajando en local

 

Edit: cuando coloco el codigo en el header.php, me da un error en la línea 32:

 

'HOOK_LEFT_COLUMN' => Module::hookExec('leftColumn'),
));

Edited by ermuni (see edit history)

Share this post


Link to post
Share on other sites

Buenas foreros,

 

Estaba haciendo unos retoques en la web para añadirle un blog y intentar ganar algo de posicionamiento.

 

El problema es el siguiente. He insertado unos archivos que he encontrado por ahí para integrar un wordpress casi perfectamente con nuestra tienda. Aprovecho para contar como he hecho la media integración por si a alguien puede interesarle.

 

Primero me he descargado los archivos de esta web que no es mía http://www.b-shop.es...op-y-wordpress/

 

Creamos en nuestro directorio de prestashop una carpeta que la llamaremos blog y ahí introducimos los archivos de nuestro blog.

Realizamos la instalación completa de nuestro blog.

Una vez instalado correctamente nuestro blog nos dirigimos a la carpeta /wp-content/themes/ y el tema que tengamos seleccionado.

Ahí seleccionamos el archivo header.php y el footer.php por los que nos hemos descargado de la otra página.

Así de sencillo seria realizar la integración.

 

El único problema es que a la hora de mostrar el blog todo el contenido se muestra en la columna central quedando un hueco a la derecha quedando así: http://regaloland.es/blog/

Lo que estoy tratando de hacer es eliminar la columna derecha del prestashop pero solo del apartado blog... estilo la pagina de inicio que en mi caso no la lleva.

 

¿Sugerencias?

 

Un saludo.

 

Hola !

 

He vuelto....

 

Te dire un metodo.............. supongo que hay miles.

 

En el header.php que tienes en wordpress (con las modificaciones que has realizado) cambia esto:

 

$css_files[_THEME_CSS_DIR_.'global.css'] = 'all';

 

por esto:

 

$css_files[_THEME_CSS_DIR_.'global2.css'] = 'all';

 

Luego haces una copia del fichero global.css y la llamas global2.css

 

Ahora en el global2.css buscas esto:

 

#center_column {
width: 763px;
float: left;
margin: 0 0 20px 0;
}

 

Y lo dejas asi

 

#center_column {
width: 1024px;
float: left;
margin: 0 0 20px 0;
}

 

Luego en el mismo global2.css buscas esto:

 

#right_column {
width: 241px;
float: left;
margin: 0 0 0 20px;
}

 

Y lo dejas asi:

 

#right_column {
width: 241px;
float: left;
margin: 0 0 0 20px;
display:none;
}

Share this post


Link to post
Share on other sites

Por cierto Nadie todavía sigo a la espera jajajaja

 

Te acabo de responder en el mensaje anterior. :P

Share this post


Link to post
Share on other sites

Asi, como te he dicho depende verte asi, que es como se te ve ahora:

 

Con lo que te he dicho se te vera así:

 

Regaloland-510x1024.png

 

Depende así. (Que es como lo tienes ahora)

 

Regaloland1-484x1024.png

 

-----------------------------

 

Supongo que es eso lo que querias ¿no?

Share this post


Link to post
Share on other sites

Argggg Nadie eres un f***ing maister!!!! jajajajaja mira que era sencillo y estuve dandole vueltas...

 

Ermuni no se si tendrá algo que ver, pero puede ser por la versión del prestashop?

Lo que hice fue cambiar el header y el footer por el que ponía ahí y también lo que hice fue poner esto al final de todo después del ?>:

 

 

<link rel="stylesheet" type="text/css" media="all" href="<?php bloginfo( 'stylesheet_url' ); ?>" />

 

Pruébalo y nos dices.

 

Saludos.

 

 

PD: Nadie piensas que es mejor para mejorar el posicionamiento tener el blog integrado dentro del prestashop o sería mejor que estuviera por separado?

y otra consultita mas ya que estamos por aquí, mi web tiene 3 meses de vida y estoy creando durante esos 3 meses backlinks, pero en las herramientas del webmaster tools no me muestra ni 1 solo enlace a mi sitio, ni siquiera los de facebook, twitter o pinterest... alguien sabe cuanto tiempo es lo normal para que empiece a mostrar enlaces?

Share this post


Link to post
Share on other sites

Argggg Nadie eres un f***ing maister!!!! jajajajaja mira que era sencillo y estuve dandole vueltas...

Un placer ayudarte y servirte!

 

Si das el tema como solucionado, edita el titulo del tema, editando el primer mensaje, pulsando en editar, y después en "Usar editor completo", añadiendo la palabra "Solucionado" al titulo, esto ayudara, a mantener una mayor organización en el foro.

 

Un saludo y recuerda que estaremos en el foro, para guiarte por este mundo oscuro y tenebroso.

Share this post


Link to post
Share on other sites

Asi, como te he dicho depende verte asi, que es como se te ve ahora:

 

Con lo que te he dicho se te vera así:

 

Regaloland-510x1024.png

 

Depende así. (Que es como lo tienes ahora)

 

Regaloland1-484x1024.png

 

-----------------------------

 

Supongo que es eso lo que querias ¿no?

 

Bonito disfraz :lol:

 

Un saludo.

Share this post


Link to post
Share on other sites

Yo también solucione el problema :D

que era lo que te ocurría al final¿?

Share this post


Link to post
Share on other sites

Pues ha sido muy sencillo. Cojo el header.php del tema del blog que tengo activado, borro todo lo que hay y pongo esto:

 

<?php
// On inclut l’environnement Prestashop
require_once(dirname(__FILE__).'/../../../../config/config.inc.php');
require_once(dirname(__FILE__).'/../../../../header.php');
$css_files[_THEME_CSS_DIR_.'global2.css'] = 'all';

?>
<link rel="stylesheet" type="text/css" media="all" href="<?php bloginfo( 'stylesheet_url' ); ?>" />

 

El footer.php borro todo y pego esto:

 

<?php
require_once(dirname(__FILE__).'/../../../../config/config.inc.php');
require_once(dirname(__FILE__).'/../../../../footer.php');
?>
<link rel="stylesheet" type="text/css" media="all" href="<?php bloginfo( 'stylesheet_url' ); ?>" />

 

Y voilá, ya funciona y va perfecto. Simplemente voy modificando el style.css del tema del blog y voy cuadrando todo para que quede perfecto.

 

Espero que sirva de ayuda esto.

Share this post


Link to post
Share on other sites

Se que has dado por solucionado el tema pero tengo un problema, he conseguido hacer la integracion a medias, en la pagina en frances pone que hay que hacerlo en la misma base de datos pero si lo hago asi no me sale me dice que hay muchos redireccionamientos, lo he hecho en otra base de datos y he cambiado los archivos header y footer, pero no me sale el pie de la tienda. ¿a ti te sale el pie como le tienes en la tienda?

 

 

he visto que el body me pone id="pagenotfound" como si no encontrara prestashop la pagina, cambiando el css me imagino que saldra, sigo probando...

 

<body class=" " id="pagenotfound">

Edited by gustavoaudiomeca (see edit history)

Share this post


Link to post
Share on other sites

Se que has dado por solucionado el tema pero tengo un problema, he conseguido hacer la integracion a medias, en la pagina en frances pone que hay que hacerlo en la misma base de datos pero si lo hago asi no me sale me dice que hay muchos redireccionamientos, lo he hecho en otra base de datos y he cambiado los archivos header y footer, pero no me sale el pie de la tienda. ¿a ti te sale el pie como le tienes en la tienda?

 

 

he visto que el body me pone id="pagenotfound" como si no encontrara prestashop la pagina, cambiando el css me imagino que saldra, sigo probando...

 

<body class="" id="pagenotfound">

 

En este punto estoy yo también.

Share this post


Link to post
Share on other sites

Si por mi parte, dejando incluso los archivos header.php y footer.php con solo las líneas que posteaste.

 

En mi caso, mi body queda <body class="home blog" id="pagenotfound"> y el footer no aparece.

 

¡Gracias por tu tiempo! ;)

 

ACTUALIZADO: Y por lo que veo, tampoco me coje el global2.css duplicado de Prestashop :S

Edited by Ivan_RM88 (see edit history)

Share this post


Link to post
Share on other sites

en mi caso pone <body class=" id="pagenotfound">, y tampoco salia el footes, lo he solucionado poniendo en el style.css de wordpress:

 

#pagenotfound #left_column,

#pagenotfound #right_column,

#pagenotfound #footer {float: left;display:block !important;}

Share this post


Link to post
Share on other sites

Si, eso tambien lo he provado. Pero lo ideal es que no se use la id pagenotfound no? :o

Share this post


Link to post
Share on other sites

Os dejo el codigo correspondiente a mi header.php. Con esto, se carga el header de Prestashop casi perfecto, pero con <body id="pagenotfound" class="home blog">. ¡Vaaaaamos, que estamos apunto! ;)

 

<?php
/**
* @package WordPress
* @subpackage Neptune Theme
*/
$options = get_option( 'neptune_theme_settings' ); ?>
<!DOCTYPE html>
<html <?php language_attributes(); ?>>
<head>
   <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
   <title><?php wp_title(''); ?><?php if(wp_title('', false)) { echo ' |'; } ?> <?php bloginfo('name'); ?></title>
   <link rel="stylesheet" type="text/css" media="all" href="<?php bloginfo( 'stylesheet_url' ); ?>" />
</head>
<body <?php body_class(); ?>>
<div id="header" class="clearfix">

    <?php
    // On inclut l’environnement Prestashop
    require_once(dirname(__FILE__).'/../../../../config/config.inc.php');
    require_once(dirname(__FILE__).'/../../../../header.php');
    $css_files[_THEME_CSS_DIR_.'global2.css'] = 'all';
    ?>

</div><!-- END header -->
<div id="wrap" class="clearfix">

Edited by Ivan_RM88 (see edit history)

Share this post


Link to post
Share on other sites

Os dejo el codigo correspondiente a mi header.php. Con esto, se carga el header de Prestashop casi perfecto, pero con <body id="pagenotfound" class="home blog">. ¡Vaaaaamos, que estamos apunto! ;)

 

<?php
/**
* @package WordPress
* @subpackage Neptune Theme
*/
$options = get_option( 'neptune_theme_settings' ); ?>
<!DOCTYPE html>
<html <?php language_attributes(); ?>>
<head>
<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
<title><?php wp_title(''); ?><?php if(wp_title('', false)) { echo ' |'; } ?> <?php bloginfo('name'); ?></title>
<link rel="stylesheet" type="text/css" media="all" href="<?php bloginfo( 'stylesheet_url' ); ?>" />
</head>
<body <?php body_class(); ?>>
<div id="header" class="clearfix">

	<?php
	// On inclut l’environnement Prestashop
	require_once(dirname(__FILE__).'/../../../../config/config.inc.php');
	require_once(dirname(__FILE__).'/../../../../header.php');
	$css_files[_THEME_CSS_DIR_.'global2.css'] = 'all';
	?>

</div><!-- END header -->
<div id="wrap" class="clearfix">

 

No lo he probado, pero con las primeras lineas estas diciendo que el documento es html5 (wordpress) cuando prestashop es html4, no habri muchos problemas pero lo que veo es que luego despues pones

require_once(dirname(__FILE__).'/../../../../header.php');

con lo que estas llamando a la cabecera de prestashop ¿No te vuelve a poner todo el html, head, body etc.?

 

 

Lo he comprobado y si te lo vuelve a pone con lo que tienes dos veces las etiquetas, no se que tal les gustara eso a los buscadores pero imagino que poco.

Edited by gustavoaudiomeca (see edit history)

Share this post


Link to post
Share on other sites

No lo he probado, pero con las primeras lineas estas diciendo que el documento es html5 (wordpress) cuando prestashop es html4, no habri muchos problemas pero lo que veo es que luego despues pones

require_once(dirname(__FILE__).'/../../../../header.php');

con lo que estas llamando a la cabecera de prestashop ¿No te vuelve a poner todo el html, head, body etc..?

 

Si me los carga pero solo muestra el header de mi tienda, mezclandose los css tanto de Prestashop como de Wordpress. Te adjunto una captura de lo que ocurre (lo que sale es la Home de mi tema).

 

Y mi estructura body queda asi:

<body class="home blog" id="pagenotfound">
<div id="header" class="clearfix">
	<div id="page" class="container_9 clearfix">
		<div id="header" class="grid_9 alpha omega"> ... </div>
		<div id="columns" class="grid_9 alpha omega clearfix">

				<div id="left_column" class="column grid_2 alpha"> ... </div>
				<div id="center_column" class=" grid_5"> ... </div>
				<div id="wrap" class="clearfix"> ... </div>
				<div id="footer" class="grid_9 alpha omega clearfix"> ... </div>
		</div>
	</div>
</div><!-- END header -->
</body>

 

Gracias por tu tiempo :)

post-359944-0-40915600-1363171792_thumb.jpg

Share this post


Link to post
Share on other sites

Si, fallo mio al cargar el head y del body del header.php original de mi tema. Ahora he dejado el archivo tal cual nos comentaba Ermuni aqui:

 

 

Header.php

 

<?php
// On inclut l’environnement Prestashop
require_once(dirname(__FILE__).'/../../../../config/config.inc.php');
require_once(dirname(__FILE__).'/../../../../header.php');
$css_files[_THEME_CSS_DIR_.'global2.css'] = 'all';

?>
<link rel="stylesheet" type="text/css" media="all" href="<?php bloginfo( 'stylesheet_url' ); ?>" />

 

Footer.php

 

<?php
require_once(dirname(__FILE__).'/../../../../config/config.inc.php');
require_once(dirname(__FILE__).'/../../../../footer.php');
?>
<link rel="stylesheet" type="text/css" media="all" href="<?php bloginfo( 'stylesheet_url' ); ?>" />

 

Y me quedo como tu gustavoaudiomeca

 

<body class="" id="pagenotfound">

 

Te afectó al rendimiento de la Web tenerlo así?

 

Muchas gracias de verdad, que no es un tema facil.

Edited by Ivan_RM88 (see edit history)

Share this post


Link to post
Share on other sites

Si te digo la verdad, es que estoy montando la tienda con el blog, pero no he notado nada raro. Estoy intentando modificar el body pero no doy con ello. En cuestion de rendimiento no deberia afectar al fin y al cabo es una definicion de un id y un class con lo que el rendimiento no tendria que afectar.

Share this post


Link to post
Share on other sites

Pues entonces iré editando así y ya está, tampoco puedo perder mucho tiempo en esto.

 

Por último, ¿te aplica el global2.css según este código?

 

$css_files[_THEME_CSS_DIR_.'global2.css'] = 'all';

 

Pongo eso en el header.php y me sigue aplicando el global.css...

 

Gracias.

Share this post


Link to post
Share on other sites

para solucionar lo del body al final he puesto

 


{$dir=$smarty.server.PHP_SELF}
{if strpos($dir,"/blog/")===0}
<body id="blog">
{else}
<body {if isset($page_name)}id="{$page_name|escape:'htmlall':'UTF-8'}"{/if} class="{if $hide_left_column}hide-left-column{/if} {if $hide_right_column}hide-right-column{/if} {if $content_only} content_only {/if}">
{/if}

 

en el header.tpl de la plantilla de prestashop, la orden de body..... es la que pone prestashop, teniendo en cuenta que yo lo tengo en la carpeta blog, sino tendras que cambiar el if strpos y poner la carpeta que tu tengas en lugar de blog

Edited by gustavoaudiomeca (see edit history)

Share this post


Link to post
Share on other sites

para solucionar lo del body al final he puesto

 


{$dir=$smarty.server.PHP_SELF}
{if strpos($dir,"/blog/")===0}
<body id="blog">
{else}
<body {if isset($page_name)}id="{$page_name|escape:'htmlall':'UTF-8'}"{/if} class="{if $hide_left_column}hide-left-column{/if} {if $hide_right_column}hide-right-column{/if} {if $content_only} content_only {/if}">
{/if}

 

en el header.tpl de la plantilla de prestashop, la orden de body..... es la que pone prestashop, teniendo en cuenta que yo lo tengo en la carpeta blog, sino tendras que cambiar el if strpos y poner la carpeta que tu tengas en lugar de blog

 

He copiado este código donde me comentas, y arreglando esta sentencia:

 

{if strpos($dir,"/blog/") == 0}

 

No se me corrige tampoco. Mi carpeta Wordpress también se llama "blog".

Edited by Ivan_RM88 (see edit history)

Share this post


Link to post
Share on other sites

en tu header.tpl (prestashop) del tema pone

 

<body {if isset($page_name)}id="{$page_name|escape:'htmlall':'UTF-8'}"{/if} class="{if $hide_left_column}hide-left-column{/if} {if $hide_right_column}hide-right-column{/if} {if $content_only} content_only {/if}">

 

sustituye eso por las lineas que te he puesto antes.

es con 3 signos de igual segun pone en el manual php http://php.net/manua...tion.strpos.php

 

yo lo tengo en http://www.3wsolucionesweb.es/blog y funciona, si lo tienes en otra carpeta como por ejemplo: www.dominio.es/tienda/blog entonces no es la posicion 0 sino la 7, hay que contar las letras empezando por 0.

Edited by 3w soluciones web (see edit history)

Share this post


Link to post
Share on other sites

en tu header.tpl (prestashop) del tema pone

 

<body {if isset($page_name)}id="{$page_name|escape:'htmlall':'UTF-8'}"{/if} class="{if $hide_left_column}hide-left-column{/if} {if $hide_right_column}hide-right-column{/if} {if $content_only} content_only {/if}">

 

sustituye eso por las lineas que te he puesto antes.

es con 3 signos de igual segun pone en el manual php http://php.net/manua...tion.strpos.php

 

yo lo tengo en http://www.3wsolucionesweb.es/blog y funciona, si lo tienes en otra carpeta como por ejemplo: www.dominio.es/tienda/blog entonces no es la posicion 0 sino la 7, hay que contar las letras empezando por 0.

 

Siento ser tan pesado, pero no me funciona...ni con 7 ni con 0 :S

Share this post


Link to post
Share on other sites

El 7 era un ejemplo. Donde lo tienes instalado?

 

Estoy trabajando en local. Mis directorios son los siguientes:

localhost/prestashop

y

localhost/prestashop/blog

 

Gracias.

 

ACTUALIZACIÓN: Arreglado, mi posición era 11!! ;)

Edited by Ivan_RM88 (see edit history)

Share this post


Link to post
Share on other sites

Exacto si no quieres tener problemas con los números puedes poner. >==0 o !== false pero no debes tener ninguna url amigable que sea /blog/

Share this post


Link to post
Share on other sites

Si, es perfecta esta solución.

 

Ahora voy a intentar usar el global2.css aparte, y dejar toda esta información reunida en un último post explicando el proceso.

 

Probaré con un:

 

<link rel="stylesheet" href="<?php bloginfo('stylesheet_directory'); ?>/../../../../themes/default/css/global2.css" type="text/css" media="all" />

 

en el header.php de Wordpress, a ver que tal :o

 

ACTUALIZO: Este código carga el global2.css que se encuentra en la carpeta css del tema "default" en Prestashop, osea que PERFECTO :D. A ver si en un rato ordeno la información y la dejo detallada, es lo menos que puedo hacer.

 

3W Soluciones Web, ¡Muuuuuuuuuchas gracias por tu ayuda! :)

Edited by Ivan_RM88 (see edit history)

Share this post


Link to post
Share on other sites

De nada, para eso estamos. Ten cuidado donde lo cargas, la opcion correcta seria en el header.tpl de prestashop haciendo algo parecido a lo del <body> y ten en cuenta que debe estar entre el <head> y el </head>

Share this post


Link to post
Share on other sites

Encontré el post por casualidad y me he animado a probar, con lo que la información que habéis aportado he modificado los archivos header.php y footer.php. Haciendo unas pequeñas modificaciones en el archivo css global2.css queda muy bien integrado.

 

El problema que encuentro es que en cuanto cargo el header.php, las categorías creadas en wordpress, archivo, etc... aparecen vacías, como si no existieran categorías. Si cargo el header.php original si que aparecen. ¿Habría que añadir alguna línea más de código al Header para solucionarlo?.

 

 

Header.php

 

<?php
require_once(dirname(__FILE__).'/../../../../config/config.inc.php');
require_once(dirname(__FILE__).'/../../../../header.php');
?>

<link rel="stylesheet" href="<?php bloginfo('stylesheet_directory'); ?>/../../../../themes/plantilla/css/global2.css" type="text/css" media="all" />

 

 

 

Footer.php

 

<?php
require_once(dirname(__FILE__).'/../../../../config/config.inc.php');
require_once(dirname(__FILE__).'/../../../../footer.php');
?>

Edited by yeremaya (see edit history)

Share this post


Link to post
Share on other sites

te has pasado por http://www.prestashop.com/forums/topic/2320[spam-filter]aporte-integrar-wordpress-con-prestashop-15/ en principio hay he puesto los pasos y no habria que hacer nada mas.

 

Te refieres a la columna de la derecha?? si es asi, a lo mejor te falta por poner en la hoja de estilos (si no has hecho todos los pasos)


#pagenotfound #left_column,
#pagenotfound #right_column,
#pagenotfound #footer {display:block !important;}

 

si has hecho todos los pasos del enlace cambia #pagenotfound por #blog

  • Like 1

Share this post


Link to post
Share on other sites

Gracias por la info 3w. Me refiero efectivamente a la columna de la derecha, donde aparece la caja de busqueda de wordpress, categorías, etc...

 

Probé a añadir las tres líneas que has puesto en la hoja de estilos y nada. He probado a cargar desde el header.php la hoja de estilos original de la plantilla twentyeleven y también con el archivo global2.css y el problema persiste. Si elimino el archivo header.php todo este menú funciona perfectamente. La verdad es que no se me ocurre que más opciones para solucionarlo.

 

Olvidé mencionar que estoy con la versión de prestashop 1.4.9

 

 

 

 

bloggy.jpg

Share this post


Link to post
Share on other sites

Ya está solucionado. Lo explico para los despistados como yo. El único problema era que estaba manejando dos bases de datos diferentes. Prestashop por un lado y Wordpress por otro. Para que funcione la integración hay que instalar Wordpress en la misma base de datos que Prestashop. Comprobando antes que los prefijos de las tablas de cada CMS sean distintos.

 

 

Saludos!

Share this post


Link to post
Share on other sites

Me alegro que al final te funcione. Yo tambien ley que había que hacerlo en la misma base de datos pero a mi tambien me funciona con dos bases de datos. Sera por las versiones yo uso la 1.5.3 con wordpress 3.5

  • Like 1

Share this post


Link to post
Share on other sites

Hola, hace un par de dias di con este post y lo estoy intentando pero no queda bien. Aqui podeís ver el enlace http://romera.es/blog

 

¿que estoy haciendo mal? he cambiado el footer, header y style. Uso Prestashop 1.5.4 y wp 3.5.1, ayer probe con Prestashop 1.5.3 y me hace lo mismo

Edited by Waterman (see edit history)

Share this post


Link to post
Share on other sites

que plantillas estas usando?? te lo digo porque no te esta cargando el archivo style.css, funciona con la plantilla default de prestshop 1.5.3 y twentytwelve de wordpress 3.5, puedes pasar por http://www.prestashop.com/forums/topic/2320[spam-filter]aporte-integrar-wordpress-con-prestashop-15/ o http://www.prestashop.com/forums/topic/233513-integrar-wordpress-y-prestashop-facilmente/page__fromsearch__1 en este ultimo es dargar el archivo y si usas las versiones que te he dicho funciona.

Share this post


Link to post
Share on other sites

no te esta cargando el style.css de wordpress,esto puede pasar si usas prestashop 1.5.4,si es asi hay que añadirle el archivo a mano en el modulo.tpl, pasate por los enlaces que te he puesto y hay vienen mas detalles.

Share this post


Link to post
Share on other sites

no encuentro nada relacionado con el modulo.tpl

entonces estas siguiendo este post y no los que te dije no???

si sigues los pasos de este post tienes que poner en el header.php de wordpress lo siguiente para que te añada el style.css


<?php
require_once(dirname(__FILE__).'/../../../../config/config.inc.php');
require_once(dirname(__FILE__).'/../../../../header.php');
?>
<link rel='stylesheet' href='/blog/wp-content/themes/twentytwelve/style.css' type='text/css' media='all' />

No se si hay que poner /blog o no.

Share this post


Link to post
Share on other sites

he mirado en los que me digiste pero no lo he encontrado.

 

He reinstalado y he puesto la versión 1.5.3 y me lo ha hecho con el modulo del enlace que pusiste, ahora está actualizando a 1.5.4 con 1 Click a ver si sigue bien.

 

Gracias por todo

Share this post


Link to post
Share on other sites

Cuando actualizo a 1.5.4 sigue pasando lo mismo de antes, he probado lo que me pones en tu ultimo mensaje y cambia el color de fondo pero no arregla nada.

Share this post


Link to post
Share on other sites

prueba a agregar tambien al header de wordpress el global.css y dejalo de la siguiente forma


<?php
require_once(dirname(__FILE__).'/../../../../config/config.inc.php');
require_once(dirname(__FILE__).'/../../../../header.php');
?>
<link rel='stylesheet' href='/blog/wp-content/themes/twentytwelve/style.css' type='text/css' media='all' />
<link href="/themes/default/css/global.css" rel="stylesheet" type="text/css" media="all" />

aunque yo mejor lo pondria mejor en el modulowp.tpl del enlace que puse y le dejaria como sigue sin tocar nada en el header de wordpress.


<!-- Inicio Modulo integracion WP -->
{$messageSmarty}
<link rel='stylesheet' href='/blog/wp-content/themes/twentytwelve/style.css' type='text/css' media='all' />
<link href="/themes/default/css/global.css" rel="stylesheet" type="text/css" media="all" />
<!-- Fin Modulo integracion WP -->

Edited by 3w soluciones web (see edit history)

Share this post


Link to post
Share on other sites

SOLUCIONADO:

La solución ha sido lo que pones en el último mensaje de modificar el header, modificando el modulo de integración ha seguido igual.

 

Muchas gracias por todo

Share this post


Link to post
Share on other sites

hola 3w soluciones web estoy implementando tu codigo para crear un modulo que me integre 3 noticias en mi home de prestashop de la siguiente manera:

 

public function hookDisplayNoticiasWpHook($params)
{
  global $smarty;
  require('./blog/wp-blog-header.php');
  query_posts('cat=1&showposts=3');

  $html .='<ul>';
  while(have_posts()) : the_post();
   $html.='<li>
   <h3>'.the_title().'</h3>
   <span>'.the_time('l j M Y').'</span>
   <p>'.the_excerpt('Leer más ->').'</p>
  </li>';
  endwhile;

  $html.='</ul>';
  $html_implement = $this->l($html);
 /*
 $message = $this->l($var);
 $mostrarblog =$this->l($blog); // no se usa pero puede servir
 */
 $smarty->assign('postHtml',$html_implement);

 return $this->display(__FILE__, 'modulowppro.tpl');
}

 

el blog de wrodpress ya esta implementaado en mi carpeta 'blog' y quiero usar las funciones de wordpress de esa misma carpeta no sé si lo estoy haciendop bien saludos.

Share this post


Link to post
Share on other sites

hola 3w soluciones web estoy implementando tu codigo para crear un modulo que me integre 3 noticias en mi home de prestashop de la siguiente manera:

 

public function hookDisplayNoticiasWpHook($params)
{
  global $smarty;
  require('./blog/wp-blog-header.php');
  query_posts('cat=1&showposts=3');

  $html .='<ul>';
  while(have_posts()) : the_post();
$html.='<li>
   <h3>'.the_title().'</h3>
   <span>'.the_time('l j M Y').'</span>
   <p>'.the_excerpt('Leer más ->').'</p>
  </li>';
  endwhile;

  $html.='</ul>';
  $html_implement = $this->l($html);
 /*
 $message = $this->l($var);
 $mostrarblog =$this->l($blog); // no se usa pero puede servir
 */
 $smarty->assign('postHtml',$html_implement);

 return $this->display(__FILE__, 'modulowppro.tpl');
}

 

el blog de wrodpress ya esta implementaado en mi carpeta 'blog' y quiero usar las funciones de wordpress de esa misma carpeta no sé si lo estoy haciendop bien saludos.

Ahora mismo estoy trabajando, a ver si esta tarde tengo tiempo y te lo echo un vistazo aunque no controlo mucho de wordpress.

Según he visto en este post no estaria mal si solo quieres el titulo de la entrada. http://www.masquewordpress.com/wordpress-mostrar-posts-en-pagina-estatica/

Edited by 3w soluciones web (see edit history)

Share this post


Link to post
Share on other sites

Hola espero estar haciendo la pregunta en el post adecuado.

Estoy usando WP 3.5.1 y PS 1.5.4.0 con un tema "responsive" que he comprado en ThemeForest.

estoy trabajndo con WAMP y WP lo tengo en una carpeta llamada blog dentro de la carpeta prestashop.

He seguido las instrucciones y he conseguido poner el header y footer de Prestashop en mi blog de wordpress, muchas gracias!

El problema que tengo es que me aparece el contenido de la columna izquierda de PS (la única activada de momento) y un par de divs que forman parte del footer de la tienda. Quisiera poder quitarlos, pero sin tener que usar el css display:none, puesto que todo ese contenido se seguiría cargando aunque no se viese.

 

Alguno me puede echar una mano?

 

Gracias

Share this post


Link to post
Share on other sites

Ahora mismo estoy trabajando, a ver si esta tarde tengo tiempo y te lo echo un vistazo aunque no controlo mucho de wordpress.

Según he visto en este post no estaria mal si solo quieres el titulo de la entrada. http://www.masquewor...agina-estatica/

hola 3w soluciones web estoy implementando tu codigo para crear un modulo que me integre 3 noticias en mi home de prestashop de la siguiente manera:

 

public function hookDisplayNoticiasWpHook($params)
{
  global $smarty;
  require('./blog/wp-blog-header.php');
  query_posts('cat=1&showposts=3');

  $html .='<ul>';
  while(have_posts()) : the_post();
$html.='<li>
   <h3>'.the_title().'</h3>
   <span>'.the_time('l j M Y').'</span>
   <p>'.the_excerpt('Leer más ->').'</p>
  </li>';
  endwhile;

  $html.='</ul>';
  $html_implement = $this->l($html);
 /*
 $message = $this->l($var);
 $mostrarblog =$this->l($blog); // no se usa pero puede servir
 */
 $smarty->assign('postHtml',$html_implement);

 return $this->display(__FILE__, 'modulowppro.tpl');
}

 

el blog de wrodpress ya esta implementaado en mi carpeta 'blog' y quiero usar las funciones de wordpress de esa misma carpeta no sé si lo estoy haciendop bien saludos.

 

algo falta por cargar pues al llamar al archivo wp-blog-header.php da error en la linea del archivo blog\wp-includes\functions.php linea 779 que pone $wp->main( $query_vars ); como si no existiese la variable $wp

 

algo falta por cargar pues al llamar al archivo wp-blog-header.php da error en la linea del archivo blog\wp-includes\functions.php linea 779 que pone $wp->main( $query_vars ); como si no existiese la variable $wp

lo he modificado a


global $smarty;

$wp_did_header = true;
require_once( dirname(__FILE__) . '/../../blog/wp-load.php' );
query_posts(....

y pone los post pero no los coloca bien.

Share this post


Link to post
Share on other sites

Hola,

 

Tengo una duda. Cuando instaláis Wordpress en Prestashop, ¿accedeis al backoffice de wordpress para escribir los posts igual que se haría normalmente?

 

¿Hay un backoffice de Wordpress o se hace desde Prestashop?

 

Gracias.

Share this post


Link to post
Share on other sites

Hola,

 

Tengo una duda. Cuando instaláis Wordpress en Prestashop, ¿accedeis al backoffice de wordpress para escribir los posts igual que se haría normalmente?

 

¿Hay un backoffice de Wordpress o se hace desde Prestashop?

 

Gracias.

Si se accede igual, tudominio/blog/wp-admin

Share this post


Link to post
Share on other sites

hola 3w soluciones web estoy implementando tu codigo para crear un modulo que me integre 3 noticias en mi home de prestashop de la siguiente manera:

 

public function hookDisplayNoticiasWpHook($params)
{
  global $smarty;
  require('./blog/wp-blog-header.php');
  query_posts('cat=1&showposts=3');

  $html .='<ul>';
  while(have_posts()) : the_post();
$html.='<li>
   <h3>'.the_title().'</h3>
   <span>'.the_time('l j M Y').'</span>
   <p>'.the_excerpt('Leer más ->').'</p>
  </li>';
  endwhile;

  $html.='</ul>';
  $html_implement = $this->l($html);
 /*
 $message = $this->l($var);
 $mostrarblog =$this->l($blog); // no se usa pero puede servir
 */
 $smarty->assign('postHtml',$html_implement);

 return $this->display(__FILE__, 'modulowppro.tpl');
}

 

el blog de wrodpress ya esta implementaado en mi carpeta 'blog' y quiero usar las funciones de wordpress de esa misma carpeta no sé si lo estoy haciendop bien saludos.

He conseguido hacer un modulo para integrar las noticias en prestashop, el problema esta en que las funciones de wordpress directamente imprimen el contenido, el modulo quedaria asi.


public function hookdisplayWPProoHook($params)
{
global $smarty;
if ( !isset($wp_did_header) ) {
$wp_did_header = true;
require_once( dirname(__FILE__) . '/../../blog/wp-load.php' );
}
query_posts('showposts=3');
  while(have_posts()) : the_post();
   the_title();
   echo"<br/>";
   the_time('l j M Y');
   echo "<br/><a href=".get_permalink().">Leer más</a><br/>";	
  endwhile;
  $html_implement = $this->l($html);
$smarty->assign('postHtml',$html_implement);

return $this->display(__FILE__, 'modulowppro.tpl');
}
[/code ]

Para visualizarle donde quiera habria que añadir la linea
[code]
{hook h='displayWPProoHook'}

subo el archivo del modulo.

modulowppro.zip

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More