Jump to content
eric69

[RESOLU] Mise A Jour De 1.4 A 1.5 Possible Ou Pas Réellement ?

Recommended Posts

Bonjour,

 

après plusieurs recherches, et test avec mise à jour en 1 clic qui ne me reconnait que 1.4.9.0 et non les suivantes, le module mise à jour facile qui ne fonctionne pas nom plus!

 

quelqu'un pourait il nous donner des informations sur la faisabilité de mettre a jour vers 1.5 ?

 

des infos de l'équipe de PS serait présieuses non ?

D'après ce que je vois il n'est pas possible non plus de mettre a jour manuellement comme avant ?

 

alors comment faire pour avoir PS 1.5 sans perdres nos stats, clients, commandes produits et tous ce qui va avec ?

 

ou alors somme nous condamné à ne jamais passer sur 1.5 ?

 

alors cela serait une mise a jour non compatible avec les anciènnes versions ?

je ne m'imagine pas repartir de 0 apres 4 ans d'utilisations, car je ne tiens pas a perdre mes clients !

 

Si quelqu'un passe un jour par là et qu'il a des infos, merci

Share this post


Link to post
Share on other sites

la solution est de faire un script php qui sort tes enregistrements de la base du presta en 1.4.X et injecte les données dans la base du 1.5.X comme ça tu n'a pas à renvoyer tes images de presta depuis l'admin elles sont déjà reperées

tu régénere et ça tourne

 

je fais comme ça avec mes clients

 

alain

Share this post


Link to post
Share on other sites

2340 000 téléchargement o)

 

ben sur les millions d'utilisateur la mise à jour de 1.4 a 1.5 n'intéresse pas grand monde, c'est currieux je trouve,

Alors moi j'en suis là:

plusieurs test de updgrade de PS, avec option en ligne, avec le zip ou avec les fichiers en locals, aucune ne fonctionne avec ce message:

Erreur Javascript (parseJSON) détectée pour l'action"updateConfig".Début de la restauration ...

 

Je n'ai toujours pas de réponse du DEV du module mise à jour facile, pas interessé apperament !

donc je confirme ce module fonctionnait avec les mises a jour jusqu'a PS 1.4.9.0, mais pas vers 1.5

 

Idem pour le team prestashop, j'ai demandé un devis pour importer mes données clients, commande dans PS 1.5, pas plus de réponse!

 

J'ai demandé a un DEV de m'aider a exporter/importé mes données de 1.4 a 1.5 j'attends ses disponibilités !

 

vu le peux d'engouement sur ce passage de 1.4 a 1.5 je me dit que si je n'avais pas investi dans un logiciel de caisse en liaison avec PS, j'aurais volontier étudier une autre application au vu des problèmes rencontrer et du peux d'aide !!

 

merci de m'avoir lu tiout de même o)

Share this post


Link to post
Share on other sites

Salut,

 

je te confirme que cela n’intéresse personne, je galère comme un diable depuis 1 mois, et dans le script qui doit tout faire en auto et depuis les 10 mises à jour je suis passé de l'étape 1 à l'étape 3 sur 100.

Le module n'arrive même pas à dé-zipper la nouvelle version.

Je me demande si je ne vais pas installer la version 1.5 toute neuve et reprendre tout mon thème à la main.

Le problème c'est pour migrer la BDD.

 

A+ et bon WE

Patrick

Share this post


Link to post
Share on other sites

Bonjour,

 

Effectivement, la mise à jour classic comme avant n'est plus valable avec ps 1.5 (cela on l'apprend seulement au début de la procédure, après avoir remplacer les fichiers).

Et la mise a jour via auto update ne fonctionne pas non plus.

Je pense que pour la version 1.5 ils ont tout simplement laissé tombé les utilisateur des versions précédentes qui ont permis de les faire connaître !!

 

Pour le module "mise à jour facile" la procédure reste bloqué à "exécution du script d'installation"

d'après le dev du module cela ne viens pas de son module, mais je n'en sais pas plus J'ai pas vraiment de réponse ?

 

si j'ai des nouvelles je vous tiens au courant "SI J'AI DES NOUVELLES "

Share this post


Link to post
Share on other sites

Salut,

 

ça y est je viens de commencer.

 

J'ai installé PS 1.5.3.1 sur un espace perso que j'ai sur mon serveur dédié.

Je suis reparti avec une base vide et une boutique toute neuve et le thème par défaut.

Je vais noter pas à pas toutes les manips que je fais et si une coince, je restaure le nouveau site.

Là je suis entrain de copier toutes mes images en local avant de les envoyer vers le nouveau site.

 

Un petit mot pour Alain, que je connais un peu, ton petit module pour mes frais de port, nickel. tu as dis :

la solution est de faire un script php qui sort tes enregistrements de la base du presta en 1.4.X et injecte les données dans la base du 1.5.X comme ça tu n'a pas à renvoyer tes images de presta depuis l'admin elles sont déjà repérées tu régénère et ça tourne

 

tu le vends combien ton script ?

 

A+

Patrick

Edited by Patrick_64 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour à tous,

 

Voici mon retour d'expérience sur la mise à jour de 1.4 vers 1.5

 

Mes tentatives de mise à jour de 1.4.9 vers 1.5.3.1 avaient systématiquement echoué

 

j'ai donc dernièrement tenté une mise à jour de 1.4.9 vers une 1.4.10 avec la dernière version du module de mise à jour auto (v1.0.12), puis mise à jour de 1.4.10 vers la 1.5.3.1 et le processus de mise à jour s'est déroulé parfaitement.

 

Tous ces essais de mise à jour ont été fait sur des versions de test et ma version de prod est toujours en 1.4.10, je dois affiner certains points sur la 1.5.3 avant de la mettre en prod.

Cela dit j'ai une boutique assez simple, peu modifiée au niveau du thème et avec peu d'articles, cela facilite aussi sûrement les choses.

J'ai tout de même "cassé" 2 ou 3 versions de test avant d'arriver à quelque chose... donc prudence !

 

Bon courage à tous

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

 

Je pense que la meilleure façon de passer de la 1.4 à la 1.5 c'est de passer d'abord par la 1.4.10.

Rester sur la version 1.4.10 si tout fonctionne bien et attendre qu'une véritable version stable 1.5.4.x ou 1.5.5.x soit proposée.

Je déconseille de passer à la version 1.5.3.1 car il y a trop de problèmes résiduels sur cette version.

Edited by btsconsult (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Bonsoir,

 

j'ai donc dernièrement tenté une mise à jour de 1.4.9 vers une 1.4.10 avec la dernière version du module de mise à jour auto (v1.0.12), puis mise à jour de 1.4.10 vers la 1.5.3.1 et le processus de mise à jour s'est déroulé parfaitement.

C'est déjà encourageant !

Pour quand la 1.5.4? :)

Share this post


Link to post
Share on other sites

Ho cela à été très complexe,

j'avais fais appel a une société pour mettre a jour mon logiciel de caisse (qui gère mes stock, produits ....)

n'arrivant pas de mon côté à mettre a jour PS j'ai donc demandé aux dev de m'aider,

ils ont importé mes données clients/commandes sur un ps 1.4.10 neuf

ls ont ensuite mis a jour ps

j'ai ensuite installé les modules que j'avais besoins et ou qui fonctionne sous ps 1.5

Sans l'aide de cette société j'aurais été dans l'impasse !!

merci à eux qui ont été très receptif et compétant ...

le prix en vallait la chandelle ...

Edited by eric69 (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More