Jump to content
jolvil

[MODULE PRESTASHOP] LeGuide.com - Export csv pour LeGuide et autres comparateurs

Recommended Posts

Je comprends mieux. Avec le module Crontab vous n'avez plus besoin de l'interface OVH.

Configurez ce module pour utiliser la fréquentation de la boutique comme méthode d'exécution et créez de nouvelles tâches contenant les URL fournies par le module Leguide.

Share this post


Link to post
Share on other sites

J'essaye avec les 2 méthodes mais que cela soit le module crontab, configuré comme indiqué ci-dessus ou le planificateur de tache OVH, rien ne fonctionne. Quelqu'un a t il réussi à faire fonctionner la tache cron du module?

Share this post


Link to post
Share on other sites

Voilà les seules lignes avec cronkey que j'ai pour hier

mondomaine.com - [09/Jun/2011:19:40:07 +0200] "GET /ps137/modules/leguide/cron.php?cronKey=1a9500c3531df4da581112f709ae23a2&auto=leguide HTTP/1.1" 200 3715 "-" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.91 Safari/534.30"
mondomaine.com - [09/Jun/2011:19:40:08 +0200] "GET /ps137/modules/modules/leguide/css/styles.css HTTP/1.1" 404 - "http://mondomaine.com/ps137/modules/leguide/cron.php?cronKey=1a9500c3531df4da581112f709ae23a2&auto=leguide" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.91 Safari/534.30"
mondomaine.com - [09/Jun/2011:19:40:08 +0200] "GET /ps137/modules/modules/leguide/jquery/jquery-latest.js HTTP/1.1" 404 - "http://mondomaine.com/ps137/modules/leguide/cron.php?cronKey=1a9500c3531df4da581112f709ae23a2&auto=leguide" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.91 Safari/534.30"
mondomaine.com - [09/Jun/2011:19:40:08 +0200] "GET /ps137/modules/modules/leguide/jquery/jquery.treeview.css HTTP/1.1" 404 - "http://mondomaine.com.com/ps137/modules/leguide/cron.php?cronKey=1a9500c3531df4da581112f709ae23a2&auto=leguide" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.91 Safari/534.30"
mondomaine.com - [09/Jun/2011:19:40:08 +0200] "GET /ps137/modules/modules/leguide/jquery/jquery.treeview.js HTTP/1.1" 404 - "http://mondomaine.com/ps137/modules/leguide/cron.php?cronKey=1a9500c3531df4da581112f709ae23a2&auto=leguide" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.91 Safari/534.30"

Share this post


Link to post
Share on other sites

Je viens de tester la nouvelle version et c'est juste parfait! Merci beaucoup! Avec le module gshopping en complément on a tout ce qu'il faut!

Share this post


Link to post
Share on other sites

@jovil

Et bien ça fonctionne :

mondomaine.com – [09/Jun/2011:19:40:07 +0200] “GET /ps137/modules/leguide/cron.php?cronKey=1a9500c3531df4da581112f709ae23a2&auto=leguide HTTP/1.1” 200


Code 200 = ok

Si vous n'avez pas de ligne avec cronKey dans les logs d'aujourd'hui c'est que le module Crontab ne se déclenche pas. Vérifiez l'heure de dernière exécution qu'il indique.
Configurez une tache qui s'exécute toutes les minutes pour tester.


@YouLab

Merci. :)

Share this post


Link to post
Share on other sites

Bonjour Super Boulot,

Juste pour te dire que dans la version 1.55 les fichiers
catalogue_declinaisons_shopzilla.php
catalogue_declinaisons_xxxxxx.php
ne sont pas présent.
Tu as juste géré les déclinaisons pour Kelkoo.
J'ai commencé mais je galère trop.
Voilà, si tu as le temps de les rajouter.
En fait actuellement ça prends "catalogue_declinaisons.php" pour les marchands autres que KelKoo.
Et du coup les fichiers sont complètement décalé entre leur header et leur données.

Merci pour ton aide

Share this post


Link to post
Share on other sites

Ces fichiers n'ont jamais existé c'est pour ça qu'ils ne sont pas dans l'archive. De plus je n'en ai pas moi même l'utilité.

Voici une version 1.56. Nouveautés :

Correction d'un éventuel recouvrement des fichiers temporaires lors d'une création par tranches
Passage à jquery.treeview v1.4
Arborescence repliée par défaut

leguide_v1.56.zip

Share this post


Link to post
Share on other sites

Merci,
Je sais pertinament que ces fichiers ne sont pas present.
Les cas de declinaisons de produits ne fonctionnent que pr kelkoo.(et encore je n'ai pas testé en reel)
Pour le reste des moteurs, ce module ne genere pas les bons formats.
C'est pour ca qu'il faudrait les creer.
Cf mon premier post.
En tout cas meme si ce module n'est pas encore complet, c'est un excellent début.
Merci bcp
Cdt

Share this post


Link to post
Share on other sites
En tout cas meme si ce module n'est pas encore complet, c'est un excellent début.


Si vous reprennez l'historique de ce module développé grâce à la participation de multiples contributeurs vous verrez que l'aventure a débuté le 04 April 2009, nous sommes donc loin du début et que le module est déja trés évolué ! :cheese:

Share this post


Link to post
Share on other sites

Souhaitez vous prendre en compte mes remarques ou discutons nous chiffons?
Si oui je veux bien contribuer avec vous sur les points specifies et en faire beneficier la communaute.
Sinon je me debrouillerai seul.
Merci

Share this post


Link to post
Share on other sites

Je souhaite juste rapeller le gros boulot qui a été fait sur ce module à l'origine uniquement pour leguide et remercier tous les contributeurs ainsi que Ktech pour leurs efforts :roll:

Share this post


Link to post
Share on other sites

Une petite remarque sur la version 1.56

lorsque l'on coche ou decoche la categorie accueil de l'arborescence, cela ouvre ou ferme le menu. Selectionner une categorie ne devrait pas agir sur l'ouverture du menu il me semble.

Share this post


Link to post
Share on other sites

Malgres toutes mes tentatives, impossible de faire fonctionner la tache cron correctement avec ps1.3.7 et OVH ou le module Crontab.

Avec le planificateur de taches OVH: Ne semble pas fonctionner avec les options dans l'URL, j'arrive a faire fonctionner normalement la tache cron d'un autre module: googleshopping (mais avec d'autres problemes).

Avec le module CronTab: Je me demande si ce module est compatible avec PS1.3.7 ou OVH, le module semble fonctionner une fois de facon aléatoire puis ne fonctionne plus. Par exemple: 1 tache cron programmée chaque jour a 0h a marché 1 fois à 21h et depuis ne fonctionne plus, ajout d'une deuxieme tache cron à 0h qui elle n'a jamais fonctionné.

Donc dur dur les taches Cron ! :long:

Quelqu'un a t il une experience concluante ?

Share this post


Link to post
Share on other sites

Si le module cronTab ne fonctionne pas sur la 1.3.7 c'est effectivement un problème. Au moins, on cerne mieux d'où vient le bug.

A ce moment là, récupérez le fichier en pièce jointe, mettez-le dans le répertoire du module, éditez-le pour mettre la bonne URL et créez une tâche dans le cron OVH pour l'appeler.

cron_linux.php

Share this post


Link to post
Share on other sites

Cette dernière solution à l'air de bien fonctionner dans mon cas, encore merci. :-)

------

Le module d'export le guide permet de générer le fichier xml dans le dossier export du module ou dans un autre dossier au choix à la racine mais pas directement à la racine du site comme dans le module Google Shopping, cela pourrait être une option utile. Qu'en pensez vous?

Share this post


Link to post
Share on other sites

Cool. Comme vous êtes sur un mutualisé, n'oubliez pas de dupliquer ce fichier autant de fois que nécessaire. C'est à dire par autant de catalogues que vous voulez générer X par le nombre de tranches éventuellement.

Share this post


Link to post
Share on other sites

Bonjour à tous,

Ce module a l'air d'être très complet, bravo ! :-) par contre j'ai parcouru les post et j'ai pas trouvé la réponse à cette question : Ce module est il compatible avec la version PS Version 1.3.1.1 ?

Avant de le télécharger , je voudrais m'en assurer !

Merci pour votre réponse :)

Share this post


Link to post
Share on other sites

Vu que jolvil l'utilise avec la v1.3.7.0, il n'y a pas de raison que ça ne fonctionne pas avec la 1.3.1.1.

Share this post


Link to post
Share on other sites

Bonjour super module.
Qui marche parfaitement avec les version 1.3 par contre je viens de tenter une utilisation avec la 1.4 et comme indiqué dans un post la version 1.56 du module ne me semble pas exporter prix en promo donc Le Guide me jete comme un vieux vilain^^.

Avez vous une solution ?

Merci d'avance pour les pistes.

Share this post


Link to post
Share on other sites

Bonjour,
J'avais jeté un coup d'oeil pour trouver la méthode qui, sous Presta 1.4, permet d'obtenir les promos et ça ne m'avait pas sauté aux yeux; du coup je n'avais pas été plus loin. Il faudra se repencher dessus, en tout cas le calcul est complètement différent des versions de Presta précédentes. Si quelqu'un connait cette méthode, je peux, normalement, faire l'intégration facilement.

Share this post


Link to post
Share on other sites

Salut,
Pour calculer la réduction sous 1.4, supposons un produit de id $id_produit :

$p = new Product($id_produit,(int)(self::$cookie->id_lang));
echo 'Produit sans réduction : '.$p->getPriceWithoutReduct();

$id_customer = (isset(self::$cookie->id_customer) AND self::$cookie->id_customer) ? (int)(self::$cookie->id_customer) : 0;
$id_group = $id_customer ? (int)(Customer::getDefaultGroupId($id_customer)) : _PS_DEFAULT_CUSTOMER_GROUP_;
$id_country = (int)($id_customer ? Customer::getCurrentCountry($id_customer) : Configuration::get('PS_COUNTRY_DEFAULT'));

echo 'Produit avec réduction'.SpecificPrice::getSpecificPrice($id_produit, (int)(Shop::getCurrentShop()), (int)(self::$cookie->id_currency), $id_country, $id_group, 1);

Allez bon courage ;)

Share this post


Link to post
Share on other sites

Bonjour,

Je n'arrive pas à faire fonctionner le module qui à l'air vraiment parfait.
le problème Aucune catégories sélectionné.

Merci de votre aide j'ai des partenariat que je ne peut mettre en place.

48645_ZOhsIabEvJ4olWsgxX1n_t

Share this post


Link to post
Share on other sites

Vous n'avez pas l'arborescence qui s'affiche tout en haut de l'écran ?

Share this post


Link to post
Share on other sites

Non je n'est rien, ou alors je suis bête :-)

Ci joint

48648_lanMxY0MZCduqQpAyS96_t

Share this post


Link to post
Share on other sites

Non, ça bug. Normalement vous avez "Tout Déplier/Replier | Inverser la sélection" et dessous l'arbo. Je soupçonne un prblm de css. Quelle version de Presta ?

Share this post


Link to post
Share on other sites

La version est 1.4.2.5.

Merci de votre aide c'est super

Share this post


Link to post
Share on other sites

En fait je pense que vous êtes avec une version du module plus ancienne que la 1.56 car dans ces versions, seul "Inverser la sélection” s'affichait au lieu de “Tout Déplier/Replier | Inverser la sélection”.

Le mieux, dans un premier temps, serait de désinstaller le module, effacer le répertoire, copier les fichiers 1.56 et réinstaller.

Share this post


Link to post
Share on other sites

Oui c'est vrai,

J'ai fais l'installation j'ai bien Tout Déplier/Replier mais le clique ne fait rien.

C'est un truc de fou je suis maudit !

Share this post


Link to post
Share on other sites

Il se peut qu'il y ai un problème avec la v1.4, pourtant il y a un utilisateur chez qui il semble fonctionner. Je regarderais ça dès que je peux.

Share this post


Link to post
Share on other sites
Il se peut qu'il y ai un problème avec la v1.4, pourtant il y a un utilisateur chez qui il semble fonctionner. Je regarderais ça dès que je peux.



Chez moi se modules fonctionne très bien sur prestashop 1.4

Share this post


Link to post
Share on other sites

Je n'ai toujours pas trouvé une solution...

Une âme charitable ?

Share this post


Link to post
Share on other sites

v1.57

Le problème de Sten a été résolu. Le problème venait de la configuration spéciale de son site qui possède une arborescence qui commence au niveau 1 au lieu de 0. Le module gère donc maintenant ce cas de figure.

J'en ai profité pour rendre le module compatible avec Prestashop 1.4 en partant des conseils de MisterGhazi. Les réductions sont donc maintenant exportées correctement. Du coup, sous Presta 1.4 il y a un nouveau choix qui apparait : la Sélection du groupe. En effet les réductions en dépendent.

Dernier changement : le produit avec l'ID 1 était systématiquement exclu. J'imagine que cela correspondait à un cas particulier qui était resté par inadvertance. J'ai donc supprimé ça.

Pour info j'ai remarqué que la plupart des requêtes sont codées en dure avec le français. Cela veut dire que le choix de la langue d'export ne doit pas être très efficace.

leguide_v1.57.zip

Share this post


Link to post
Share on other sites

J'ai mis à jour l'archive du 1er post.

Pour plus de compatibilité entre les tab de 1.3 et 1.4 je suggere

        if(_PS_VERSION_<'1.4')
           $this->tab = 'Tools';
       else
           $this->tab = 'smart_shopping';




Pour la tache cron avec le fichier cron-linux, ca marche tres bien avec ce module chez OVH, du coup j'ai du faire la meme chose avec le module followup de Prestashop qui avait le meme probleme de parametres dans l'url !

Share this post


Link to post
Share on other sites

ANNIVERSAIRE !! Ce poste à 2 ans :cheese: Le petit module a bien grandi !

Share this post


Link to post
Share on other sites

Bonjour,

J'ai installé Leguide 1.57 dans Prestashop 1.3.6 et lorsque je sélectionne "Générer" fichier Leguide, j'obtiens une erreur qui dit "Aucune catégorie ne AVOIR Sembler Été Sélectionnez"
Ensuite, essayez de trouver tous mes catégories pour sélectionner dans le module mais je ne peux pas sélectionner, j'ai ne pouvez sélectionner des catégories par défaut de PrestaShop j'ai jamais utiliser mais je ne vois pas les miennes. Est-ce que quelqu'un sait ce qui se passe?

Merci beaucoup pour votre module
Pd. Je parle très peu français

49227_wXTl7h0YDAniBf666qUy_t

Share this post


Link to post
Share on other sites

Merci beaucoup pour votre réponse, je sélectionne "Inverser la sélection" mais le fichier mercamania_leguide.txt seule génère 15 articles des Accueil (homefeatured articles). Je pense que s'ils ne sont pas toutes mes catégories pour la sélection puis alors ne pouvez pas générer le fichier avec mon 1500 articles,
Avez-vous à apparaître toutes les catégories pour pouvoir sélectionner?
merci

Share this post


Link to post
Share on other sites

Votre capture d'écran fait apparaitre 16 + 3 + 0 + 2 = 21 produits.
Vous êtes sûr de faire l'export sur le bon serveur ?

Share this post


Link to post
Share on other sites

Les 6 autres articles sont ceux qui viennent par défaut dans prestashop et j'ai désactivé. Tout est installé fine et ne pas toucher la boîtes qui a été par défaut. Maintenant j'ai sélectionnés beaucoup de boîtes et changé le nom du fichier à exporter mais toujours ne génère des articles Home featured.
Peut-être ce module ne lit que les catégories qui sont faites avec la langue français?

Share this post


Link to post
Share on other sites

Oui, je pense que c'est le problème. Je regarderai ça ce soir.

Share this post


Link to post
Share on other sites

Tout d'abord, merci à tous les contributeurs pour ce module très utile.

Un petit truc me gène un peu, et je suis étonné d'être le seul à avoir un problème avec ça :

Les produits ne sont pas rattachés à leur catégorie par défaut, mais à la première catégorie dans laquelle ils sont inclus et dans l'ordre d'affichage du treeview. Mon catalogue contient beaucoup de produits appartenant à plusieurs catégories en même temps et ça pose un vrai problème. Pour remédier à ça, j'ai modifié la requête d'extraction des produits du fichier guide-script.php, voilà ma requête qui attribue bien le produit à sa catégorie par défaut. Ligne 549 en remplacement de la ligne existante.

$req = "SELECT id_product FROM ".$ps_."product where id_category_default = $id_catego ORDER BY 1";



Je suis sur une 1.4.3

Share this post


Link to post
Share on other sites

J’ai une petit problème avec la contribution Leguide.com v1.57 (gratuite) que j’ai trouvé sur le forum. Elle me génère un fichier pour l’intégration du catalogue mais les liens images dans ce fichier sont bizarre et n’affiche rien qu’une page blanche :

-http://mondomaine.com/img/p/55-97-large.jpg

Alors que coté front office en faisant un clic droit puis afficher l’image sur l’image du produit concerné on obtient le lien suivant :

-http://mondomaine.com/97-large/nom_du_produit.jpg

Je ne comprends pas d’où vient le problème. Merci d’avance de votre aide.

Share this post


Link to post
Share on other sites
v1.57

Le problème de Sten a été résolu. Le problème venait de la configuration spéciale de son site qui possède une arborescence qui commence au niveau 1 au lieu de 0. Le module gère donc maintenant ce cas de figure.

J'en ai profité pour rendre le module compatible avec Prestashop 1.4 en partant des conseils de MisterGhazi. Les réductions sont donc maintenant exportées correctement. Du coup, sous Presta 1.4 il y a un nouveau choix qui apparait : la Sélection du groupe. En effet les réductions en dépendent.

Dernier changement : le produit avec l'ID 1 était systématiquement exclu. J'imagine que cela correspondait à un cas particulier qui était resté par inadvertance. J'ai donc supprimé ça.

Pour info j'ai remarqué que la plupart des requêtes sont codées en dure avec le français. Cela veut dire que le choix de la langue d'export ne doit pas être très efficace.



Bonjour, j'ai installé la dernière version du module, le 1.57, j'ai un problème comme Sten, j'ai installé ce module dans ma version prestashop 1.4 et je ne vois pas l'arbre de la sélection de la catégorie.
je reçois le errror suivantes:

Pas de catégorie de niveau 0 ni niveau 1 ! Impossible de construire l'arborescence

C'est peut-être, vous devez changer quelque chose?
Merci beaucoup pour votre aide.
une salutation.

49642_ySVKnuJvqzDO9w2IrIWQ_t

Share this post


Link to post
Share on other sites

Hello,

J'utilisais il y encore tous récemment la version 1.42 qui fonctionnait à merveille pour moi.
Passant à Prestashop 1.4.3, j'ai upgradé le module vers sa dernière version la 1.57.

Voici mes remarques ou changements que j'ai trouvé pour améliorer ce module (génial en passant) car il y a quelques bugs :

- le type de promotion ne fonctionne pas chez moi, çà apparait toujours à 0, malgré que ce soit coché sur la fiche produit...

- les frais de port sont affichés HT, alors qu'ils devraient être TTC (dans le cadre d'une TVA sur les frais de port bien sur)

- le prix des déclinaisons en HT, ce qui fait que le prix total est faussé puisqu'il mélange le TTC et le HT

- seule 1 déclinaison est prix en compte dans l'export, alors qu'elles devraient toutes y être

- pour les déclinaisons, seule l'image par défaut est prise en compte et pas celle attribuée à la déclinaison

Voili, ++

Share this post


Link to post
Share on other sites

Merci beaucoup pour votre réponse, dans mon catalogue il ya plus de 3000 produits, mais le script je exporter seulement 12 points. Où est le problème?

49911_1BLj3XVS2xywqLDUYfjf_t

Share this post


Link to post
Share on other sites

il faut déplier toutes les rubriques pour cocher toutes les sous-rubriques
dans votre exemple vous n'avez coché que les produits de l'accueil donc vous n'avez que cela, c'est normal...
vous devriez avoir un + pour déplier l'accueil pour voir les autres rubriques, mais je ne le vois pas...
++

Share this post


Link to post
Share on other sites

Le problème est que je fais ici, mais le menu ne s'affiche pas mes catégories
Pouvez-vous être que je n'ai plus de sous-catégories?
J'ai cette structure:

Catégorie principale
|----- Sous catégorie1
|------Sous categoría01
Catégorie principale
|-----Sous catégorie2
|------Sous categoría02
Catégorie principale
|-----Sous categoría3
|------Sous categoría03

Share this post


Link to post
Share on other sites

vous avez bien pris la version 1.57 car ce problème a déjà décrit sur ce forum
++

Share this post


Link to post
Share on other sites

j'utilisais la 1.4.2 avec Prestashop 1.3 et çà marcher parfaitement
si tu es sur Prestashop 1.4 tu dois absoluement utiliser la 1.57 ou une version supérieur à la tienne car ta version n'est pas compatible 1.4
+

Share this post


Link to post
Share on other sites

J'ai un peu peur de mettre à niveau ma version, il ya une certaine possibilité de modifier le module à utiliser dans ma version? Je n'ai pas trouvé rien de mieux que ce module. Merci beaucoup!

Share this post


Link to post
Share on other sites

il suffit de sauvegarder les fichiers pour revenir en arrière, c'est très simple à faire !

Share this post


Link to post
Share on other sites

tu parles de ta version de Prestashop, moi je te parle de la version de ce module
je te conseille d'upgrader le module, c'est simple et sans danger
+

Share this post


Link to post
Share on other sites

oui mais peut être donc pas compatible avec ta version notamment avec le JQUERY utilisé
je te conseille d'essayer une version en dessous entre ta 1.4.1 et la 1.57
++

Share this post


Link to post
Share on other sites

ah oui il n'y a pas d'ancienne version dispo
j'ai la 1.4.2 si tu veux, mais j'ai rien d'autre...

Share this post


Link to post
Share on other sites

Hello,

 

J'utilisais il y encore tous récemment la version 1.42 qui fonctionnait à merveille pour moi.

Passant à Prestashop 1.4.3, j'ai upgradé le module vers sa dernière version la 1.57.

 

Voici mes remarques ou changements que j'ai trouvé pour améliorer ce module (génial en passant) car il y a quelques bugs :

 

- le type de promotion ne fonctionne pas chez moi, çà apparait toujours à 0, malgré que ce soit coché sur la fiche produit...

 

- les frais de port sont affichés HT, alors qu'ils devraient être TTC (dans le cadre d'une TVA sur les frais de port bien sur)

 

- le prix des déclinaisons en HT, ce qui fait que le prix total est faussé puisqu'il mélange le TTC et le HT

 

- seule 1 déclinaison est prix en compte dans l'export, alors qu'elles devraient toutes y être

 

- pour les déclinaisons, seule l'image par défaut est prise en compte et pas celle attribuée à la déclinaison

 

Voili, ++

Share this post


Link to post
Share on other sites

Hi everybody.

I have tried to install this module, because Leguide also offers its services in Denmark, however i do not speak or read french, so im a little bit in trouble reading if it works and what to do, after installation.

 

I tried both 1.56 and 1.57, hovever i do not see the categories, that are supposes to e displayed.

 

Could a friendly soul please tell me what to do?

 

Best regards fro denmark,

Kristian

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai un petit soucis avec la V1.57 que j'utilise sous PS 1.4.3, il ne me génère pas les frais de ports, le champ reste vide dans le fichier généré. Soit dit en passant, j'ai du bidouiller le code pour que mes images s'affichent, le fichier généré donnait des url qui n'aboutissaient sur rien. Je pense que c'est dû au fait que j'ai activé l'url rewriting dans PS.

 

Question au passage, il n'est pas possible de gérer plusieurs comparateurs avec le même module ?

 

Merci d'avance de votre aide.

Share this post


Link to post
Share on other sites

J'ai un petit soucis avec la V1.57 que j'utilise sous PS 1.4.3,

 

C'est peut etre normal, le module n'a pas encore été complètement adapté pour PS1.4, il fonctionne bien sous PS1.3.7

 

 

 

Share this post


Link to post
Share on other sites

Merci de ta réponse.

 

Tout s'explique alors. Désolé mais je découvre PS, je n'ai donc pas toutes les références en tête.

Sous OSC ce serait une autre histoire, j'ai pratiqué depuis 2005 jusqu'à maintenant, j'ai forcement une autre maitrise du sujet lol.

 

Et en ce qui concerne l'utilisation du module pour plusieurs comparateurs ? Le simple fait de dupliquer le module en changeant simplement le nom du répertoire du module suffirait ?

Share this post


Link to post
Share on other sites

Et en ce qui concerne l'utilisation du module pour plusieurs comparateurs ? Le simple fait de dupliquer le module en changeant simplement le nom du répertoire du module suffirait ?

 

Il suffit de générer des fichiers differents avec le meme module (a choisir dans les options).

 

 

 

Share this post


Link to post
Share on other sites

Et en ce qui concerne l'utilisation du module pour plusieurs comparateurs ? Le simple fait de dupliquer le module en changeant simplement le nom du répertoire du module suffirait ?

 

Il suffit de générer des fichiers differents avec le meme module (a choisir dans les options).

Je me trompe peut être, mais je ne vois pas une telle option.

Share this post


Link to post
Share on other sites

en BO tu as

 

Caractéristiques Fichier

Comparateur :

 

avec une liste deroulante de comparateurs, cela va generer un fichier specifique avec un nom different pour chaque comparateur choisi

Share this post


Link to post
Share on other sites

Bonjour,

 

si vous avez la 1.4.2 ou 1.4.3 de ce module à mettre en téléchargement faites vous plaisir..

 

j'ai une PS 097 et n'est pas compatible avec la dernière version..

 

Merci d'avance..

Share this post


Link to post
Share on other sites

en BO tu as

 

Caractéristiques Fichier

Comparateur :

 

avec une liste deroulante de comparateurs, cela va generer un fichier specifique avec un nom different pour chaque comparateur choisi

Comme en changeant de comparateur dans le menu deroulant la configuration ne revenait pas au paramètre du comparateur choisis je pensait que c'était un choix "ou" et non pas un choix complémentaire.

 

Merci.

Share this post


Link to post
Share on other sites

Bonjour,

 

Merci mais n'est pas compatible avec ma ps 097..

 

je cherche je cherche..

 

je pense savoir l'origine de mon pb

 

les catégories.. car pour un autre script http://www.prestashop.com/forums/topic/37900-module-product-export-module-v05-free/

 

dès que j'ajoute les catégories ça ne marche plus !

 

question ?

ou est-ce que je peux retrouver le bon fichier pour reprendre le non des catégories ?

 

Merci d'avance..

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai mis la version 1.55 de ce module pour la version Presta 1.3.6.

 

Pour générer le fichier pour LeGuide.com ou Shopmania, aucun problème.

 

Par contre, lorsque je souhaite générer un fichier pour ShoppyDoo, la colonne catégorie reste vide et mon fichier est donc refusé.

 

Est-ce qu'on pourrait m'aiguiller sur cette erreur ?

Faut-il cocher ou décocher une case ?

 

Je choisie bien évidemment ShoppyDoo dans le menu déroulant.

 

Merci pour votre aide,

 

Teddy

Share this post


Link to post
Share on other sites

This is what happens when i start the module. NO categories are shown. This is module version 1.57, and im using PrestaShop™ 1.4.3. There is no way to fold\unfold the tree. It's just not showing

ANYONE KNOWS THE REASON AND HOW TO FIX IT?

bug.jpg

Share this post


Link to post
Share on other sites

Bonjour à toutes et à tous,

 

J'aimerais aborder un sujet pratique.

 

jusqu'à aujourd'hui passage en ps 1.4.4 mon indexation d'images était reconnue avec des url simples

"http://www.XXX.fr/img/p/772-large.jpg"

 

Malheureusement le nouveau système d'indexation recrée des sous-dossiers et mon module ne sait pas

comment faire pour avoir la bonne adresse. Du coup, les comparateurs ont bien les produits mais pas

les images.

 

Ce qui pose un gros problème.

 

Voici comment il les écrit

 

"http://www.XXX.fr/img/p/327-772.jpg"

(327=article et 772=photo)

 

Or la nouvelle indexation envois les images en sous-dossier en découpant le numéro d'image soit

pour la photo 772 celle ci est rangée en dossier img/p/7/7/2/772-large.jpg

 

donc

 

Comment faire pour passer de

 

"http://www.XXX.fr/img/p/327-772.jpg"

 

à

 

"http://www.XXX.fr/img/p/7/7/2/772-large.jpg"

Share this post


Link to post
Share on other sites

Oui même problème :angry: :angry: :angry:

Voici comment il les écrit

 

"http://www.XXX.fr/img/p/327-772.jpg"

(327=article et 772=photo)

 

Or la nouvelle indexation envois les images en sous-dossier en découpant le numéro d'image soit

pour la photo 772 celle ci est rangée en dossier img/p/7/7/2/772-large.jpg

 

donc

 

Comment faire pour passer de

 

"http://www.XXX.fr/img/p/327-772.jpg"

 

à

 

"http://www.XXX.fr/img/p/7/7/2/772-large.jpg"

 

Si un initié peut corriger ce problème, il rendrait heureux un grand nombre de personne. Merci :)

Share this post


Link to post
Share on other sites

Oui même problème :angry: :angry: :angry:

Voici comment il les écrit

 

"http://www.XXX.fr/img/p/327-772.jpg"

(327=article et 772=photo)

 

Or la nouvelle indexation envois les images en sous-dossier en découpant le numéro d'image soit

pour la photo 772 celle ci est rangée en dossier img/p/7/7/2/772-large.jpg

 

donc

 

Comment faire pour passer de

 

"http://www.XXX.fr/img/p/327-772.jpg"

 

à

 

"http://www.XXX.fr/img/p/7/7/2/772-large.jpg"

 

Si un initié peut corriger ce problème, il rendrait heureux un grand nombre de personne. Merci :)

J'ai posé la question plus haut dans le fil de discution puisque j'avais le même problème mais personne ne m'a apporté de réponse. J'ai donc codé en dur le fichier pour composer l'url correctement, j'en ai profité pour ajouter une variable aux urls générés pour les comparateurs afin de traquer les entrées dans piwik.

Share this post


Link to post
Share on other sites

effectivement en plus des points que je site dans mon post http://www.prestashop.com/forums/topic/22501-module-prestashop-leguidecom-export-csv-pour-leguide-et-autres-comparateurs/page__view__findpost__p__592098 il faut rajouter que le chemin d'accès aux images de la version 1.4 n'est pas pris en compte et que si on possède plusieurs transporteurs, çà ne fonctionne pas.

+

Share this post


Link to post
Share on other sites

bonjour johnny57

"J'ai donc codé en dur le fichier pour composer l'url correctement, j'en ai profité pour ajouter une variable aux urls générés pour les comparateurs afin de traquer les entrées dans piwik."

 

Apparement vous avez trouvé une solution mais je n'ai rien compris à votre méthode étant simplement un amateur avancé de la construction de site.

 

Pourriez vous être plus clair sur la méthode que vous utilisez.

 

Cordialement.

 

Alain.

Share this post


Link to post
Share on other sites