Jump to content
jolvil

[MODULE PRESTASHOP] LeGuide.com - Export csv pour LeGuide et autres comparateurs

Recommended Posts

Hello!
je rencontre un petit problème avec l'export vers LEGUIDE lorsque je coche l'option déclinaisons.
après 25.000 lignes environ, soit un peu plus de 14 Mo, le script cesse de fonctionner.
ce n'est pas un problème de config serveur à priori.
qulqu'un a-t-il déjà rencontré ce problème d'export avec les déclinaisons ? et résolu ?
tks !

Share this post


Link to post
Share on other sites

bonjour à tous,

J'utilise la version 1,46 avec Kelkoo etc

J'ai un problème avec l'export au niveau de la gratuité des frais de ports: je coche ''Utiliser la gratuité des frais de port (à tester)''

j'imagine que le ''( à tester)'' n'est pas là pour rien, cependant j'aimerai savoir si quelqu'un à trouver une solution car ca ne marche pas.

Est ce que ca prend les règles qu'on a établi dans le back de prestashop (ex frais = 0 pour toute commande supérieur à 300 eur) ou est ce que ca doit mettre toutes les commandes à ''0'' soit toutes gratuites ?

De toutes façon dans les deux cas j'ai toujours les frais de ports payants, que le produit soit à + de 300 euros ou moins de 300 Euros.

Voilà si qq un pouvait m'aider ca serait très sympas !

Share this post


Link to post
Share on other sites

Merci pour ce super module mais malheureusement lorsque j'ai voulu soumettre le catalogue généré pour kelkoo j'ai obtenu des erreurs dans le rapport de transmission :

* Dans la section Titres
o Attention ligne 2 : Le paramètre update=NO doit apparaître en haut du fichier
Déplacer le paramètre en haut ou remplacer NO par YES.
* Dans la section Champs
o Erreur ligne 1 : Le champ obligatoire "offerid" n'a pas été utilisé
Veuillez ajouter ce champ dans la section "champs" s'il vous plaît.
o Erreur ligne 1 : Le champ obligatoire "url" n'a pas été utilisé
Veuillez ajouter ce champ dans la section "champs" s'il vous plaît.
o Erreur ligne 1 : Le champ obligatoire "price" n'a pas été utilisé
Veuillez ajouter ce champ dans la section "champs" s'il vous plaît.
o Erreur ligne 1 : Le champ obligatoire "description" n'a pas été utilisé
Veuillez ajouter ce champ dans la section "champs" s'il vous plaît.
o Erreur ligne 1 : Le champ obligatoire "title" n'a pas été utilisé
Veuillez ajouter ce champ dans la section "champs" s'il vous plaît.

Pourtant le module est réglé pour kelkoo en .txt

Que dois-je faire pour solutionner ces erreurs ?

Merci !

Share this post


Link to post
Share on other sites

personne n'a une une piste ?

Prestashop version 1.2.5
Module: 1.46

Un extrait de la première ligne:

"#type=basic
#update=NO
#quoted=NO
#country=fr
#currency=EUR
url Title offerID description price deliverycost image availability
http://127.0.0.1/prestashop"

Sur le site kelkoo j'ai aussi des problemes avec les accents...

Bref j'ai un peu la puasse.

Merci pour votre aide !

Share this post


Link to post
Share on other sites

Bonjour,
Jusque la, la version 1.46 fonctionnait super bien puis, j'ai mis à jour vers prestashop 1.3.1.1 et depuis, le module ne fonctionne plus correctement, meme apres avoir désinstallé puis réinstallé, meme probleme, pas moyen d'avoir la liste des categories.

Du coup, je ne peu plus générer le fichier pour les comparateurs.

Vous avez ce probleme ?

Share this post


Link to post
Share on other sites
Bonjour,
Jusque la, la version 1.46 fonctionnait super bien puis, j’ai mis à jour vers prestashop 1.3.1.1 et depuis, le module ne fonctionne plus correctement, meme apres avoir désinstallé puis réinstallé, meme probleme, pas moyen d’avoir la liste des categories.

Du coup, je ne peu plus générer le fichier pour les comparateurs.

Vous avez ce probleme ?


Merci pour ton rapport, effectivement le module a été développé du temps de la la 1.1, prestashop évolue et le module devrait etre adapté aussi.

Share this post


Link to post
Share on other sites

Bonjour j'utilise la version 1.42 du module sur une install Presta 1.2.4 et j'ai un soucis avec les prix des produits qui ont une remise ... lagrille affichée dans le module affiche bien le prix avec la remise mais dans le fichier CSV généré, j'obtiens le prix sans la remise.
QUelqu'un a rencontré ce problème ?

Share this post


Link to post
Share on other sites

Pour les problèmes d’accent pour shopzilla (pas essayé pour kelkoo) j’ai résolu le PB en copient le contenu dans le fichier joint fourni sur le site de shopzilla.
Donc le problème vient du format du fichier généré par le module et non du contenu.
Si qu’elle qu’un a une idée pour résoudre le problème je suis partant.

Fichier_ok.txt

Share this post


Link to post
Share on other sites

Bonjour,

je suis avec PS 1.2.5 et je teste la version 1.46.
l'installation se passe sans probleme, je parametre la génération pour le guide.
Je n'ai pas de message d'erreur mais par contre j'ai un fichier vide avec uniquement le nom des champs?
Avez vous déjà rencontré ce problème ?

Merci d'avance

Share this post


Link to post
Share on other sites

De mon côté ce module fonctionne avec la version de PS 1.3.1

Share this post


Link to post
Share on other sites

Bonjour, mon catalogue webmarchand n'est pas normalisé à cause des frais de ports manquants, savez vous comment résoudre le probléme? merci d'avance.

Share this post


Link to post
Share on other sites

Bonjour,

Je viens d'installer le module, je le vois bien dans la liste des modules, je rentre bien dans sa page de configuration et je selectionne les options me conviennent...

MAIS

quand je clique sur "Générer", le fichier généré ne contient que les titres des colonnes... :(

est-ce la faute de mon serveur ?

Merci pour votre aide

Share this post


Link to post
Share on other sites
Bonjour,

Je viens d'installer le module, je le vois bien dans la liste des modules, je rentre bien dans sa page de configuration et je selectionne les options me conviennent...

MAIS

quand je clique sur "Générer", le fichier généré ne contient que les titres des colonnes... :(

est-ce la faute de mon serveur ?

Merci pour votre aide


Bonsoir,
a tu l'arbre de tes catégories de généré dans l'interface de configuration du module ? Si non, c'est le meme probleme que moi et je n'ai toujours pas de solution.

Share this post


Link to post
Share on other sites
Bonjour,

Je viens d'installer le module, je le vois bien dans la liste des modules, je rentre bien dans sa page de configuration et je selectionne les options me conviennent...

MAIS

quand je clique sur "Générer", le fichier généré ne contient que les titres des colonnes... :(

est-ce la faute de mon serveur ?

Merci pour votre aide


Bonsoir,
a tu l'arbre de tes catégories de généré dans l'interface de configuration du module ? Si non, c'est le meme probleme que moi et je n'ai toujours pas de solution.


Salut Stephforum,

Je ne vois pas l'arbre des catégories.

Est-ce que pour être généré cet arbre a besoin d'être activé d'une manière ou d'une autre ?

Merci

Share this post


Link to post
Share on other sites

Bonjour basiatko,
non, normalement, le module cré l'arbre en appelant les catégories , ensuite, il suffit ce cocher celles que l'on veu référencer hors, cela fonctionne bien sur les autres sites (version antérieur) sauf sur la version 1.3.1.1 :smirk:

Par contre, ce que je ne comprend pas, c'est qu'apparement, certain utilisateurs n'ont pas ce probleme :long:
Est ce que ceux qui ont la chance que cela fonctionne peuvent confirmer qu'ils ont bien mis à jour leur site 1.3.0 vers 1.3.1.1 ?
Merci beaucoup pour votre participation car là, on rame avec les mains :-)

Share this post


Link to post
Share on other sites

bonjour.

Alors tous d'abord merci pour ce module qui est tres interressant :)
mais j'ai un probleme avec l'export enfaite ca m'export rien c'est embetant :)
je clic sur generer et je verifie dans mon ftp dans le dossier export mais il n'y a rien.
et le lien ne fonctionne pas (normal s'il n'y a rien dans mon dossier export)

J'ai la version 1.46 du module (j'ai essayer la version 1.42 c'est pareil ca fonctionne pas)
et ma version prestashop 1.2.5.0 voila :)

Share this post


Link to post
Share on other sites

Bonjour à tous,

Merci pour votre contribution. J'ai installé la version 1.46 du module.

Mes produits sont indexés sur webmarchand depuis peu.

Cependant, je souhaiterais apporter quelques modifications :
- je vends des produits alimentaires, serait il possible de supprimer le champ "garantie".
- je propose la gratuité des frais de livraison à partir de 150 euros d'achats, aussi, je souhaiterais mettre le champ "frais de port" à 0.
- mes produits sont classés en catégories "divers", alors que mes produits pourraient être classés dans des catégories existantes sur le site webmarchand.

Ces modifications sont elles possibles ? Comment faire ?
Merci d'avance pour votre aide.

Share this post


Link to post
Share on other sites

rebonjour.

A j'ai trouver pourquoi ca fonctionne pas, tous le dossier leguide est en lecture seul.

donc pour ceux qui ont des problemes car je n'arrive pas a retirer la lecture seul sur mon bureau, il faut la retirer depuis le ftp clic droit sur le dossier leguide,puis permission des fichier, puis valeur numerique mettre 777 puis recurtion dans les sous dossier et valider voila et ca fonctionne tres bien apres :)

cordialement,

cyril

Share this post


Link to post
Share on other sites

Bonjour,

Déjà, un grand merci pour ce module.

J'ai lu l'ensemble de ce post et il me semble ne pas avoir trouvé de réponse à mon problème :
- je suis en attente d'approbation du fichier datafeed sur shopmania
- en lançant le processus de validation du fichier, je m'aperçois que les colonnes générées par le module dont il est question ici ne correspondent pas aux colonnes du site
- d'un côté, j'ai :
categorie
identifiant_unique
titre
description
prix
url_produit
url_image
frais de livraison
disponibilite
delai de livraison
garantie
reference_modele
D3E
marque
ean
prix_barre
type_promotion
devise
occasion
url_mobile
- de l'autre, j'ai :
Category
Brand
Model
Code
Name
Description
URL
Image
Price  
Currency


Est-ce qu'une bonne âme pourrait m'expliquer la marche à suivre pour faire correspondre les deux svp ;-)

Merci d'avance,

Niconof

Share this post


Link to post
Share on other sites

rebonjour.

oui a moi aussi ca m'interresserais car je m'en suis apercu aussi hier
que les colonnes ne tombe pas pareil :)

si quelqu'un pouvais nous dire comment modifier ce serait super :)

d'avance merci

Share this post


Link to post
Share on other sites

Bonjour à tous,

Mes frais de ports ne sont pas repris (colonne vide) et Le guide n'aime pas bien.
Ces frais sont forfaitaires : comment affecter le même montant à tous mes produits ? Modifier le guide-script ?
Merci pour votre aide. (J'utilise une Presta 1.1.0.5 et le Module 1.46.)

Mat

Share this post


Link to post
Share on other sites

Bonjour,

Petite question...euh..j 'ai acheté sur Prestastore le module le Guide V1.0....dois je comprendre que le module présent ici est plus performant ?????
Merci pour vos lumières :-)
Jes

Share this post


Link to post
Share on other sites

Bonjour,

J'utilise ce module pour exporter mon catalogue leguide.com. Il marche à merveille, merci infiniment !

Petite question : j'aimerais également effectuer des exports pour kelkoo, netaffiliation et shopzilla.

Quelqu'un a-t-il modifié-dupliqué ce module pour ces plateformes ou dois-je me rabattre sur la version proposée par prestashop pour kelkoo et shopzilla... et développer moi-même la version netaff qui n'est à priori dispo nulle part ?

Merci de votre aide !
C.

Share this post


Link to post
Share on other sites

Salut,

Avez-vous pu automatiser l'export de vos produits avec ce module ?
A priori, il faut simplement mettre en place une tâche CRON sur un PHP d'export.

Est-ce que quelqu'un pourrait partager ledit PHP ?

Merci.

Share this post


Link to post
Share on other sites

De mon côté le module avait, semble-t-il, très bien marché la première fois. Mais depuis il se passe quelque chose de bizarre : le tableau qui apparait dans le back office est bon, mais il ne génère pas le fichier texte (fichier introuvable, le dossier "export" est vide). Quelqu'un sait comment résoudre ce problème ou comment copier le tableau dans le bon format ?

En tout cas, merci de proposer ce module gratuitement !

EDIT : Ca marche. Je n'avais pas passé le dossier 777, c'est pour cela que ça ne marchait pas.

Share this post


Link to post
Share on other sites

Bonjour à tous,

Je ne sais pas si je suis le seul dans ce cas, bref j'ai du ajouter des utf8_decode() dans catalogue.php parce que le fichier généré comportait un problème d'encodage des caractères. Cela vient peut-être de ma base de données.

Voila...

Share this post


Link to post
Share on other sites
Bonjour,

J'utilise ce module pour exporter mon catalogue leguide.com. Il marche à merveille, merci infiniment !

Petite question : j'aimerais également effectuer des exports pour kelkoo, netaffiliation et shopzilla.

Quelqu'un a-t-il modifié-dupliqué ce module pour ces plateformes ou dois-je me rabattre sur la version proposée par prestashop pour kelkoo et shopzilla... et développer moi-même la version netaff qui n'est à priori dispo nulle part ?

Merci de votre aide !
C.


Bonjour,
J'ai une version avec Shopzilla si vous êtes toujours intéressés...

Share this post


Link to post
Share on other sites
Bonjour,
J'ai une version avec Shopzilla si vous êtes toujours intéressés...


Bonjour,

Pourquoi ne pas proposer les fichiers directement ?

Share this post


Link to post
Share on other sites

Il me semble l'avoir déjà fait quelque part dans le forum mais je ne sais plus où ;)...Je regroupe tout ça et je repost :)

Share this post


Link to post
Share on other sites

Voici donc le module LEGUIDE modifié pour intégrer l'export vers Shopzilla et Shopping.com.

TUTO :
Installer le module normalement.
Remplacer votre fichier AdminProducts.php avec celui présent dans l'archive (FAITES TOUJOURS UN BACKUP !!!;))

UTILISATION :
Shopzilla a besoin d'un numéro de catégorie pour chacun de vos produits pour que ceux-ci soient bien répertoriés. Pour ce faire, je me suis servi du champs "Référence fournisseur" (puisque j'en avais pas besoin) qui a été renommé pour l'occasion en "Référence Shopzilla".

N'hésitez pas si vous avez des questions...:)

leguide-DSI94.zip

Share this post


Link to post
Share on other sites

Bonjour à tous,

Je suis très surpris de voir que mon module est encore présent et que des membres l'on fait évolué et c'est tant mieux.

Je me permets de faire une petite annotation pour la peine : actuellement je sors un nouveau module d'exportation (payant) mais qui est plus complet et stable que ce que j'avais fait à l'époque. (le traitement se base beaucoup plus sur les classes de PS).

De plus vous aurez des nouvelles possibilités d'exports par la suite. Le gros avantage est que vous ne dépendez pas d'un abonnement "mensuel", il s'agit donc d'une option intéressante pour ceux qui désirent gagner en visibilité.

http://www.prestashop.com/forums/viewthread/77026/appels_doffres_et_prestations/module_salesbooster_exportez_vers_leguide_shopzilla_google_shopping_kelkoo_icomparateur_twenga

Et oui je reviens sur Prestashop ;)

A bientôt

Share this post


Link to post
Share on other sites

Le module d'origine de m1bs posté ici http://www.prestashop.com/forums/viewthread/22501/a été beaucoup modifié par des membres du forum, de nombreux bugs ont été corrigés et de nouvelles fonctionnalités ajoutées.
Esperont que cette nouvelle version payante (je rapelle que l'on est ici dans la partie modules gratuits du forum) aura été bien améliorée.

Share this post


Link to post
Share on other sites

Sorry but I don't speak French and my English is not soo good.

I installed this module, but I have a problem. I can not select my categories, only appears three categories and all are in French (the catagories included in the Prestashop initial box).

I have my website in English and Spanish. How can I do to select all my categories? I can not see them.

Thanks

Share this post


Link to post
Share on other sites

Ou télécherger la derniere version de ce module gratuit qui a l'air fabuleux.

Est t'il compatible aver prestashop 1.3.6

Share this post


Link to post
Share on other sites

Bonjour à tous,

Comme c'est l'époque des soldes, il est nécessaire d'indiquer au site Leguide.com, le type de promotion :

type_promotion : Indique le type de promotion dont bénéficie votre offre («0» : aucune promotion, «1» : offre soldée, «2» : offre soldée en 2ème démarque, «9» offre en solde en dehors des périodes de soldes déterminés par décret national)


Je suis allé au plus simple, en mettant à jour le fichier guide-script.php, les valeurs sont soit 0, aucune promotion, soit 1 en solde.

$type_promotion = $Valeur['on_sale'];



Merci d'avance pour vos commentaires. :smirk:

Share this post


Link to post
Share on other sites

Bonjour ,

J'ai un problème , les catégories ne s'affichent pas sur le module et l'exportation ne se fait pas puisque je ne peux avoir acces aux catégories . J'ai la version 1.3.6

Merci pour vos solutions
Gilbert

Share this post


Link to post
Share on other sites

Bonjour, j'ai un petit pb mes tarif de livraison son en HT sur ma partie admin pour éviter les erreur de TVA fausse sur le panier et facture . quand j'exporte mes catalogue vers les comparateur ces prix sont aussi en HT. Comment faire ?.

merci d'avance

Share this post


Link to post
Share on other sites

merci pour ce module.
j'utilise la version 1.42.
j'ai soumis mon catalogue sur leguide.com mais il me dit que mon catalogue n'est pas normalisé car il manque l'URL de l'image.
est ce que quelqu'un à modifié le module pour l'avoir?

Share this post


Link to post
Share on other sites

Bonjour,
quelqu'un a t'il deja installé le module de webbax ?
pour connaitre vos impression

Merci
Cordialement

Share this post


Link to post
Share on other sites

Salut à tous, j'utilise la v 1.42 sur un presta 1.3.X

je propose une modif pour afficher l'url des images liées aux déclinaisons, au lieu de celles liées au produit.
dans guide-script.php, modifier la requête à la ligne 362

$Resulats = $Mysql->TabResSQL("
                   SELECT * FROM ".$ps_."product_attribute LEFT JOIN ".$ps_."product_lang ON ".$ps_."product_attribute.id_product = ".$ps_."product_lang.id_product LEFT JOIN ".$ps_."product_attribute_image ON ".$ps_."product_attribute.id_product_attribute = ".$ps_."product_attribute_image.id_product_attribute WHERE ".$ps_."product_attribute.id_product= $id_product AND id_lang = $id_lang");

Share this post


Link to post
Share on other sites

Utilisez le module Salebooster, il le fait très bien et est aussi gratuit.

Share this post


Link to post
Share on other sites

Et voilà le module Webbax n'est plus gratuit, le module leguide développé par plusieurs membres du forum lui l'est toujours. ;-)

  • Like 1

Share this post


Link to post
Share on other sites

Webbax,

pourquoi avoir annoncé alors partout que tes modules étaient gratuits ?
Dommage ...

Share this post


Link to post
Share on other sites

Hello a tous
Le module devrait pouvoir fonctionner sur la 1.4
la seul modif à faire c'est la gestion de l'id des taxe qui plante
Erreur SQL iD Taxe

A Voir

Share this post


Link to post
Share on other sites

Bonjour,
Effectivement grosse galère...
J'ai une catégorie sur 20 qui apparait dans le module LeGuide.
Si il y en a une, pourquoi n'y a -t-il pas les autres ???

Le problème c'est que j'ai absolument besoin de ce module sous la 1.4.
Quel qu'un aurai-t-il une version même payante de ce module ? C'est assez urgent ???

Ou comment faire pour que les catégories soient reconnus ? Vu que j'en ai une qui apparait et qui est exportable, qu'est ce qu'il faut bidouiller pour que se soit ok pour es autres ?

Merci d'avance

Tramber.

Share this post


Link to post
Share on other sites

Bon, pour mon histoire de catégories, c'est résolu, eles apparaissent bien, je peux les sélectionner et les exporter, ça marche.

reste le problème du taux de tva : Erreur de requete SQL:
SELECT rate FROM ps_tax where id_tax =
Fichier :(.....)/modules/leguide/class/mysql.php
Impossible de s�lectionner le taux de TVA
Ligne : 68

la requête SQL étant :

"SELECT rate FROM ".$this->ps_."tax where id_tax =$id_tax"



il ne lit pas $id_tax...

Quelqu'un aurait une idée pour débugger ça ?

Share this post


Link to post
Share on other sites

Bon, n'ayant que des articles à TVA 19.6, j'ai mis :
"WHERE id_tax = 1"
avec 1 correspondant à rate = 19.600

Pour l'instant mon module d'export LeGuide fonctionne sous prestahop 1.4.0.17, enfin version "Custom foireux.."


Tramber.

Share this post


Link to post
Share on other sites

Il y a une nouvelle table de jointure pour la version 1.4 au niveau de la TVA, ce qui implique une nouvelle relation pour que cela puisse passer correctement.

Share this post


Link to post
Share on other sites

Heu... Tramber !!
Tu peux partager la modif que tu as fait éventuelement !
A moins que tu ais simplement ajouté une table ?

Share this post


Link to post
Share on other sites

Eh bien No Problemo
mais faut savoir qu'il n'y a rien de propre dans les modifs que j'ai apporté, faute de temps j'ai simplement rendu opérationnel le module LeGuide V1.46.
donc ce n'est pas un modèle mais une alternative (temporaire !!)

Pour faire apparaitre les categories :
dans fonctions.php (ligne 106)

function base_arbre($ps_,$module_name){

   // Lit la catégorie parent début de l'arbre   MODIF 1.4 TRAMBER : id_parent = 0 au lieu de id_parent = 1 
   $sql = 'SELECT * from '.$ps_.'category LEFT JOIN '.$ps_.'category_lang ON '.$ps_.'category.id_category = '.$ps_.'category_lang.id_category WHERE level_depth=1 AND id_parent = 0 AND id_lang=2 AND active=1';



puis pour l'histoire du taux de TVA comme expliqué plus haut, class/art_info.php (ligne 31)
j'ai remplacé $id_tax par 1 car pour moi la valeur 1 de id-tax est 19.6

Voilou, du coup ça marche et j'ai pu imprimer mes étiquettes magasin avec tout les bon prix.
Pour ce qui est des fichiers généré tout semble correct.
Si un developpeur digne de ce nom peut corriger et/ou compléter c'est kool.

Tramber.

Share this post


Link to post
Share on other sites

OK merci pour le partage, en faite perso je n'ai aucun problème avec les catégorie cela fonctionne sans aucune modification
Juste le problème des taxes qui est maintenat résolu, tellement simple que je n'y avais pas pensé !!!

***Pour tous d'ailleur, la modif fonctionne également pour le module "idéalo" qui est basé sur "leguide"

Share this post


Link to post
Share on other sites

I'm Italian,
prestashop 1.4.1
Leguide 1.46 permission 777 all files
The "produits_leguide.txt" is BLANK
Please help me!

Share this post


Link to post
Share on other sites

Bonjour

Avez vous trouvez des solutions ?

Moi j'ai erreur :

Erreur de requete SQL:
SELECT rate FROM pss_tax where id_tax =

Share this post


Link to post
Share on other sites

The “produits_leguide.txt” is BLANK

je n'ai pas eu aucune solution!!!

Share this post


Link to post
Share on other sites

Le-Cathare, la réponse est plus haut post Tramber :

***puis pour l’histoire du taux de TVA comme expliqué plus haut, class/art_info.php (ligne 31)
j’ai remplacé $id_tax par 1 car pour moi la valeur 1 de id-tax est 19.6

Voilà

Share this post


Link to post
Share on other sites

Salut, j'ai bien réussi à mettre en place ce super module par contre un souci au niveau du site LeGuide: lorsque je m'inscris en version gratuite je ne reçois pas le mail de confirmation me permettant de finaliser l'inscription! Une idée?

Share this post


Link to post
Share on other sites

Bonjour à tous.

J'ai suivi vos explications pour adapter le module à PS 1.4,tout fonctionne parfaitement sauf pour la colonne "prix barré" ou tout est vide.

Avez-vous une solution? une astuce?

Merci d'avance.

Share this post


Link to post
Share on other sites

Bonjour,

Je viens de tester la version 1.46 du module, avec la version 1.4.2.3. Ca fonctionne, il faut juste faire la modification en ligne 31.
$Resulats = parent::$this->mysql->TabResSQL("SELECT rate FROM ".$this->ps_."tax where id_tax =1");
(1 étant l'ID du taux de TVA choisi)

Quelqu'un aurait il trouvé la solution un peu plus propre qui gère les multi-taux de TVA?

Merci pour vos retours...

Share this post


Link to post
Share on other sites

Voici une grosse mise à jour du module qui passe en version 1.52 car j'ai compté les modifications proposées précédemment comme autant de saut de version.

Principales nouveautés :
_ Ajout de la génération par tranches pour outrepasser la limitation du timeout PHP sur un serveur mutualisé
_ Ajout de la gestion du paramètre 'auto' dans l'URL permettant de lancer automatiquement la génération du catalogue
_ Format du fichier de sortie définie automatiquement en fonction du catalogue généré
_ Affichage de l'arborescence correctement indentée
_ Prise en compte des produits de la racine
_ Calcul de la TVA compatible avec Prestashop 1.4

+ d'autres petites améliorations cosmétiques

leguide_v1.52.zip

Share this post


Link to post
Share on other sites

Sympa cette nouvelle version, particulierement l'ajout du parametre auto pour les taches cron, ce serait cool d'avoir ca aussi sur le module google shopping http://www.prestashop.com/forums/viewthread/76681/

Je viens de tester sur 1.3.7

premiere remarque, je n'ai plus de couleur dans le BO (voir image), le module 1.52 est il compatible 1.3.7 et autres precedentes versions de PS?

Share this post


Link to post
Share on other sites

Pour les couleurs j'ai du mal à voir exactement ce qui ne va pas sur la capture d'écran. Par contre, je vois que la barre d'outils sous le menu Presta est décalée vers le bas.

Quoi qu'il en soit, j'ai fait une correction sur le CSS concernant les liens (v 1.53).

Pour Presta 1.3 je n'ai pas testé mais j'ai vu que j'ai gardé la compatibilité 1.2.5 ça devrait tourner.

Pour le Module Google Export, oui, je j'essaierai de rajouter le mode auto.

Share this post


Link to post
Share on other sites

pour les couleurs en fait le module leguide a déja ce probleme mais cela ne m'avait pas autant frappé.

Voila ce que devrait etre l'aspect du bo

Share this post


Link to post
Share on other sites

Effectivement. Il y avait un css qui trainait dans le répertoire jquery et qui redéfinissait le style du body...
J'ai supprimé ça et gardé juste la taille de la font qui n'est pas mal, sur l'interface du module.

leguide_v1.54.zip

Share this post


Link to post
Share on other sites

Merci pour la mise à jour! En effet le souci de TVA sur 1.4 est réglé!

Par contre chez moi ça me met le prix à 0 pour tous mes articles, est ce que cela peut venir du fait que les stocks sont à 0?

Share this post


Link to post
Share on other sites

Désolé de revenir sur le sujet
L'aspect du Bo est bon maintenant par contre le texte n'est pas lisible chez moi (trop petit, flou), testé avec Chrome - voir image

Autre probleme, le fichier d'export est vide

Share this post


Link to post
Share on other sites
L’aspect du Bo est bon maintenant par contre le texte n’est pas lisible chez moi (trop petit, flou), testé avec Chrome – voir image

Est-ce que avec ce nouveau css c'est bon ? (penser à faire ctrl + F5)

Autre probleme, le fichier d’export est vide

Je pense que ça doit venir de la version de Presta. Le module attaque les tables en dur donc à la moindre modification du schéma de la BDD il y a un risque que ça ne fonctionne plus. Je testerai sur une 1.3.1

Par contre chez moi ça me met le prix à 0 pour tous mes articles, est ce que cela peut venir du fait que les stocks sont à 0?

Non, je viens de tester. Quelle sous version de Presta 1.4 ?

css.zip

Share this post


Link to post
Share on other sites