Jump to content
petb

[SOLVED] Afbeeldingen importeren via .csv bestand lukt niet ps 1.5.3.1

Recommended Posts

Als ik via een .csv bestand de prodcuten importeer komt alles netjes binnen.

 

Echter de afbeeldingen worden niet geimporteerd vanaf de externe links die in de kolum afbeelding staan. zoals bijv: http://ww.levarancie.../afbeelding.jpg

 

Dit gebeurt bij meerdere verschillende .csv bestanden.

 

Krijg ook geen foutmelding vanuit de backoffice van prestashop tijdens of na het importeren.

Om de een of andere reden worden de categorien ook niet aangemaakt,dit heb ik al handmatig gedaan.

 

ik heb de folder IMG en alle onderliggende folders op 777 gezet.

ook dat lost het probleem niet op.

 

Zou dit een bug kunnen zijn?

 

 

ik werk met prestashop versie : 1.5.3.1

 

Alvast bedankt voor het meedenken.

Edited by petb (see edit history)

Share this post


Link to post
Share on other sites

De lijst met .csv informatie om te importeren in de webwinkel krijg ik van mijn leveranciers.

 

Je hebt het over exporteren?

Share this post


Link to post
Share on other sites

De lijst met .csv informatie om te importeren in de webwinkel krijg ik van mijn leveranciers.

 

Je hebt het over exporteren?

 

hallo,

 

Jah over exporteren.

 

Ik wil graag mijn producten en categorieen en fabrikanten exporteren, zodat ik dan een backup hebt.

 

Ik wou graag weten hoe je dat gedaan hebt.

 

mvg,

Share this post


Link to post
Share on other sites

Ik dacht die gaat mij iets vertellen om mijn probleem op te lossen ;-)

 

Voor wat het exporteren betreft Google eens op lengow.

 

 

Peter.

Share this post


Link to post
Share on other sites

Ik heb het zelfde.. wanneer ik mijn csv bestand in lees dan maakt hij de foto's niet aan op een of andere vage manier...

 

Ik heb onder preferences -> Images alle resoluties die daar staan al verwijderd en opnieuw aangemaakt, maar dat hielp ook niks.

Ook geprobeerd met de BO op engels te zetten en dan proberen te importeren alleen dat hielp ook niet.

 

Ik gebruik de zelfde versie PS als jij dat doet alleen heb ik mijn PS geupdate misschien dat het daar door niet goed is gegaan.

 

Als ik iets vind dan laat ik het je weten.

 

Groet Kris

Share this post


Link to post
Share on other sites

Kris Vind het voor jou ook heel vervelend,maar begin nu wel meer in de richting van een bug te denken.

Denk niet dat het door de update komt,ik heb een totaal schone installatie uitgevoerd in instaltron.

 

Ik heb op net engels sprekend gedeelte van dit forum ook een bericht geplaatst.

 

Houd dat ook in de gaten en zal net als jij gelijk iets doormelden als ik meer weet.

 

@scorpionsworld bedankt alvast!

Edited by petb (see edit history)

Share this post


Link to post
Share on other sites

Petb,

 

Zou je iets kunnen proberen? Wanneer ik dus via csv bestand wat importeer dan doet het helemaal niks.. maar wanneer ik handmatig via catalog -> products -> en dan image, een foto toevoeg dan krijg ik die wel te zien in het product scherm van dit artikel.

 

Alleen als ik op mijn home pagina kijk dan zie ik dus geen kleine afbeelding van dit artikel, dit geld voor alle afbeeldingen.

 

Zie deze link naar mijn site: Klik hier voor de link

Share this post


Link to post
Share on other sites

Klopt ,

Paar dagen geleden heb ik bij een artikel handmatig een foto toegevoegd en deze was dan wel te zien in de webwinkel.

 

Net even een test product toegevoegd en handmatig een foto.

Deze foto word zowel in de backoffice als in de webwinkel correct weergegeven.

Edited by petb (see edit history)

Share this post


Link to post
Share on other sites

Petb,

 

Zou je iets kunnen proberen? Wanneer ik dus via csv bestand wat importeer dan doet het helemaal niks.. maar wanneer ik handmatig via catalog -> products -> en dan image, een foto toevoeg dan krijg ik die wel te zien in het product scherm van dit artikel.

 

Alleen als ik op mijn home pagina kijk dan zie ik dus geen kleine afbeelding van dit artikel, dit geld voor alle afbeeldingen.

 

Zie deze link naar mijn site: Klik hier voor de link

Heb je in de Voorkeuren->Afbeeldingen wel een definitie staan voor home_default?

Share this post


Link to post
Share on other sites

@ scorpionsworld: Ja die had ik er staan heb hem nogmaals opnieuw toegevoegd en nu laat hij de afbeeldingen wel zien op mijn home pagina. Alleen het importeren word er niets anders van.. helaas

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Zoals hier staat beschreven Link kan het dus kloppen.. ik had ook last van dat mijn nieuwe artikelen in de root werden gezet en niet in de category dat ik zelf aangaf.

 

Ik moet nog verder lezen of er ook een fix is..

 

Kris

Share this post


Link to post
Share on other sites

Ik heb ook het probleem dat de categorie folders ook niet aan gemaakt worden.

Zou het een en ander met elkaar te maken hebben...

 

Er moet dus iets verwijderd en iets toegevoegd worden ,durf ik nog niet aan eerlijk gezegd ben niet zo thuis hierin.

Share this post


Link to post
Share on other sites

 

In the folder controllers/admin/ open the file AdminImportController.php

 

Delete next lines

do $uniqid = uniqid(); while (file_exists(PS_UPLOAD_DIR.$uniqid));

$tmp_file = file_put_contents(PS_UPLOAD_DIR.$uniqid, $field);

$fd = fopen($temp, 'r');

 

Add this lines

do $uniqid_path = PS_UPLOAD_DIR.uniqid(); while (file_exists($uniqid_path));

file_put_contents($uniqid_path, $field);

$fd = fopen($uniqid_path, 'r');

 

delete this line:

unlink($tmp_file);

 

Add this line:

unlink($uniqid_path);

 

Tested in PrestaShop 1.5.3.1 in http://www.venlotodo.com and it works.

Regards.

 

 

Dit zou moeten werken maar ik kan die regels niet vinden in mijn bestand.. :blink:

Share this post


Link to post
Share on other sites

Ik heb hem volgens mij wel op regel 645 als ik hem met notepad++ open

Toch?

 

 

==============================================================

 

do $uniqid = uniqid(); while (file_exists(_PS_UPLOAD_DIR_.$uniqid));

$tmp_file = file_put_contents(_PS_UPLOAD_DIR_.$uniqid, $field);

$fd = fopen($temp, 'r');

$tab = fgetcsv($fd, MAX_LINE_SIZE, $separator);

fclose($fd);

unlink($tmp_file);

 

if (empty($tab) || (!is_array($tab)))

return array();

return $tab;

==================================================================

Edited by petb (see edit history)

Share this post


Link to post
Share on other sites

Ja klopt heb hem idd aangepast (zat in verkeerde bestand te kijken) en de afbeeldingen komen er nu weer bij te staan.

 

Én ze komen weer in de juiste groepen te staan! :D

Share this post


Link to post
Share on other sites

@scorpionsworld: Ik krijg nu wel de afbeeldingen te zien op me hoofdpagina en op de product pagina alleen de "sub categorie" pagina heeft nog niet de juiste afbeeldingen.. Enig idee?

Share this post


Link to post
Share on other sites

Mooi een goed begin alvast dus.

 

Zit nu niet op de juiste plek maar zal later eens kijken wat er bij mij gebeurt na de verandering.

Share this post


Link to post
Share on other sites

@scorpionsworld: Ik krijg nu wel de afbeeldingen te zien op me hoofdpagina en op de product pagina alleen de "sub categorie" pagina heeft nog niet de juiste afbeeldingen.. Enig idee?

Ja, afbeeldingsformaat "home" kan niet gevonden worden.

Da's het fijne van Prestashop 1.5.X. De default theme+standaard modules zoeken naar formaten zowel met als zonder _default toevoeging...met andere woorden, beide formaatdefinities moeten bestaan.

Share this post


Link to post
Share on other sites

Heb de wijziging ook doorgevoerd

En inderdaad foto's worden nu wel ingeladen!

 

Super.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More