Jump to content
Hugol

"solucionado" Error Al Recuperar Contraseña (Correo Electrónico)

Recommended Posts

Hola buenos días, tengo el PS 1.5.2 instalado y estaba funcionando todo bien, hasta que claro me llamó un cliente que no podía acceder a su perfil.

Por lo que imaginé que era porque se había olvidado la contraseña, y pues intenté con un usuario-cliente que tengo para hacer pruebas, para restablecer mi contraseña y me da el siguiente error:

 

 

 

¿Olvidaste tu contraseña?

 

 

Hay 1 error

  1. Se produjo un error al enviar el correo electrónico.

Por favor, introduzca el email que utilizó para registrarse y le enviaremos su nueva contraseña.

 

 

Por lo que realicé todos los pasos que encontré en el foro:

 

Copié la carpeta de mails por una nueva

Cambié la carpeta mails>es por la de mails>en

hice diferentes combinaciones quitando el cache, modificando las opciones smart.

configuré todo lo que pude, pero parece que no es suficiente.

TAMBIÉN CONFIGURÉ LA CUENTA POR SMTP PERO NO FUNCIONA!

 

Alguien tiene alguna otra alternativa?

 

 

 

Muchas gracias!

Edited by Hugol (see edit history)

Share this post


Link to post
Share on other sites

Nos puedes pasar la url de tu web para hecharle un vistazo?

VIlwebs: muchisimas gracias por responder.!!!

 

la url de la web es www.materialesmedicos.com.

 

muchas gracias! :lol:

Share this post


Link to post
Share on other sites

Un usuario del foro, tuvo un problema parecido con la misma versión de prestashop y era por que no tenia subido bien el logo en la pestaña Preferencias -> Temas.

 

Otro usuario del foro le paso tambien algo parecido, por que el titulo de la tienda era demasiado largo.

Edited by Rubalcaba (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Muchas gracias Vilwebs, por tu interés!

 

y Rubalcaba, tu solución funciona, listo, tanto complicarse la vida, tantos días y era solo eso!

en fin, que lástima que ocurra este error por el título no veo la relación, pero la verdad es que te agradezco tu apoyo...

 

Saludos!!!!

Share this post


Link to post
Share on other sites

Buenas tardes! Hugol, tengo exactamente el mismo problema que tú. Si un cliente olvida su contraseña y quiere recuperarla, me da el mismo error. ¿Podrías indicarme exactamente cómo lo solucionaste? Quizá estoy haciendo algo mal porque he intentado probar lo que comenta Rubalcaba y sigo igual.

 

Creo que igual no lo estoy haciendo bien :(

Share this post


Link to post
Share on other sites

Buenas tardes! Hugol, tengo exactamente el mismo problema que tú. Si un cliente olvida su contraseña y quiere recuperarla, me da el mismo error. ¿Podrías indicarme exactamente cómo lo solucionaste? Quizá estoy haciendo algo mal porque he intentado probar lo que comenta Rubalcaba y sigo igual.

 

Creo que igual no lo estoy haciendo bien :(

 

 

hola eleguitierrez, mira lo único que hice en este caso fue cambiar el nombre de mi tienda de "Instant Medical Solutions - Materiales Medicos" por "IMS - Materiales Medicos".

y ya... en ese caso se solucionó el problema.

 

Ahora también hice una migración desde un PS 1.4.7 a un PS 1.5.2, y el problema fue que perdí toda la historia de pedidos de los clientes, ya que parece que las bases de datos son diferentes en uno y otra versión. Por lo que los clientes viejos no se puede recuperar la contraseña hasta de hecho el sistema no los deja entrar en sesión y claro que como el mail, no se puede duplicar no pueden registrarse de nuevo, entonces ahí tengo que borrar el cliente, crearlo con los datos personales nuevamente, y pedirle que cambie la clave por defecto que le pongo.....

no me gusta para nada esto pero no he encontrado otras soluciones.

 

espero que te pueda haber servido de algo mi experiencia...

 

 

saludos!

Share this post


Link to post
Share on other sites

Gracias por la respuesta. He cambiado el nombre de mi tienda, tal y como comentas, y nada. Voy a crear un nuevo hilo, a ver si alguien me puede ayudar.

Share this post


Link to post
Share on other sites

Un usuario del foro, tuvo un problema parecido con la misma versión de prestashop y era por que no tenia subido bien el logo en la pestaña Preferencias -> Temas.

 

Otro usuario del foro le paso tambien algo parecido, por que el titulo de la tienda era demasiado largo.

 

Hola Rubalcaba,

 

Tengo exactamente el mismo problema, tendras el post en donde se soluciono? y esque llevo trabajando en la tienda desde octubre del año pasado y todavia no acabo. gracias!

 

 

 

RESUELTO, LES COMPARTO LA SOLUCION QUE ENCONTRE, SE BASABA EN LA CONFIGURACION DEL BACKOFFICE / PREFERENCIAS/ MAIL, ANEXO LA IMAGEN, ESPERO QUE A ALGUIEN LE SIRVA,

SALUDOS.

Edited by Dtheater (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Hola Dtheater,

 

¿Tu tienda de momento sólo la tienes en local? Lo digo porque veo que la captura de pantalla es de localhost. Yo todavía no he conseguido solucionar el problema de recuperar las contraseñas olvidadas, porque al intentar enviar el email me da error.

 

¿Has probado tu solución con una tienda funcionando ya en un hosting o sólo en local?

 

Gracias!

Share this post


Link to post
Share on other sites

Hola Dtheater,

 

¿Tu tienda de momento sólo la tienes en local? Lo digo porque veo que la captura de pantalla es de localhost. Yo todavía no he conseguido solucionar el problema de recuperar las contraseñas olvidadas, porque al intentar enviar el email me da error.

 

¿Has probado tu solución con una tienda funcionando ya en un hosting o sólo en local?

 

Gracias!

 

Que tal elegutierrez, mira, no soy mega experta ni nada pero lo hice mediante mi local host porque no me dejan subirla al host hasta que quede lista toda la pagina (realmente falta poquito).

 

Lo que te puedo sugerir es........ pon los datos como los ingreses en la imagen y en donde dice CONTRASEÑA pon la contraseña del correo al cual quieres te llegue todo y creeme que a mi me funciono, yo me dedique a realizar muchas pruebas y solo esa me funciono. Mira, basicamente esa es una configuración de tu host.

 

Porque no capturas la imagen de tu configuracion para que todos veamos en el foro para checar si alguien podemos ayudarte pero ojo!!! no soy experta ehhh?? jajaja!

Share this post


Link to post
Share on other sites

Hola Dtheater,

 

Todos los correos que se envían desde mi tienda llegan perfectamente. El único problema lo tengo cuando un cliente intenta recuperar su contraseña (lo típico de que se le ha olvidado).

 

La configuración que has puesto tú en la imagen, yo la tengo puesta por defecto (es decir, tengo marcado "Usar la función mail() de PHP. Recomendado en la mayoría de los casos"). Y esto me funciona perfectamente, de hecho, envío el email de prueba y llega sin problemas.

 

Como te digo, el problema sólo lo tengo a la hora de recuperar contraseñas.

  • Like 1

Share this post


Link to post
Share on other sites

Hola Dtheater,

 

Todos los correos que se envían desde mi tienda llegan perfectamente. El único problema lo tengo cuando un cliente intenta recuperar su contraseña (lo típico de que se le ha olvidado).

 

La configuración que has puesto tú en la imagen, yo la tengo puesta por defecto (es decir, tengo marcado "Usar la función mail() de PHP. Recomendado en la mayoría de los casos"). Y esto me funciona perfectamente, de hecho, envío el email de prueba y llega sin problemas.

 

Como te digo, el problema sólo lo tengo a la hora de recuperar contraseñas.

 

El problema lo tienes en el modulo de mailalerts, ponle el de otra version inferior para que se te solucione la generacion del pass

 

Saludos

Share this post


Link to post
Share on other sites

En mi caso la solución fue editar la traducción del Asunto del correo que se envía.

 

La letra Ñ de la palabra "contraseña" metía la pata.

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More