Jump to content
4play

Cant connecting with Addons in PrestaShop adminpanel

Recommended Posts

I cant connect to Addons in Prestashop modules bookmark (in admin panel). So i cant instal modules. When i try login appear information: "PrestaShop cant login to modules, check your permision and internet connection." Login (adres email) and pass are correct.

 

Any idea why I cant conneting to Addons?

Share this post


Link to post
Share on other sites

I'm having the same problem. Except on one site, I input my credentials and it logs me in then shows me the login section again asking if I have an account so I can't search. The other site returns this error:

PrestaShop was unable to login to Addons, please check your credentials and your internet connection.

Share this post


Link to post
Share on other sites

When I try to login to Addons from the back office, it looks like it logged me in, then the Login Panel displays again asking for a userid and password.

 

I'm not getting any errors.

 

How do I tell if I am logged in or not?

 

For what purpose do I need to login to Addons from the 1.5.3 backoffice?

Share this post


Link to post
Share on other sites

I'm getting same error message:

PrestaShop was unable to login to Addons, please check your credentials and your internet connection.

 

I can log into the prestashop addon site no problem. When I use the exact same login info through the adminpanel it doesn't work. Anyone found a solution yet?

Share this post


Link to post
Share on other sites

Im getting the same error:  i changed my password online just to make sure i have the right email address and password.  after changing the password, the login still returns error:  PrestaShop was unable to login to Addons. Please check your credentials and your internet connection.

Share this post


Link to post
Share on other sites

Im getting the same error:  i changed my password online just to make sure i have the right email address and password.  after changing the password, the login still returns error:  PrestaShop was unable to login to Addons. Please check your credentials and your internet connection.

 

Hi, have you cleared cache and changed browsers? 

Share this post


Link to post
Share on other sites

Hi,

are there any news on this topic?

 

I already cleared caches, changed browsers and verified the account - nothing helped, the error message is still the same!

Edited by Servatius (see edit history)

Share this post


Link to post
Share on other sites

Hi,

are there any news on this topic?

 

I already cleared caches, changed browsers and verified the account - nothing helped, the error message is still the same!

 Hi all

 

Same problem here. I noticed that I can't update modules also.

Thinking about a hosting problem or php not active but it seems that it has allow_url_fopen.

 

Any advice? Regards.

Share this post


Link to post
Share on other sites

Same thing here, on french version : I can install and update modules, but impossible to log on Prestashop Addons by using my Addons credentials (and yes, I tried on different browser, even fresh installed Firefox or Chrome).

Strange…

Share this post


Link to post
Share on other sites

Same problem here: "PrestaShop cant login to modules, check your permission and internet connection."

 

I can install and update modules.

I can login fine to https://addons.prestashop.com, but I can't login using the admin panel.

 

I've tried using the admin email and a new email, and same problem. I've also tried with different browsers, clear cache, clear cookies and even with all browser addons uninstalled.

 

I'm using Prestashop 1.6.0.11, in spanish. Maybe it's a problem with using Prestashop in another language?

Share this post


Link to post
Share on other sites

Nope, it is not a problem with the language: I've installed PS 1.6.0.11 in a virtual machine (VirtualBox) on my LAN, and the connection through the admin panel works perfectly.

Same installation, but on a shared server on the real Internet: connection through the admin panel doesn't  work anymore.

I don't know why…

Share this post


Link to post
Share on other sites

fopen extension, or allow url connection is most likely disabled by your hosting provider.  you should research these PHP settings

  • Like 1

Share this post


Link to post
Share on other sites

Here is my PHP settings :

PHP Version 5.6.4

Directive                 Local Value       Master Value

allow_url_fopen      On                    On

 

And I don't see any line containing "allow url connection" or things like that.

Edited by Orphee (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

I'm troubled with this issue as well. Any one got it resolved yet?

Share this post


Link to post
Share on other sites

It works now, with 1.6.0.14. I absolutely don't know why, or if it has been fixed, or if something has changed on my hosting service, or whatever.

 

But this is of no use: the modules updating work very well, with or without this connexion.

Share this post


Link to post
Share on other sites

Well, I am using 1.6.0.14 and I cannot connect to prestashop addons from the admin tools to update modules... I have check passwords, changed browsers and still get the message that Prestashop could not log me in Addons...

 

Why? please help.

 

Vic

Share this post


Link to post
Share on other sites

I solved it by enabling allow_url_fopen.

I'm not sure if this is a security risk.

Share this post


Link to post
Share on other sites

I have same problem.

 

Addons website (credential stored in browser) can login

 

Addons website with another browser can't login

 

Backoffice store can't login

 

I have tried to reset password but not receive the email send by the System

Share this post


Link to post
Share on other sites

i Add following command line @ Home/Yourwebsitename/public_html/

allow_url_fopen = On;

 

in 2 files

 

1 = .user.ini ( this file was already exist)

2 = php.ini  ( i create this file )

 

i did not changes any thing in htaccess file do not touch 

 

try it its work for me

(Prestashop 1.6.0.9)

Share this post


Link to post
Share on other sites

I'm having the same issues, 1.6.1.4

 

Prestashop was unable to log in to Addons
 

I've tried the 128mb, different browsers, different computers.

Can some one help?

Edited by vaporz (see edit history)

Share this post


Link to post
Share on other sites

Still no resolution?
I've checked all my credentials, made new accounts, contacted my host provider and nothing works.
With so many having the same issues, I don't think its my particular setting or account info.
Everything worked fine before the upgrade, on the same account.
 

Someone may want to look into this issue.

Edited by vaporz (see edit history)

Share this post


Link to post
Share on other sites

Hi,

I've same problem about login to addon from backoffice admin panel.

My server is a debian jessie new release.

I've other server and all work well, but this last new server don't work.

Featured active:

allow_url_fopen = On

curl, php5-curl installed

ssl too.

Share this post


Link to post
Share on other sites

According to my host provider, it has something to do with the htaccess, we have it fixed but not without a fight with the hosting folks.

This was their answer
There was an .htaccess file in your ~/public_html directory referencing a php.ini file.
This file contained an incompatible or obsolete PHP directive which caused the log-in to fail. I have renamed the php.ini

I have multiple installs that this fixed. Seems that some hosts may be sharing the same files is why all my new test installs would still not work. Or they were giving me an answer they thought would make me happy.

 

If you are still having these issues, it is Definitely with your host provider. 
I have another host provider I made a fresh install on and all addon logins worked great with no problems.
Don't let your host provider tell you it is not their fault.
But, I could be wrong??

Consider my issues fixed on this thread.


 

Share this post


Link to post
Share on other sites

Had the same problem...Changing php version from 5.6 to 5.5 worked for me. After update I will try to change php up again.

  • Like 1

Share this post


Link to post
Share on other sites

Had the same problem...Changing php version from 5.6 to 5.5 worked for me. After update I will try to change php up again.

 That worked for me too! 

Share this post


Link to post
Share on other sites

SOLVED !!

--------------

Hello everyone,

 

I also had this issue with the last version of PrestaShop (1.6.1.6), and I was searching and looking for the solution for weeks. I saw somewhere I needed to updated PHP version.

 

I originally had PHP version 5.4, then I realized my hosting provider has available PHP version 5.5, 5.6 and 7.0 so I chose to update to the newest.

 

The thing is, with PHP v7.0 I still had the same problem, I couldn't connect to Addons from my PrestaShop backoffice and I was beginning to get frustrated and thinking to call my hosting provider; until I found this forum (I don't know why I didn't get here before), and then checked ALL POSTS, every single one. Until....

 

Until I found arutha86 answer in post #30.

 

So, I updated my PHP 7.0 version to PHP 5.5, tried that out, and IT WORKED AT LAST !!!.

 

I just thought it was important to tell everyone, that the problem is solved.

 

I insist, to all fellows, UPDATE YOUR PHP version to 5.5, and that's all (it updates your PHP.INI file including the "allow_url_fopen = On" directive), you'll able to connect to PrestaShop Addon from your PrestaShop 1.6.1.6 backoffice.

 

Hope it works for you guys.

Share this post


Link to post
Share on other sites

or you can just keep you same version of PHP and enable either CURL extension, or allow FOPEN to function.

Share this post


Link to post
Share on other sites

Hi all,

 

I have tried everything: CURL is enabled, FOPEN is allowed and I just got my hosting company to downgrade from PHP 5.6 to 5.5.38 but I am still unable to login to Prestashop Addons from within Prestashop. As such none of my modules are being updated. I have changed the addons password and can login from the website fine. Can anyone from Prestashop please contact me to resolve this issue?

 

Thanks

http://dar-us-salam.com/phpinfo.php

Share this post


Link to post
Share on other sites

I finally figured out the problem after having Prestashop technicians look at my backend: The problem was that I was using overrides. I was able to update the modules automatically after disabling the overrides (under Advanced Parameters > Performance ). There were 18 modules that needed updating. I reverted back the overrides once it was done.

 

 

Hi all,

 

I have tried everything: CURL is enabled, FOPEN is allowed and I just got my hosting company to downgrade from PHP 5.6 to 5.5.38 but I am still unable to login to Prestashop Addons from within Prestashop. As such none of my modules are being updated. I have changed the addons password and can login from the website fine. Can anyone from Prestashop please contact me to resolve this issue?

 

Thanks

http://dar-us-salam.com/phpinfo.php

Share this post


Link to post
Share on other sites

SOLVED

-----------

 

Worked: when enabled php_curl module and Disabled allow_url_fopen in php.ini

Not worked: enabled php_curl module and enabled allow_url_fopen in php.ini

Share this post


Link to post
Share on other sites

Hello,

 

I solved by making following changes.

 

in js/admin.js

 

find

function bindAddonsButtons()
{
    // Method to log on PrestaShop Addons WebServices
    $('#addons_login_button').click(function()

In that i just replace the code for AJAX success. There is something wrong in that.

 

Below is the change which i applied:

success : function(data){
                    var datastring = (data.trim());
                    if (datastring == "OK")
                    {
                        $('#addons_loading').html('');
                        $('#addons_login_div').fadeOut();
                        window.location.href = currentIndex + '&token=' + token + '&conf=32';
                    }
                    else {
                        $('#addons_loading').html('<br><div class="alert alert-danger">'+errorLogin+'</div>');
                    }
                }

Hope its work.

Share this post


Link to post
Share on other sites

After several hours, I have finally found the issue and solved it for 1.6.x.x versions.

 

(You must be sure that curl and allow_url_fopen are activated)

 

In /classes/tools.php, the function file_get_contents never uses curl because one of the conditions is wrong.

 

In the function file_get_contents, you must replace the following line :

if (in_array(ini_get('allow_url_fopen'), array('On', 'on', '1')) || !preg_match('/^https?:\/\//', $url)) { 

by this line :

if (!preg_match('/^https?:\/\//', $url)) { 

You should now be able to connect to prestashop addons.

Edited by ynocquet (see edit history)
  • Thanks 1

Share this post


Link to post
Share on other sites

Hi

i am facing the same issue almost. 

 

I am running Presta 1.7.1.1 and with the php version in the atached .jpg. 

 

It's a bit strange, because i can connect to addons marketplace in the Modules & Services , but when select the Employees and try to login there to the ADDONS it keeps the wheel spinning and give no error . 

 

I have other Prestashop for testing that is on 1.6.1.13 version and both logins to addons marketplace works good.

 

the domains for each version are on the subtree of the public_html , so i think that is not a Cpanel issue or anything related with the htaccess or Curl

 

Kindly see the prinscreens , your help is really appreciated.

 

Many thanks

Nuno

Share this post


Link to post
Share on other sites

Had the same problem...Changing php version from 5.6 to 5.5 worked for me. After update I will try to change php up again.

 How to change the php version

Share this post


Link to post
Share on other sites

I'm facing this issue on 1.7.1.2 and I have both curl and url fopen in On status.

Using php 5.5

 

Can't login to addons marketplace in my backoffice. I changed the login password twice and still, no way to get this sorted.

  • Like 1

Share this post


Link to post
Share on other sites

Same issue here with a 1.7.1 install.
(Was working in local but not on remote)

 

had fopen and curl enabled

Resolved by upgrading to 1.7.2 and changing some server configuration file
(The server is hosted @OVH and i had to change a line in the .ovhconfig file:

container.image=legacy
to 
container.image=stable

)


Hope it helps someone !
Edited by lafeuilleZER (see edit history)

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More