Jump to content
quadfun

Ik krijg regelmatig: Cart cannot be loaded or an order has already been placed using this cart

Recommended Posts

Deze melding krijg ik regelmatig bij het valideren van een bestelling:

 

Na pagina vernieuwen krijg ik dit:

 

Cart cannot be loaded or an order has already been placed using this cart

 

Wat is het probleem ?

 

Kan iemand me helpen ?

 

Prestashop kan de bestelling niet helemaal afronden.

 

1.5.3.1 versie.

 

Zo mis ik veel bestellingen !!

 

Graag een dringende oplossing gevraagd.

Edited by quadfun (see edit history)

Share this post


Link to post
Share on other sites

Ik heb de indruk dat het bij sommige artikels is:

Bij dit artikel is er een probleem: TX21-HF145/10

Ik heb de indruk dat hij niet overweg kan met speciale tekens zoals "-"

De fout heb ik bij diverse betaalmodules.

Share this post


Link to post
Share on other sites

Intussen een het artikelnummer aangepast,, maar dit is geen oplossing.

Raar is wel, dat bij sommige artikels geen probleem is, en bij sommige wel.

Wie kan mij helpen ?

 

Ik zie de artikels wel staan in het correcte winkelmandje, maar hij stuurt de bestelling niet door naar een definitieve bestelling.

Bij validation is er altijd een probleem. (bij sommige artikels)

Share this post


Link to post
Share on other sites

Probleem gevonden:

 

 

Het probleem zit in de omschrijving:

 

Over waar er "<" of ">" in de omschrijving van het artikel staat daar komt hij vast te zitten !!

 

Bij het valideren van de order.

 

2de probleem is: na de import heb ik zo'n 1000 artikels met deze tekens in de omschrijving.

 

Hoe ik dit snel ga oplossen weet ik nog niet.

 

Hoe heb ik de fout gevonden:

 

Door naar deze film te kijken en op deze manier de fout gevonden:

 

http://nemops.com/debug-prestashop-error-500/

 

Groeten

 

Wim.

Share this post


Link to post
Share on other sites

Probleem gevonden:

 

 

Het probleem zit in de omschrijving:

 

Over waar er "<" of ">" in de omschrijving van het artikel staat daar komt hij vast te zitten !!

 

Bij het valideren van de order.

 

2de probleem is: na de import heb ik zo'n 1000 artikels met deze tekens in de omschrijving.

 

Hoe ik dit snel ga oplossen weet ik nog niet.

 

Hoe heb ik de fout gevonden:

 

Door naar deze film te kijken en op deze manier de fout gevonden:

 

http://nemops.com/de...shop-error-500/

 

Groeten

 

Wim.

Dus hij loopt vast op html tags in de omschrijving? :blink:

Dat is wel erg vaag, want vrijwel ieder artikel heeft wel html opmaak in de omschrijving.

Ik kan me ook niet bedenken welke betaalmethode de omschrijving nodig heeft voor het valideren van de order.

Share this post


Link to post
Share on other sites

Inderdaad ik heb de omschrijving waar er dit "->","<-"," >" of "<" staat verwijderd in de omschrijving en het probleem was opgelost.

Ik denk zelfs dat hij een probleem heeft met "=" (moet ik nog testen)

Maakt niet uit welke betaalmodule ik gebruik.

Als ik deze tekens niet gebruik, is er geen probleem. ( om het even welke betaalmodule)

Zodra er een van deze tekens in de omschrijving staat, dan kan ik de winkelwagen niet valideren.

Hoe ik dat moet oplossen weet ik nog niet. (Ik heb 1201 artikels waar deze tekens in voorkomen).

 

Voorbeeld probleem:

 

http://www.quadwinke...-ring-geel.html

 

Nog een voorbeeld van een probleem:

 

http://www.quadwinke...rizzly-07-.html

 

Geen probleem:

 

http://www.quadwinke...zzly-02-06.html

 

Als er iemand een oplossing weet, dan hoor ik het graag.

Ik kan onmogelijk alle beschrijvingen gaan veranderen.

Edited by quadfun (see edit history)

Share this post


Link to post
Share on other sites

Inderdaad ik heb de omschrijving waar er dit "->","<-"," >" of "<" staat verwijderd in de omschrijving en het probleem was opgelost.

Ik denk zelfs dat hij een probleem heeft met "=" (moet ik nog testen)

Als ik deze tekens niet gebruik, is er geen probleem.

Zodra er een van deze tekens in de omschrijving staat, dan kan ik de winkelwagen niet valideren.

Hoe ik dat moet oplossen weet ik nog niet. (Ik heb 1201 artikels waar deze tekens in voorkomen).

 

Voorbeeld probleem:

 

http://www.quadwinke...-ring-geel.html

 

Nog een voorbeeld van een probleem:

 

http://www.quadwinke...rizzly-07-.html

 

Geen probleem:

 

http://www.quadwinke...zzly-02-06.html

 

Als er iemand een oplossing weet, dan hoor ik het graag.

Ik kan onmogelijk alle beschrijvingen gaan veranderen.

Het probleem zit dus zo te zien niet in de beschrijving/korte beschrijving maar de daadwerkelijke productnaam.

Dit is te voorkomen door het "=" teken te encoden zodat PHP het niet parsed. Het "=" teken moet dan worden vervangen door "="

Voor je huidige catalogus kun je dat overigens doen door met phpmyadmin de ps_product_lang tabel te exporteren, het .sql resultaat te bewerken met notepad/notepad++ en iedere verwijzing van "=" in de description veld te vervangen door "=".

Na bewerken weer importeren met phpmyadmin.

Share this post


Link to post
Share on other sites

Probeer eens een andere charset in de head van je pagina

 

nu

<meta http-equiv="Content-Type" content="application/xhtml+xml; charset=utf-8" />

 

voor testen

<meta http-equiv="Content-Type" content="application/xhtml+xml; charset=ISO-8859-1" />

Edited by Frens (see edit history)

Share this post


Link to post
Share on other sites

Ik heb dit probleem bij elke bestelling erg lastig.

Maar heb geen rare tekens in mijn beschrijving. Met een test product zonder beschrijving doet hij het ook. Maar alleen bij betaling via IDEAL.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More