Jump to content

Recommended Posts

Hallo,

 

We zijn laatst overgegaan op een eigen server omdat het andere host te traag werd. Ik heb alleen nu een paar probleempjes. De vorige winkel is ook nog online en daar heb ik deze problemen niet.

Als ik iets in mijn winkelwagen doe en dan nog even verder ga shoppen en na ongeveer 5 min wil ik afrekenen krijg ik de melding dat mijn winkelwagen leeg is.

 

Ook wilde ik een paar aanpassingen in mijn winkelwagen layout maken. De wijzigingen in het css bestand zijn wel zichtbaar maar in shoppingcart.tpl is niet zichtbaar. Hij verwijst op de site nog steeds naar gif bestand en in het bestand shoppingcart.tpl naar png bestanden.

 

Ik werk met versie 1.4.4.1. Compliceren forceren staat aan en cache staat uit. ik heb ook de cache van tools/smarty en tools/smarty_v2 geleegd. en de cache in mijn root.

Heeft iemand een idee waar dit aan kan liggen? alvast bedank.

 

Mark

Share this post


Link to post
Share on other sites

ik weet niet of het er iets mee te maken heeft maar ik krijg ook de volgende foutmelding als ik de cache uitzet en compliceren foceren aan, deze foutmelding komt op de plek van de subcategorieen in het menu (linkerkolom frontstore):

 


  • Warning: include(/storage/web/public/sites/www.elektrastunt.nl/tools/smarty/compile/032bae21dd1f79a970f93eb71f3fd0bfb8401f27.file.category-tree-branch.tpl.php): failed to open stream: No such file or directory in /storage/web/public/sites/www.elektrastunt.nl/tools/smarty/sysplugins/smarty_internal_template.php on line 433 Warning: include(): Failed opening '/storage/web/public/sites/www.elektrastunt.nl/tools/smarty/compile/032bae21dd1f79a970f93eb71f3fd0bfb8401f27.file.category-tree-branch.tpl.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /storage/web/public/sites/www.elektrastunt.nl/tools/smarty/sysplugins/smarty_internal_template.php on line 433

Share this post


Link to post
Share on other sites

Hoi ,

Maak op je server je cache en compile map leeg ,,

deze vind je in


  • /tools/smarty/compile/

en /tools/smarty/cache/

 

de foutmelding verwijst naar een bestand in je compile folder ,,

Share this post


Link to post
Share on other sites

Hoi maconl, bedankt voor t snelle antwoord,

 

Ik heb de mappen tools/smarty/cache , tools/smarty/compile en tools/smarty_v2/cache, tools/smarty_v2/compile geleegd.

Ook heb ik de cache van mijn browser geleegd. maar niks helpt.

 

Het bestand waar de foutmelding naar verwijst bestaat gewoon. hij zegt alleen dat hij hem niet kan openen. ik snap niet waarom want alle rechten staan goed.

 

het vreemde is dat als ik andere bestanden aanpas het wel zichtbaar is maar bij shoppingcart.tpl is het niet zichtbaar.

dit is een 1 op 1 kopie van een andere shop waar alles wel naar behoren werkt.

 

Mark

Share this post


Link to post
Share on other sites

Hoi maconl, bedankt voor t snelle antwoord,

 

Ik heb de mappen tools/smarty/cache , tools/smarty/compile en tools/smarty_v2/cache, tools/smarty_v2/compile geleegd.

Ook heb ik de cache van mijn browser geleegd. maar niks helpt.

 

Het bestand waar de foutmelding naar verwijst bestaat gewoon. hij zegt alleen dat hij hem niet kan openen. ik snap niet waarom want alle rechten staan goed.

 

het vreemde is dat als ik andere bestanden aanpas het wel zichtbaar is maar bij shoppingcart.tpl is het niet zichtbaar.

dit is een 1 op 1 kopie van een andere shop waar alles wel naar behoren werkt.

 

Mark

Hoe staan de rechten op de /tools/smarty/compile/ folder dan, en hoe staan de rechten van de bestanden in die folder?

Share this post


Link to post
Share on other sites

Al die mappen en bestanden heb ik chmod 777 gegeven. Vandaag de /tools map nog een keer overgezet en de foutmelding is weg.(chmod is nu 644 voor de bestanden)

Het bestand shoppingcart laat nog steeds niet de wijzigingen zien. De hoofdmap van het thema en shoppingcart.tpl heb ik ook chmod 777 gegeven maar hij geeft nog geen wijzigingen weer. (Op de site waar alles t wel doet staat hoofdmap van het thema op 775 en shoppingcart.tpl op 644.)

 

Ik heb nog iets waar ik niet uitkom, als ik inlog in de shop (front) met een verkeerd wachtwoord , komt boven het inlogscherm een error melding te staan:

Er is 1 fout :

  • Authentication failed

 

Ik wil deze foutmelding vertalen/omzetten naar "u heeft een verkeerd wachtwoord of gebruikersnaam ingevoerd".

 

Weet iemand waar ik dit kan doen?

Bedankt voor het meedenken

 

Mark

Share this post


Link to post
Share on other sites

probleem van shoppingcart is opgelost.

 

Ik wilde de knoppen veranderen van quantity up en quantity down. In shopping-cart.tpl staat hier een stuk code over en dat had ik aangepast. Ik zat net iets verder te kijken dan mijn neus lang is en precies dezelfde stuk code staat ook in shopping-cart-product-line.tpl Hier verwijst hij nog naar de .gif bestand ipv de .png bestanden waarin ik het had gewijzigd. heb de code in shoppingcart.tpl verwijderd en alles werkt nog normaal.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More