Jump to content

I want to increase server's maximum upload file size


Recommended Posts

Hi,

 

I am trying to make a downloadable product that has 81mb. I cannot upload it to the server because i receive the following message:

Your server's maximum upload file size is 64M.

I want to increase this limit, how do i proceed ?

 

Thank you!

 

I run on 1.5.2 version

  • Like 1

Share this post


Link to post
Share on other sites

Hi, connect with your hosting provider or try one of it:

1) php.ini

 

memory_limit = 256M

upload_max_filesize = 256M

post_max_size = 256M

 

2) .htaccess

 

php_value memory_limit 256M

php_value upload_max_filesize 256M

php_value post_max_size 256M

 

 

Regards

Edited by Alexander Simonchik (see edit history)
  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 7 months later...

I also still have this problem. My file size in the back end shows 25MB but I can still only upload 2MB and less. The techs at my hosts are running a suPHP on the server because I had to place the php.ini file in my main directory. If I placed the php.ini file in my PrestaShop directory, it didn't work.

 

The following is the message I received from the host. This is the only way to show the increased limits in the back end.

 

"I have moved the php.ini file to your public_html directory and set the suPHP_ConfigPath in order to apply the php.ini file recursively according to the KB article at http://kb.acenet.us/How_to_make_a_php.ini_file_apply_to_all_subdirectories . The upload settings now show increased limits."

 

 

Any ideas?

Share this post


Link to post
Share on other sites
  • 2 years later...
  • 7 months later...

It;s not diffiuclt.

 

If you CANNOT  edit php.ini  or htacces  I've this tips:   You must acces Direct Admin Account.  Make 3 browser tabs

 

1 First open your product (vritual product) in a browswer tab

2 Open you Direct admin in antoher tab of your browser

3 Open you preferences in PRestashop backoffice, by the upload size settings.

 

Al those Three tabs must open.  

 

Go to your first tab first Ad your uppload virtual product   Thisproduct.zip  (BUT NOT SAVE)

Go to Direct admin, and settings set on php module version:  NATIVE and SAVE

Go to third tab and change te prestahop backend upload size to 600 (megabytes) SAVE.

Go back to the first tab and Click SAVE and STAY...   Wait, and now upload is succesfull.

 

Go back to your php settings in direct admin, and set this to current 7.0 version,  SAVE your module set.

You can set back in orginal settings the prestashop backend upload settiings, but' its not nessescsy.

 

Works in 1.6 PRestashop.

-------------------------------

Go to http://www.hideurlscript.com  for  hide your files url path like mp4 video in source code! And in browser address.

Share this post


Link to post
Share on other sites
  • 1 year later...
  • 1 year later...
  • 4 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More