Jump to content

[Résolu] PROBLEME AFFICHAGE FLASH.swf sur IE


Recommended Posts

J'ai cherché dans le forum des cas similaires au mien, mais je n'y ai rien compris.
Je reste ce soir à 03:00 SANS AUCUNE SOLUTION !!!!!!!

PLEASE HELP PLEASE

Mon header ne s'affiche pas sur IE !!!!!
Par contre tout est OK sur FF

Merci d'avance pour votre votre aide !

Share this post


Link to post
Share on other sites

bon je ne trouve toujours pas la solution

j'ai eu l'information suivante :

" ... dans ton div sotewsadds,
tu mets :


mais il faut ecrire l'adresse complete du swf sinon il risque de pas trouver, car t'as pas le nom exact du fichier qui est :
proxilys2_fr.swf

je suppose que c'est :


mais faut verifier l'emplacement evidemment...."

PB : je ne peu pas ouvrir le fichier header.?????? car il n'a pas d'extension.

Alors, je le met en telechargement sur ce lien (7jrs) : http://www.yousendit.com/download/cmczYkJqTStvQnNLSkE9PQ
Mon fichier s'appelle bien proxilys2_fr.swf
et se trouve dans /www/modules/sotewsadds/files

JE RAPPELE MON PB : ANIMATION FLASH N'APPARAISSANT PAS DANS Internet Explorer IE, mais apparaissant dans Firefox FF.

cdlt

9133_rUKg3h5NX0HoEsHnjT2a_t

Share this post


Link to post
Share on other sites

l'extension du fichier header.tpl n'apparait pas dans ton explorateur parce que windows n'affiche pas les extensions, ou alors seulement les extensions dont le type est connu (ie associées à une application pour open/edit), dans les options "affichage", tu peux régler ça.

Sinon fais glisser le fichier sur un éditeur de texte. Ou si tu as un éditeur avancé, genre UltraEdit : clic-droit "UltraEdit" ...

Share this post


Link to post
Share on other sites

je ne comprends pas ton problème pour trouver la solution, ananly, je t'ai donné le lien poitant sur une réponse dans mon sujet !!

je vais la retranscrire ici, ma fois, en plus détaillé :


Ce n’est pas un problème de “chemin relatif d’accès” ni de nom de fichier non reconnu. C’est tout simplement parce que encore une fois, j’ai donné la possibilité de rajouter des éléments graphiques entre les balise <head> et </head>, qui se trouve donc ne pas être le haut de page mais l'emplacement pour des éléments non graphiques, tels du javascript ou des balises META. C'est une erreur de ma part.

Firefox déplace de lui même l‘élément juste au début de la balise <body>, tandis que IE applique exactement le principe de l’HTML : si tu sais pas faire, tu fais pas.

La solution la plus rapide à ce niveau pour ajouter un élément dans le haut de page ainsi est de prendre l’HTML généré par mon module (en regardant le code source de la page vue avec firefox et en cherchant tout ce qu’il y a entre les commentaires “Modules SotEW’s Adds”) et le placer directement dans le fichier header.tpl, juste APRES la balise <body>

Share this post


Link to post
Share on other sites

bonjour ,
@Alekhine
Merci de ton aide, j'ai déjà essayé plein de logiciel, explorer me dit que c'est un fichier MIME, mais il n'y a aucune extension, alors j'ai essayé avec MAcromediat, winzip, stuffit...rien ne fonctionne. impossible pour moi d'ouvrir ce fichier, je vai essayé avec le logiciel que tu me conseil

@SotEW

Je rame depuis des jours et c'est peu de le dire. néanmoins, mon problème peut paraitre banal pour un pro, mais je n'en suis pas une.
Ton programme est génial, juste que je ne dors pas la nuit pour trouver une P£@%# de solution a ce foutu problème et là, je touche le fond.

Bref, je vais tenter de déplacer le code comme tu me l'as dit, mais comme j'y connais rien en code, j'ai déjà un doute.

[La solution la plus rapide à ce niveau pour ajouter un élément dans le haut de page ainsi est de prendre l’HTML généré par mon module (en regardant le code source de la page vue avec firefox et en cherchant tout ce qu’il y a entre les commentaires “Modules SotEW’s Adds”) et le placer directement dans le fichier header.tpl, juste APRES la balise <body>]

je teste...

Share this post


Link to post
Share on other sites

Merci SotEW
J'ai réussi à copier le code dans le header.tpl (je te l'envoie quand même en MP)

Alors maintenant, J'ai 2 X mon flash sur ma page FF et 1 X sur IE
J'essaie de supprimer la ligne avec Firebug pour FF.

Pas évidant, je bug ( Haaa y a toujours un soucis qq part)

:-S c'est déprimant :-S

Share this post


Link to post
Share on other sites

Après avoir copié manuellement le code à l'endroit souhaité il faut désactiver ce bloc dans le module "Sotew"...
Parce que sinon ce module continue à injecter le code de l'affichage du flash dans le HEAD (visible sur FF et pas sur IE), or vous venez de l'ajouter au BODY (il est en double :P )

Share this post


Link to post
Share on other sites

Maintenant que vous avez placé le HTML directement dans le code (BODY du header.tpl), vous pouvez éventuellement modifier directement le nom du fichier dans ce code statique pour utiliser un autre swf.

Si cela pose un problème à cause d'autres paramètres, comme la dimension par exemple, servez-vous du module pour ajouter votre nouveau swf, et faites exactement comme vous venez de le faire : récupérez le code créé dynamiquement pas le module dans le HEAD pour le placer à la place de l'autre dans le BODY; et enfin, désactivez le swf en question du module puisque vous n'avez plus besoin de lui pour injecter le code (vous évitez ainsi le cas du swf en double sur FF...)

Pour résumer : Dans ce cas de figure le module ne vous sert qu'à créer le HTML dont vous avez besoin pour le placer dans le BODY.

Alek.

Share this post


Link to post
Share on other sites

Mille MERCIS Alekhin et SotWE et tous les autres...

Mon problème est maintenant résolu

Je vais pouvoir mettre mon nouveau flash!

Encore MERCIS
ET a bientôt
:-)

Share this post


Link to post
Share on other sites

promis, je trouverais une solutions pour ce problème pour la prochaine version ( quitte à faire un nouveau hook.)

Et sinon, très bonne réponse de Alekhine, merci à toi.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More