Jump to content
exadra37

[Dica] Configuração Do Servidor Com Php.ini Optimizado Para Prestashop

Recommended Posts

Como vc previo estou realmente com o problema de tradução, pedi para meu servidor aumentar p mim e olha a resposta

:

"Tendo em vista que trata-se de um ambiente compartilhado, infelizmente não é possível ser realizado o aumento do limite de "max_input_vars"

 

colei o ficheiro que vc disponibilizou mas ainda não consegui fazer a tradução, teria outro jeito?

Share this post


Link to post
Share on other sites

Este ficheiro só consegue alterar as configurações do servidor se o mesmo estiver configurado para o ler na raiz da sua pasta e aceitar incondicionalmente as alterações, o que parece não ser o caso.

 

Procure na net como colocar a mesma directiva max_input_vars pelo ficheiro .htaccess ... pode ser que resulte ;)

 

Adicione ao ficheiro .htaccess, que está na raiz da pasta da sua loja.

php_value max_input_vars 10000

 

Se o seu servidor utilizar o Suhosin para o PHP, acrescente estas linhas ao .htaccess

php_value suhosin.request.max_vars 10000
php_value suhosin.post.max_vars 10000

 

Como já disse muitas vezes, grande parte dos problemas que os utilizadores das plantaformas de comércio electrónico enfrentam estão diretamente relacionados com o serviço de hospedagem que escolhem... um serviço de alojamento partilhado é o mais indicado para pequenos blogs e sites de conteudo estático, já para lojas online, que possuem conteúdo dinâmico e são muito mais exigentes em termos de recursos já é necessário a contratação de outro tipo de serviço mais especializado.

 

Eu aprendi isto da maneira mais dificil, ou seja depois de muitas horas e dias perdidos a tentar resolver o mais variados tipos de problemas e após ter utilizado vários tipos de serviços de hospedagem, acabei por criar o meu próprio servidor optimizado só para Prestashop e que costumo disponibilizar aos clientes para os quais desenvolvo trabalhos de programação.

  • Like 8

Share this post


Link to post
Share on other sites

Ok! não deu certo servidor! é uma porcaria mesmo, vc pode me indicar um servidor que atenda as configurações do prestashop?

Share this post


Link to post
Share on other sites

Coloque um print screen das configuraoes da sua loja online, que pode ver em Advanced Parameters -> Configuration Information .

Share this post


Link to post
Share on other sites

olá, isto tambem serve para mim, é para por em public_html??

Share this post


Link to post
Share on other sites

Crie um arquivo php.ini com as diretivas das quais você precisa, uma por linha.

Exemplo:

register_globals = off

magic_quotes_gpc = off

max_input_vars = 5000

 

Pronto é só colocar o php.ini que você criou dentro do diretório /public_html.

Obs: verifique se você tem dentro da pasta /public_html um arquivo chamado ".htaccess" você deve editar este arquivo inserindo a seguinte linha:

 

suPHP_ConfigPath /home/LOGIN/public_html

 

Substitua a palavra LOGIN por seu login do Cpanel ou FTP.

 

Pronto devolva o arquivo ao seu servidor e atualize sua loja.

  • Like 2

Share this post


Link to post
Share on other sites

Bem vindo á nossa comunidade @higorsilvarosa :)

 

È sempre bom saber que o meu tópico foi útil!!

 

Sempre que algum tópico ou post lhe for útil, por favor clique no botão Like This, pois assim estará a incentivar o seu autor a ser mais participativo e contribuitivo para a nossa comunidade ;)

  • Like 2

Share this post


Link to post
Share on other sites

Bem vindo á nossa comunidade @higorsilvarosa :)

 

È sempre bom saber que o meu tópico foi útil!!

 

Sempre que algum tópico ou post lhe for útil, por favor clique no botão Like This, pois assim estará a incentivar o seu autor a ser mais participativo e contribuitivo para a nossa comunidade ;)

 

Muito obrigado pelas boas vindas.

 

Vou passar a usar os recursos do fórum melhor e apertar o botão Like This mais vezes ;) Assim como no Prestashop, estou pegando o jeito da coisa ainda.

  • Like 2

Share this post


Link to post
Share on other sites

exadra67, estive vendo seu post, porém estou usando a versão mais recente do Prestashop, procurei na instalção o arquivo .httaccess e não o encontrei. Será que ocorreu erro na instalação??

Share this post


Link to post
Share on other sites

O ficheiro .htaccess é um ficheiro escondido, pelo que deve ter a opção de mostrar ficheiros escondidos no file manager que estiver a utlizar.

 

De qualquer forma, se o mesmo ainda não foi gerado, e como diz que utiliza a versão mais recente, portanto superior a 1.5.x, pode ir em Preferences > Seo & URL's e a meio da página clicar em Save, para que o mesmo seja gerado ;)

  • Like 2

Share this post


Link to post
Share on other sites

Galera que tem o Prestashop em um servidor em uma hospedagem, comigo funcionou da seguinte forma, tentem o seguinte:

 

Dentro da pasta ADMIN do seu prestaShop crie um arquivo php.ini e adicione os códigos que o exadra37 postou!

 

 

Comigo funfo de boa, tendo em vista que eu também tentei falar com o provedor e eles me deram uma resposta negativa!

 

:)

 

Obs: Pode ser que algumas variáveis desse código não seja compativel com a versão do prestashop que esteja usando no seu sevidor, mas como teste eu adicionei a max_input_vars dessa forma no meu e corrigi o erro que apresentava quando eu estava tentando traduzir meu PS!

 

Espero ter ajudado vocÊs! :)

Edited by igorsantana2005
  • Like 2

Share this post


Link to post
Share on other sites

Galera que tem o Prestashop em um servidor em uma hospedagem, comigo funcionou da seguinte forma, tentem o seguinte:

 

Dentro da pasta ADMIN do seu prestaShop crie um arquivo php.ini e adicione os códigos que o exadra37 postou!

 

 

Comigo funfo de boa, tendo em vista que eu também tentei falar com o provedor e eles me deram uma resposta negativa!

 

:)

 

Obs: Pode ser que algumas variáveis desse código não seja compativel com a versão do prestashop que esteja usando no seu sevidor, mas como teste eu adicionei a max_input_vars dessa forma no meu e corrigi o erro que apresentava quando eu estava tentando traduzir meu PS!

 

Espero ter ajudado vocÊs! :)

 

FUNCIONOU CARA!!!!

VALEU!

Share this post


Link to post
Share on other sites

Galera que tem o Prestashop em um servidor em uma hospedagem, comigo funcionou da seguinte forma, tentem o seguinte:

 

Dentro da pasta ADMIN do seu prestaShop crie um arquivo php.ini e adicione os códigos que o exadra37 postou!

 

 

Comigo funfo de boa, tendo em vista que eu também tentei falar com o provedor e eles me deram uma resposta negativa!

 

:)

 

Obs: Pode ser que algumas variáveis desse código não seja compativel com a versão do prestashop que esteja usando no seu sevidor, mas como teste eu adicionei a max_input_vars dessa forma no meu e corrigi o erro que apresentava quando eu estava tentando traduzir meu PS!

 

Espero ter ajudado vocÊs! :)

 

Não existe a necessidade de criarem o ficheiro... basta fazerem o download do php.ini.zip e descompactar o mesmo na raiz da loja e assim o ficheiro fica válido para toda a loja ou se apenas quiserem os valores válidos para o back-office é que deverão coloca-lo somente na pasta admin.

 

Atenção que se colocarem o ficheiro na raiz da loja, não será necessário colocá-lo em mais nehuma pasta da vossa loja.

 

Se não funcionar terão de utilizar um ficheiro .htaccess com os valores devidamente convertidos ;)

  • Like 1

Share this post


Link to post
Share on other sites

olá exadra37, este ficheiro é para por em public_html certo??

 

ha algum sitio onde possamos comparar as defenições antes e depois de pormos o ficheiro?

cumprimentos

Share this post


Link to post
Share on other sites

Sim é no public_html

 

Depois pode verificar no backoffice do prestashop no separador Desempenho

 

Cumps

Share this post


Link to post
Share on other sites

olá, separador desempenho??

nao estou a encontrar, tem outro nome??

 

cumprimentos

 

Sim é no public_html

 

Depois pode verificar no backoffice do prestashop no separador Desempenho

 

Cumps

Share this post


Link to post
Share on other sites

Coloque um print screen das configuraoes da sua loja online, que pode ver em Advanced Parameters -> Configuration Information .

 

Verifique se não será este o separador ...

 

Pode também criar um ficheiro info.php na raiz da sua loja, onde colocou o php.ini.

 

Num editor de texto, tipo o wordpad crie um ficheiro com o nome info.php e depois escreva o seguinte código:

<?php
phpinfo();
?>

 

 

Agora faça o upload para o servidor e acesse com www.oseudominio.com/info.php .

Share this post


Link to post
Share on other sites

olá

 

aguardo informação, se é razoalvel ou não.

Edited by Speed2010

Share this post


Link to post
Share on other sites

Não é bom partilhar este tipo de informação com um link directo para o seu servidor, pelo que aconselho-o a apagar o ficheiro após ter verificado a sua configuração.

 

Para verificar se cada uma das configurações do php.ini deste tópico foram assumidas basta clicar em ctrl+f no seu browser, que aparecerá uma caixa de pesquisa, onde deverá colocar o nome da configuração e ver se o valor que aparece é igual ao da que está colocada no ficheiro php.ini.

Share this post


Link to post
Share on other sites

olá, e qual o nome da configuracao ke tinha de por?

nao percebo muito disso, so queria saber se é razoavel ou nao. onde tenho de ver se os valores sao bons ou nao??

Edited by Speed2010

Share this post


Link to post
Share on other sites

olá exadra37, pelo que tive a ver, o meu servidor, sem o ficheiro ou com o ficheiro, continua igual, por exemplo

 

Exemplo de alguns dados:

 

Meu servidor:

max_execution_time: 60

max_input_time: 120

max_input_vars: 4096

memory_limit: 256M

 

Teu Ficheiro:

max_execution_time: 120

max_input_time: 180

max_input_vars: 10000

memory_limit: 128M

 

 

O servidor não deve estar a assumir o teu ficheiro, com estes dados o servidor é razoável?

 

aguardo informação

cumprimentos

Edited by Speed2010

Share this post


Link to post
Share on other sites

As suas configurações para uso normal da loja online são sufecientes e até excedem no caso do limite de memória.

 

Entretanto se ler com atenção o meu tópico eu afirmo lá que existem serviços de alojamento que não suportam o php.ini.

 

A solução passa por pedir ao seu provedor para lhe activar esse ficheiro, o que eu duvido que aconteça se for um serviço de alojamento partilhado ou por colocar as mesma directivas de configuração do php.ini no ficheiro .htaccess, conforme já mostrado num dos primeiros posts.

 

Se optar por esta última solução deverá procurar a sintaxe correcta para cada uma das configurações no Google ou qualquer outro motor de pesquisa da sua prefrência.

 

De salientar que mesmo pelo .htaccess os valores podem não ser assumidos se o servidor estiver configurado para ignora-los.

 

Quando tiver tempo efectuarei outro tópico sobre como colocar as mesmas directivas de configuração do php.ini através do .htaccess ;)

Share this post


Link to post
Share on other sites

Boa tarde,

 

Venho apenas agradecer, depois de até ter "encostado" o projecto da minha pagina por alguns meses por não conseguir ultrapassar o facto de estar a com erro "max_input_vars 1000" quando tentava actualizar as traduções do backoffice, formulários etc.. Uso o prestashop 1.5.2.0 e o wampserver 2.2, php 5.3.13, para funcionar tive de copiar o código do ficheiro partilhado pelo exadra37 e acrescentar ao código do ficheiro php que no meu caso está na raiz do wampserver \wamp\bin\php\php5.3.13\php.ini.

 

Agradeço desde já a ajuda partilhada e espero ajudar com mais esta informação.

 

Abc

Share this post


Link to post
Share on other sites

Bem vindo á nossa comunidade @rcarvalho :)

 

Obrigado por ter compartilhado a sua dica.

 

Sempre que um post ou tópico lhe for útil não se esqueça de agradecer ao seu autor, clicando em Like This, pois estará a incentivar o mesmo a ser mais contributivo para a comunidade.

Share this post


Link to post
Share on other sites

Esse ficheiro é o init.php que aparece na raiz do public_html?

Obrigado e parabéns pelas ajudas que tem dado à malta!

Edited by Marco Oliveira

Share this post


Link to post
Share on other sites

Sim é colocado no www ou public_html (São a mesma pasta)

Share this post


Link to post
Share on other sites

Esse ficheiro é o init.php que aparece na raiz do public_html?

Obrigado e parabéns pelas ajudas que tem dado à malta!

 

o ficheiro init.php não é a mesma coisa que o ficheiro php.ini, pois são coisa totalmente diferentes.

 

php.ini é usado para alterar as configurações do php no servidor.

 

init.php é utilizado para correr o prestashop.

Share this post


Link to post
Share on other sites
O ficheiro .htaccess é um ficheiro escondido, pelo que deve ter a opção de mostrar ficheiros escondidos no file manager que estiver a utlizar. De qualquer forma, se o mesmo ainda não foi gerado, e como diz que utiliza a versão mais recente, portanto superior a 1.5.x, pode ir em Preferences > Seo & URL's e a meio da página clicar em Save, para que o mesmo seja gerado ;)

 

 

Nossa muiiitooo obrigada, foi de muita ajuda!! Eu estou com o Prestashop instalado em Localhost ainda, e pensei que nao seria possivel fazer as traducoes, mas com a sua ajuda deu tudo certo. Valeu!! :D

Share this post


Link to post
Share on other sites

todas mudanças no php.ini eu posso fazer pq meu plano eh VPS

 

porém nada faz funcionar o upload de imagens!!!!!

 

"error undefinied"

Share this post


Link to post
Share on other sites

Bem vindo á nossa comunidade @workzbr ;)

 

Efectue uma pesquisa no fórum que irá encontrar a resposta á sua questão, pois já foi colocada e respondida várias vezes.rigado

 

Obrigado

Share this post


Link to post
Share on other sites

naaao! procurando há 3 dias....

todas as dicas e nada da certo

 

no mesmo vps tenho varias aplicacoes com download de imagens, musicas e até video com mencoder

 

o problema eh no prestashop creio eu...

 

qto ao mod_security o pessoal do hosting deu essa dica:

 

http://forum.hostdime.com.br/showthread.php/427-Apache-mod_security?highlight=mod_security

 

q nada adiantou no meu caso.

Share this post


Link to post
Share on other sites

realmente Exadra.. fiz tudo.. segui todos os posts... enfim... nao tem como...

instalei em outros 2 dominios diferentes e da a mesma coisa

 

como estou utilizando o softcoulos do meu vps, vou baixar a versao oficial (apesar de ser a mesma) pra desencargo de consciência..

Share this post


Link to post
Share on other sites

Boa noite,

Estou com esse problema quando tento modificar as traduções:

 

'Atenção, o seu provedor de hospedagem está usando o patch Suhosin para PHP, o que limita o número máximo de campos para postar em um formulário: 1000 para suhosin.post.max_vars.

1000 para suhosin.request.max_vars.

Por favor, pergunte ao seu provedor de hospedagem para aumentar a pós suhosin e solicitar um limite de 1433 pelo menos ou editar o arquivo de tradução manualmente.'

 

Alguma sugestão?

Obrigado

Edited by blooddark

Share this post


Link to post
Share on other sites

Bem vindo á nossa comunidade @blooddark ;)

 

Por favor leia com atenção os posts deste tópico que irá encontrar a resposta para a sua questão.

 

Obrigado pela compreensão.

Share this post


Link to post
Share on other sites

Bem vindo á nossa comunidade @blooddark ;)

 

Por favor leia com atenção os posts deste tópico que irá encontrar a resposta para a sua questão.

 

Obrigado pela compreensão.

 

Obrigado!

Por favor, dê uma olhada nessa imagem para mim. Sou novo no prestashop!

O arquivo php.ini está no diretório correto, certo?

Não encontrei o arquivo .htaccess pra adicionar as 2 linhas que você disse num post acima quando se trata do Suhosin!

 

Imagem:

phpini.png

Edited by blooddark

Share this post


Link to post
Share on other sites

Basta colocar a imagem 1 vez... por favor edite o tópico e corrija.

 

O ficheiro php.ini tem de ficar no root da pasta da loja, que no seu caso deverá ser dentro da pasta prestashop onde também deverá encontrar o ficheiro .htaccess .

Share this post


Link to post
Share on other sites

Basta colocar a imagem 1 vez... por favor edite o tópico e corrija.

 

O ficheiro php.ini tem de ficar no root da pasta da loja, que no seu caso deverá ser dentro da pasta prestashop onde também deverá encontrar o ficheiro .htaccess .

 

Certo, coloquei o php.ini dentro dessa pasta!

No entanto, só consegui achar .htaccess utilizando um programa de FTP.

Em todo caso, quando adicionei as 2 linhas:

 

 

php_value suhosin.request.max_vars 10000
php_value suhosin.post.max_vars 10000

 

 

O site fica offline!

 

 

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@gmoshop.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Edited by blooddark

Share this post


Link to post
Share on other sites

Não existe necessidade de efectuar quotes da totalidade do post imediatamente anterior ao que acabou de colocar, pois não existe nenhum outro post a quebrar a sequência.

 

Experimente:

<Ifmodule mod_php5.c>
  php_value suhosin.request.max_vars 10000
  php_value suhosin.post.max_vars 10000
</Ifmodule>

 

Senão resultar entre em contacto com o seu provedor de alojamento.

Share this post


Link to post
Share on other sites

Boas exadra37 e demais utentes do Fórum,

 

Hoje com a versão 1.5.4.1 tive que aumentar o valor para os 15000 devido à tradução dos módulos. Enfim...

 

Obrigado.

Share this post


Link to post
Share on other sites

Mais uma dica para que tem o suhosin ativado, altere os 2 seguintes parâmetros:

suhosin.post.max_name_length = 150
suhosin.request.max_varname_length = 150

o default de ambos é 64.

 

No meu caso, tive um problema em que a tradução de um dos TPLs do front office teimava em não gravar, e isto solucionou o problema.

Share this post


Link to post
Share on other sites

Boas a todos

 

Segui todas as indicações aqui colocadas, e apenas consigo aceder à tradução dos módulos se colocar o ficheiro php.ini na pasta "Admin".... o problema é que ao gravar as traduções feitas vai parar à "pagina não encontrada" e não grava as traduções efectuadas....

 

Se colocar apenas no root do site nem consigo aceder às traduções dos módulos...

 

A versão do Presta é a 1.5.5 e a do PHP é 5.3.18

 

Algumas sugestões??

 

Cumps

Edited by jcoke

Share this post


Link to post
Share on other sites

Estou com o mesmo problema do jcoke.

Antes estava com o problema do max_input_vars, o que foi resolvido quando inserir o arquivo .user.ini com o valor max_input_vars = 4000 dentro da pasta onde está instalado o prestashop. Só assim funcionou. Colocando apenas no public_html nada funcionava e dava erro ao clicar na bandeira em traduções.

 

Agora, que já consigo visualizar os campos a serem alterados, quando clico em salvar, vai para o Erro 404 - Pagina não encontrada, do Prestashop.

 

Curioso é que isso só está ocorrendo quando tento salvar uma tradução do tema que instalei. Se faço no Default, funciona normal!

 

Alguém tem idéia de como resolver este problema?

Share this post


Link to post
Share on other sites

Boa tarde,

 

Pode ser um problema com o Tema escolhido.

Já verificaste se é compatível com a versão do PS que estás a usar?

Tens as opções desativadas? Em Preferences -> SEO & URL...

Disable apache multiviews

Disable apache mod security

Share this post


Link to post
Share on other sites

Boa tarde,

 

Pode ser um problema com o Tema escolhido.

Já verificaste se é compatível com a versão do PS que estás a usar?

Tens as opções desativadas? Em Preferences -> SEO & URL...

Disable apache multiviews

Disable apache mod security

Do tema acho difícil pois são dois sites diferentes, 1 com tema instalado e outro com o tema default da instalação do Presta e ambos dão o mesmo erro....

 

Mas vou testar essas opções...

 

Cumps

Share this post


Link to post
Share on other sites

@Jonadabe

 

Tentei com essas opções activadas e desactivadas e continuam a ir para a pág. não encontrada ao salvar as traduções.... :(

Share this post


Link to post
Share on other sites

Pessoal, o meu caso foi resolvido quando mudei para um servidor VPS e o pessoal do suporte configurou todo pra mim de acordo com as recomendações daqui do forum.

 

Agora está tudo ok.

Estou com um problema com o PagSeguro que abri um tópico, mas nao tive respostas.

Se alguem puder me ajudar, o link do tópico é este: http://www.prestashop.com/forums/topic/281744-pagseguro-não-está-gerando-faturas/

Share this post


Link to post
Share on other sites

Boa tarde, nenhuma alteração descrita neste tópico resolveu a questão.

 

Instalei o php.ini, alterei o .htacess e continuo sem acesso as traduções no cms.

 

existe outra maneira de fazer traduções? 

 

obrigado

Share this post


Link to post
Share on other sites

Bem vindo á nossa comunidade @ricbt :)

 

Por favor pesquise bem no fórum que existem vários tópicos relacionados com o seu problema.

 

Se nenhum tópico lhe resolver o problema, por favor abra o seu próprio tópico e não se esqueça de ser o mais detalhado possível.

 

Obrigado pela compreensão ;)

Share this post


Link to post
Share on other sites

Grato pela mensagem de boas vindas, exadra37.

 

Procurei com bastante atenção nos tópicos, fiz as alterações sugeridas, mas infelizmente, por aqui, não deu certo. A mensagem de erro ao acessar as traduções no cms permanece e meu hosting (kinghost), não permite a alteração dos valores em servidor compartilhado.

 

O que está acontecendo é que quando baixei o tema http://addons.prestashop.com/pt/search.php?search_query=iSimple+Light+Blue , boa parte do site ficou em inglês e não estou conseguindo alterar.

 

Gostaria de saber se é possível alterar de outra forma que não seja via cms.

 

Pelo inspetor do browser, vejo que algumas traduções podem ser alteradas. Por exemplo, "shopping-cart summary" na página do carrinho. Só que também não estou achando esta html dentro dos arquivos do tema, nem nos arquivos do prestashop....

 

Obrigado

Ricardo

Share this post


Link to post
Share on other sites

O melhor é colocar o ficheiro sempre na pasta admin. E quando nao esta a ser utilizado renomear o mesmo. Porque a o risco de hack na loja ou servidor. Tudo que se possa correr com mais de 1000 carecteres é um risco de segurança tanto para a loja como para a conta :D Fica a dica. 

Share this post


Link to post
Share on other sites

Instalei esse php.ini tanto na raiz da loja como no admin e ainda não consigo acessar os modulos, ele da o erro abaixo:

 

Estou usando a versão 1.6.06.

 

[PrestaShop] Fatal error in module smarty_internal_parsetree:
Allowed memory size of 25165824 bytes exhausted (tried to allocate 3207 bytes)

 

O que fazer?

Edited by rcamu

Share this post


Link to post
Share on other sites

Boas,

 

Peça informações a empresa de alojamento de como e onde deve configurar o seu ficheiro php.ini.

 

 

Cumps

Share this post


Link to post
Share on other sites

Galera que tem o Prestashop em um servidor em uma hospedagem, comigo funcionou da seguinte forma, tentem o seguinte:

 

Dentro da pasta ADMIN do seu prestaShop crie um arquivo php.ini e adicione os códigos que o exadra37 postou!

 

 

Comigo funfo de boa, tendo em vista que eu também tentei falar com o provedor e eles me deram uma resposta negativa!

 

:)

 

Obs: Pode ser que algumas variáveis desse código não seja compativel com a versão do prestashop que esteja usando no seu sevidor, mas como teste eu adicionei a max_input_vars dessa forma no meu e corrigi o erro que apresentava quando eu estava tentando traduzir meu PS!

 

Espero ter ajudado vocÊs! :)

 

Grande!!!

 

Me salvou!!!  Aqui também funcionou de boa!

 

MAndei um ticket de suporte para o meu servidor pedindo para alterar o php.ini e eles me responderam que era impossível fazer isso no meu plano, que eu deveria pagar um servidor dedicado por R$700,00 por mês.....

 

Valeu!!!

Share this post


Link to post
Share on other sites

Este ficheiro php.ini contêm todas as configurações necessárias a um bom funcionamento de uma loja online Prestashop.

 

O mesmo deverá ser descompactado e colocado na raiz da sua conta de alojamento.

 

Alguns serviços de alojamento podem não suportar a utilização deste ficheiro ou terem limites para a utilização de alguns dos parametros usados no mesmo ou não suportarem sequer o uso dos mesmos.

 

Em último caso forneça o ficheiro ao seu serviço de hospedagem e solicite a sua activação.

 

Caso não consiga pondere mudar de serviço de hospedagem ;)

 

Exemplo do ficheiro para download:

 

[PHP]
	; By Exadra37 - Optimized php configuration for servers that use Prestashop Online Stores
	; This tips are inspired in http://www.prestatraining.com/12-tips-to-optimise-your-php-ini-file-for-prestashop/
	; Some are changed and i add others rules
	; Feel free to contribute with more tips to this php.ini file to optimize more the Prestashop Compability and Performance in the server
	;;;;;;;;;;;;;;;;;;;
	; About php.ini   ;
	;;;;;;;;;;;;;;;;;;;
	; PHP's initialization file, generally called php.ini, is responsible for
	; configuring many of the aspects of PHP's behavior.
	; How many GET/POST/COOKIE input variables may be accepted
	max_input_vars = 10000
	; Allow files to be uploaded
	file_uploads = On
	; Allow external URLs to be opened
	Allowllow_url_fopen = On
	; Disable PHP register globals
	register_globals = Off
	; Enable GZIP compression at the default level for best performance
	zlib.output_compression = On
	zlib.output_compression_level = 6
	; Load mcrypt extension
	extension=mcrypt.so
	; Disable PHP magic quotes
	magic_quotes_gpc = Off
	magic_quotes_runtime = Off
	magic_quotes_sybase = Off
	; Load PDO MySQL extension
	extension=pdo.so
	extension=pdo_mysql.so
	; Set memory limit in megabytes
	memory_limit = 128M
	; Set maximum execution time in seconds
	max_execution_time = 120
	; Set maximum file upload size in megabytes
	upload_max_filesize = 32M
	; Set maximum post size in megabytes
	post_max_size = 32M
	; Set maximum input time in seconds
	max_input_time = 180
Utilize-o por sua conta e risco ;)

 

attachicon.gifphp.ini.zip

 

 

Oi.

 

Joguei seu ficheiro descompatado em meu servidor FTP, na pasta /httpdocs, onde tenho os conteúdos do Presta. E não resultou. Também fiz um ficheiro com o nome de php.ini onde escrevi:

 

suPHP_ConfigPath /home/LOGIN/public_html
 
max_input_vars = 10000
 
Onde tem LOGIN, eu coloquei o nome de utilizador do FTP, mas nada. Depois alterei para o anfitrião, e nada. Tudo na mesma sem resultado nenhum.
 
Você pode ajudar? Possivelmente estou fazendo alguma coisa errada. 
Edited by promaniaeurope

Share this post


Link to post
Share on other sites

Olá, eu uso a ultima versão do prestahop,

O único arquivo no meu ftp que poderia ser o ini.php, tem o nome de init.php, isto é normal? e a loja tá dando problemas de mais e fui ver, as unicas linhas q tem dentro dele são estas:

 

if (isset(Context::getContext()->controller))
$controller = Context::getContext()->controller;
else
{
$controller = new FrontController();
$controller->init();
}
 
Socorro!!!
dá erro '500' o tempo todo, depois q mudei o site para a raiz, deu problema no BD, então contatei o provedor, eles resolveram, depois não parou mais d dar problemas, a area administrativa não consigo acessar.
 
Se vc pudesse me dar uma luz do que pode estar acontecendo.
 
Muito obrigado

Share this post


Link to post
Share on other sites

Olá Bom dia 

 

Eu estou com um servidor novo configurei php.ini porem meus clientes ainda encontra erros na instalação 

No caso pelo teste que pelo navegador com PrestaShop se não marcar opção criar Instalar e criar um Produto de demostração

A loja Instala sem erros

 

Mas quando marca essa opção gera um erro e pede para retornar a instalação.

 

Sendo assim não teria problema 

 

Sendo que alguns clientes usa o WebAcappella e com ele o e-commerce,e por ele não tem a opção de desmarcar  Instalar e criar um Produto de demostração

 

Ja recopilei o apache  e nada antes estava travando para instalar recopilei apache do servidor melhor mais ainda está esse erro

 

Php 5.4.35   Apache versão 2.4.10  open ssl 1.0

 

Onde posso arrumar esse erro.

 

Se alguém puder ajudar fico agradecido

 

Fico aguardo por uma ajuda.

Share this post


Link to post
Share on other sites

Já resolvi problema.

 

Através de um comentário de um membro em relação SOAP.

 

Dei uma configurada no php.ini  e Recopilei o apache com SOAP ativado funcionou aqui sem erros.

Edited by exadra37
Referenciava um post que foi removido

Share this post


Link to post
Share on other sites

Bom galera, depois de ter apanhado muito com as tentativas de corrigir o erro do "MAX_INPUT_VARS". 

 

Consegui resolver o problema da minha loja virtual. 

 

Era o seguinte:

 

Quando eu precisava editar as traduções dos módulos, via back-office aparecia o referido erro "MAX_INPUT_VARS"...

 

Utilizei o arquivo php.ini fornecido pelo nosso amigo exadra37, mas ao invés de colocar na pasta raiz, coloquei na pasta /admin.

 

Deu certo!

 

Valeu por todo apoio de todos, acredito que o conhecimento é para ser compartilhado, pois um dia podemos esquecer de certos procedimentos, e sempre é bom encontrar alguém disposto a nos "tirar do sufoco".

 

Cumps.

  • Like 2

Share this post


Link to post
Share on other sites

Ola .. boa noite,

sou do brasil e estou tendo os mesmos problemas de traduçao,

ja fiz todos os topicos, aqui dito, porem continua igual falei com a locaweb e a mesma disse oque todos ja sabem .. servidor compartilhado nao é possivel alteerar os valores,

gostaria de mais alguma dica, 

estou usando o prestashop1.6.1.1

error

 

1000 para suhosin.post.max_vars.
1000 para suhosin.request.max_vars

 

grato 

Fernando Grayeb

Edited by idata

Share this post


Link to post
Share on other sites

Olá boa noite entre em contato com seu servidor e solicite que ele adicione isso dentro do php.ini

 

Colocar a baixo da seguinte linha  217

 

 
 Resource Limits 
 
max_execution_time = 3600
max_input_time = 3600
max_input_vars = 10000

 

suhosin.post.max_vars = 5193
suhosin.request.max_vars = 5193
suhosin.get.max_value_length = 2048
suhosin.request.max_varname_length = 350
 
observação consulte com seu servidor a taxa de memoria livre para php minimo recomendado de 64MB
 
Recomendo padrão de hoje em dia minimo seria 256 MB
de upload minimo 70 MB se não não adianta subir se não vai conseguir extrair aumentar também taxa de upload e post
eles se recusarem tente por manualmente no php.ini local 
 
Sendo que alguns servidores tem ioncube e ode ter conflito deixando a pagina branca caso aconteça isso remova php.ini entre em contato
com host se eles não tiverem uma solução recomendo que mude de servidor.
 
post_max_size =  valor que seu host achar melhor mais deve ser o minimo recomendado
 
upload_max_filesize =  valor que seu host achar melhor mais deve ser o minimo recomendado
 
Qualquer duvida estarei a disposição 

Share this post


Link to post
Share on other sites

Ola Newbie,

obrigado pela resposta,

acabo de fazer a introdução do código no php.ini como foi informado, e o tradutor funcionou porem quando mandei ele salvar a tradução repostou esse erro

Erro interno do Servidor!

O servidor encontrou um erro interno e não pode completar sua requisição.

Mensagem de Erro: 
Premature end of script headers: index.php

Se você acredita ter encontrado um problema no servidor, por favor entre em contato com o

 

se o thema nao tem alteração para ser feita ele funciona, mas quando dou salvar aparece essa msg.

novamente obrigado pela atenção.

Share this post


Link to post
Share on other sites

Olá bom dia conforme informei php.ini  que senhor adicionou as informações dos suhosin ele reconheceu somente como raiz em sua conta de hospedagem

porem os dados a cima que informei isso deve ser posto global no php.ini do servidor  recomendo que entre em conto com seu host

 

Ou senhor me enviar seu php.ini para que eu possa dar uma olhada e tentar lhe informar uma configuração de acordo com seu servidor.

 

​Também é notável lembrar  que as taxas do de upload,post,memoria deve ser relevante ao tamanho do arquivo de tradução se for menor

vai dar erro na hora de extrair as informações no local.

 

​Para ver as informações básicas do php acesse seu cpanel vai em PHP Configuration

 

La terá as informações como exemplo 

 

ax_execution_time deve ser padrão para 3600

max_input_time deve ser padrão para 3600

memory_limit minimo 256

register_globals isso deve ser em modo off

safe_mode isso também necessário estar off

 

upload_max_filesize minimo 70 MB isso depende do tamanho da tradução

 

--------------------------

 

observação se a taxa é upload_max_filesize 70 MB a taxa do post_max_size = 70 MB

 

Lembrando que essa informação------>  post_max_size = 70 MB não é visível no cpanel

Share this post


Link to post
Share on other sites

Nem todos os servidores permitem a utilização de arquivos php.ini personalizados ou permitem a edição de tais parâmetros.

Caso não consiga fazer funcionar, deve contatar o suporte do seu host

Share this post


Link to post
Share on other sites

Oi pessoal vejam se alguém pode me ajudar, atualizei minha loja para a versão 1.6.1.1 , parece que o php.in não está carregando corretamente

e a configuração está ficando como abaixo

 

 

 

 INFORMAÇÃO DO SERVIDOR

Informação do servidor Linux #1 SMP Wed Mar 11 22:03:14 UTC 2015 x86_64

Versão do Software do Servidor Apache/2.2.31 (Unix) mod_ssl/2.2.31 OpenSSL/1.0.1e-fips mod_bwlimited/1.4

Versão PHP 5.6.14

Limite de memória 2G

Tempo máximo de execução 0

 

isto está fazendo a loja demorar para abrir o admin e carregar home, acho que o problema não é na hospedagem pois tenho outra loja que funciona normalmente.

Share this post


Link to post
Share on other sites

Vc. colocou todo o limíte de memória ddisponível no seu servidor como configuracao constante ?

 

Se o seu espaco web possue um RAM de 2G, nao deverá dispoinibilizar todo. 256M sao suficientes para uma loja de médio porte (até 2.000 produtos). 10.000 produtos 512M é o suficiente.

Além do mais o tempo max. de execucao e tempo max. de input bastam ambos em 300 ou entao se quiser dar mais 600. Mais nao é necessário. 0 nao acredito que seja configuracao correta.

 

ponha aqui os valores do seu phpinfo.php, que sao os valores que estao configurados no servidor.

Edited by selectshop.at

Share this post


Link to post
Share on other sites

Vc. colocou todo o limíte de memória ddisponível no seu servidor como configuracao constante ?

 

Se o seu espaco web possue um RAM de 2G, nao deverá dispoinibilizar todo. 256M sao suficientes para uma loja de médio porte (até 2.000 produtos). 10.000 produtos 521M é o suficiente.

Além do mais o tempo max. de execucao e tempo max. de input bastam ambos em 300 ou entao se quiser dar mais 600. Mais nao é necessário. 0 nao acredito que seja configuracao correta.

 

ponha aqui os valores do seu phpinfo.php, que sao os valores que estao configurados no servidor.

 

 

Este é o info.php

 

http://lojaroupadebaixo.com/info.php

Share this post


Link to post
Share on other sites

Os valores do seu servidor estao em:

 

max_execution_time 120

max_input_time 180

memory_limit 128M

 

Para rodar Prestashop 1.6.x sem problemas vc. deveria aumentar os valores para:

 

max_execution_time 300

max_input_time 300

memory_limit 256M ao menos ou se a loja possuir mais do que 2.000 produtos entao 512M (desculpa eu tinha escrito 521, mas sao 512 - o dobro de 256M)

Edited by selectshop.at

Share this post


Link to post
Share on other sites

Este ficheiro php.ini contêm todas as configurações necessárias a um bom funcionamento de uma loja online Prestashop.

Esse arquivo serve para a versão 1.6.0???? 

Share this post


Link to post
Share on other sites

 

Para rodar Prestashop 1.6.x sem problemas vc. deveria aumentar os valores para:

 

max_execution_time 300

max_input_time 300

memory_limit 256M ao menos ou se a loja possuir mais do que 2.000 produtos entao 512M (desculpa eu tinha escrito 521, mas sao 512 - o dobro de 256M)

Pergunta respondida um tópico mais acima....

 

Alem do mais pode consultar as requisicoes mínimas também por aqui (lá constam indicadas por cada VERSAO PS): http://www.prestashop.com/forums/topic/236128-tutorial-servidor-configuracao-minima-para-ps-15/

Share this post


Link to post
Share on other sites

funciona assim comigo assim

 

1 - ir ao cpanel

2 - software - select PHP version

3 - switch to top php optinio  ( no canto superior direito)

4 - procurar (max_input_vars) e mudar para 10000

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More