Jump to content
Aftabbajaj

Problem in Create default shop and languages ..

Recommended Posts

Please help me to install Prestashop For Ecommerce Website ,I am Facing a lot Problem .

the same problem, anyone can give a sollution for this?

Share this post


Link to post
Share on other sites

Hi.

 

Found it guys.

 

Just try to install using United states as your default location and US as your default language.

 

I hope this help.

Share this post


Link to post
Share on other sites

just tried to install on localhost for the second time with the same error..

everything is same as before , but still error.. :blink:

 

when installing with my pc is connected to internet

everything just fine.. :D

 

sorry bad english :P

  • Like 1

Share this post


Link to post
Share on other sites

it's because prestashop installation needs an internet connection... but to be honest, i never tried to install without connection to the internet

  • Like 1

Share this post


Link to post
Share on other sites

hello,what language pack you're trying to install?

please try with default one, then you will be able to import your localization pack in back office.

are you connected to the internet while installing?

Share this post


Link to post
Share on other sites

thanks for information! im convined that you information will be helpfull for another merchants with similar problem.

i've got additional question: by "the server enabled ini_set()" you mean that your hosting provider changed something in the server configuration?

Share this post


Link to post
Share on other sites

thanks for information! im convined that you information will be helpfull for another merchants with similar problem.

i've got additional question: by "the server enabled ini_set()" you mean that your hosting provider changed something in the server configuration?

yes, i was very confused, almost going to use oscommerce, but the admin set ini_set() enable and now the store works perfect! no issues on the installation..

Share this post


Link to post
Share on other sites

it mean that you have to change the server configuration. If you're on shared hosting you have to contact with your hoster, ask them for turn on ini_set() php feature.

Share this post


Link to post
Share on other sites

@coronatonewmedia,

 

I'm with Go Daddy and came across your post.

 

Have you been able to install the language pack?

 

If not I would like to be of further assistance. Feel free to reply or send me a private message.

Share this post


Link to post
Share on other sites

Same Installation error, stack on 23%

  • Create default shop and languages

How is possible to enable ini_set ? I`ve seen php.ini and there is no any disabled function

 

There is no any explain of this error, is there any installation logs ?

 

ZettaHost provider

Php 5.2.17

PrestaShop 1.5.4

 

 

s-15.jpg

Edited by artemu78 (see edit history)

Share this post


Link to post
Share on other sites

what language pack you're trying to install?

Share this post


Link to post
Share on other sites
what language pack you're trying to install?

 

I`ve tried english, tried russian.

I`ve tried to edit install/langs/en/language.xml from

<language_code>en-en</language_code>

to

<language_code>en</language_code>

 

And same with russian language.xml (ru-ru to ru)

 

All i got is error on next step

  • Populate database tables

And again no any little error explain. Not a single code line. Why is that? Why it has no logs and no Error explain?

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

I hope this late reply can help shed some light,

This is definitely a internet connection problem between your server and prestashop server

Maybe your hosting provider doesn't allow http request from inside your account.

 

To confim my statement, when you have a working internet connection and installing PS, you should be able to view additional banner from prestashop addons below the progress bar

 

dSZ9ns.jpg

 

As how to fix this by passing-through the internet connection issue, is by (1) pre-download the language pack (2) overriding the request to your own domain

see: classes/Language.php line: 696

 if (!$lang_pack)
  $lang_pack = Tools::jsonDecode(Tools::file_get_contents('http://www.prestashop.com/download/lang_packs/get_language_pack.php?version='._PS_VERSION_.'&iso_lang='.$iso_code));

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

I hope this late reply can help shed some light,

This is definitely a internet connection problem between your server and prestashop server

Maybe your hosting provider doesn't allow http request from inside your account.

 

 

Yes, you right, my hosting provider did not allow outgoing connections. Now problem is gone.

Share this post


Link to post
Share on other sites

that's right, i suppose that function file_get_contents is disabled

it's necessary for prestashop - not only for installation process, also for other things like currecy exchange rates, importing localization packs etc.

Share this post


Link to post
Share on other sites

Artemu78, please edit this topic and mark it as [sOLVED] in your subject :)

 

As this maybe trivial, but this issue has managed to make a handful of people pulling out their hair during PS installation, and complaining this to be a bug in PS. I think it would be a good idea for the release of PS installer to check the internet connection from the installing server before executing the installation.

Share this post


Link to post
Share on other sites

Hi,

I hope this late reply can help shed some light,

This is definitely a internet connection problem between your server and prestashop server

Maybe your hosting provider doesn't allow http request from inside your account.

 

To confim my statement, when you have a working internet connection and installing PS, you should be able to view additional banner from prestashop addons below the progress bar

 

dSZ9ns.jpg

 

As how to fix this by passing-through the internet connection issue, is by (1) pre-download the language pack (2) overriding the request to your own domain

see: classes/Language.php line: 696

  if (!$lang_pack)
   $lang_pack = Tools::jsonDecode(Tools::file_get_contents('http://www.prestashop.com/download/lang_packs/get_language_pack.php?version='._PS_VERSION_.'&iso_lang='.$iso_code));

i don't know much about php; can you please guide me how to do this?

Share this post


Link to post
Share on other sites

i don't know much about php; can you please guide me how to do this?

 

it's not related to php. You need to use installation script on the computer connected to internet (computer where you installing ps)

Share this post


Link to post
Share on other sites

I am also facing error at 23%, but fortunately get resolved.....

might be this can help you...

1)i have unzipped the folder using terminal....

2)the unzipped folder destination (where i extracted it) is different from folder where zip file is kept.

3)changed  permissions of folder access to Create and delete File. and file access to read and write of zipped folder.

4) and name of database i used any thing dissimilar to "prestashop" like "test". 

Share this post


Link to post
Share on other sites

This error driving me crazy. I've tried to install Prestashop on two different VPS servers and I always have got this error in 1.5.6.2 version. In the log there is Class 'AdminTranslationsController' not found in /var/www/presta.plzgo.org/classes/Language.php on line 853

Share this post


Link to post
Share on other sites

Hello,

 

I have same problem when I try to install 1.6.0.7 on a computer with internet access.

Share this post


Link to post
Share on other sites

Hello,

 

I have same problem when I try to install 1.6.0.7 on a computer with internet access.

1.6.0.8 finish to install, but when I try to access admin link:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@xxx.xx and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Share this post


Link to post
Share on other sites

Hello all...

 

I have the same error installing PS 1.6.0.14 stable...

 

Installation is with internet... Can some one explain how to solve this problem ?

 

My experience is limited...

 

Regards

post-859035-0-79596800-1437355072_thumb.png

Share this post


Link to post
Share on other sites

Old thread but seems to lack any answers so figured I'd post anyway.

 

Ran into this now when trying to install Prestashop 1.6 locally with MAMP. For me the solution was to switch to PHP 5 instead of PHP 7 which is default in newer versions of MAMP (maybe on XAMPP as well). Might be the same for those of you experiencing issues with your hosting providers so check what PHP version is used before trying to fix something with your Prestashop installation. 

 

Prestashop 1.7 seems to work fine with PHP 7.

  • Like 1

Share this post


Link to post
Share on other sites

I had the same issue, on GoDaddy, what I did to solve this was to downgrade form PHP version:  7 to PHP version:  5.6 and it fixed it for me.

Hope this helps.

Share this post


Link to post
Share on other sites

Hello all. I know this topic is old, however I just started dealing with the stubborn PrestaShop installation and while working locally on my development server, the @yay post saved my hair from being pulled out.

The version I am working with is 1.6.1.3 as it came with my theme quick install and decided to give it a try to see how it works before moving it online.  My default setup had MySQL 8.0 x64 with PHP 7.3 x64, so I switched my dev. server to MySQL 5.5 and PHP 5.2 and it all worked like a charm or at least I finished the install completely and got inside the admin panel.

Thanks @yay you are the man !!!

Share this post


Link to post
Share on other sites

Hello to all, for me was to problem "Outgoing Connections Manager" check this...

Share this post


Link to post
Share on other sites

I had the same issue installing an old Prestashop 1.6.1.9 in local WAMP server. The solution is to remove some code trying to dowonload languages pack, in install\models\install.php as described here:

https://www.prestashop.com/forums/topic/476182-install-language-problem-23/?tab=comments#comment-2167657

After this, the install would break at 34%, populating tables in database: the solution is to switch PHP at version 5.6

 

Share this post


Link to post
Share on other sites
On 4/26/2020 at 11:56 PM, zod said:

I had the same issue installing an old Prestashop 1.6.1.9 in local WAMP server. The solution is to remove some code trying to dowonload languages pack, in install\models\install.php as described here:

https://www.prestashop.com/forums/topic/476182-install-language-problem-23/?tab=comments#comment-2167657

After this, the install would break at 34%, populating tables in database: the solution is to switch PHP at version 5.6

 

Thanks this was helpful.

Installed Prestashop 1.6.9 with this version of XAMPP 7.0.13

https://svwh.dl.sourceforge.net/project/xampp/XAMPP%20Windows/7.0.13/xampp-portable-win32-7.0.13-1-VC14-installer.exe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More