Jump to content
myriamrv

Mise à jour 1.3.1.1 vers 1.5.2

Recommended Posts

Bonjour,

 

J'utilise depuis un bon moment Prestashop en version 1.3.1.1

 

Ma boutique ayant bientôt 3 ans, j'ai installé plusieurs modules que je n'utilise plus etc, donc j'aimerais repartir sur une installation propre de la version 1.5.2, dans laquelle j'importerais mes produits, clients et commandes. J'installerais uniquement les modules dont j'ai besoin sur celle-ci.

 

Ma question est donc de savoir s'il y a un moyen d'importer dans une nouvelle installation le contenu des tables de la BDD, ou bien d'un quelconque export csv, xml ou autre...

 

Quelqu'un l'aurait déjà fait et pourrait me conseiller ?

 

Merci d'avance !

Share this post


Link to post
Share on other sites

Tu peux faire facilement une mise à jour avec le module "Mise à jour en 1 clic"

Voici un petit tuto.

http://doc.prestasho...pageId=11272345

Il y a la possibilité avec ce module de faire un roll-back (retour en arrière) mais je te conseil de ne pas faire la mise à jour en production.

 

La seul chose qui ne sera plus compatible c'est ton thème et certain module.

En effet de la version 1.3 à un 1.4 la version de smarty à changé sans compté qu'il faut ajouter et supprimer certain élément a certain endroit pour pouvoir profiter pleinement des fonctionnalités de la 1.5.

Edited by simon.bonjean (see edit history)

Share this post


Link to post
Share on other sites

Merci pour ta réponse rapide, j'étais déjà tombée sur cette page lors de mes recherches préalables, mais le module de mise à jour en un clic ne semble compatible qu'à partir des versions 1.4... C'est du moins ce qui est indiqué quand on veut le télécharger.

 

Par contre, la mise à jour m'obligera à rester sur mon install actuelle et non pas à repartir sur une install propre... du coup, je devrai toujours me traîner un paquet de modules, qui en plus de ne plus être utilisés, ne seront peut-être plus compatibles avec la version 1.5 (à moins qu'il soit possible de les supprimer au passage ?)

 

Pour le thème, pas de problème : la société qui m'avait fourni mon thème actuel en version 1.3 m'en fournit une version adaptée en 1.5

Share this post


Link to post
Share on other sites

Le module "Mise à jour en 1 clic" fonctionne avec la 1.3

 

Lors de la mise à jour le module propose de sélectionné les modules que tu souhaites garder. Mais au pire du les supprimes après la mise à jour s'il pose problème.

Edited by simon.bonjean (see edit history)

Share this post


Link to post
Share on other sites

Nickel !

 

Bon et bien dans ce cas je vais essayer, le temps de créer une copie de mon site pour tester et je vous tiendrai informés...

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

 

Je souhaiterais savoir si votre expérience avec ce plugins a été productive?

Je suis encore aujourd'hui en version 1.3.1.

Je vais moi aussi tester avant une reelle mise en prod mais si vous avez un route positif ou négatif, je suis preneur.

 

Merci d'avance.

Share this post


Link to post
Share on other sites

Mise à jour 1.3.1.1 --> 1.5.2 réussi sans aucun soucis pour ma part.

Y a un peu de boulot après mais c'est pas méchant. Prend toutes tes précautions pour pouvoir revenir en arrière au cas où.

Share this post


Link to post
Share on other sites

Bonjour,

 

Est-il possible de tester la mise à jour en local avant de la faire en prod avec le module "Mise à jour en 1 click" ? (Je souhaite faire une mise à jour de la version 1.3.1 vers la 1.5.)

 

Pour ma part lorsque j'essaie d'utiliser le module "Mise à jour en 1 click" en local, j'ai les messages d'erreur suivants :

Warning: file_get_contents(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP?

Warning: file_get_contents(https://api.addons.prestashop.com): failed to open stream

 

D'autre part j'ai modifié un certain nombre de fichiers, comment intégrer ces modifs dans la nouvelle version ? Faut-il recopier les modifs dans chaque nouveau fichier ou peut-on écraser le nouveau fichier par l'ancien ? (je pense en particulier au global.css)

 

Merci d'avance pour vos réponses.

Share this post


Link to post
Share on other sites

Bonjour à tous !

 

Je reviens vous dire que pour moi, tout s'est bien passé ! Comme cela a été dit par J-F Dupin plus haut, il y a effectivement un peu de boulot derrière, mais rien de bien méchant. J'ai dû :

- Changer de thème car les développeurs de mon thème sous 1.3 n'assuraient pas les mises à jour.

- Effectuer une modif dans un fichier du module So Colissimo, car dans sa version actuelle il ne fonctionnait pas (le sujet est traité par ailleurs dans le forum).

- Bien penser à regénérer les vignettes des produits / catégories car mes images ne s'affichaient plus (solution trouvée également après quelques secondes de recherche dans le forum)

 

A part ça, RàS. La mise à jour en soi est assez rapide, je dirais qu'en 30min ça a été fait (inclus le temps de bien lire le tuto pour ne rater aucune étape, et de faire des sauvegardes du contenu du FTP et de la base de données par mesure de précaution).

 

Je précise également que la 1.5.3 étant sortie entre temps, j'ai fait directement la mise à jour 1.3.1.1 vers 1.5.3 ce lundi. Puis hier j'ai vu que la 1.5.3.1 était sortie tout récemment, j'ai donc refait la mise à jour 1.5.3 vers 1.5.3.1 selon le même procédé, et ça s'est également très bien passé.

 

Pour répondre (partiellement) à caroled, je pense qu'il est effectivement conseillé de tester en local au préalable, ou à défaut sur une copie du site sur le même serveur. Pour ma part je préfère la seconde méthode car tu es exactement dans la même config que tu seras au final, donc ça limite les imprévus liés à la configuration du serveur (genre paramètres du php.ini).

 

Je laisserai par contre des personnes plus expérimentées concernant les erreurs que tu as rencontrées car ça ne me parle pas tellement. Pour ce qui est des fichiers que tu as modifiés, je ne te conseille pas de remplacer les nouveaux par les anciens. Il y a probablement trop de différences entre les versions 1.3.1.1 et 1.5.X de Prestashop, tu t'exposes au risque de rencontrer des bugs. A ta place, je ferais déjà ma mise à jour en laissant les fichiers par défaut tels quels. Ensuite, une fois que tout est installé et fonctionnel, tu ouvres l'ancienne version de ton fichier que tu as modifié en parallèle avec la nouvelle version, et tu reportes tes modifs dans le nouveau (si tu as bien commenté tes fichiers au niveau des modifs, tu devrais t'en sortir assez facilement)

 

Bon courage, et merci à ceux qui ont participé à ce topic pour leurs précieux conseils ;)

  • Like 1

Share this post


Link to post
Share on other sites

@myriamrv

Content que ça ce soit bien passé pour toi aussi et merci pour le complément d'infos. C'est exactement ce que j'ai fais pour notre boutique.

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour, je viens de faire (en local) une mise à jour de la V 1.3.1.1 à la V 1.5.3.1 avec le module automatique de prestashop. La mise à jour en elle même s'est plutôt bien passé. Par contre j'ai quelques soucis, mon thème n'est plus compatible (mais j'étais prévenue), donc pour les tests en attendant de prendre une décision pour le thème, j'ai mis le thème par défaut. Et j'ai un problème avec les photos : sur le détail d'un produit la photo passe par dessus le texte. Il semble qu'il y ait un problème aussi dans le module réduction, mais là c'est le texte qui passe sur la photo. J'ai regénéré les photos après la mise à jour mais toujours pareil ! Quelqu'un a t-il eu le même problème ? Merci à ceux qui pourront m'aider

Share this post


Link to post
Share on other sites

Bonjour je viens ici car je voudrais également passer de la version 1.3.1.1 à la dernière version de prestashop.

J'ai téléchargé le module de mise à jour automatique (v1.1.7) tous les indicateurs sont au vert mais je n'ai pas le bouton de mise à jour, il ne détecte pas la dernière version  ??

Quelqu'un saurait me dire pourquoi ?

 

1.3.1.1.jpg

 

En vous remerciant

Edited by Maxsmall02 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Il me semble avoir eu le problème lors de mes premiers tests, je pense que si tu choisis plus d'option (mode expert) tu devrais pouvoir choisir ta version.

Bonne journée

Share this post


Link to post
Share on other sites

Bonjour je viens ici car je voudrais également passer de la version 1.3.1.1 à la dernière version de prestashop.

J'ai téléchargé le module de mise à jour automatique (v1.1.7) tous les indicateurs sont au vert mais je n'ai pas le bouton de mise à jour, il ne détecte pas la dernière version  ??

Quelqu'un saurait me dire pourquoi ?

 

 

 

En vous remerciant

 

Oui effectivement il cherche par branche 1.4/1.5 et la il cherche le canal majeur pour les 1.3 qui n'existe pas ! Il faut donc choisir le canal en mode avancé, merci @Carpediemja.

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour ce n'est pas la version 1.1.7 mais la 1.2.5 qui  ne fonctionne pas avec la version 1.3.7...est-il possible d'avoir une version qui fonctionne ou la fameuse version 1.1.7 s'il vous plait?

Edited by Kouadjio (see edit history)

Share this post


Link to post
Share on other sites

Bonjour, je l'ai re télécharger, re installer, rien a faire quand je clique sur configurer j'ai un belle page blanche...je précise je suis en local

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai essayé de faire la mise à jour de mon Prestashop 1.3.7 grâce à ce module téléchargé ce matin.

J'ai donc copié ma boutique dans un sous-dossier de celle-ci, créé un sous-domaine pour l'occasion, désactivé et désinstallé les modules additionnels, j'ai aussi remis le thème par défaut.

La mise à jour se passe correctement, aucun message d'erreur.

J'accède bien au back office et au front office.

Le seul hic, c'est que je n'ai plus aucune image sur mes produits...

 

J'ai re-copié le site une seconde fois, refait la mise à jour et idem...

 

Quelqu'un a-t-il une idée ?

 

Merci d'avance et bonnes fêtes de fin d'année à tous :)

Share this post


Link to post
Share on other sites

Hello,

 

Dans l'onglet images en back office en bas, essayez de migrer les images. Ensuite il faut verifier les formats utilisés par le theme.

 

Cordialement

Share this post


Link to post
Share on other sites

Merci Gregory.

 

En effet, ça a marché... après avoir regénéré les miniatures.

 

Bon week-end :)

Share this post


Link to post
Share on other sites

J'ai super peur de faire une mise à jour de Version 1.3.1.1 vers une 1.5.x pourtant je vais bien être obligé… je recule devant l'obstacle depuis des années...

Ce qui me fais super peur c'est qu'a l'époque j'avais complètement customisé un thème gratuit dont je ne me souvient même plus du nom… je pense qu'il est obsolète de toute façon...

 

Vous me recommandez de passer par "Mise à jour en 1 clic" ? parce qu'il est marqué : 

Compatibilité

PrestaShop v1.4.0.0 - v1.5.6.2 ???

Share this post


Link to post
Share on other sites

Bonjour,

 

Je suis en train de faire en test une mise à jour 1.3.1.1 vers 1.5.6.2 sur une copie de mon environnement de prod sur le même serveur. j'ai fait la mise à jour avec "mise à jour en 1 clic"

Comme tout le monde j'ai eu le problème des images, donc à régénérer.

Sinon ton thème n'est forcément plus fonctionnel (depuis le 1.4 il me semble) donc c'est le gros du travail. Il ne faut pas que tu repartes du thème gratuit que tu avais pour la 1.3.1 car il n'est plus compatible.

Je pense que ça représente un peu de travail pour refaire le thème et retester et adapter toutes les fonctionnalités, mais je n'ai pas trouvé d'autres solutions.

Pour le moment mon site fonctionne en version 1.3.1 et je ne basculerai vers la 1.5.6.2 que lorsque je serai satisfaite de la version qui tourne en test.

Bon courage

Share this post


Link to post
Share on other sites

Bonjour,

 

Je souhaite également tester la mise à jour 1 clic sur mon site,

j'ai donc en local une version qui tourne 1.3.1.1 , j'ajoute le module module 1 clic téléchargé  ici  : via  le lien 'ajouter un module' , ça m'indique que le module s'est correctement installé, en revanche pas de module 1 clic dans ma liste...

est-ce que j'ai loupé quelque chose ?

(est ce que ce ne serait pas prestashop qui aurait fait un nouveau module qui serait compatible qu'a partir de la 1.4 ?) mais là c'est contradictoire avec le post de 'ecosxm' de février ?

Merci par avance

Share this post


Link to post
Share on other sites

Personne n'a donc rencontré ce problème ?? où bien ce n'est donc plus du tout d'actualité ??

pour le moment je n'ai toujours pas trouvé de solution et presta me conseille de passé par une agence pour un développement...

le module existe bien pourtant !

S.V.P

Share this post


Link to post
Share on other sites

Desolé de ne pas avoir posté depuis quelques temps..

@Michael79

tu peux y aller tranquille...je n'ai eu aucun conflit (avec just 1 click), même sur les nombreuses extensions installées...

J'ai douté et me suis lancé... de la balle.... j'ai tout retrouvé, des mises à jours oui (plugins), mais pas de conflit...

du bonheur... je te souhaite le même

Share this post


Link to post
Share on other sites

Personne n'a donc rencontré ce problème ?? où bien ce n'est donc plus du tout d'actualité ??

pour le moment je n'ai toujours pas trouvé de solution et presta me conseille de passé par une agence pour un développement...

le module existe bien pourtant !

S.V.P

 

Bonjour,

 

Essayez de dézipper le module et de le copier le dans le dossier /modules/ de votre site, plutôt que l'installer par 'ajouter un module'.

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour,

 

Module dézippé, inséré avec les autres modules, mais toujours pas visible dans la page des modules

d'où pourrait bien venir le problème ?

 

précisions

 - je teste en local

 - mon front-office est personnalisé mais je doute que ce soit le problème (je n'ai jamais eu ce problème par exemple avec les autres modules installés "Facebook Like v1.5.1" Module envoyer à un ami v1.2.0 " PSS / Inscrits au bloc Newsletter v0.8 " Diaporama en page d'accueil v1.0)

- la page d'accueil du backoffice est personnalisée (certains blocks sont supprimés)

 

Merci

Share this post


Link to post
Share on other sites

Si cela peux vous aider , est-ce que je peux mettre l'adresse url de la boutique ?

Share this post


Link to post
Share on other sites

Hello,

 

A part un conflit avec un autre module non je ne vois pas. Faites moi des accès temporaires BO et ftp par email svp et je regarde dès que je peux.

 

Cordialement

Share this post


Link to post
Share on other sites

RÉSOLU !

Bonjour,

merci pour la proposition, j’apprécie vraiment.

Suite à votre post en désespoirs de cause, j'ai désactivé tous les modules et j'ai retenté... rien de mieux

et la l'idée :  j'ai retéléchargé le module one click au cas où....

et miracle ! en fait c'était manifestement le zip qui avait un problème !

je m'en veux un peu car j'aurais du essayé ça depuis longtemps ..! :wacko:

 

Merci et à une prochaine

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More