Jump to content
LuluJ1984

URGENT - Can't log in to my admin back office area - Help

Recommended Posts

I was getting a Technical Error when trying to use Live Edit. It was suggested I upgrade, which I did to 1.5.2 and although this made no difference to the Live Edit Technical Error I was still able to do everything else as usual.

 

Then around forty minutes later, anything I pressed from the Admin back office suddenly directed me to the log in page.

 

When I enter my details - nothing happens.

 

This is very worrying as I am due to open my store in a couple of weeks. Does anyone know how I can get access to my admin back and also what might have caused this as I cant afford to be locked out whilst orders and money are flowing in.

 

Any help would be greatly appreciated.

post-436567-0-21349900-1353515863_thumb.jpg

Share this post


Link to post
Share on other sites

Did you tried the lost password option?

 

I know it sounds dumb but, did you do it?

 

I can help you if that doesn't work but I'll

need access to your hosting acount while

I'll need to take a look to some files and

then modify some database values.

 

Best regards,

 

Roberto

  • Like 1

Share this post


Link to post
Share on other sites

Hi Roberto,

 

I did not try the password option as the password was one I could remember and didn't want it changed to a random one in case I couldn't change it back.

 

I have done this now and the new password is not working either.

 

With regards to accessing my hosting account - is this allowed? as my host Falcoda states that I should not give out my log in details.

 

Many thanks for your help. I appreciate it very much.

Share this post


Link to post
Share on other sites

I also can't login to the backoffice after a 1.5.2 upgrade.

 

I have used the renew password process .. and it still doesn't accept the new password.

Instead, it refreshes the login screen with some other text in the username and password .. and does this with each try.

 

Is there a way to edit the username and password directly in the database or appropriate script?

 

We're dead in the water now ...

Share this post


Link to post
Share on other sites

I can't grant access to the hosting account .. I don't have that privilege .. but I am database familiar and can make edits as you instruct.

 

this is urgent..thanks!

Share this post


Link to post
Share on other sites

This is what I get AFTER entering my correct username and password.

 

username: hawaiiani

password: ***********

 

so it's pulling a username from somewhere..even tho I am the only user in the database after a fresh install...???

Edited by moses5407 (see edit history)

Share this post


Link to post
Share on other sites

This is what I get AFTER entering my correct username and password.

 

username: hawaiiani

password: ***********

 

so it's pulling a username from somewhere..even tho I am the only user in the database after a fresh install...???

 

luluj1984 try this also.

 

Try this in the front office create an account and use a password that you would want as an administrator, now go to the database and look in the ps_customers table click browse then click edit on the account you just created and copy the password, now go to ps_employees table click browse then click edit on your account and paste the password in your admin account password area and try to log in with this password.

Take note of the email address associated with your ps_employee account and make sure its the same as what you enter to log in to the BO.

Edited by tdr170 (see edit history)

Share this post


Link to post
Share on other sites

ohh..you mean login as a new customer and then to database? I'll give it a try .. but it still makes no sense why the admin login shows data when there is only 1 user in ps_employees..?

 

I;ll try and then report back

Share this post


Link to post
Share on other sites

 

luluj1984 try this also.

 

Try this in the front office create an account and use a password that you would want as an administrator, now go to the database and look in the ps_customers table click browse then click edit on the account you just created and copy the password, now go to ps_employees table click browse then click edit on your account and paste the password in your admin account password area and try to log in with this password.

Take note of the email address associated with your ps_employee account and make sure its the same as what you enter to log in to the BO.

 

This has not worked either - but an error box is now appearing stating

 

"There is 1 error

1. Employee does not exist or password is incorrect"

 

And that is only when I use the 32 character password. When I type the actual password nothing happens still as before.

Edited by LuluJ1984 (see edit history)

Share this post


Link to post
Share on other sites

The password you copied and pasted is not the password its encryted with md5 so if you created a password like

password it will appear as 2b8d5c0493a73a5c32635d98de4b52f8 in the database.

you would still use password in the password text box on login.

Are you able to log into the front office with the account you just created.

In the database was your employee account still showing the correct email.

After entering the 32 character password as you described have you tried lost password while the error message is present.

Share this post


Link to post
Share on other sites

Hi tdr170,

 

Yes I tried both the the 32 character encrypted password and the actual password directly.

 

Yes the account I created is still able to log in to the front office, as is the initial test account I made. Both log in fine.

 

The correct email account was showing in the database (Although I didn't use this email to create either customer accounts - does this need to be the same email for it to work?)

 

I have tried the Lost Password option both after putting in the correct password and nothing happening and after using the encrypted password. The new password does arrive but has no affect. I have just tried again now.

 

 

I tried this too http://nickbartlett....-in-prestashop/ - which is pretty much the same thing right. I also tried restoring my backed up MySQL database and I changed the admin file name on the ftp.

 

Do you have anymore ideas? Or is deletion my only option? :-(

 

How did you get on Moses has yours worked?

Edited by LuluJ1984 (see edit history)

Share this post


Link to post
Share on other sites

hi, my site crash after i update dit to 1.5.2.0...now it is not reversible....

 

i cannot login via admin nor will the password reset works!!!!

Share this post


Link to post
Share on other sites

I think I will have to delete it all and start again and if that doesn't work I'll have to look for an alternative.

 

Does anyone know if I delete all the files from the ftp, download prestashop again, upload the new files will I also need to use a new MySQL database or will the old one clear out once I delete presta??

Share this post


Link to post
Share on other sites

There is one last option PM me your FTP login details so I can look at your files also PM me your login info for the back office and your login for your servers control panel.

 

No you will need to delete all tables from the database if you want to use the same database or just delete the database itself and create a new one.

 

But don't do that yet unless you do not want to give your login info out.

Share this post


Link to post
Share on other sites

Thank you so much for all your help but I deleted it already (needed to be proactive, hate twiddling my thumbs :-)

 

I've created a new database to use too.

 

Thanks again.

 

I hope you other guys resolve the problem (I may be back here in a few hours with the same issue).

 

Good luck.

Share this post


Link to post
Share on other sites

:-( Still stuck!!

 

Deleted everything, created a new database. Re-downloaded Prestashop, uploaded to server. Twice. But I again get stuck at back office log in. - Have tried the above again but this time I am unable to log in from the front office even as a customer so as to swap the passwords on the database.

 

Happy to send you all log in details etc if the offer still stands tdr170 or anyone else.

 

All help very much appreciated.

Share this post


Link to post
Share on other sites

Just to keep everyone updated. I explained my problem to my hosting company (as I was getting the same issue when I tried to use opencart and tomatocart).

 

They installed version 1.4. I'm not even sure what... 7 I think and it seems to be alright.

 

Except like a plum I imported a theme which has screwed things up again.

 

I will start another post for it though. Hope everyone else has had good luck with it all :-)

Share this post


Link to post
Share on other sites

After trying nearly everything .. my problem turned out to be simple.

The default waiting period after a password reset was 360 mins!

 

So, I'd reset the password and try too soon. Then reset the password and try again.

Then fiddle with some files and try again.

Then probably reset the password.

 

Once I reset the password and gave up ... several hours later..voila!..I was in.

Share this post


Link to post
Share on other sites

Worked for me too

 

thanks

---------------

Solved!

I have update ps_shop_url table field and it works

Share this post


Link to post
Share on other sites

Solved!

I have update ps_shop_url table field and it works

 

 

How exactly did you update the ps_shop_url table field?

Share this post


Link to post
Share on other sites

It could be just save of the sets in this table.

 

It works, but not everywhere. I have two subdomains, where on first this solution works, but on the second - did't. I don't know why...

Edited by 2grosiek7 (see edit history)

Share this post


Link to post
Share on other sites

Huh, I solved this...

I forgot, that I was changed the e-mail address in the BO.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More