Jump to content
ritepac

[Résolu] mise a jour 1.4.6.2 vers 1.5.2 en local : probleme

Recommended Posts

Bonjour,

 

J'ai suivi scrupuleusement les informations d'upgrade manuel pour déjà le faire fonctionner en local afin de tout faire dans l'ordre avant de le rebalancer sur serveur web distant.

 

• J'ai créer mes répertoires prestashop-prep que j'ai copié sur mon htdocs de mamp (mac).

• J'ai ajouter mes modules (un seul)

• J'ai ajouter mon theme

• J'ai surtout fait des mises à jours de css donc pas de produit ou de gros dev supplémentaire.

• J'ai recréer ma base

• J'ai modifié le fichier settings

• Je me connecte au fichier http://localhost:888...ade/upgrade.php

• Il m'affiche de suite du code PHP mais ne semble pas tourner.

• J'ai vu que j'étais passé de 168 à 232 tables dans ma base de donnée local.

• Mais rien ne se passe au final : il m'affiche toujours ce code :

SET NAMES 'utf8' /* PHP:category_product_index_unique(); */ CREATE TABLE IF NOT EXISTS
...

/* PHP:fix_cms_shop_1520(); */

 

J'ai testé l'url http://localhost:8888/prestashop-prep/

Il me redirige sur http://localhost:8888/index.php

et sur l'admin page blanche.

 

Je n'ai aucune erreur et aucun succès. Une idée, un éclaircissement ?

 

Merci par avance.

 

P.

Edited by ritepac (see edit history)

Share this post


Link to post
Share on other sites

Bon alors, je n'ai pas eu d'éclaircissements, mais en fouillant longuement, j'ai réussi à avoir ma boutique sur mon local et mon admin. Cependant j'ai un soucis sur le front.

 

Avant, pour ceux qui rencontrerait un soucis équivalent. Voilà comment j'ai résolu le probleme :

• avant d'exporter la BDD distante pour la sauvegarde, il faut 'ne pas forcer les urls canoniques" dans URLS / SEO

• exporter la base

• lancer MAMP

• fichier settings :

_DB_SERVER => localhost

_DB_USER => root

_DB_PASS => root

_DB_NAME => meme nom que celle qui est en ligne (afin de conserver même organisation)

• lancer le fichier d'upgrade

• pour voir le résultat : http://localhost:8888/ et la même chose avec admin (mettez le meme nom que votre dossier)

• vous serez certainement limité en mémoire d'éxécution pour vos scripts. Si c'est le cas, ouvrez le fichier config.inc.php et ajouter en première ligne :

@ini_set('memory_limit','32M');

 

Bien à vous.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More