Jump to content

[Free Module] Prestashop Social Buttons


Recommended Posts

Facebook, Twitter, Google Plus and many other social media buttons in the same row.

Download link


Compatible with Prestashop 1.4.x, 1.5.x and 1.6.x

Available Hooks (Positions):

  • Page Top
  • Page Footer
  • Left Column
  • Right Column
  • Home Page
  • Product Page Extra Left
  • Product Page Extra Right
  • Product Page Product Actions
  • Product Footer

* This module is built on the contribution of Şahin Yıldız of Prestashop Official Forums.


SUGGESTION: The module is installed on Product Page Extra Left area right above the Print link. However, for Prestashop 1.5.x, it is suggested to be installed on Product footer as the space is limited in product extra left and right.

Version 0.2 Released:

Change Log:

Open graph tags are added to display the correct image on like actions.



prestashop-social-buttons.jpg

Edited by MEG Venture (see edit history)
  • Like 9

Share this post


Link to post
Share on other sites
  • 1 month later...

a big thanks for your module, seems to work perfecty :)

I just put a line in comment in the tpl (for the addthis_counter addthis_pill button), because once it was used, the logo wans't align anymore

Edited by bllcll (see edit history)

Share this post


Link to post
Share on other sites

a big thanks for your module, seems to work perfecty :)

I just put a line in comment in the tpl (for the addthis_counter addthis_pill button), because once it was used, the logo wans't align anymore

 

Could you be more specific? I'm also having the alignment issue after the share button has been used.

 

Thanks for the module.

Share this post


Link to post
Share on other sites
  • 1 month later...

you mean does my https'option for my store is activated ? No it is not activated, but I didn't change anything, was working perfectly, and now it doesn't, so weird, don't understand what happened !

Share this post


Link to post
Share on other sites
  • 4 weeks later...

hello, you can upgrade to make modifications, etc.?

respects

 

I suggest you to transplant the module to the product footer instead of extra left hook.

 

That way, it will be displayed better.

 

Regards.

Share this post


Link to post
Share on other sites

I suggest to transplant it to the product footer for your site.

 

BTW, version 0.2 is released to fix the facebook product image post problem. You can download the new version from the same address.

Share this post


Link to post
Share on other sites

hello, seems to work well, you can only equal spaces between them?

You could take on the social networking category, and not in front office.

 

now you have the module to 1.4 QUICK STATS xxx

 

respects

Edited by Speed2010 (see edit history)

Share this post


Link to post
Share on other sites
  • 5 weeks later...

I see, thanks for the reminder.

 

However, we have a limit to upload a file and I am so close to my limit.

 

I edited my post and just provided a reference link.

Hi,

 

Couldn't see any relevant editing here, since your link still points to your website.

 

If you are going to give a link to your modules instead of attaching files to your posts, please use a third party service. Makes sense ? :)

Share this post


Link to post
Share on other sites

Hi MEGVenture, how large is your module? I can change the limits for larger file sizes.

Hi,

 

Couldn't see any relevant editing here, since your link still points to your website.

 

If you are going to give a link to your modules instead of attaching files to your posts, please use a third party service. Makes sense ? :)

 

Hi

 

A direct download link is provided on the first post instead of the product page. Does it solve the problem?

 

Regards.

Share this post


Link to post
Share on other sites

Anyway to make the facebook-button automatically fit the size of the text? "Like" in Danish is "Synes godt om" and it only shows some of the text without the counter.

 

Alternately, a way to force locale_en_US?

 

Thank you

Edited by Nondo (see edit history)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hi

 

For 1.5.4.1 you need to make the below changes in socialbuttons_header.tpl

 

Find

 

<meta property="og:image" content="{$link->getImageLink($product->link_rewrite, $cover.id_image, large)}" />

 

and change it to

 

<meta property="og:image" content="{$link->getImageLink($product->link_rewrite, $cover.id_image, large_default)}" />

 

BTW, don't forget to use JPG images in your Prestashop installation, because facebook doesn't like PNG for caching purposes.

 

Regards.

  • Like 2

Share this post


Link to post
Share on other sites

Is not working yet, I'm sad :/

 

There is a predefined og type on your website and the predefined og:type is "product". So there is a confliction. Please see the debug report of Facebook: https://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fwww.madeinlondon.com.br%2Findex.php%3Fid_product%3D9%26controller%3Dproduct

 

Do you use any other facebook application on your website? If so, what is their og:type defined? og type should be "website"

  • Like 1

Share this post


Link to post
Share on other sites

<!-- Social buttons BEGIN -->

<meta property="og:type" content="website" />

<meta property="og:image" content="{$link->getImageLink($product->link_rewrite, $cover.id_image, large_default)}" />

<!-- Social buttons END -->

 

I have to change which line ?

Share this post


Link to post
Share on other sites

Old:

 

<meta property="og:type" content="website" />

 

New:

 

<meta property="og:type" content="product" />

 

or for your case remove that line completely as it is already defined as 'product' by the help of a module of yours.

Edited by MEG Venture (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
  • 3 weeks later...

I have installed it in product footer but I dont see this module anywhere !!!!

I just can see its code when I clicl view page source on my browser.

Do I have to unnistall another module for it?

I am using 1.5.3.1 version

This is the top module in product footer hook

Share this post


Link to post
Share on other sites

I have installed it in product footer but I dont see this module anywhere !!!!

I just can see its code when I clicl view page source on my browser.

Do I have to unnistall another module for it?

I am using 1.5.3.1 version

This is the top module in product footer hook

Share this post


Link to post
Share on other sites

I have installed it in product footer but I dont see this module anywhere !!!!

I just can see its code when I clicl view page source on my browser.

Do I have to unnistall another module for it?

I am using 1.5.3.1 version

This is the top module in product footer hook

 

Could you please uninstall and install the module again?

Share this post


Link to post
Share on other sites

Could you please uninstall and install the module again?

 

I did it but nothing happened. I have dis activated the right column of the product page ( new products....) . Can it be the cause of this problem?

Share this post


Link to post
Share on other sites

I did it but nothing happened. I have dis activated the right column of the product page ( new products....) . Can it be the cause of this problem?

 

I understand something now ! Do I have to import facebook... logos myself? I thought that this module have them already !

Share this post


Link to post
Share on other sites

How can I transplant this module to a ne hook in a custom theme? ( I get "This module cannot be transplanted to this hook."). Is there a way to set which buttons show and how they show (text/size/count view/ etc).

 

Thank you. Good module

Share this post


Link to post
Share on other sites

How can I transplant this module to a ne hook in a custom theme? ( I get "This module cannot be transplanted to this hook."). Is there a way to set which buttons show and how they show (text/size/count view/ etc).

 

Thank you. Good module

 

You need to define the hook function in the socialbutton.php file to hook the module to that hook.

 

And by editing the tpl file, you can select which button to display. For the text and count view, I am sorry. This is a limited version. I suggest you a premium one like http://addons.prestashop.com/en/front-office-features-prestashop-modules/7292-social-power-with-button-templates.html

Share this post


Link to post
Share on other sites

Ok

 

I dont know what is the problem ! I reinistalled it again but nothing happened. When I use inspect element of chrome I can see its code but there is no sign of it in my page! the logos are 0X0 px when I check in inspect element

Share this post


Link to post
Share on other sites

Ok

 

I dont know what is the problem ! I reinistalled it again but nothing happened. When I use inspect element of chrome I can see its code but there is no sign of it in my page! the logos are 0X0 px when I check in inspect element

 

Can you share the address of your website, please?

Share this post


Link to post
Share on other sites
  • 5 weeks later...

ASAP in some places are more than 2 months :)

 

Btw nice module

 

I prefered to use another module so I didnt put this module on my website. Thus, I dont think putting my website address here would be relevant, but if you want to visit my shop it is on www.elisud.ir :)

Edited by arash_a2k (see edit history)

Share this post


Link to post
Share on other sites

I prefered to use another module so I didnt put this module on my website. Thus, I dont think putting my website address here would be relevant, but if you want to visit my shop it is on www.elisud.ir :)

Thx - it was only ment as a summer joke, to make someone smile :)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Is it possible to delete the share button?

 

Thanks!

 

There is a workaround!

 

Please open socialbuttons.tpl find below line and delete it

 

    <a class="addthis_counter addthis_pill_style"></a>

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for another great module, however, I am still having issues with the photos showing up when I share to facebook. I have tried the fixes above by editing the socialbuttons_header.tpl, but still does not work. Any other suggestions?

 

I am using PrestaShop™ 1.5.4.1 and my site is DesertDecals.com Thanks in advance.

Share this post


Link to post
Share on other sites

Thanks for another great module, however, I am still having issues with the photos showing up when I share to facebook. I have tried the fixes above by editing the socialbuttons_header.tpl, but still does not work. Any other suggestions?

 

I am using PrestaShop™ 1.5.4.1 and my site is DesertDecals.com Thanks in advance.

 

I checked your website and liked two of your products and the pictures are OK. Can you provide an example page, please? Also, there is a facebook social plugin. Can you try to disable it and like the product if it is not working fine on your side? There maybe a confliction.

Share this post


Link to post
Share on other sites

I checked your website and liked two of your products and the pictures are OK. Can you provide an example page, please? Also, there is a facebook social plugin. Can you try to disable it and like the product if it is not working fine on your side? There maybe a confliction.

 

Thanks for a quick reply. I was just going through and disabling all my social apps to see if there was a conflict.....and sure enough, my FacebookComment Module was it. Seems towork fine now.

 

Do you have any ideas as far as getting rid of the conflict so I can use both?

 

Thanks again.

Share this post


Link to post
Share on other sites

Well, from what I can tell they should be fine, but no worries. I prefer to use your mod anyways. I can always use regular comments block for the comments on page.

 

Thanks again for a great Mod and fast support!!

Share this post


Link to post
Share on other sites

I have a little of problem with the button. the SHARE button is not at the same row.

Any solution?

 

here is my product link here

 

There is no enough place on the extra left hook of product page. If you want to see them aligned, I suggest you to transplant the module to the product footer area.

Share this post


Link to post
Share on other sites

I have a little of problem with the button. the SHARE button is not at the same row.

Any solution?

 

here is my product link here

 

If you modify your PRODUCT.CSS file with a WIDTH entry it will expand that area to put everything on one line. 298px was the EXACT amount to get everything on one line for me. It may be different for you, but just change the amount until it fits. It starts on line 111 for me.

 

#usefull_link_block {
list-style-type:none;
margin-top:20px;
width: 298px;
}

post-595250-0-64723000-1374102894_thumb.jpg

Edited by JANDSCLOTHINGCO (see edit history)

Share this post


Link to post
Share on other sites

If you modify your PRODUCT.CSS file with a WIDTH entry it will expand that area to put everything on one line. 298px was the EXACT amount to get everything on one line for me. It may be different for you, but just change the amount until it fits. It starts on line 111 for me.

 

#usefull_link_block {
list-style-type:none;
margin-top:20px;
width: 298px;
}

 

great, now it works, but I will set it to a larger bigger width,

because with that width, when there is already someone click on the SHARE button, the icon will drop down to the bottom again

Share this post


Link to post
Share on other sites

How do I remove the gap betweed facebook and tweeter button?

I tried to edit the css, but there is no css for facebook.

 

Hi,

 

I guess you can smash the css of addthis, but I need your temporary FTP for the socialbuttons module and url of the product page to work on it. You can PM me.

Share this post


Link to post
Share on other sites
  • 4 weeks later...

Like the image of facebook does not appear.

I checked in the code of the module and it is present.

 

Attached Thumbnails

  • post-595359-0-60238600-1376255680_thumb.jpg

Please disable the left column facebook social plugin and retry. You are having Invalid App ID: 100003980943251 error.

Share this post


Link to post
Share on other sites

I have removed all the modules share and I left only yours.

The image still does not appear like facebook. How come?

 

 

#usefull_link_block {

list-style-type:none;

margin-top:20px;

width: 298px;

post-595359-0-57187300-1376256900_thumb.jpg

Share this post


Link to post
Share on other sites
  • 1 month later...

Hello,

May you tell me please why module can't be unhooked?

And when I try to hook them to 

  • Product Page Extra Right

I got duplicate buttons. They can't be unhooked correctly.

Do you know why?

 

Thanks in advace

Share this post


Link to post
Share on other sites

Hello,

May you tell me please why module can't be unhooked?

And when I try to hook them to 

  • Product Page Extra Right

I got duplicate buttons. They can't be unhooked correctly.

Do you know why?

 

Thanks in advace

 

Do you unhook the not used hook manually? If you do so and have an error, can you share the error message?

Share this post


Link to post
Share on other sites

Hi,

I have no any errors. everything looks fine, but can't unhook from the main position.

please look here: http://www.progrower.pl/donice-plastikowe/195-doniczka-kwadratowa-produkcyjna-11l.html

 

I unhooked it and replaced to displayRightColumntProduct but it still appears twice. how to force module to show only once? (on RightColumnProduct).

 

thanks

Share this post


Link to post
Share on other sites

yes, unfortunately it does not work.  I moved buttos to the right side, under the "add to cart" there are social buttons correctly, but what I did I can not detach from the space below the image. I tried to re-install the module. when I removed the cache of module, then the buttons disappear from the "add to cart" but were still below the image ... I do not know what to do.

Share this post


Link to post
Share on other sites
  • 1 month later...

If you modify your PRODUCT.CSS file with a WIDTH entry it will expand that area to put everything on one line. 298px was the EXACT amount to get everything on one line for me. It may be different for you, but just change the amount until it fits. It starts on line 111 for me.

 

#usefull_link_block {
list-style-type:none;
margin-top:20px;
width: 298px;
}

 

Hi.. how can i move this module under the product's image? like the 2 post in the previous page.

I have tryed different hook position uselessly :(

I haven't extraLeft position.

 

Other questions:

when i click on facebook like, appears a confirmation box.. it's normal?

 

Thank you very much! Very nice module!

Tia

Edited by Tia© (see edit history)

Share this post


Link to post
Share on other sites

Hi.. how can i move this module under the product's image? like the 2 post in the previous page.

I have tryed different hook position uselessly :(

I haven't extraLeft position.

 

Other questions:

when i click on facebook like, appears a confirmation box.. it's normal?

 

Thank you very much! Very nice module!

Tia

 

 

Hi 

 

Confirmation box is normal. 

 

What about the Prestashop version you use?

Share this post


Link to post
Share on other sites

Hi

 

From your answer, I understand that your theme has changed the original positions of Prestashop hooks. So please hook it to the product page on any hook(preferably product left) and give me your product page address. The I'll provide you the code change you need.

 

Regards,

Caglar

Share this post


Link to post
Share on other sites

Yes.. i read a lot of html code and that position has changed.. but ok, no problem.

 

The last question... :rolleyes: :rolleyes:

 

How can i translate the facebook button text "Like" in "mi piace" for italian user?

 

Thank you again!

Share this post


Link to post
Share on other sites

Yes.. i read a lot of html code and that position has changed.. but ok, no problem.

 

The last question... :rolleyes: :rolleyes:

 

How can i translate the facebook button text "Like" in "mi piace" for italian user?

 

Thank you again!

 

The source of the facebook connect javascript is: http://connect.facebook.net/en_US/all.js

just change en_US to the locale you want. en_ES is Spain's locale, and a list of all facebook locales is athttp://facebook.com/translations/FacebookLocales.xml

Share this post


Link to post
Share on other sites

Where can i find it in your module? There isn't in the addthis javascript or in socialbuttons.php.

Thanks

 

Unfortunately, that is the main gap of this free module. We don't have the ability to change the addthis code.

Share this post


Link to post
Share on other sites
  • 2 months later...

Hi again :)

I found a lot error in the log, from the file modules/socialbuttons.php on line 81/82: PHP Notice: Undefined variable

 

How can i fix?

 

That lines are 'confirm' => $confirm and 'errors' => $error, variable.

 

Thank you.

Share this post


Link to post
Share on other sites
  • 2 weeks later...