Jump to content
  • 0
MetroWeb

PayPal Security Error

Question

Prestashop 1.5.2(stable)

Paypal 3.2.5

 

I get this error:

 

PayPal response:

TIMESTAMP -> 2012-10-31T10:37:05Z

L_ERRORCODE0 -> 10002

L_SHORTMESSAGE0 -> Security error

L_LONGMESSAGE0 -> Security header is not valid

L_SEVERITYCODE0 -> Error

 

Could somebody help me? :(

 

I have tried clearing my cache and I still get the same errors.

 

Any help would be greatly appreciated as I cannot move forward with PrestaShop until I get this resolved.

 

Thanks in advance,

MetroWeb

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

From the looks of it, its Authorization error from paypal few things to look at:

 

1. Is the module in sand box or live mode

2. Do you know sand box and live mode needs different API keys

 

PayPal API error code list page:

https://cms.paypal.com/us/cgi-bin/?cmd=_render-content&content_ID=developer/e_howto_api_nvp_errorcodes

Share this post


Link to post
Share on other sites
  • 0

That error is ually generated by your api key being typed wrong. Try typing it, instead of copy an pasting it. For some reason they pick up extra stuff when you copy and paste them some times.

Share this post


Link to post
Share on other sites
  • 0

That error is ually generated by your api key being typed wrong. Try typing it, instead of copy an pasting it. For some reason they pick up extra stuff when you copy and paste them some times.

 

 

Solved!

Problem was from a bad copy and paste of the api key. The copy had picked up an extra space.

Thanks

Share this post


Link to post
Share on other sites

×