Jump to content
pneeds

*Help* Block Currency and Block Language not showing up.

Recommended Posts

Can anyone help me? I've upgraded my website and I'm using the default theme with some modifications.

 

Since changing from the old 'PrestaNew Theme' to the the 'Default 1.5 theme' I've lost my currency and language blocks at the top of the page.

 

They are installed and they are in the 'header', 'top content' position but not showing up.

 

Can anyone help me please. I launch my site soon and I need to get this fixed. Thanks in advance.

  • Like 1

Share this post


Link to post
Share on other sites

I also experiencing same sort of issue.

 

I un-installed currency module and re installed it.

Then it started appear below the menu bar, not in the display header.

 

Wondering how to fix it.

 

Regards,

/sg

  • Like 1

Share this post


Link to post
Share on other sites

In Admin panel, go to Module -> Positions (And try following steps, bold steps itself should fix the issue)

 

1)Currency Block Issue: First locate the Currency block. You may find it in two groups Header of pages, Top of pages

- Move & Place Currency block in "Header of pages" just below the "Specials block"

- Move & Place Currency block in "Top of pages" just below the " Language block"

 

 

2)Language Block Issue: First locate the Language Block. You may find it in two groups Header of pages, Top of pages

- Place Currency block in "Header of pages" just below the "user Info block"

- Move & Place language block as the fist one in "Top of pages"

 

p.s. Just drag the block to move it

  • Like 1

Share this post


Link to post
Share on other sites

hello alls,

 

i got the problem too with language block, i've un-installed and re-installed it.. remove all the position in modules/positions BO.

i checked the appearance of the block with Live-edit, but cannot even see it on the page.... i was wondering what's wrong..... :huh:

 

any input/help will be highly appreciated... ;) cheers !

Share this post


Link to post
Share on other sites

Try this FIX:

 

I have already posted a fix for previous issues. Please find my previous post and 2 part of it should be corrected as follows :)

 

2)Language Block Issue: First locate the Language Block. You may find it in two groups Header of pages, Top of pages

- Place language block in "Header of pages" just below the "user Info block"

- Move & Place language block as the fist one in "Top of pages"

 

If you cant see the Language block,

1) In Admin panel, go to Module -> Positions

2) Locate the Language Block. You may find it in two groups Header of pages, Top of pages. If not add it to those two places and move it following my above instructions.

 

Regards,

 

/sg

  • Like 1

Share this post


Link to post
Share on other sites

Try this FIX:

 

I have already posted a fix for previous issues. Please find my previous post and 2 part of it should be corrected as follows :)

 

2)Language Block Issue: First locate the Language Block. You may find it in two groups Header of pages, Top of pages

- Place language block in "Header of pages" just below the "user Info block"

- Move & Place language block as the fist one in "Top of pages"

 

If you cant see the Language block,

1) In Admin panel, go to Module -> Positions

2) Locate the Language Block. You may find it in two groups Header of pages, Top of pages. If not add it to those two places and move it following my above instructions.

 

Regards,

 

/sg

 

THANKSSSS STARGAIN!

Share this post


Link to post
Share on other sites

Hi. This works for me, but hooking the Language block to Top of Pages creates a conflict and some pages will just show up blank (while the URL seems correct). The conflict goes away when disabling extra languages or when unhooking Language block from top of Pages. Any ideas?

Share this post


Link to post
Share on other sites

in fact everything depends on prestashop version that he/she use

Share this post


Link to post
Share on other sites

Most common error is that multiple languages and currencies should be there in store. Then only these blocks will be displayed. They are not visible for single currency/language.

 

 

www.beayurganic.com

Edited by beayurganic (see edit history)

Share this post


Link to post
Share on other sites

Most common error is that multiple languages and currencies should be there in store. Then only these blocks will be displayed. They are not visible for single currency/language.

 

 

www.beayurganic.com

 

 

you've got some trouble with currencies / languages ? from what i see on your website everything is okay

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More