Jump to content
Sign in to follow this  
Piggen

Varukorgsproblem

Recommended Posts

Hej,

 

Jag har problem med min varukorg.

 

När jag lägger till en produkt i varukorgen när jag använder Internet Explorer så får jag följande felmedelande:

 

Impossible to add product to the cart.

 

textStatus: 'error'

errorThrown: 'no transport'

responseText:

undefined

 

Det fungerar utan problem med:

 

-Firefox

-Chrome

-Safari

 

Är tacksam för svar.

Share this post


Link to post
Share on other sites

Detta brukar bero på att du har angett ex www.profilstjärnan.se som domännamn/ssl domän i din butik, sedan har du inte aktiverat kanonsisk url ompekning för butiken.

Om du då surfar in på profilstjärnan.se utan www innan så kommer js länkarna peka mot www.profilstjärnan.se vilket gör att webbläsarens säkerhetsskydd mot cross site script kan kliva in eftersom www. och utan www. klassas som två olika sidor.

 

Så, det första du ska kontrollera är om kanonsik urlompekning är aktiverat i butiken (det kontrollerar du under inställningar -> SEO & URL

Om det inte är det, aktivera det, och prova sedan igen.

  • Like 1

Share this post


Link to post
Share on other sites

jag har också dragits med ett varukorgsproblem, när man lägger i en vara så försvinner den när man lägger i nästa eller om man klickar på en länk i webbutiken.

 

det jag gör är att ta bort cachen i webbläsaren så fungerar det, men för många av mina kunder funkar det inte alls.

skulle verkligen behöva hjälp med detta.

 

kanonsik urlompekning är aktiverat,

och shop domain och SSL domain är satt till www.mindomän.se

jag tror inte min sida använder SSL?

Share this post


Link to post
Share on other sites

Detta brukar bero på att du har angett ex www.profilstjärnan.se som domännamn/ssl domän i din butik, sedan har du inte aktiverat kanonsisk url ompekning för butiken.

Om du då surfar in på profilstjärnan.se utan www innan så kommer js länkarna peka mot www.profilstjärnan.se vilket gör att webbläsarens säkerhetsskydd mot cross site script kan kliva in eftersom www. och utan www. klassas som två olika sidor.

 

Så, det första du ska kontrollera är om kanonsik urlompekning är aktiverat i butiken (det kontrollerar du under inställningar -> SEO & URL

Om det inte är det, aktivera det, och prova sedan igen.

 

Hej,

 

Tack för svar.

 

Jag har kanonsisk url ompekning för butiken.

Dock så är:

 

Shop domain: xn--profilstjrnan-jfb.se

 

och

 

SSL domain: xn--profilstjrnan-jfb.se

 

Kan det vara ett problem?

Share this post


Link to post
Share on other sites

Hej,

 

Tack för svar.

 

Jag har kanonsisk url ompekning för butiken.

Dock så är:

 

Shop domain: xn--profilstjrnan-jfb.se

 

och

 

SSL domain: xn--profilstjrnan-jfb.se

 

Kan det vara ett problem?

Okej, låter konstigt, felet "no transport" brukar oftast vara just att säkerhetsinställningarna inte tillåter att man skickar data via jquery till urlen.

Du kan ju göra ett snabbt test och ändra domännamnet till profilstjärnan.se istället för det riktiga domännamnet och se vad som händer, kan ju vara en bugg i IE som gör det.

 

 

jag har också dragits med ett varukorgsproblem, när man lägger i en vara så försvinner den när man lägger i nästa eller om man klickar på en länk i webbutiken.

 

det jag gör är att ta bort cachen i webbläsaren så fungerar det, men för många av mina kunder funkar det inte alls.

skulle verkligen behöva hjälp med detta.

 

kanonsik urlompekning är aktiverat,

och shop domain och SSL domain är satt till www.mindomän.se

jag tror inte min sida använder SSL?

Låter som att cookien inte sparas korrekt.

  • Like 1

Share this post


Link to post
Share on other sites

Provade att byta domännamn till profilstjärnan.se, utan framgång.

Kan det bero på att jag har ett "ä" i domännamnen (IDN)?

 

Det är ju märkligt att det fungerar i Chrome, safari och firefox men inte i Explorer?!

Share this post


Link to post
Share on other sites

Provade att byta domännamn till profilstjärnan.se, utan framgång.

Kan det bero på att jag har ett "ä" i domännamnen (IDN)?

 

Det är ju märkligt att det fungerar i Chrome, safari och firefox men inte i Explorer?!

 

Det ska inte spela någon roll, har du tittat så du inte har max nivå på säkerhet i IE eller något sådant? ett plugin eller något kanske?

Share this post


Link to post
Share on other sites

Det ska inte spela någon roll, har du tittat så du inte har max nivå på säkerhet i IE eller något sådant? ett plugin eller något kanske?

 

Det är möjligt, men jag har provat från flera olika datorer och samma problem uppstår tyvärr. Tycker det är väldigt märkligt.

Och det är ju synd att majoriteten använder IE :(

Share this post


Link to post
Share on other sites

Är det någon annan som har upplevt det här tidigare? Och har en lösning på det?

Vore oerhört tacksam för svar som leder till att detta löser sig.

Share this post


Link to post
Share on other sites

Låter som att cookien inte sparas korrekt.

 

ja, det kan helt klart ligga något i det du säger, men hur kan jag avgöra eller rätta till felet?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More