Jump to content
vekia

[moduł] Facebook like box za darmo

Recommended Posts

W pliku rightcolumn.tpl jest odwołanie do języka, czyli

 

js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.3";

Share this post


Link to post
Share on other sites

Dla potomnych i innych takich coś takiego jak adblock lub u block blokuje oryginalny moduł "Blok Lubię to na Facebooku v1.4.0 " oraz moduł z tego artykułu. 


#nie działa facebook moduł presta

Share this post


Link to post
Share on other sites

Witam,

 

moduł po edycji w tpl po zmianach wyświetla się poprawnie w pl, ale pytanie do "PrestaShop Fanatic" jak edytować ten sam kod, aby aktualizował się automatycznie moduł w zależności od języka w przeglądarce lub po ip, robię sklep w języku czeskim i chciałbym aby moduł (patrz lewa kolumna ostatnia pozycja) sam się aktualizował względem wcześniej napisanych aspektów.

 

dzieki, męcze się z tym, ale no nie poradze sobie sam

 

http://kudowabutik.pl/cs/3-zena

Share this post


Link to post
Share on other sites

nowa wersja została wydana!

- poprawki do procesu instalacyjnego

- nowa funkcja pozwalająca na wyłączenie procesu ładowania biblioteki facebook. Jeżeli Twój sklep korzysta już z jakiegoś modułu facebook - to kolejne ładowanie biblioteki jest niepotrzebne. Możesz teraz wyłączyć ładowanie tej biblioteki w związku z czym sklep będzie działał nieco szybciej.

Share this post


Link to post
Share on other sites

Witam,

 

chciałbym się Ciebie zapytać o Twój moduł facebook. Na mojej stronie nie działa ani ten standardowy, ani Twój. W panelu sterowania zaś wyświetla mi panel facebook Twój i stockowy. A na stronie głównej nic nie ma. Stockowy pokazuje tylko napis "Śledź nas na Facebooku" a Twój znajdujący się nad panelem newslettera nie pokazuje się wcale. Czy mógłbyś zobaczyć w czym jest problem? moja strona www.e-zakupy24h.pl

 

Pozdrawiam,

reansys

Share this post


Link to post
Share on other sites

nowa wersja modułu została opublikowana.

do modułu dodano drobne poprawki, dzięki którym działa on z PrestaShop 1.7

moduł przetestowano w PrestaShop 1.7 alpha 3,  - nowa wersja to solidny grunt pod przyszłe oficjalne wydania prestashop w wersji 1.7, które dodatek z cała pewnością będzie wspierał

Share this post


Link to post
Share on other sites

Gdzie znajdę plik rightcolumn.tpl ?

W module modules/blockfacebook nie mam nic takiego.

Share this post


Link to post
Share on other sites

Mylisz moduły blockfacebook to natywny moduł, a z tego wątku moduł się nazywa likeboxfree.

Share this post


Link to post
Share on other sites

otóż to
/modules/likeboxfree/rightcolumn.tpl

Share this post


Link to post
Share on other sites

  To w takim razie nie wiem, jaki mam moduł, bo nie mam modułu likeboxfree :)

Wiec nie wiem, jaki to moduł mam na stronie. 

Ale nic, jakoś dojdę do tego, założyłem inny wątek.

Share this post


Link to post
Share on other sites

Sprawdź do jakiego hooka jest moduł przypisany i czy taki hook w ogóle jest w szablonie.

Share this post


Link to post
Share on other sites

Możesz podpowiedzieć jak to sprawdzić? ;) 

Share this post


Link to post
Share on other sites

W moduły > pozycje > sprawdzisz do jakich hooków jest moduł przypięty, obstawiam że wcześniej go skonfigurowałeś?

Share this post


Link to post
Share on other sites

Już wiem o co chodzi, działa na podstronach, Dzięki za pomoc
Myślałem, że będzie wysuwany. Mój błąd :) 

 

Share this post


Link to post
Share on other sites

Witam

Co muszę zrobić aby ten moduł wskoczył na pierwsze miejsce w stopce? Póki co wygląda to u mnie tak jak na screenie. Presta 1.6.0.14, szablon NewYork od Fieldthemes

post-1274736-0-39951500-1465838365_thumb.jpg

Share this post


Link to post
Share on other sites

Moduł zainstalowałem, ale nie wyświetla się ani w pozycjach, ani na podstronach. Gdzie szukać problemu? Presta 1.6.1.6

Share this post


Link to post
Share on other sites

przejdź do moduły > pozycje > przeszczep moduł

spróbuj dodać like boxa np. do lewej kolumny

następnie sprawdź czy wyświetla się na liście modułów w pozycji "displayLeftColumn" (moduły > pozycje)

Share this post


Link to post
Share on other sites

Ok, zatem moduł można podpinać pod wybrane hooki poprawnie.

Teraz problem z wyświetlaniem się: czy sklep ma lewą kolumnę aktywną ?

czy został skonfigurowany kod języka, czy podany został link do fanpage a nie prywatnego profilu?

Share this post


Link to post
Share on other sites

Moduł jest widoczny w pozycjach, w bo poprawnie wyświetla fanboxa, z obojętnie jakimi danymi.

Share this post


Link to post
Share on other sites

tutaj chodzi o przekonfigurowanie języka w pliku php modułu? Bo w opcjach nic takiego nie widzę.

Share this post


Link to post
Share on other sites

tutaj chodzi o przekonfigurowanie języka w pliku php modułu? Bo w opcjach nic takiego nie widzę.

Share this post


Link to post
Share on other sites

nowa wersja wydana

- poprawki do strony konfiguracyjnej modułu, dodane brakujące oraz nowe tłumaczenia

Share this post


Link to post
Share on other sites

Witam

Wersja prest 1.4.8.2 - moduł nie wyświetla się. Obecnie jest ustawiony po prawej stronie. Cache był czyszczony (tools/smarty/compile). Adres strony www.ekaliber.pl

Share this post


Link to post
Share on other sites

Witam

Wersja prest 1.4.8.2 - moduł nie wyświetla się. Obecnie jest ustawiony po prawej stronie. Cache był czyszczony (tools/smarty/compile). Adres strony www.ekaliber.pl

według to co widzę na wskazanej stronie, to moduł nie jest skonfigurowany

Share this post


Link to post
Share on other sites

Vekia i co o tym sądzisz?
Na stronie głównej mam kod i się nic nie wyświetla...

<div style="display:block; clear:both; border:1px solid #; ">
<iframe src="//www.facebook.com/plugins/likebox.php?href=&width=&height=&colorscheme=&show_faces=&show_border=false&stream=&header=" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:px; height:px;" allowtransparency="true"/>

Share this post


Link to post
Share on other sites

wygląda to tak, jakby nie była dołącana poprawna bilbiotka facebook

moesz włącyć tę opcję: "facebook library"

TnLa3Sa.png

 

dodatkowo, być może będize trzeba odnaleźć niepoprawną bibliotekę fb i ją wyłączyć. zacznijmy od "facebook library" :-)

Share this post


Link to post
Share on other sites

Pomogło :) Plus wyczyszczenie cache'a. Dziękuję.

 

Edit:
Zauważyłem że mam w języku angielskim, oraz nie zgadza się liczba lubiących. Najprawdopodobniej pokazuje ile znajomych lubi a nie całkowitą ilość polubień.

Edited by flamaster (see edit history)

Share this post


Link to post
Share on other sites

najprawdopodobniej chodzi o to, że likebox pokazuje tylko polubienia "nie ukryte" przez lubiących.

 

Ustawienia prywatności na fb pozwalają na wyłączenie pokazywania "lubianych" fanpage, gdy ktoś tę opcję włączoną, wówczas nie pokazuje się w oknie likebox

Share this post


Link to post
Share on other sites

To nie jest związane z ustawieniami prywatności. Sprawdziłem.
U mnie na 202 lubiących wyświetla się tylko jeden. U kolegi wyświetla się 88 z 202. Czyli tylko wyświetla liczbę lubiących ale spośród znajomych.

Share this post


Link to post
Share on other sites

Witam,

 

Mam mały problem odnośnie modułu. Mianowicie zainstalowałem moduł niby wszystko powinno działać. Pozycja została przypisana ale like box mi się nie wyświetla.

 

Korzystam z prestashop 1.7

 

Pozdrawiam

 

http://pokazywarka.pl/xxbzbm/

Edited by szyman (see edit history)

Share this post


Link to post
Share on other sites

Witam, mam podobny problem jak kolega wyżej, także zainstalowałem lecz się nie wyświetla.

Share this post


Link to post
Share on other sites

moduł należy skonfigurować tj. włączyć aplikację fb

wyglada na to, że sklepy nie wykorzystują żadnej biblioteki facebook w związku z czym likebox nie moze zostać zainicjowany.

Share this post


Link to post
Share on other sites

A jak mogę włączyć bibliotekę facebooka w prestashop ?

Share this post


Link to post
Share on other sites

A jak mogę włączyć bibliotekę facebooka w prestashop ?

Wystarczy zaznaczyć w konfiguracji modułu: Facebook library

Share this post


Link to post
Share on other sites

Witam

Zainstalowałem moduł, ale niestety nie wyświetla się na stronie www.hydraulicznie.pl nawet nie ma podglądu na preview, kiedy zmienię adres np. na prestashop to wszystko jest ok. Kombinowałem już na różne sposoby, przeglądając cały temat i stosując to co jest opisane, ale w dalszym ciągu jest problem. Bardzo proszę o pomoc.

image.thumb.png.c66f8ee115d0b22705c2cbd42b852a1f.pngimage.thumb.png.c9f6cb42d03dea1ef21f8ec7f6a919b2.png

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More