Jump to content

Google Analytics Tracking zoals het hoort


Recommended Posts

Zoals je misschien wel gemerkt hebt krijg je in Google Analytics alleen maar /order/step0.html te zien als er bezoekers op je site zijn bij de realtime weergave.

 

Dat schiet natuurlijk niet op als je echt wil zien waar je bezoekers naar kijken. En wat de het meest bezocht wordt.

 

Hieronder vindt je een Fix hoe je dit kunt aanpassen zodat het wel zichtbaar wordt.

Getest met PS 1.4.9

 

Voor:

google1.png

Na:

 

google2.png

 

Ga in je FTP naar de modules map van Google Analytics:

modules/ganalytics/

Open hier het bestand Header.tpl

 

Verander hier de regel:

 

{if isset($pageTrack)}_gaq.push(<'_trackPageview', '{$pageTrack}'>);

 

Naar het volgende:

 

{if isset($pageTrack)}_gaq.push(<'_trackPageview', '{$meta_title}'>);

 

Je code ziet er dan als volgt uit:

 

code1.png

 

Sla dan het bestand op en upload het terug naar je FTP.

Open nu het ganalytics.php bestand dat zich in de zelfde map bevind.

 

Onder de volgende regel:

 

$file = str_replace(array('.php', '-'), '', basename($_SERVER<'SCRIPT_NAME'>));

 

Voeg je het volgende toe:

if($file == "category" ||
$file == "product" ||
$file == "search" ||
$file == "cms" ||
$file == "index") {
$file = $_SERVER<"REQUEST_URI">;
}

 

Sla vervolgens het bestand weer op en upload het terug naar de server.

 

Maak nu de map; /tools/smarty/compile leeg en test google analytics of nu de links goed worden weergegeven...

EDIT:

Hierbij de exacte regels:

 

TPL File:

//{if isset($pageTrack)}_gaq.push(['_trackPageview', '{$pageTrack}']);{/if}//
{if isset($pageTrack)}_gaq.push(['_trackPageview', '{$meta_title}']);{/if}

 

PHP File:

 

// Better way to check which file / controller name is loaded
if (!($file = basename(Tools::getValue('controller'))))
$file = str_replace(array('.php', '-'), '', basename($_SERVER['SCRIPT_NAME']));
if($file == "category" ||
       $file == "product" ||
        $file == "search" ||
        $file == "cms" ||
        $file == "index") {
       $file = $_SERVER["REQUEST_URI"];
   }

Bron: http://www.prestasho...eter-weergeven/

Edited by djkavaa (see edit history)
  • Like 4

Share this post


Link to post
Share on other sites

  • 3 months later...
  • 4 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 1 month later...

Beste,

 

Kan je deze instellingen ook in v 1.5.4.1 toepassen?

 

MVG,

Generaal

 

Als ik probeer Analytics for ecommerce te installeren, krijg ik volgende foutmelding:

 

Warning: curl_setopt_array(): CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /customers/0/4/c/erotiekfabriek.be/httpd.www/modules/jirafe/vendor/jirafe-php-client/src/Jirafe/HttpConnection/Curl.php on line 119 {"app_id":88253,"name":"erotiekfabriek","token":"f9860ba715ebd410e7b50ded2e791046"} Fatal error: Call to undefined method Jirafe_Api_Collection_Applications::resources() in /customers/0/4/c/erotiekfabriek.be/httpd.www/modules/jirafe/jirafe15.php on line 133 [PrestaShop] Fatal error in module jirafe15:

Call to undefined method Jirafe_Api_Collection_Applications::resources()

 

Ik heb m'n gegevens van Google analytics correct ingevoerd (ID).

En de maprechten op 777 gezet, ivm de hogervermelde verwijzing.

Share this post


Link to post
Share on other sites

  • 1 month later...

Beste,

 

Kan je deze instellingen ook in v 1.5.4.1 toepassen?

 

MVG,

Generaal

 

Als ik probeer Analytics for ecommerce te installeren, krijg ik volgende foutmelding:

 

Warning: curl_setopt_array(): CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /customers/0/4/c/erotiekfabriek.be/httpd.www/modules/jirafe/vendor/jirafe-php-client/src/Jirafe/HttpConnection/Curl.php on line 119 {"app_id":88253,"name":"erotiekfabriek","token":"f9860ba715ebd410e7b50ded2e791046"} Fatal error: Call to undefined method Jirafe_Api_Collection_Applications::resources() in /customers/0/4/c/erotiekfabriek.be/httpd.www/modules/jirafe/jirafe15.php on line 133 [PrestaShop] Fatal error in module jirafe15:

Call to undefined method Jirafe_Api_Collection_Applications::resources()

 

Ik heb m'n gegevens van Google analytics correct ingevoerd (ID).

En de maprechten op 777 gezet, ivm de hogervermelde verwijzing.

De foutmelding lijkt me duidelijk een misconfiguratie issue op de server:
CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set
. De module is verder compatible met 1.5.4.1

Share this post


Link to post
Share on other sites

Dit staat er in mijn header:

<script type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['_setAccount', '{$ganalytics_id}']);
// Recommanded value by Google doc and has to before the trackPageView
_gaq.push(['_setSiteSpeedSampleRate', 5]);
_gaq.push(['_trackPageview'{if isset($pageTrack)}, '{$pageTrack}'{/if}]);
{if $isOrder eq true}  {* If it's an order we need more data for stats *}
 _gaq.push(['_addTrans',
   '{$trans.id}',   {* order ID - required   *}
   '{$trans.store}',  {* affiliation or store name *}
   '{$trans.total}',  {* total - required    *}
   '{$trans.tax}',   {* tax	   *}
   '{$trans.shipping}', {* shipping	  *}
   '{$trans.city}',  {* city	   *}
   '{$trans.state}',  {* state or province   *}
   '{$trans.country}'  {* country	  *}
 ]);
{foreach from=$items item=item}
 _gaq.push(['_addItem',
 '{$item.OrderId}',  {* order ID - required  *}
 '{$item.SKU}',   {* SKU/code - required  *}
 '{$item.Product}',  {* product name    *}
 '{$item.Category}',  {* category or variation *}
 '{$item.Price}',  {* unit price - required *}
 '{$item.Quantity}'  {* quantity - required  *}
 ]);
{/foreach}
{* submits transaction to the Analytics servers *}
{literal}
 _gaq.push(['_trackTrans']);
{/literal}
{/if}
{literal}
(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})(); {/literal}
</script>

Share this post


Link to post
Share on other sites

Dit staat er in mijn header:

<script type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['_setAccount', '{$ganalytics_id}']);
// Recommanded value by Google doc and has to before the trackPageView
_gaq.push(['_setSiteSpeedSampleRate', 5]);
_gaq.push(['_trackPageview'{if isset($pageTrack)}, '{$pageTrack}'{/if}]);
{if $isOrder eq true}  {* If it's an order we need more data for stats *}
 _gaq.push(['_addTrans',
'{$trans.id}',   {* order ID - required   *}
'{$trans.store}',  {* affiliation or store name *}
'{$trans.total}',  {* total - required	*}
'{$trans.tax}',   {* tax	   *}
'{$trans.shipping}', {* shipping	  *}
'{$trans.city}',  {* city	   *}
'{$trans.state}',  {* state or province   *}
'{$trans.country}'  {* country	  *}
 ]);
{foreach from=$items item=item}
 _gaq.push(['_addItem',
 '{$item.OrderId}',  {* order ID - required  *}
 '{$item.SKU}',   {* SKU/code - required  *}
 '{$item.Product}',  {* product name	*}
 '{$item.Category}',  {* category or variation *}
 '{$item.Price}',  {* unit price - required *}
 '{$item.Quantity}'  {* quantity - required  *}
 ]);
{/foreach}
{* submits transaction to the Analytics servers *}
{literal}
 _gaq.push(['_trackTrans']);
{/literal}
{/if}
{literal}
(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})(); {/literal}
</script>

Juistem. Zie de eerste post in dit topic.

Pas de regel

_gaq.push(['_trackPageview'{if isset($pageTrack)}, '{$pageTrack}'{/if}]);

aan naar

_gaq.push(['_trackPageview'{if isset($pageTrack)}, '{$meta_title}'{/if}]);

Share this post


Link to post
Share on other sites

  • 5 months later...

Had hier ook last van, vond alleen eerst deze post:

http://www.onlineshop-module.de/blog/google-analytics-trackt-nur-orderstep0-html/

 

Je moet dus in meta-tags een waarde invullen voor de order pagina. Die wordt blijkbaar niet goed ingevuld voor Nederlands. Nadat ik hier order had ingevuld, werkte het gewoon. Zonder aanpassen header.tpl

meta-order.png

Edited by MaartenPol (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More