Jump to content
Presta 2 Doli

[MODULE Gratuit] Changer le transporteur

Recommended Posts

Coucou

 

je viens de tester sur une 1.6.1.1 il s’intègre bien dans la page de commande et recalcule les frais de transport 

 

@++

 

Loulou66

salut et deja merci pour l'aide que tu fournis sur ce module

sur une 1.6.1.2 ca ne fonctionne pas : pas d'accés a la liste des transporteurs ...

Cdt

Share this post


Link to post
Share on other sites

Coucou

je viens de tester sur une 1.6.1.2 fraichement installer j'ai bien la listes des transporteurs après verif la classe ne semble pas avoir été changer

 

vérifie que vous avez pas un ovveride de la class carrier avec la fonction getCarriers

@++

 

Loulou66

Share this post


Link to post
Share on other sites

Coucou

 

je viens de tester sur une 1.6.1.2 fraichement installer j'ai bien la listes des transporteurs après verif la classe ne semble pas avoir été changer

 

vérifie que vous avez pas un ovveride de la class carrier avec la fonction getCarriers

 

@++

 

Loulou66

je dois donc avoir un probleme de class du a un autre module ... tant pis comme jy connais pas grand chose c'est raté lol merci quand meme

 

** edit du 12/11/15**

Ah bah j'ai trouvé  ! , en fait pour ceux qui utilisent le module envoismoincher , pas la peine de vous casser la tete , ces 2 modules se contrent donc pas de possibilité de changer de transporteur.

Ca evitera peut etre a d'autres de chercher pendant 2 heures :lol:

Edited by nazdupresta (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

Ce module est vraiment très utile.

Mais il n'est pas compatible avec php5.6

on obtient ce message d'erreur:

 mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead

 

Si vous avez une solution, ça serait top.

Merci

Share this post


Link to post
Share on other sites

Un grand merci pour ce module qui fonctionne à merveille sur 1.6 !

Share this post


Link to post
Share on other sites

Hello, 

 

Super module qui fonctionne mais semble ne pas fonctionner lorsque le transporteur est lié avec un module propriétaire 

 

Avec Kiala et Bpost, ceux-ci ne sont pas dans la liste.

 

Seul les transporteur crée via Prestashop en Bo fonctionne.

 

Une idée à comment régler cela ?

 

Merci 

Share this post


Link to post
Share on other sites

Exactement, mais c'est courant ce genre de pratique, on utilise la communauté pour faire son beurre^^

 

C'est une des raisons pour laquelle j'ai arrêté le développement de modules gratuits.

Share this post


Link to post
Share on other sites

Salut,

 

On est effectivement en droit de se poser des questions....

 

Mais bon, à sa décharge, l'idée est libre, et il n'y a pas 36 façons de traiter cette fonction : une liste déroulante, on choisi, et ça change le transporteur

 

Ce qui me gêne le plus la-dedans, c'est le prix...!!!

 

30.00 € pour une fonction ultra simple, qui demande grand maximum 2 heures de développement et éventuellement 15 minutes de mise à jour aux changements de versions de PrestaShop, on croit rêver...!!!

Surtout que sa version n'apporte rien de plus, alors qu'il y aurait tant à faire...(comme le demande utaku un peu plus haut)

 

Enfin bon, c'est sûrement le vendeur qui a raison, et les plus "bêtes" ce sont peut-être ceux qui payent ce prix, alors qu'une version gratuite existe...

 

Pour rappel, nous avions lancé cette fonction il y a plus plus de 3 ans (Octobre 2012)

 

Presta2Doli

Edited by Presta 2 Doli (see edit history)

Share this post


Link to post
Share on other sites

Exactement, mais c'est courant ce genre de pratique, on utilise la communauté pour faire son beurre^^

 

C'est une des raisons pour laquelle j'ai arrêté le développement de modules gratuits.

Tout à fait d'accord,

 

Et je rajouterais, que tant que certains modérateurs de ce Forum (et ils sont nombreux), sont aussi des "vendeurs" de modules, ça ne pourra qu'aggraver les choses sur la partie Module Gratuit

 

ça fait bosser ceux qui ont les idées, on leur demande d'améliorer et de debugger, puis on finit par pomper... :ph34r:

 

Enfin bon, c'est mon ressenti, mais je me trompe peut-être    :P

Share this post


Link to post
Share on other sites

Oui Eolia, tu as là aussi raison

 

Mais tout le monde ne va pas forcément passer tout de suite à la version 1.7, donc il y a encore de quoi se faire du "beurre" sur le dos des autres...

 

Surtout que j'avais pas fait attention, c'est 30 € Hors Taxes, soit 36 €/TTC (tout le monde ne récupère pas la TVA)

 

De la folie pure.... :angry:

Share this post


Link to post
Share on other sites

Hello, 

 

Merci pour vos réactions, je trouve cela lamentable également, mais bon... perso je ne suis pas prêt à dépenser un telle somme sachant qu'il y a cette version gratuit qui fonctionne certainement mieux ...

 

Bon pour ma part, cela ne fonctionne malheureusement pas vu que mes transporteurs sont installer depuis leurs module respectif...penser vous que cela serait possible de rajouter cette possibilité sur le module ? 

 

Et effectivement Presta 2 doli , je suis le développement de ce module depuis sa création ;)

 

Pourquoi dès lors ne pas encrypter vos modules ( ou du moins une partie ) ?, j'ai déjà vu cela, j'ai acheter un module de markeplace qui était en partie crypter.

 

Les fonctionnalités du module de Eolia , sont intéressante, penser vous qu'il serait possible de les rajouter sur cette version ci ? puisque Eolia ne développe plus sur des modules gratuit.

 

Ps : Merci pour votre module de newsletter Eolia, depuis plus 1 ans que je l'utilise et toujours impeccable ;) au fil des mises à jours.

Share this post


Link to post
Share on other sites

Je reviens vers vous, car j'avais contacter le " developpeur " du module sur addon, et celui-ci me confirme que le module est compatible avec les transporteurs dépendant ( crée part ) leurs modules, donc selon lui, se serait compatible avec Kiala et Bpost.

 

Par contre le prix ne se modifie pas lors du changement... qu'il me confirme.

Share this post


Link to post
Share on other sites

Surtout que j'avais pas fait attention, c'est 30 € Hors Taxes, soit 36 €/TTC (tout le monde ne récupère pas la TVA)

c'est le prix minimum sur addons, on ne peut pas vendre moins chère.

 

 

 

Pourquoi dès lors ne pas encrypter vos modules ( ou du moins une partie ) ?, j'ai déjà vu cela, j'ai acheter un module de markeplace qui était en partie crypter.

 

1- encrypté signifie que le code peut contenir tout et n'importe quoi, donc danger,

2- mais aussi qu'il n'est pas modifiable par celui qui l'achète, j'ai d'ailleurs eu un gros problème avec un client qui avait acheté le module crypté de marketplace, TOUT est crypté y compris les overrides, ça veux dire que le jour où tu installer un nouveau module avec un override sur la même fonction c'est impossible... il faut être bien conscient que ça bloque toute la boutique.

3- et pour finir, comme vous l'aurez compris, c'est non personnalisable.

Share this post


Link to post
Share on other sites

Merci pour ce complément d'information coeos.pro ;)

Share this post


Link to post
Share on other sites

 

Pourquoi dès lors ne pas encrypter vos modules ( ou du moins une partie ) ?, j'ai déjà vu cela, j'ai acheter un module de markeplace qui était en partie crypter.

 

Nous avons essayé plusieurs fois, et en général, on se fait "incendier" par les "modérateurs/vendeurs" du Forum qui ne peuvent plus "pomper", et en soit, coeos a plutôt raison, cela peut gêner le développement, la personnalisation et la sécurité

 

De notre côté, par choix (je sais très discutable), nous ne développons plus que pour PrestaShop 1.4.11, version "vieillotte", mais stable, simple et très légère pour de l'hébergement en mutualisé entre autre

 

PrestaShop 1.5 passerait encore, mais la 1.6 demande beaucoup trop de ressources, et en général, ça rame en Front Office...(en tout cas sur du mutualisé)

 

Et quand on s'intéresse un peu aux statistiques faites par Google, Amazon, Ebay ...etc..., sur les conséquences du temps d'affichage des pages sur le chiffre d'affaire, on se rend vite compte qu'il faut que ça s'affiche très vite pour le client.

Moi le premier, qui achetait beaucoup sur Cdiscount avant (par exemple), avec toutes leurs images et autres animations, ça met tellement de temps à s'afficher, que je préfère souvent passer mon chemin pour trouver ailleurs... Et posez-vous la question à chaque fois que vous voulez acheter quelque chose sur internet (hormis pour le prix), de pourquoi vous avez choisi cette boutique plutôt qu'une autre, vous serez peut-être surpris vous aussi quand à la raison de votre choix...

  • Like 1

Share this post


Link to post
Share on other sites

c'est le prix minimum sur addons, on ne peut pas vendre moins chère.

Désolé, je ne savais pas, dommage qu'il n'y ai pas plus de choix (Pourquoi ????)

 

De toute façon, suivant ce que signale utaku, si ça apporte des fonctions complémentaires par rapport à la version gratuite, ça explique (au moins) en partie le prix à payer

 

Je retire donc tout ce que j'ai pu dire avant sur le prix élevé

Share this post


Link to post
Share on other sites

Désolé, je ne savais pas, dommage qu'il n'y ai pas plus de choix (Pourquoi ????)

 

c'est la politique d'addons, il ne faut pas oublier qu'ils gagnent de l'argent à chaque vente, et pour un module à 30€HT ils prennent 10€

Share this post


Link to post
Share on other sites

c'est la politique d'addons, il ne faut pas oublier qu'ils gagnent de l'argent à chaque vente, et pour un module à 30€HT ils prennent 10€

Ah la VACHE......!!!!!!! :o

 

C'est pas rien.....!!!!!! :wacko:

 

Mais bon, il y a des équipes de développement à rémunérer, après tout, on en profite bien :wub:

Share this post


Link to post
Share on other sites

Il ne faut pas oublier qu'il existe d'autres places de marchés quand même où l'on peut trouver, vendre ou acheter des modules moins cher comme sur Code canyon.

Share this post


Link to post
Share on other sites

Il ne faut pas oublier qu'il existe d'autres places de marchés quand même où l'on peut trouver, vendre ou acheter des modules moins cher comme sur Code canyon.

Merci pour l'info, je ne connaissais pas ... (mais je n'ai jamais beaucoup cherché)

 

Je retiens ce site pour voir

Share this post


Link to post
Share on other sites

la majorité de ces modules sont 15$ et moins, ça fait grosso modo 10€ (et je ne compte pas les charges URSSAF, l'IS...), et vu le SAV qu'il faut avoir derrière, à première vue ça ne me semble pas du tout rentable (à moins de bacler le SAV et encore)

  • Like 1

Share this post


Link to post
Share on other sites

Euh... codecanyon ou codeur.com on trouve de tout et n'importe quoi, du code plutôt dégeu (mais qui sert souvent de base à certains dev^^), un sav quasi inexistant et en anglais made in Google translate.

 

Avant d'acheter ce genre de module, demandez l'avis des membres de ce forum, c'est un conseil ;)

  • Like 2

Share this post


Link to post
Share on other sites

la majorité de ces modules sont 15$ et moins, ça fait grosso modo 10€ (et je ne compte pas les charges URSSAF, l'IS...), et vu le SAV qu'il faut avoir derrière, à première vue ça ne me semble pas du tout rentable (à moins de bacler le SAV et encore)

C'est vrai, mais moi je voyais plutôt ça dans le sens ACHETER, pas dans le sens VENDRE sur cette place...

Et dans ce sens, les prix sont intéressant.... :) (si pas besoin de SAV après :( biensûr)

 

Je sais, je suis égoïste ... :rolleyes:

Share this post


Link to post
Share on other sites

Je réagissais juste aux propos concernant un tarif minimum imposé à la vente sur addons pour un module qui d'après certains ne vaut pas ce prix. 

 

De fait, il existe des places de marchés qui proposent des modules (je ne juge pas leur qualité) à moindre prix. 

 

Donc c'est juste pour rappeler que si même l'auteur du module trouve que 30€ c'est trop cher pour son bout de code, il est possible de vendre son module à moindre prix sur d'autres places de marché (et éventuellement de toucher un plus grand nombre de personnes intéressées  ;) ). 

Share this post


Link to post
Share on other sites

Euh... codecanyon ou codeur.com on trouve de tout et n'importe quoi, du code plutôt dégeu (mais qui sert souvent de base à certains dev^^), un sav quasi inexistant et en anglais made in Google translate.

 

Avant d'acheter ce genre de module, demandez l'avis des membres de ce forum, c'est un conseil ;)

ça sent un peu la mauvaise expérience et la désillusion ce message... ;)

 

En tout cas c'est noté :rolleyes:

Share this post


Link to post
Share on other sites

Hello, 

 

Je reviens vers vous concernant codecanyon que je ne connaissait pas du tout, merci d'avoir partager cette info.

J'y ai acheter un module "Brands" et celui-ci fonctionne parfaitement bien, et semble avoir été bien codé.

 

En ce qui concerne le module de ce post, j'ai fini par trouver la réponse à ma question ( le faire fonctionner avec les transporteurs dépendant de leurs module ).

 

Voici ce qu'il faut modifier : 

$carriers = Carrier::getCarriers(intval($this->context->language->id), true, false);

devient

$carriers = Carrier::getCarriers(intval($this->context->language->id), true, false, false, null, Carrier::ALL_CARRIERS);

Il faut faire la modification au deux endroit en fin du fichier.

 

La réponse ce trouve à la dernière page du topic suivant : 

 

https://www.prestashop.com/forums/topic/112504-module-modifier-le-transporteur-dans-une-commande/page-3

 

Merci à cette personne ;)

Share this post


Link to post
Share on other sites

Hello, 

 

En effet, c'est toujours sa de pris ;)

 

Cela fait toujours plaisir quand il y a de l'entraide sur ce forum ;)

Share this post


Link to post
Share on other sites

Bonjour,

 

merci pour ce module,

 

juste une question a quel endroit ou puis je télécharger la dernière version ?

 

J'ai téléchargé la version du premier post sur la page 1 , est ce le bon endroit ?

 

J'ai installé cette version et cela fonctionne correctement sur ma version preta 1.6.1.1,

 

cependant lorsque je suis sur une des commandes j'ai le popup à ma droite me proposant de modifier le transporteur tout le temps est ce normal?

 

merci de vos retour

Share this post


Link to post
Share on other sites

Utilisant la version 1.6.1.4, je n'ai eu aucun problème à l'installation et tout semble fonctionner correctement.

 

Pour le problème de pop-up cité ci-dessus, lors de l'installation du module, il suffit de décocher la première option ("Pour que le module soit flottant dans la commande client") pour que la pop-up n'apparaisse pas. Le choix des options est également accessible depuis le panneau "Modules et services", donc modifiable n'importe quand ;)

Share this post


Link to post
Share on other sites

Version améliorée du module ici http://eoliashop.com/carriermodify

  • Fenêtre flottante qui fonctionne en 1.6
  • Prix modifiables avec mise à jour de la commande et choix de la génération d'un bon de réduction si trop-perçu
  • Like 1

Share this post


Link to post
Share on other sites

Bonjour à tous 

Merci utaku , je partage avec vous le fichier modifier...! Dommage pour ce forum qui ma beaucoup appris.

Je voudrais dire un grand merci à mes amis qui se reconnaitront...!!

changetransp.php

Edited by Soyons Solidaires (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Bonjour, 

 

Je suis sous Presta 1.6.2 et quand je cree une commande manuellement pour mes clients, je ne sais pas changer le transporteur. Il me prend directement le premier de ma liste, qui est gratuit, et si je souhaite changer le transporteur, rien ne se passe.

 

J'ai telechargé ce module mais je ne vois pas apparaitre dans les modules  ! (mais bien dans mon ftp) Comment fais je pour l'activer ?

 

Bien à vous,

Share this post


Link to post
Share on other sites

... un petit MODULE Gratuit qui vous permet de changer le transporteur sur la commande d'un client, ...

 

Compatible PrestaShop 1.4.11 / 1.5.6.1 / 1.5.6.2 / 1.6.0.1 / 1.6.0.2 (mais en attente de vos tests...)

 

 Merci, fonctionne parfaitement sous 1.4.9 :)

Share this post


Link to post
Share on other sites

A tous ceux qui ont téléchargé ce module sur leur boutique, et même si le module n'est pas installé, vous devez le désinstaller ET IMPÉRATIVEMENT LE SUPPRIMER ! il comporte des failles de sécurité.
 
Vous pourrez remercier okom3pom qui à pris le temps de vérifier le code du module ;)

Share this post


Link to post
Share on other sites

A tous ceux qui ont téléchargé ce module sur leur boutique, et même si le module n'est pas installé, vous devez le désinstaller ET IMPÉRATIVEMENT LE SUPPRIMER ! il comporte des failles de sécurité.

 

Vous pourrez remercier okom3pom qui à pris le temps de vérifier le code du module ;)

 

Peut-on savoir plus ? La version pour PS1.6 de ce post est-elle également concernée ? https://www.prestashop.com/forums/topic/196722-module-gratuit-changer-le-transporteur/page-4?do=findComment&comment=1890927

 

Quelqu'un se sent-il de corriger ce module gratuit ?

Edited by KevinNash (see edit history)

Share this post


Link to post
Share on other sites

Peut-on savoir plus ? 

 

 

 

Pas génial de dire plus ...

 

A vu d'oeil Loulou à fait du bon travail :) Mais vous devez absolument supprimer le module de votre serveur et ensuite installer la version de Loulou

Edited by okom3pom (see edit history)

Share this post


Link to post
Share on other sites

Pas génial de dire plus ...

 

A vu d'oeil Loulou à fait du bon travail :) Mais vous devez absolument supprimer le module de votre serveur et ensuite installer la version de Loulou

 

Quelle est cette version de Loulou dont tu parles?

Share this post


Link to post
Share on other sites

Celle que j'ai linkée 3 posts au-dessus du tien ;)

 

Sur okom3pom pour la version de loulou66, on peut y aller ?

 

Car à vu d'oeil ça laisse un doute he he :)

Share this post


Link to post
Share on other sites

Celle que j'ai linkée 3 posts au-dessus du tien ;)

 

Sur okom3pom pour la version de loulou66, on peut y aller ?

 

Car à vu d'oeil ça laisse un doute he he :)

 

Merci KevinNash, en effet après vérification sur mon serveur c'est la version de Loulou que j'utilise ;)

Edited by Cyrius91 (see edit history)

Share this post


Link to post
Share on other sites

Sur okom3pom pour la version de loulou66, on peut y aller ?

 

Oui !

 

Merci KevinNash, en effet après vérification sur mon serveur c'est la version de Loulou que j'utilise

Fais quand même ce que je préconise on efface tout on réinstalle

Share this post


Link to post
Share on other sites

Merci Loulou66,

 

Cette version fonctionne très bien, mais ne permet plus de modifier le transporteur dans la table ps_orders.

Dommage parce que ceux qui comme moi ont rajouté la colonne transporteur dans la page commande ne voit plus la modification du transporteur.

 

Si cela est possible, ça serait parfait.

Merci

Share this post


Link to post
Share on other sites

Bonjour,

 

J'en profite pour à mon tour apporter ma pierre à l'édifice en vous présentant le module "Modifier le transporteur final".

 

Il est bilingue (français / anglais), compatible avec les versions 1.5 et 1.6 de Prestashop, super facile à utiliser et entièrement Ajax (pas de rechargement de page).

 

Comme vous pourrez le voir sur les captures d'écran, il permet de :
- modifier le transporteur lié à une commande depuis le back-office
- modifier le numéro de suivi et envoyer l'e-mail de suivi au client (facultatif)
- modifier le poids (également facultatif)

Share this post


Link to post
Share on other sites

mauvaise section @BeComWeb

 

Bonjour ChDUP,

Est ce que tu aurais quelques minutes à m'accorder en MP par rapport à cet aspect du forum ?

Voir aussi ce topic ouvert hier

Share this post


Link to post
Share on other sites

Je vois simplement que tu es dans une section "modules et thèmes gratuits" et que tu y fais une pub pour ton module payant.

Pour ta question, il faut t'adresser à un modo ou au CM.

Share this post


Link to post
Share on other sites

Je vois simplement que tu es dans une section "modules et thèmes gratuits" et que tu y fais une pub pour ton module payant.

Pour ta question, il faut t'adresser à un modo ou au CM.

 

Oui je suis d'accord avec toi et je me suis permis de le faire exceptionnellement pour 2 raisons :

1. Parce que l'utilisation du module de Presta 2 Doli est maintenant déconseillé (voir les messages précédents, notamment celui de coes.pro)

2. Parce qu'Eolia et coes.pro ont déjà publié avant moi des liens vers des modules payants (posts #141 et #142).

 

Je vais me renseigner sur les moyens de contacter un CM ou un modo.

 

Merci pour ton retour

Share this post


Link to post
Share on other sites

Est ce la module d'eolia en gratuit est déconseillé aussi ?

Je ne sais pas quelle version vous avez, mais elle ne doit plus vraiment être à jour^^

Share this post


Link to post
Share on other sites

Effectivement, tu aurais un lien ou c'est devenu payant  ?

merci par avance de ta réponse

Share this post


Link to post
Share on other sites

c'est devenu payant depuis plus d'un an, le lien est plus haut dans le post.

Share this post


Link to post
Share on other sites

Bonjour

C'est le module parfait. Mais il y a un petit problème: il ne respecte pas la devise de la commande. Quelqu'un peut-il le réparer? S'il vous plait Merci

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More